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Overview
Ansys Workbench is a workflow analysis platform, combining the strength of our core simulation tools
with the tools necessary to manage your projects. To build an analysis, you add building blocks called
systems to the main project workspace. These systems make up a flowchart-like diagram that represent
the data flow through your project. Each system is a block of one or more components called cells,
which represent the sequential steps necessary for the specific type of analysis. Once added, you can
link them together to share or transfer data between systems.

From the cells, you can work with various Ansys applications and analysis tasks; some of these open in
tabs within the Workbench environment, while others open independently in their own windows.

Ansys applications enable you to define analysis characteristics such as geometry dimensions, material
properties, and boundary conditions as parameters. You can manage parameters at the project-level in
the Workbench environment. To perform your analysis, work through the cells of each system in or-
der—typically from top to bottom—defining inputs, specifying project parameters, running your simu-
lation, and investigating the results.

Workbench enables you to easily investigate design alternatives. You can modify any part of an analysis
or vary one or more parameters, and then automatically update the project to see the effect of the
change on the simulation result.

Related topics:

The Ansys Product Improvement Program

User Interface Overview

Interacting with Project Objects

Using Help

The Ansys Product Improvement Program

This product is covered by the Ansys Product Improvement Program, which enables Ansys, Inc., to collect
and analyze anonymous usage data reported by our software without affecting your work or product
performance. Analyzing product usage data helps us to understand customer usage trends and patterns,
interests, and quality or performance issues. The data enable us to develop or enhance product features
that better address your needs.

How to Participate

The program is voluntary. To participate, select Yes when the Product Improvement Program dialog
appears. Only then will collection of data for this product begin.

15
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How the Program Works

After you agree to participate, the product collects anonymous usage data during each session. When
you end the session, the collected data is sent to a secure server accessible only to authorized Ansys
employees. After Ansys receives the data, various statistical measures such as distributions, counts,
means, medians, modes, etc., are used to understand and analyze the data.

Data We Collect

The data we collect under the Ansys Product Improvement Program are limited. The types and amounts
of collected data vary from product to product. Typically, the data fall into the categories listed here:

Hardware: Information about the hardware on which the product is running, such as the:

• brand and type of CPU

• number of processors available

• amount of memory available

• brand and type of graphics card

System: Configuration information about the system the product is running on, such as the:

• operating system and version

• country code

• time zone

• language used

• values of environment variables used by the product

Session: Characteristics of the session, such as the:

• interactive or batch setting

• time duration

• total CPU time used

• product license and license settings being used

• product version and build identifiers

• command line options used

• number of processors used

• amount of memory used

• errors and warnings issued

Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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Session Actions: Counts of certain user actions during a session, such as the number of:

• project saves

• restarts

• meshing, solving, postprocessing, etc., actions

• times the Help system is used

• times wizards are used

• toolbar selections

Model: Statistics of the model used in the simulation, such as the:

• number and types of entities used, such as nodes, elements, cells, surfaces, primitives, etc.

• number of material types, loading types, boundary conditions, species, etc.

• number and types of coordinate systems used

• system of units used

• dimensionality (1-D, 2-D, 3-D)

Analysis: Characteristics of the analysis, such as the:

• physics types used

• linear and nonlinear behaviors

• time and frequency domains (static, steady-state, transient, modal, harmonic, etc.)

• analysis options used

Solution: Characteristics of the solution performed, including:

• the choice of solvers and solver options

• the solution controls used, such as convergence criteria, precision settings, and tuning options

• solver statistics such as the number of equations, number of load steps, number of design points,
etc.

Specialty: Special options or features used, such as:

• user-provided plug-ins and routines

• coupling of analyses with other Ansys products

Data We Do Not Collect

The Product Improvement Program does not collect any information that can identify you personally,
your company, or your intellectual property. This includes, but is not limited to:
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• names, addresses, or usernames

• file names, part names, or other user-supplied labels

• geometry- or design-specific inputs, such as coordinate values or locations, thicknesses, or other
dimensional values

• actual values of material properties, loadings, or any other real-valued user-supplied data

In addition to collecting only anonymous data, we make no record of where we collect data from. We
therefore cannot associate collected data with any specific customer, company, or location.

Opting Out of the Program

You may stop your participation in the program any time you wish. To do so, select Ansys Product
Improvement Program from the Help menu. A dialog appears and asks if you want to continue parti-
cipating in the program. Select No and then click OK. Data will no longer be collected or sent.

The Ansys, Inc., Privacy Policy

All Ansys products are covered by the Ansys, Inc., Privacy Policy.

Frequently Asked Questions

1. Am I required to participate in this program?

No, your participation is voluntary. We encourage you to participate, however, as it helps us create
products that will better meet your future needs.

2. Am I automatically enrolled in this program?

No. You are not enrolled unless you explicitly agree to participate.

3. Does participating in this program put my intellectual property at risk of being collected or discovered
by Ansys?

No. We do not collect any project-specific, company-specific, or model-specific information.

4. Can I stop participating even after I agree to participate?

Yes, you can stop participating at any time. To do so, select Ansys Product Improvement Program
from the Help menu. A dialog appears and asks if you want to continue participating in the program.
Select No and then click OK. Data will no longer be collected or sent.

5. Will participation in the program slow the performance of the product?

No, the data collection does not affect the product performance in any significant way. The amount
of data collected is very small.

6. How frequently is data collected and sent to Ansys servers?

The data is collected during each use session of the product. The collected data is sent to a secure
server once per session, when you exit the product.

Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.18

Overview

http://www.ansys.com/privacy


7. Is this program available in all Ansys products?

Not at this time, although we are adding it to more of our products at each release. The program
is available in a product only if this Ansys Product Improvement Program description appears in the
product documentation, as it does here for this product.

8. If I enroll in the program for this product, am I automatically enrolled in the program for the other Ansys
products I use on the same machine?

Yes. Your enrollment choice applies to all Ansys products you use on the same machine. Similarly,
if you end your enrollment in the program for one product, you end your enrollment for all Ansys
products on that machine.

9. How is enrollment in the Product Improvement Program determined if I use Ansys products in a cluster?

In a cluster configuration, the Product Improvement Program enrollment is determined by the host
machine setting.

10. Can I easily opt out of the Product Improvement Program for all clients in my network installation?

Yes. Perform the following steps on the file server:

a. Navigate to the installation directory: [Drive:]\v222\commonfiles\globalsettings

b. Open the file ANSYSProductImprovementProgram.txt.

c. Change the value from "on" to "off" and save the file.

User Interface Overview

Use the following image and topics to understand basic user interface functionality.
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Related topics:

Tabs

Panes

Systems and Cells

Links

Tabs

Tabs are workspaces that allow you to interact with different parts of your project. The Project tab
is used as the main workspace, but other tabs can be opened; either by double-clicking the associated
cell, or by right-clicking it and selecting Edit from the context menu.

Each cell that does not launch an external application has a single workspace that can be opened
inside Workbench. In some cases, you can open multiple tabs of the same type; for example, if you
have three Engineering Data cells in three separate systems, you can open three Engineering Data
tabs at the same time.

You can right-click tabs to Close Tab, Close Other Tabs, and Close All. You can also close individual
tabs by clicking the x icon. Only the Project tab cannot be closed.
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For a detailed list of available tabs, see Tabs in Workbench (p. 439).

Panes

Tabs in Workbench are made up of multiple panes that contain information relating to the project
shown in the tab.

Some panes are common to multiple tabs, while others are tab-specific. Some panes are only shown
in the tab for which they’ve been enabled, while others, once enabled, are shown across all the tabs
either until you either disable them or reset the tab layout.

To configure panes, see Configuring Panes (p. 29). For a detailed list of available panes, see Panes
within Tabs (p. 440).

Systems and Cells

A system is a workflow building block and is made up of one or more analysis components called
cells.

You can interact with a cell to perform any of the following actions:

• Launch an application that opens independently of Workbench

• Open a tab inside Workbench

• Add connecting systems, either upstream or downstream

• Assign input or reference files

• Assign properties to components of your analysis

Each cell has either an application or a tab associated with it. Some cells are associated with an ap-
plication that launches in a separate window, such as Fluent or Mechanical; in some cases, multiple
cells in a system can be associated with the same application. Other cells, such as the Parameters
cell or a cell in a System Coupling system, are associated with tabs that open inside Workbench.

Icons for each cell indicate the state of that particular cell, such as whether the cell requires attention,
is up-to-date, and so on. For more information, see Understanding Cell States (p. 449).

To display a quick help panel for the cell, click the blue triangle in the lower right corner of the cell
(where available). The quick help message that displays explains any immediate action that must be
taken and can include links to more detailed help.

For more information on working with systems, see Working Through a System (p. 67). For a detailed
list of cell types, see Types of Cells (p. 447).

Links

Links represent data sharing or data transfer between the systems added to the Project Schematic.

For more information on link types and working with links, see Creating Connected Systems (p. 60).

21
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

User Interface Overview



Interacting with Project Objects

The Toolbox and Project Schematic pane contain project objects such as systems, cells, and links. You
can interact with these objects in a number of different ways:

• Single-click: Selects an object. This does not modify data or initiate any action.

• Double-click: Initiates the default action from the context menu. This allows users who are familiar
with Workbench to quickly move through basic or common operations.

• Right- click: Displays a context menu applicable to the current state of the selected object. From the
context menu, you can select from multiple actions. The default action is shown in bold.

• Drag-and-drop: Previews possible locations for an object in the Project Schematic. A drag-and-drop
operation can have multiple alternative targets, depending on context and schematic complexity.
Holding down the mouse button, hover over any target to see details of how the target location
would be implemented (for example, what components would be connected after the operation is
completed).

To cancel a drag-and-drop operation, press the Esc key while holding down the mouse button.

Using Help

Workbench offers three levels of help:

• Quick Help (p. 22)

• Sidebar Help (p. 23)

• Online Help (p. 24)

Quick Help

Quick help is available for most cells in a system. Click the blue arrow in the bottom right corner of the
cell to see a brief help panel on that cell. Quick help is generally state-sensitive; as the state of a cell
changes, the content of the quick help panel updates to match. From quick help, you can also access
related help topics in the online help system.
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Sidebar Help

The Sidebar Help  pane is shown on the right side of the screen. The content of this help panel is de-
termined by the portion of the interface that has focus (that is, where the mouse was last clicked).

• If no area has focus, a user interface overview topic is displayed.

• If the Project Schematic has focus but no systems are defined, a getting started topic is displayed.

• If the Project Schematic has focus and one or more systems have been defined, links to those spe-
cific system types, as well as links to general topics are displayed.

To access the Sidebar Help pane, press F1 or, from the menu bar, select Help → Show Context Help.
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Online Help

Online help is available from the Workbench Help menu, or from any of the links in the quick help or
the Sidebar Help pane. Online help provides a comprehensive overview of all features and capabilities
and includes full search capabilities.
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Configuring Workbench
Use the following topics to configure Workbench:

Configuring the Toolbox

Configuring Units in Workbench

Configuring Panes

Configuring User Preferences

Configuring External Solvers for Use with Workbench

Customizing Workbench with Ansys ACT

Configuring the Toolbox

When you open Workbench, the Toolbox pane on the Project tab contains the systems available to
you. These are the products you have installed and for which licenses are available.

To configure the Toolbox to show only the systems you use, rather than all available systems:

1. At the bottom of the Toolbox, Click View All / Customize.

2. In the Toolbox Customization pane, deselect systems you want to hide.
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3. To close the Toolbox Customization pane, click << Back.

Configuring Units in Workbench

Workbench provides:

• Predefined unit systems that contain the most commonly used sets of units.

• The ability to define custom unit systems (p. 28) based on the predefined unit systems. (You cannot
edit or delete predefined unit systems.)

• The ability to display the following project data using the project unit system:

– Engineering data

– Parameters

– Charts.

• The ability to share the unit system between users.

Note:

Unit settings in Workbench are not passed to Fluid Flow analysis systems; to CFX, Fluent,
Results, or TurboGrid systems; or to FSI: Fluid Flow custom systems.

To open the Unit Systems dialog box, from the menu bar select Units → Unit Systems.

The Unit Systems dialog is displayed and contains the following options:
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DescriptionOption

Sets unit system for active project.

Active
Project

Sets default unit system. This will be default unit system for every project.
Default

Hides/displays unit system menu item. Only 15 unit systems can be unsuppressed and
displayed as in the Units menu.Sup-

press/Unsup-
press

Creates a custom unit system based on selected unit system.Duplicate

Deletes unit system. The following unit systems cannot be deleted:Delete

• Predefined Unit System

• Active Project Unit System

• Default Unit System

Imports a units file (*.xml).Import

Exports the active project unit system as a units file (*.xml).Export

Units

A unit system is a collection of the preferred unit for the base, common, and other quantity types.

• Base Units: All other units are derived from these units.

– Angle

– Chemical Amount

– Current

– Length

– Luminance

– Mass

– Solid Angle

– Time

– Temperature

• Common Units: These are units which are derived from the base units and are typically used as base
units for other units.

– Electric Charge

– Energy

– Force

– Power

– Pressure

– Voltage
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• Other Units: Several other units are derived from base and common units.

For a detailed description on how units are used in expressions, see Expressions, Functions, Quantities,
and Units (p. 291).

Predefined Unit Systems

Workbench offers the following predefined unit systems:

• Metric (kg, m, s, °C, A, N, V) (default unit system)

• Metric (tonne, mm, s, °C, mA, N, mV)

• U.S. Customary (lbm, in, s, °F, A, lbf, V)

• SI (kg, m, s, K, A, N, V)

• U.S. Engineering (lbm, in, s, R, A, lbf, V)

You cannot edit or delete predefined unit systems.

Workbench also provides the following additional unit systems. These are suppressed by default.

• Metric (g, cm, s, °C, A, dyne, V)

• Metric (kg, mm, s, °C, mA, N, mV)

• Metric (kg, µm, s, °C, mA, µN, V)

• Metric (decatonne, mm, s, °C, mA, N, mV)

• U.S. Customary (lbm, ft, s, F, A, lbf, V)

• Consistent CGS

• Consistent NMM

• Consistent µMKS

• Consistent BIN

• Consistent BFT

For a detailed description of unit systems for the Mechanical application, see Understanding Solving
Units in the Mechanical User's Guide.

You can also display values as defined and display values in project units. See Units Menu (p. 454) for
more information on using these options.

Custom Unit Systems

To create a custom unit system based on a predefined unit system, select the unit system and click
Duplicate.

• The default name for the new Unit system is Custom Unit System. You can change the name.

• You can change the units for any quantity type from the available list.

• The list of units that are available are either consistent with SI or US Customary, depending on the
original unit system. This to assure that a consistent unit system can be constructed for solution
purposes.
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• Changing base units can automatically change Common and Other derived units if appropriate. For
example, if the mass unit is kg, the length unit is m, and the force unit is N, then changing mass to
g and length to cm will automatically change force to dyne.

Unit Limitations

Sound Pressure Level and A Weighted Sound Pressure Level are dimensionless quantities with units dB
and dBA, respectively.

• Math operations between these two units or either of these and a numerical value will result in
a value with no unit. For example, 10 dB x 10 = 100. (no unit)

• Math operations between either of these units and a dimensional unit will result in a value with
the dimensional unit. For example, 10 dB x 10 m = 100 m.

Configuring Panes

The configuration and persistence of panes across tabs varies to give you the maximum flexibility in
customizing the information you see on each tab. The header bar of each pane contains icons and
context menus that allow you to control pane attributes such as visibility, size, and floating/docked
state. You can access the context menu either by clicking the down arrow or by right-clicking in the
header.

Some panes—for example, the Table, Chart, Outline, and Properties panes—are defined per tab, so
that changes to a pane are specific to that tab. For example, if you resize and float the Chart pane in
the Parameter Set tab and then switch to the Response Surface tab in a DesignXplorer system, the
Chart pane in the new tab is not resized and floated.

For more information on specific panes, see Panes within Tabs (p. 440).

Related topics:

Opening and Closing Panes

Hiding and Resizing Panes

Floating and Docking Panes

Resetting Panes

Opening and Closing Panes

To open a pane, from the menu bar, select View → pane name. Once the pane is open, it updates
its content according to what you’ve selected; by selecting different objects, you can view or edit the
associated properties of those objects.

To close a pane, use one of the following options:

• From the menu bar, select View → pane name to deselect it.

• Right-click the header bar of the pane and from context menu, select Close.

• From the Windowing drop-down menu on the pane header bar, select Close.
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• On the header bar, click .

Hiding and Resizing Panes

To change how the pane displays, from the pane header bar context menu or the Windowing drop-
down menu, select from the following options:

• Minimize: Displays the pane as a tab in the bottom left corner of the Workbench window. To display
the pane again, click the tab.

• Maximize: Expands the pane to its largest size.

You can only maximize a floating pane; you cannot maximize a docked pane.

• Restore: Returns the pane to its pre-maximized size and location.

To resize a pane, use your mouse to drag its edges to the desired size.

Floating and Docking Panes

By default, most panes are docked, or embedded, in their tab. You can separate a pane from its tab,
so it can be moved outside of the Workbench window. When you dock a pane, it returns to its place
on its usual tab.

When you float a pane, you separate it from its tab, so it is still available when you switch tabs. This
is especially useful when you want to see a pane that is not available as part of a tab. For example,
the Files pane is not visible in the Parameter Set tab, but you can float the Files pane so you can
see it while working with project parameters.

To float a pane, use one of the following options:

• Right-click the header bar of the pane and from context menu, select Float.

• From the Windowing drop-down menu on the pane header bar, select Float.

• On the header bar of the pane, click .

• Tear the pane from its dock by dragging the header bar of the pane to another location.

To dock a pane, use one of the following options:

• Right-click the header bar of the pane and from context menu, select Dock.

• From the Windowing drop-down menu on the pane header bar, select Dock.

• On the header bar of the pane, click .

When you dock a pane, it returns to its usual tab and may not be visible in the current tab.

Resetting Panes

You can reset the panes for one tab or for all the tabs.
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• To reset all the panes in the current tab to their default position, select View  → Reset Workspace.

• To reset all the panes in the project, select View  → Reset Window Layout. This resets the panes
in all tabs to their default positions and switches to the Project tab.

Configuring User Preferences

To set your preferences for Workbench, from the menu bar, select Tools → Options.

The preferences you set here are local settings, affecting only you. Some changes made in the Options
dialog take place immediately, while others take place after you restart Workbench.

For detailed descriptions of each preference dialog box, see Workbench User Preferences (p. 417).

Configuring External Solvers for Use with Workbench

This section describes how to set up your environment to use the Samcef and ABAQUS solvers within
Workbench.

Configuring Samcef

Configuring ABAQUS

Configuring Samcef

After installing the Samcef program, you must set the following environment variables for compatib-
ility with Workbench:

SAMTECH_LICENSE_FILE

The path to your license server or license file. See the Samcef documentation for more information.

SAM_EXE

The path to the Samcef executable folder. In a standard installation, this is the Exec folder in the
base directory of the Samcef install. For instance, if Samcef is installed at C:\Samcef, the path
to the executable folder is C:\Samcef\Exec

SAM_WORK

The path to a temporary folder for a local run of Samcef. See the Samcef documentation for more
information.

The Samcef Result Storage Configuration File

The exact results stored by the Samcef solver can be controlled using an XML configuration file.
This file uses Samcef SAI codes to define which results to write to the results file. Results are classified
by result type and category. The configuration file is located at ANSYS_IN-
STALL_DIR\v222\aisol\WBAddins\SamcefAddin\SamcefArchiveSettings.xml.

The configuration file is read when Mechanical is launched. If changes are made to the file while
Mechanical is running, Mechanical must be restarted to reflect the changes.
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The XML root element in this file is <SamcefArchiveSettings>. The child nodes of this root
element represent analysis types. The only valid child node is <Analysis>, and this child node
has the following attribute:

name (type string)

The analysis type:

• default

• modal

• non_linear

• harmonic

• thermal

The <Analysis> node can have a child node of <Output>, which has the following attribute:

type (type string)

The option type, used to order SAI codes in the solver input file:

• nodal

• elemental

The <Output> node has child nodes of <Codes> which have the following attributes:

value (type string)

List of Samcef SAI codes separated by spaces. Usually a list of integers, positive or negative.

category (type string)

Optional, used for options enable or disabled by the user.

• stress

• strain

• thermal_flux

• contact

When a solve is executed and the solver input file is created, Mechanical finds the correct <Ana-
lysis> node in the configuration file to determine the SAI codes to write to the input file. This
check is performed by finding the analysis type and whether the analysis is linear or nonlinear. The
following table describes the mapping:

<Analysis> Node UsedOptionWorkbench Analysis Type

defaultLinearStatic Structural (Samcef )

non_linearNonlinear

defaultLinearTransient Structural (Samcef )

non_linearNonlinear

modalLinearModal (Samcef )

non_linearNonlinear

harmonic-Harmonic Response (Samcef )
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<Analysis> Node UsedOptionWorkbench Analysis Type

No SAI code written-Eigenvalue Buckling (Samcef )

thermal-Steady-State Thermal (Samcef )

thermal-Transient Thermal (Samcef )

The Samcef Postprocessing Configuration File

In order to postprocess all results from the Samcef solver in the Workbench interface, an XML file
is used to map the results between Samcef and Workbench. The XML file defines all of the Workbench
result codes with associated data, and lists the corresponding Samcef codes. The configuration file
is located at ANSYS_INSTALL_DIR\v222\aisol\WBAddins\SamcefAddin\SamcefRes-
ultCodes.xml.

The configuration file is read when Mechanical starts postprocessing Samcef data. If changes are
made to the file while Mechanical is running, Mechanical must be restarted to reflect the changes.

The following is an example result as expressed in the XML configuration:

<Result result_name="U" result_id="101" data_type="nodal" out_unit="length" style="vector"
   num_comp="5" comp_labels="XYZLABELS" description="Deformations(XYZs)">
      <Codes>
           <Code name="Code 163" />
      </Codes>
</Result>

The listing provides the following information:

• The Workbench code "U" identified by Mechanical by the ID 101 is a nodal result and is interpreted
as a length.

• The result is represented in the vector style, has 5 components and is part of the XYZLABELS
group.

• The result corresponds to Samcef result code, "Code 163".

The XML Result object can have the following attributes:

result_name (type string)

The Workbench name of the result. Standard Mechanical names are reserved.

result_id (type integer)

The Workbench ID of the result. Standard Mechanical IDs are reserved; you should start num-
bering solver-specific results at 100000. You should not choose a number larger than 1000000
because those numbers are internally reserved.

data_type (type string enumerate)

The result type:

• nodal

• elem_nodal
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• elemental

out_unit (type string enumerate)

The unit type of the result. If this value is defined_per_component, the subtag <Units-
PerComponent> must be defined.

The <UnitsPerComponent> node contains individual <Component> nodes with the attributes
name and out_unit. The name attribute corresponds to the component name, and the
out_unit attribute has the same requirements as this attribute.

<UnitsPerComponent>
     <Component name="XXX" out_unit="XXX" />
     <Component out_unit="XXX" />
</UnitsPerComponent>

• no_units

• acceleration

• angle

• angular_velocity

• area

• capacitance

• charge

• charge_density

• conductivity

• current

• current_density

• density

• displacement

• electric_conductivity

• electric_field

• electric_flux_density

• electric_resistivity

• energy

• film_coeff

• force

• force_intensity

• frequency

• heat_flux

• heat_generation

• heat_rate

• inductance

• inverse_stress

• length

• magnetic_field_intensity

• magnetic_flux

• magnetic_flux_density
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• mass

• moment

• moment_inertia

• permeability

• permittivity

• poisson

• power

• pressure

• relative_permeability

• relative_permittivity

• section_modulus

• specific_heat

• specific_weight

• shear_strain

• stiffness

• strain

• stress

• strength

• thermal_expansion

• temperature

• time

• velocity

• voltage

• volume

• gasket_stiffness

• moment_inertia_mass

• psd_acceleration

• psd_acceleration_grav

• psd_displacement

• psd_velocity

• rotational_damping

• rotational_stiffness

• translational_damping

• angular_acceleration

• seedbeck_coefficient

• decay_constant

• fracture_energy

• shock_velocity

• energy_density_mass

• electric_conductance_per_unit_area

• psd_stress

• psd_strain

• psd_force
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• psd_moment

• psd_pressure

• force_per_angular_unit

• impulse

• impulse_per_angular_unit

• temperature_difference

• material_impedance

• rs_acceleration

• rs_acceleration_grav

• rs_displacement

• rs_velocity

• warping_factor

• thermal_conductance

• inverse_length

• inverse_angle

• thermal_capacitance

• normalized_value

• mass_flow_rate

• unitless

• stress_intensity_factor

• sqrt_length

• energy_per_volume

• thermal_gradient

style (type string enumerate)

The style of the value:

• scalar

• vector

• tensor

• tensor_strain

• euler_angles

• coordinate

• shear_moment_diagram

num_comp (type integer)

Number of components, between 1 and the length of comp_labels.

comp_labels (type string enumerate)

The component labels:

• XYZLABELS

• STRESSLABELS

• CONTACTLABELS

• BEAMLABELS
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• GASKETLABELS

• NLLABELS

• MISCLABELS

• SENGLABELS

• SPRINGLABELS

• BEAM188LABELS

• RADIOSITYLABELS

• EULERLABELS

• BEAMRXLABELS

• THERMALMASSLABELS

• SHELLMBPLABELS

• SLASHPNUMLABELS

• CINTLABELS

• PRIN_S_LABELS

• PDMG_LABELS

• PFC_LABELS

• CDM_LABELS

• CONTDEBONDLABELS

• BEARINGLABELS

• BLANKLABELS

description (type string)

Free text.

Once the <Result> node is defined, the <Codes> node with the individual <Code> child nodes
are defined. The <Codes> node can have the following attributes:

hasShell (type string)

If present and value = true, the layer attribute should be defined.

layer (type integer)

Only necessary if hasShell is set to true.

• 1 - bottom

• 2 - middle

• 3 - top

Note:

It is possible to have a <Codes> node without any child <Code> nodes. It can be used
to define a result with layers but no associated codes for those layers, for example
TEMP_UPSHELL.

The <Code> child nodes can have the following attributes:

37
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Configuring External Solvers for Use with Workbench



name (type string)

Value of the Samcef solver code, generally of the form "Code XXX" or "Sdb XXX".

module (type string)

Optional, if set, defines the code only for a specific Samcef module. Possible values are:

• ba - bacon

• me - mechano

• as - asef

• st - stabi

• dy - dynam

• mt - mechano/thermal

• re - repdyn

Limitations

• If the XML of the configuration file is missing or not well-formed, no results are available.

• If a result has invalid syntax (missing XML components, invalid attributes), it is not available.

• Mechanical must be restarted if any changes are made to the result configuration file during
operation.

Configuring ABAQUS

ABAQUS version 6.14 is supported.

After installing ABAQUS, you must configure the ANSYS_INSTALL_DIR\v222\aisol\WBAd-
dins\AbaqusAddin\config.xml file in order to postprocess results. Edit the config.xml file
with a text editor, and specify the version of ABAQUS you have installed:

<AbaqusVersion version="6.14-3">

If more than one version of ABAQUS is installed on your machine, the paths to the version configured
for use with Workbench must appear first in your PATH environment variable.

Assuming ABAQUS is installed at C:\SIMULIA\Abaqus, for ABAQUS 6.14-3, the PATH environment
variable must contain:

• C:\SIMULIA\Abaqus\Commands

• C:\SIMULIA\Abaqus\6.14-3\code\bin

• C:\SIMULIA\Abaqus\6.14-3\tools\SMApy\python2.7\Lib

If the ABAQUS version installed does not match the version specified in the config.xml file,
Mechanical returns an error when trying to postprocess the ODB result file.
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The ABAQUS Result Storage Configuration File

The exact results stored by the ABAQUS solver can be controlled using an XML configuration file.
This file uses ABAQUS Program Controlled codes to define which results to write to the results file.
Results are classified by result type and category. The configuration file is located at ANSYS_IN-
STALL_DIR\v222\aisol\WBAddins\AbaqusAddin\AbaqusArchiveSettings.xml.

The configuration file is read when Mechanical is launched. If changes are made to the file while
Mechanical is running, Mechanical must be restarted to reflect the changes.

The XML root element in this file is <AbaqusArchiveSettings version="1">. The child
nodes of this root element represent analysis types. The only valid child node is <Analysis>, and
this child node has the following attribute:

name (type string)

The analysis type:

• struct

• eigen

• thermal

The <Analysis> node can have a child node of <Output>, which has the following attribute:

type (type string)

The option type, used to order codes in the solver input file:

• nodal

• elemental

• contact

• energy

• radiation

The <Output> node has child nodes of <Codes> which have the following attributes:

value (type string)

List of ABAQUS codes separated by spaces. Usually a list of integers, positive or negative.

position (type string)

For elemental results, if a result exists with a matching position, it is used. Otherwise results
without position are used.

category (type string)

Optional, used for options enable or disabled by the user.

• stress

• strain

• thermal

• contact
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When a solve is executed and the solver input file is created, Mechanical finds the correct <Ana-
lysis> node in the configuration file to determine the SAI codes to write to the input file. This
check is performed by finding the analysis type and whether the analysis is linear or nonlinear. The
following table describes the mapping:

<Analysis> Node UsedWorkbench Analysis Type

structStatic Structural (ABAQUS)

structTransient Structural (ABAQUS)

eigenModal (ABAQUS)

thermalSteady-State Thermal (ABAQUS)

thermalTransient Thermal (ABAQUS)

The ABAQUS Postprocessing Configuration File

In order to postprocess all results from the ABAQUS solver in the Workbench interface, an XML file
is used to map the results between ABAQUS and Workbench. The XML file defines all of the Work-
bench result codes with associated data, and lists the corresponding Samcef codes. The configuration
file is located at ANSYS_INSTALL_DIR\v222\aisol\WBAddins\AbaqusAddin\VkiAbaqus-
ResultCodes.xml.

The configuration file is read when Mechanical starts postprocessing ABAQUS data. If changes are
made to the file while Mechanical is running, Mechanical must be restarted to reflect the changes.

The following is an example result as expressed in the XML configuration:

<Result result_name="U" result_id="101" data_type="nodal" out_unit="length" style="vector"
   num_comp="5" comp_labels="XYZLABELS" description="Deformations(XYZs)">
      <Solver name="Abaqus">
           <Code name="U" />
      </Solver>
      <vki vki_root_name="D" />
</Result>

The listing provides the following information:

• The Workbench code "U" identified by Mechanical by the ID 101 is a nodal result and is interpreted
as a length.

• The result is represented in the vector style, has 5 components and is part of the XYZLABELS
group.

• The result corresponds to vki result "D", which comes from ABAQUS code "U".

The XML Result object can have the following attributes:

result_name (type string)

The Workbench name of the result. Standard Mechanical names are reserved.
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result_id (type integer)

The Workbench ID of the result. Standard Mechanical IDs are reserved; you should start num-
bering solver-specific results at 100000. You should not choose a number larger than 1000000
because those numbers are internally reserved.

data_type (type string enumerate)

The result type:

• nodal

• elem_nodal

• elemental

out_unit (type string enumerate)

The unit type of the result:

• no_units

• acceleration

• angle

• angular_velocity

• area

• capacitance

• charge

• charge_density

• conductivity

• current

• current_density

• density

• displacement

• electric_conductivity

• electric_field

• electric_flux_density

• electric_resistivity

• energy

• film_coeff

• force

• force_intensity

• frequency

• heat_flux

• heat_generation

• heat_rate

• inductance

• inverse_stress

• length

• magnetic_field_intensity

• magnetic_flux
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• magnetic_flux_density

• mass

• moment

• moment_inertia

• permeability

• permittivity

• poisson

• power

• pressure

• relative_permeability

• relative_permittivity

• section_modulus

• specific_heat

• specific_weight

• shear_strain

• stiffness

• strain

• stress

• strength

• thermal_expansion

• temperature

• time

• velocity

• voltage

• volume

• gasket_stiffness

• moment_inertia_mass

• psd_acceleration

• psd_acceleration_grav

• psd_displacement

• psd_velocity

• rotational_damping

• rotational_stiffness

• translational_damping

• angular_acceleration

• seedbeck_coefficient

• decay_constant

• fracture_energy

• shock_velocity

• energy_density_mass

• electric_conductance_per_unit_area

• psd_stress

• psd_strain
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• psd_force

• psd_moment

• psd_pressure

• force_per_angular_unit

• impulse

• impulse_per_angular_unit

• temperature_difference

• material_impedance

• rs_acceleration

• rs_acceleration_grav

• rs_displacement

• rs_velocity

• warping_factor

• thermal_conductance

• inverse_length

• inverse_angle

• thermal_capacitance

• normalized_value

• mass_flow_rate

• unitless

• stress_intensity_factor

• sqrt_length

• energy_per_volume

• thermal_gradient

style (type string enumerate)

The style of the value:

• scalar

• vector

• tensor

• tensor_strain

• euler_angles

• coordinate

• shear_moment_diagram

num_comp (type integer)

Number of components, between 1 and the length of comp_labels.

comp_labels (type string enumerate)

The component labels:

• XYZLABELS

• STRESSLABELS

• CONTACTLABELS
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• BEAMLABELS

• GASKETLABELS

• NLLABELS

• MISCLABELS

• SENGLABELS

• SPRINGLABELS

• BEAM188LABELS

• RADIOSITYLABELS

• EULERLABELS

• BEAMRXLABELS

• THERMALMASSLABELS

• SHELLMBPLABELS

• SLASHPNUMLABELS

• CINTLABELS

• PRIN_S_LABELS

• PDMG_LABELS

• PFC_LABELS

• CDM_LABELS

• CONTDEBONDLABELS

• BEARINGLABELS

• BLANKLABELS

is_membrane (type boolean)

If this attribute is present and marked true, the result is only added if the model has a membrane.

is_six_dof (type boolean)

Optional, applies for only "R" and "M" type Mechanical results.

description (type string)

Free text.

The <Solver> node references the solver used by the attribute name. All child <Code> nodes
are the codes associated to the Workbench result for this solver. A code is an alphanumerical string
referred by attribute name. It is possible to define several codes for the same solver.

The <vki> node is another way to match the solver result. This node has the following attributes:

vki_root_name (type string)

The vki root name as described in the documentation/API.
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vki_aux_name (type string)

Only required if vki_root_name is set to UNKNOWN. Matches the vki result in case of unknown
vki type.

Note:

If solver-specific data and vki data are fulfilled for a specific result, Mechanical will first
try to match the vki code. If it is not found, it will try to match the solver-specific code.
For example, when reading a result file, the vki dataset E_ELAST is found, with solver-
specific data EE. Mechanical looks for a Workbench result having vki root name E_ELAST.
If not found, it looks for a Workbench result having Abaqus code EE.

Limitations

• If the XML of the configuration file is missing or not well-formed, no results are available.

• If a result has invalid syntax (missing XML components, invalid attributes), it is not available.

• Mechanical must be restarted if any changes are made to the result configuration file during
operation.

The following results don't appear in the XML file, as they have behavior which is not compatible:

• SERR - not associated to VKI or ABAQUS, is available if S and SVOLU are also available.

• NDIR, EDIR - not associated to VKI or ABAQUS, is available if the model contains shells.

Customizing Workbench with Ansys ACT

With Ansys ACT, you can create extensions to customize supported Ansys products, including Workbench.

ACT provides three levels of Workbench customization:

• Feature Creation

Feature creation is the direct, API-driven customization of an Ansys product. In addition to leveraging
the functionality already available in Workbench, ACT enables you to add functionality and operations
of your own. Examples of feature creation include the creation of custom loads and geometries, the
addition of custom preprocessing or postprocessing features, and the integration of third-party
solvers, sampling methods, and optimization algorithms.

For general feature creation information, see Feature Creation in the ACT Developer's Guide. For
Workbench-specific feature creation information, see Workbench Feature Creation in the ACT Custom-
ization Guide for Workbench.

• Simulation Workflow Integration

Simulation workflow integration is the incorporation of external knowledge such as apps, processes,
and scripts into the ANSYS ecosystem. Using ACT, you can customize simulation workflows in the
Workbench Project tab.
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For example, you can create custom task groups (systems) and custom tasks (components) for insertion
in the Project Schematic, constructing consistent and cohesive simulation workflows that allow your
business-specific elements to coexist and interface with pre-built Ansys solutions.

For components that support updates in Remote Solve Manager (RSM), you can use ACT to configure
job submission options for remote and background updates.

For more information, see Simulation Workflow Integration and Simulation Workflow Integration Ex-
amples in the ACT Customization Guide for Workbench.

Process Compression

Process compression is the encapsulation and automation of existing processes available in an Ansys
product. The result is a wizard that provides guidance within the product workflow, walking the end
user step-by-step through a simulation. You can create single wizards to run in the Workbench Project
tab or mixed wizards to be run across several Ansys products.

Wizards allow you to leverage both the existing functionality of Workbench and the scripting capab-
ilities of the Workbench framework API. With a wizard, you can manipulate existing features and
simulation components, organizing them as needed to produce a custom automated process. You
can also customize the user interface of a wizard as a whole and define layouts for individual interface
components.

For general wizard information, see Simulation Wizards in the ACT Developer's Guide. For Workbench-
specific wizard information, see Workbench Wizards in the ACT Customization Guide for Workbench.
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Creating, Opening, and Importing Projects and Files
When you start Workbench, or open a project in Workbench, it opens to the Project tab. The Project
tab is the main workspace where you build your analysis.

Like all tabs, the Project tab is made up of different panes that can be reconfigured according the in-
formation you want to see. By default, the Project tab has the Toolbox pane and the Project Schem-
atic pane.

You can start adding systems to the Project Schematic immediately or you can create, open, or import
a project.

Related topics:

Creating a New Project

Opening an Existing Project or File

Importing Files
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Importing Legacy Databases

Creating a New Project

When Workbench opens, it displays a blank Project Schematic that you can start adding systems to.
If you need to open a new blank Project Schematic, you can create a new project.

To create a new project:

1. From the menu bar, select File → New.

If you have added a system to the Project Schematic, the following message is displayed:

The project has been modified. Do you want to save it?

2. To save the modified project before opening the new one:

a. From the dialog box, select Yes.

b. Type a name for the project.

c. Browse to the location you want to save the project in.

d. Click Save.

To delete the project, click No.

Opening an Existing Project or File

You can open a previously saved project or file to continue working with it.

On Windows systems, you can also double-click a .wbpz archive file from the directory it is saved in
to open the archive.

If you have deleted any project files through the file system and not through the Workbench interface,
you may see a warning message when you attempt to open the project. The error message lists the
missing files. The corrective action depends on the type of files that are missing:

• For files that are programmatically integrated with Workbench (such as database files, geometry files,
engineering data files, application-generated files, and so on), open the Files pane and use the context
menu to repair a file or permanently remove it (p. 276) from the project’s Files list if it is no longer
needed. Repairing these types of files should be done carefully; it is possible to use files or file types
that are not similar to the original. Missing or erroneous files can cause unintended consequences
for project stability and usability.

• For files that are not programmatically integrated with Workbench (such as user-supplied input files,
dpn files, and so on), you can replace them using your file system and then open the project again.
These files may not be necessary for the project; in this situation, you can safely ignore the warning
message.

To open an existing project:
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1. From the menu bar, select File → Open.

2. Optionally, select a file type from the file selection filter list.

• Workbench Files (*.wbpj, *.wbpz, *.wbjn)

• Project Files (*.wbpj)

• Archive Files (*.wbpz)

• Journal Files (*.wbjn)

• Python Script Files (*.py)

• All Files (*.*)

3. Browse to the file location.

4. Select the file to open.

5. Click Open.

6. If you are opening an archive file (*.wbpz), browse to the location where you would like to extract
the archive to and click Save.

Importing Files

When working on a Workbench project, you may need to import files such as input files, existing mesh
files, and geometries.

When you edit an imported file, Workbench saves a copy of the file to the project directory, rather than
overwriting the original file. This process ensures that your original files are never compromised.

Importing an archived project adds the data contained in the project to the currently-loaded project.
Systems in the imported project are added to the schematic, along with all the data they contain. The
connections between imported systems are kept, but no connections are made to the systems in the
existing project by the import process.

Older archived projects containing Ansoft systems cannot be imported. To import these projects, re-
archive the project from the current version first.

To import files:

1. Select File > Import. There is also a Import option on the Project tab.

2. Optionally, specify a desired file type from the file selection filter list. File types include:

• NASTRAN File (*.nas)• Workbench Project Archive Files (*.wbpz)

• Workbench R10/11 Project (*.wbdb) • NASTRAN Data File (*.dat)

• ABAQUS Input (*.inp)• Importable Mechanical File (*.dsdb, *.mechdat)
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• Fluent Mesh File (*.msh) • LS-DYNA Input File (*.k and *.key)

• Ansys Amco File (*.acmo)• Importable Mesh File (*.cmdb, *.meshdat)

• Engineering Data File (*.xml, *.engd) • ICEM CFD Project (*.prj)

• BladeGen File (*.bgd)• Geometry File (*.sat, *.sab, *.ant, *pmdb, *.agdb, *.model, *.exp, *.session,
*.div, *CATPart, *CATProduct, *.3dxml, *.ipt, *.iam, *.jt)

• AQWAWB Database (*.aqdb)

AUTODYN Save File (*.ad)
• FEModeler Database (*.fedb)

• Mechanical APDL CDB (*.cdb)
• CFX-Pre-Case File (*.cfx)

• ICEM CFD Mesh File (*.uns)
• CFX-Solver Input File (*.def, *.mdef)

• Fluent Case File (*.cas)
• CFX-Solver Results File (*.res, *.bak, *.mres, *.trn)

• NASTRAN Bulk Data File (*.bdf)

3. Browse to the file location.

4. Select the file to import.

5. Click Open.

All data for the current design point is imported; systems that were up-to-date in the archive are up-
to-date after import and contain any generated results. User files in the imported project are added to
the current project and are renamed if needed to avoid conflicts with existing files.

Parameters from the imported project are added to the parameter set. If the imported project contains
design points, those design points are added to the design point table, using the current parameter
values from the existing project. Retained design point files from the imported project are not added
to the new project. However, if the archived project to be imported contains DX systems, the DX systems
are not imported, although the other systems in the project are imported.

Importing Legacy Databases

Workbench offers several methods to import databases from earlier releases:

• Context Menu Import: Create the appropriate system and cell in the Project Schematic, right-click
the cell, and import the file into the cell from the context menu.

• File Import: From the menu bar, select File → Import, then select the file to import. The proper
systems and cells are created and populated with the data from the imported file. You can also drag-
and-drop one or multiple files from Windows Explorer onto the Project Schematic. These files are
treated as if they were imported.

• Project Import: From the menu bar, select File → Import, then select the project to import. All ne-
cessary systems, cells, and links are established and populated with data from the various files that
made up the earlier release's project.
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In each of these cases, you must launch the associated application to use the imported file, which is
typically the same application that was used to edit the file in the earlier release. The imported files are
not undergoing any transformation in this release of Workbench; rather, access to the files is being co-
ordinated through the Project Schematic interface.

Not all products/databases use all of these methods.

DesignXplorer Release 11 (.dxdb) file import is not supported; however, basic parameter import is
supported.

The following table shows which applications can use the three methods described above.

Project ImportFile ImportContext Menu
Import

Application

XAnsys Workbench, Release 10 or 11 (.wbdb)

XXMechanical (.dsdb)

X

(except
convections

Engineering Data (.eddb)

and load
histories)

XEngineering Data (.xml, .engd)

XXAnsys Aqwa, Release 12 only (.aqdb)

XXAutodyn (.ad)

XMechanical APDL (.inp, .dat, .cdb, .mac,
.anf)

XXXDesignModeler (.agdb)

XXMeshing (.cmdb)

XFluent (.msh, .cas, .dat)

XXCFX (.cfx, .def, .res)

XXBladeGen (.bdg)

Additional Mechanical Application Import Details

• Any .dsdb files and .wbdb project files created in Release 11 or earlier containing items that convert
into Mesh or Mechanical systems cannot be imported. To import these files, import them first into a
version between Release 12 and 19.2, save as file in that version, and then import into Release 2022
R2.

• Legacy .dsdb files that contain multiple models are split into multiple files.

• .dsdb files become .mechdb files internally.

• Separate systems are created to correspond to each of the Release 11 environments. Environments
that use the same geometry and model are represented with a link between the Geometry and
Model cells of the systems. Physics environments are typically represented as a link between a
Solution cell of the originating system and the Setup cell of the receiving system. For example, a
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thermal condition is represented by a connection between the Solution cell of a thermal system and
the Setup cell of a structural system.

• Information that is transferred from the Release 11 system to the current system includes:

– Model name

– Model state

– Physics type

– Internal IDs for model, mesh, environment, and answer set

– Engineering Data file path

– Material property suppression path

– Solver files directory path

– Solver type

– Geometry preferences

– Parameters

• Legacy .dsdb files that do not contain an environment are imported as Mechanical Model (p. 197)
systems.

• When you import a database that does not include a result file (such as .mechdat files), certain
Mechanical result-based features may be lost. For example, if no result file is available:

– Results do not deform or animate properly.

– A Harmonic Acoustics environment has multiple RPM values selected. The Tabular Data for a result
lists all frequencies in the analysis, not just the frequencies in the selected RPM Set Number.

Additional Aqwa Import Details

• Only Ansys Aqwa Release 12 databases can be imported. More recent versions are not imported
correctly and may cause functional issues.

• An Aqwa Release 12 database is imported as a standalone Hydrodynamic Diffraction system.

• If the Release 12 database contains multiple analyses, they are converted into multiple Hydrodynamic
Diffraction systems.

• Geometry associated with the legacy database is associated with the Geometry cell of the Hydro-
dynamic Diffraction system and is editable.

Additional Autodyn Import Details

Links are not created when Autodyn files are imported from Release 11.0.
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Additional CFX Import Details

• If CFX files are included in the .wbdb project, they appear in the Files pane, but system or links as-
sociated with these files are not created. To create a CFX system and import the selected file, select
Import to Schematic from the Files pane. This creates a CFX system and imports the selected file.

• You can import CFX-Solver .bak files or full .trn files into the Project Schematic so that you can
postprocess results for debugging when a run fails. You may find it useful to use full .trn files as a
backup mechanism because all timesteps are retained, instead of just the most recent ones, and it
is easier to postprocess multiple timesteps.

Additional DesignModeler Import Details

• DesignModeler files (.agdb) can be imported through context menu import.

• .agdb and .modeldv files can be imported by selecting File → Import.

• Links with other cells are automatically generated when .agdb files that are present in the Release
11.0 .wbdb project are imported into the appropriate system (Mechanical Model or other appropriate
system).

• Parameters contained in the .agdb file are not immediately published to the Project Schematic
interface. They are published when the DesignModeler application is opened.

• CAD files that were imported into the .agdb are not immediately registered in the Files pane of the
Project Schematic. Registration of these files occurs when the DesignModeler application is opened.

Additional Meshing Import Details

• .cmdb files from Release 10 that contain CFX-Mesh data are not supported. To import these files,
import them first into Release 11, save as a Release 11 file, and then import into Release 2022 R2.

• Links with other cells are automatically generated when .cmdb files that are present in the Release
11.0 .wbdb project are imported into the appropriate system (Mechanical model or other appropriate
system).

• CFX-Mesh files (.gtm, .cfx) can be imported via context menu import from the Mesh cell of a Mesh
system.
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Adding Systems to the Project Schematic
In the Project tab, you take systems from the Toolbox and add them to the Project Schematic. Projects
can vary in complexity, from a single system representing all the necessary steps for a desired analysis,
to a complex set of connected (linked) systems representing coupled analyses or variations in modeling
approaches.

Note:

We recommend that a project contain only systems that are relevant to a specific analysis
or coupled analysis with a well-defined focus. Adding systems for multiple unrelated analyses
to the same project can have an adverse effect on performance and cause corruption with
portions of the project.

Most analysis systems are defined by three primary attributes: physics type, analysis type, and solver
type. Workbench uses these attributes to determine valid data transfer and system replacement possib-
ilities. For more information on the types of systems, see Working Through a System (p. 67).

Related topics:

System Placement

Adding a System by Double-Clicking

Adding a System using Drag-and-Drop

Adding a System using the Context Menu

Adding Multiple Independent Systems

Creating Connected Systems

System Placement

Systems are added from left-to-right, and from top-to-bottom. All data transfer occurs from left (upstream)
to right (downstream); you cannot transfer data from right to left.

When placing or moving systems, it is important that you place receiving systems to the right of
sending systems. All processing of data (such as updates) also occurs in the same direction, from left-
to-right and top-to-bottom.
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Adding a System by Double-Clicking

The simplest way to add a new system to the Project Schematic is to double-click the system in the
Toolbox.

The system is placed in a new row in the Project Schematic, below any existing systems.

The following Show-Me animation is presented as an animated GIF in the online help. If you are reading the
PDF version of the help and want to see the animated GIF, access this section in the online help. The interface
shown may differ slightly from that in your installed product.
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Adding a System using Drag-and-Drop

You can add a system to the Project Schematic by dragging it from the Toolbox and dropping it in
the desired location. This method provides a preview of possible target locations, allowing you to choose
the best location for that system.

To add a system using drag-and-drop:

1. In the Toolbox, click the required system.

2. Holding down the mouse button, drag the system over to the Project Schematic.

3. Hover the mouse over the green drop targets to see the result of dropping the system in that
location.

The drop target turns red when the mouse is over the target. In cases where the new system can
be linked to one or more existing systems, drop targets are also shown on the eligible cells of the
existing systems.

4. Release the mouse button to place the system onto the drop target.

Note:

When you attempt to add an invalid system (for example, if the mesh type is not compatible
with the system you are attempting to add), the drop target preview will be visible, but the
system is not added when you release the mouse. Details are written to the Messages
pane (p. 446).

The following Show-Me animation is presented as an animated GIF in the online help. If you are reading the
PDF version of the help and want to see the animated GIF, access this section in the online help. The interface
shown may differ slightly from that in your installed product.
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Adding a System using the Context Menu

The context menu includes a list of available systems, divided into categories. From this list, you can
browse and select a system to add to the Project Schematic.

The available systems in this list reflect your Toolbox configuration (p. 25).

To add a system using the context menu:

1. Right-click the white space in the Project Schematic.

2. From the context menu, select New category Systems  → system name.
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Adding Multiple Independent Systems

Independent systems are systems on the Project Schematic that are not connected to other systems
by data links. Multiple independent systems can be used to keep the analyses for related but separate
components within the same project (for example, two parts of the same vehicle). You may also want
to create independent systems if you are analyzing the same model but using different solvers to
compare the results, or are using different editors on independent yet related data (for example, you
are using Mechanical APDL on an independent input file, and using Mechanical on a geometry file that
has related origins to the input file of the Mechanical APDL system).

You can create a new independent system using either of the following methods:

• Double-click the desired system (p. 56).

The new system is created on the Project Schematic below an existing system and is not linked to
any existing system.

• Drag-and-drop the desired system (p. 57).

When you drag the system from the Toolbox and move it over the Project Schematic, a preview of
all possible drop targets is shown. Drop the system on a target that displays the message Create
standalone system.
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Creating Connected Systems

Connected systems are systems on the Project Schematic that are connected together by data links
so data can be shared and/or transferred between the two systems. You can use connected systems
for sequential physics coupling (for example, thermal-stress) or for sequential simulation steps, such as
a pre-stress modal (stress analysis followed by modal), mode-superposition (modal followed by harmonic),
and so on. You can either create connections between existing systems or create a new system that is
connected to an existing system.

Link Types

Links connecting systems represent data sharing or data transfer between the systems. The following
table provides descriptions of links used in the Project Schematic.

DescriptionImageLink
Name

Data is shared between systems.Shared
data

Data is transferred from an upstream system
to a downstream system.

Data
transfer

A system is consuming input parameters.
These links connect systems to the Paramet-
er Set bar.

Input
parameters
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DescriptionImageLink
Name

A system is providing output parameters.
These links connect systems to the Paramet-
er Set bar.

Output
parameters

A Design Exploration system is connected
to project parameters. These links connect

Design
Exploration
system Design Exploration systems to the Paramet-

er Set bar.

Design point data is transferred from a
Design Exploration component to a Design

N/ADesign
point
data Exploration Direct Optimization system. For

more information, see Transferring Design
Point Data for Direct Optimization in the
DesignXplorer User's Guide.

System Highlighting

To trace how data is shared and/or transferred between systems, click a system cell. The shared data
and data transfer links connected from this cell to upstream and downstream systems are highlighted,
allowing you to easily see how the data in this cell is connected to other systems in the project.

The following Show-Me animation is presented as an animated GIF in the online help. If you are reading
the PDF version of the help and want to see the animated GIF, access this section in the online help. The
interface shown may differ slightly from that in your installed product.
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Connecting Two Existing Systems

You can connect systems on the Project Schematic by linking one or more component cells (for
example, a Geometry cell and/or an Engineering Data cell) from one system to eligible cells in an-
other system.

To connect two existing systems:

1. To preview possible drop targets, drag a cell from the source system and hold it over cells in the
target system.

2. Drop the system on the target best suited to your engineering goals.

Data transfer links are displayed between the connected cells.

Creating a New Connecting System

When you create a new system that is connected to an existing system, Workbench generates data
shares and/or data transfers between the systems to achieve a compound analysis. In this case, the
two systems are then interdependent.

The new system can be created either upstream (the new system provides inputs to the existing
system) or downstream (the new system receives inputs from the new system) of the existing system.
The system receiving input is also called the dependent system. To create a new connected system,
you can either a drag-and-drop the new system or use the Transfer Data context-menu option.
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Connecting a New System Using Drag-and-Drop

You can use drag-and-drop functionality to create a new dependent system.

To drag-and-drop a new connected system:

1. Drag a system from the Toolbox to the Project Schematic.

2. Move the new system over cells in the existing system to preview available drop targets.

3. Drop the system on the desired target.

The new system is created downstream on the Project Schematic.

The following animation demonstrates the various drop targets and their results. For example, se-
lecting the Geometry cell as the drop target results in a second system that shares the Engineering
Data and Geometry data. Selecting the Model cell as the drop target results in a second system
that shares the Engineering Data, Geometry and Model data. The preview for each drop target in-
dicates how the new system will be connected to the existing one.

If you select the Solution cell as the drop target, the preview displays the text Share A2:A4
Transfer A6, meaning that the data for cells A2, A3, and A4 (Engineering Data, Geometry, and
Model in the following animation) would be shared, and data from cell A6 (in this case, Solution)
would be transferred as input to the new system. It is important to review each potential drop
target carefully to ensure that you select the target that best suits your needs. Note that in addition
to the red, linked drop targets, you can also preview the green independent drop targets.

The following Show-Me animation is presented as an animated GIF in the online help. If you are reading
the PDF version of the help and want to see the animated GIF, access this section in the online help.
The interface shown may differ slightly from that in your installed product.
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Connecting a New System Using Transfer Data

The Transfer Data options available in the context menu allow you to select a cell in an existing
system and create a new system either upstream or downstream of that system.

To transfer data to a new connected system:

1. Right-click the target cell in the existing system.

2. Select from the following options:

• To create the new system upstream of the existing system (so the existing system is depend-
ent), select Transfer Data from New from the context menu. Select your new system from
a list of all possible analysis types that can provide data to the existing cell.

• To create the new system downstream of the existing system (so the new system is depend-
ent), select Transfer Data to New from the context menu. Select your new system from a
list of all possible analysis types that can accept data from the existing cell.

When using either of the Transfer Data options, all possible cells are shared, up to the position of
the selected cell.

The following Show-Me animation is presented as an animated GIF in the online help. If you are reading
the PDF version of the help and want to see the animated GIF, access this section in the online help.
The interface shown may differ slightly from that in your installed product.
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Deleting Links

In most cases, you can delete links by right-clicking the link and selecting Delete from the context
menu. The data associated with the cell in the upstream system is copied to the downstream system
so the cells can be edited independently.

In some cases (for example, links between two mechanical model cells), you cannot delete shared
data links. In these cases, the linked cells in the downstream system have a gray background (as
shown in the following image).
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Working Through a System
Workbench provides you with a straightforward workflow for creating and working through a system.
First, you select a system from the Toolbox and add it to the Project Schematic (see Adding Systems
to the Project Schematic (p. 55)). Then you work through the cells in the system, generally from top-
to-bottom, until you have completed all the required steps for your analysis.

In most cases, data flows from top-to-bottom through the system, as well. For example, in a Mechanical
system, the geometry must be defined before you can define the model; the Model cell uses the geo-
metry defined in the Geometry cell as its input.

Because the workflows for different types of analyses differ to some degree, we have included two
typical examples of working with analysis systems: one for a mechanical analysis and one for a fluid
flow analysis.

Related topics:

Understanding Data Flow

Defining your Simulation Geometry

Basic Mechanical Analysis Workflow

Basic Fluid Flow Analysis Workflow

Analysis Systems

Component Systems

Custom Systems

Design Exploration

Submitting Solutions

Opening Mechanical without a License (Read-Only Mode)

Understanding Data Flow

To complete your analysis, you work downward through each cell in order. In general, data flows
downstream (from top-to-bottom within systems and from left-to-right across systems). Output data
from upstream component cells is provided as the input data for downstream cells. Output data from
certain types of cells in one system can also be transferred and/or shared with cells in another system.

The following example shows two systems in the Project Schematic, a Fluid Flow (Fluent) system
(system A) and a Static Structural system (system B).

67
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.



The geometry from the Geometry cell in system A becomes the input for the Mesh cell of system A.
The mesh generated in the Mesh cell of system A, in turn, becomes input to the downstream Setup
cell of system A, and so on.

Data also flows between system A and system B. These two systems share the same geometry, as indic-
ated by the blue link with the square terminator between the Geometry cell in system A and the
Geometry cell in system B.

Solution data from System A is provided to the Setup cell of system B, as indicated by the fuchsia
connector with the round terminator.

At a glance, you can see the data relationship between the two types of analysis systems.

Defining your Simulation Geometry

All analysis systems and several component systems begin with a geometry-definition step. You can
define the geometry differently depending on the type of simulation you are running. In most cases,
you use the Geometry cell. With the Geometry cell, you can:

• Create a geometry in DesignModeler or SpaceClaim.

• Import an existing geometry:

– From neutral formats such as IGES, STEP, Parasolid, and ACIS.

– From CAD files.

– From a CAD session running on the same machine.

– From ECAD files.

For Fluid Flow simulations, you can also start with an imported mesh or case file; see Basic Fluid Flow
Analysis, Starting from an Imported Mesh (p. 73) for details.
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To specify the geometry using the context menu:

1. Right-click the Geometry cell.

2. Select New DesignModeler Geometry or New SpaceClaim Geometry to launch those respective
programs and create a new model or select Import Geometry and browse to an existing CAD
model.

Alternatively, you can also launch Workbench directly from some CAD systems. When doing so, Work-
bench starts with a Geometry system in place and the CAD file already attached.

After you have attached or imported your geometry, the state appears as Up to Date (p. 449), and the
icon indicates the type of file imported. Geometry types include:

ACIS (.sat)

ANSYS Neutral File (.anf)

Autodesk Inventor (.ipt, .iam)

BladeGen (.bgd)

CATIA v4 (.model, .dlv)

CATIA v5 (.CATPart, .CATProduct)

Creo Elements/Direct Modeling (.pkg, .bdl, .ses, .sda, .sdp, .sdac, .sdpc)

Creo Parametric (formerly Pro/ENGINEER) (.prt, .asm)

DesignModeler (.agdb)

IGES (.iges, .igs)

JT Open (.jt)

Monte Carlo N-Particle (.mcnp)

NX (.prt)

Parasolid (.x_t, .xmt_txt, .x_b, .xmt_bin)

Solid Edge (.par, .asm, .psm, .pwd)

SOLIDWORKS (.SLDPRT, .SLDASM)
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SpaceClaim (.scdoc)

STEP (.stp, .step)

Stereolithography (.stl).

No file imported.

If you do not need to make any additional changes to your geometry, you can continue working through
the analysis as described in the next sections.

If your geometry must be modified before continuing with your analysis, you can edit the geometry in
DesignModeler or SpaceClaim. After modifying the geometry, the icon in the Geometry cell changes
to the icon of the application you used to make those modifications. For a file imported and then
modified in DesignModeler, you can open the file in DesignModeler, and the DesignModeler model
tree indicates the original source of the geometry.

After the geometry is defined, you can share it with other systems. See Data Sharing and Data Transfer
for more information on sharing geometry systems.

For detailed CAD-related information specific to the Ansys DesignModeler application and Workbench,
see CAD Integration.

Basic Mechanical Analysis Workflow

After introducing a new Mechanical analysis system to the Project Schematic and assigning an appro-
priate name, the focus is typically directed to the Geometry cell, because this is usually the first cell in
the system that requires user input. You can edit or define material models in the Engineering Data
cell, but this example assumes that the default materials are sufficient.

Important:

You are not required to define a geometry. You can open Mechanical without an attached
geometry. You can simply skip the step of specifying a geometry and open Mechanical. This
can be done to create a template for use with multiple geometries. Moreover, you are not
required to define an analysis system. You can begin your simulation with a Mechanical
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Model system and build the simulation as desired until you wish to add a geometry as well
as specify an analysis type. This flexibility can be beneficial.

You typically work through the system from top to bottom. Use the context menus for each cell to view
and select operations that can be performed for that cell.

1. Import or create a geometry:

• To import an existing geometry, right-click the Geometry cell and select Import Geometry.
From the context menu, select a previously used geometry, an active CAD model, or browse to
a desired folder location.

• To create a new geometry, select New DesignModeler Geometry or New SpaceClaim Geometry,
as appropriate.

2. To define all loads and boundary conditions, right-click the Setup cell and select Edit.

Mechanical opens. Set up your analysis using the application's tools and features.

3. Typically, you solve your analysis from within Mechanical, however, you can right-click the Solution
cell and select Update. The results appear automatically.

For more information on setting up and running specific Mechanical analyses, see Analysis Sys-
tems (p. 74).

Basic Fluid Flow Analysis Workflow

After introducing a new Fluid Flow analysis system to the project schematic and assigning it an appro-
priate name, the focus is typically directed to the Geometry cell, because this is usually the first cell in
the system that requires user input. An example of both a CFX and a Fluent fluid flow system is shown
below.

You typically work through the system from top to bottom. Use the context menus for each cell to view
and select operations that can be performed for that cell. For fluid flow systems, the process is somewhat
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flexible; you can start from geometry, from an existing mesh, or from an existing case file; each is de-
scribed in the following sections.

Basic Fluid Flow Analysis, Starting from Geometry

Typically, you start working through the system at the Geometry cell.

1. To launch a geometry program and create a new model, right-click the Geometry cell and select
New DesignModeler Geometry or New SpaceClaim Geometry from the context menu or select
Import Geometry and browse to an existing CAD model.

For details, see Defining your Simulation Geometry (p. 68).

2. After your geometry is defined and the Geometry cell shows the green check mark indicating
that the cell is up to date, you can proceed to the Mesh cell. To launch the meshing application,
double-click the Mesh cell or right-click the cell and select Edit from the context menu.

To generate a default mesh, right-click the Mesh cell and selected Update. This generates the
mesh in the background without launching the meshing application.

When this step has successfully completed, the Mesh cell displays a green check mark, indicating
an up-to-date state.

3. To load the physics pre-processor, double-click the Setup cell or right-click the cell and select
Edit from the context menu.

If you are working a Fluid Flow (Polyflow) system, the editor is the Fluent application. If you are
working with a Fluid Flow (Ansys CFX) system, the editor is CFX-Pre.

When you have successfully defined your physics, the Setup cell displays a green check mark,
indicating an up-to-date state.

4. To open the associated Solution cell editor, double-click the Solution cell or right-click the cell
and select Edit from the context menu.

to run the solution in the background, right-click the Solution cell and select Update from the
context menu.

If you are working a Fluid Flow (Polyflow) system, the associated editor is the Fluent application.
If you are working with a Fluid Flow (Ansys CFX) system, the associated editor is the CFX-Solver
Manager.

When the solution is complete, the Solution cell displays a green check mark, indicating an up-
to-date state.

5. You can now post-process the resulting solution. To open the resulting solution in Ansys CFD-
Post, double-click the Results cell or right-click the cell and select Edit from the context menu.

Once the process has been completed, all cells in the system should display a green check mark, in-
dicating an up-to-date state.
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Basic Fluid Flow Analysis, Starting from an Imported Mesh

You can bypass the Geometry cell and start the simulation process by importing a mesh.

1. To import your mesh file, right-click the Mesh cell and select Import Mesh File from the context
menu.

2. In the Open dialog, browse to find your mesh file and click Open.

The process for CFX and Fluent differs only in the types of files that are supported (as shown by
the options shown in the Files of Type drop-down list).

After selecting Open, the Mesh cell changes to Imported Mesh and shows a green check mark,
to indicate an up-to-date state. The Geometry cell (which must be unused for the Import Mesh
File option to be shown in the Mesh cell context menu) is deleted from the system (examples
shown below for both a CFX and a Fluent-based Fluid Flow system).

3. To load the physics pre-processor, double-click the Setup cell or right-click the cell and select
Edit from the context menu.

4. From this point, follow the procedure described in Basic Fluid Flow Analysis, Starting from Geo-
metry (p. 72).

Basic Fluid Flow Analysis, Starting from an Imported Case File: Fluid Flow
(Ansys CFX) System

You can bypass the Geometry cell and the Mesh cell and begin the simulation process by importing
a case file. The process differs slightly for CFX and Fluent-based systems.

1. Right-click the Setup cell and select Import Case → Browse.

2. In the Open dialog, browse to find your case file and click Open.

3. If the Geometry and Mesh cells are unused (empty), then the unused cells are automatically
deleted.
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If either cell has an incoming or outgoing connection, then it is considered used, and is not de-
leted.

Because CFX supports multiple meshes imported into a single setup cell, if either of the Geometry
or Mesh cells contains data, neither cell is deleted. As a result, both the Mesh generated in the
Mesh cell and the mesh imported from the case file is combined in CFX-Pre.

4. Once the import is complete, to start CFX-Pre, double-click the Setup cell or right-click the cell
and select Edit from the context menu.

5. From this point, follow the procedure described in Basic Fluid Flow Analysis, Starting from Geo-
metry (p. 72).

Basic Fluid Flow Analysis, Starting from an Imported Case File: Fluid Flow
(Polyflow) System

You can bypass the Geometry cell and the Mesh cell and begin the simulation process by importing
a case file. The process differs slightly for CFX and Fluent-based systems.

1. To import a case file, right-click the Setup cell and select Import Polyflow Case from the context
menu.

2. Select a case file either from the list of recently used case files or select Browse….

3. A warning dialog informs you that completing this action deletes the Geometry and Mesh cells
and any associated data. Click OK.

The Geometry and Mesh cells are deleted from the system. Any existing connections to the
Geometry and Mesh cells are also deleted.

4. From this point, follow the procedure described in Basic Fluid Flow Analysis, Starting from Geo-
metry (p. 72).

Analysis Systems

Analysis systems include all the necessary component cells already defined and ready to be populated.
For example, a static structural analysis system includes all the cells needed for the analysis, Engineering
Data through Results.

Some analysis types offer different solvers, noted in parentheses. The features available can differ from
one solver to another.

The following analysis systems are available:

Ansys Motion

Coupled Field Harmonic

Coupled Field Modal

Coupled Field Static

Coupled Field Transient

Eigenvalue Buckling
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Electric

Explicit Dynamics

Fluid Flow - Icing (CFX)

Fluid Flow - Icing (FENSAP)

Fluid Flow - Icing (Fluent)

Fluid Flow (CFX)

Fluid Flow (Fluent)

Fluid Flow (Fluent with Fluent Meshing)

Fluid Flow (Polyflow)

Harmonic Acoustics

Harmonic Response

Hydrodynamic Diffraction

Hydrodynamic Response

LS-DYNA

LS-DYNA Restart

Magnetostatic

Modal Acoustics

Modal

Random Vibration

Response Spectrum

Rigid Dynamics

Speos

Static Acoustics

Static Structural

Steady-State Thermal

Structural Optimization

Substructure Generation

Thermal-Electric

Throughflow and Throughflow (BladeGen)

Transient Structural

Transient Thermal

Turbomachinery Fluid Flow

Ansys Motion

The Ansys Motion system performs Multibody Dynamic (MBD) Analysis, a means of analyzing the
dynamic behavior of a system of interconnected bodies.

This system is configured in Ansys Mechanical, using the Ansys Motion solver to compute the solution.
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The system is an Ansys ACT app and is not automatically visible in the toolbox until it is installed. For
installation instructions, see Adding Motion Analysis.

To work through a Ansys Motion system:

1. To add a Ansys Motion analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu or double-
click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

For information on standard Mechanical features, see Using Standard Mechanical Features. For
Ansys Motion specific features, see Define Motion Specific Features.

5. To connect the Ansys Motion system to a Harmonic Acoustics system:

a. Drag the Harmonic Acoustics system from the Toolbox to the Project Schematic.

b. Drag the Solution cell of the Ansys Motion system onto the Setup cell of the Harmonic
Acoustics system.

Coupled Field Harmonic

The Coupled Field Harmonic system determines the steady-state response of a structure and the
surrounding fluid medium to loads and excitations that vary sinusoidally (harmonically) with time.
The system supports 2D coupled, structural acoustic, and structural electric physics.

This system is configured in Ansys Mechanical, using the Mechanical APDL solver to compute the
solution.

To work through a Coupled Field Harmonic system:
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1. To add a Coupled Field Harmonic analysis system, drag the system from the Toolbox to the
Project Schematic or double-click the system in the Toolbox.

Once the analysis type is selected, the following prompt displays.

This prompt informs you that you can automatically create a Physics Region (object) in the
downstream Mechanical system by selecting physics types in the Setup cell properties. Both the
Structural and Electric properties, as illustrated below, are read-only properties that are always
active. The Acoustics property is also read-only and is off by default.

2. To ensure the prompt is not displayed again, select the Do not show me this again check box.

3. To close the prompt, click OK.

4. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

5. To import the model, double-click the Setup cell or right-click the Setup cell and select Edit
from the context menu.

6. In the Mechanical application window, complete your analysis using the application's tools and
features.

7. To link one Coupled Field Harmonic analysis with another one:

a. Drag a second Coupled Field Harmonic system from the Toolbox to the Project Schematic
or double-click the system in the Toolbox.
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b. Drag the Solution cell of the first system to the Setup cell of the second system.

The following Show-Me animation is presented as an animated GIF in the online help. If you are
reading the PDF version of the help and want to see the animated GIF, access this section in the
online help. The interface shown may differ slightly from that in your installed product.

Coupled Field Modal

The Coupled Field Modal system models a structure and the surrounding the fluid medium to de-
termine frequencies and standing wave patterns within a structure. The system supports 2D coupled,
structural acoustics, and structural electric physics.

This system is configured in Ansys Mechanical, using the Mechanical APDL solver to compute the
solution.

To work through a Coupled Field Modal system:

1. To add a Coupled Field Modal analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

Once the analysis type is selected, the following prompt displays.

This prompt informs you that you can automatically create a Physics Region (object) in the
downstream Mechanical system by selecting physics types in the Setup cell properties. Both the
Structural, Acoustics, and Electric properties, as illustrated below, are read-only properties that
are always active. The Acoustics property is also read-only and is off by default.
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2. To ensure the prompt is not displayed again, select the Do not show me this again check box.

3. To close the prompt, click OK.

4. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

5. To import the model, double-click the Setup cell or right-click the Setup cell and select Edit
from the context menu.

6. In the Mechanical application window, complete your analysis using the application's tools and
features.

Coupled Field Static

The Coupled Field Static system determines the displacements, stresses, strains, and forces caused
by loads that do not induce significant inertia and damping effects. Steady loading and response
conditions are assumed. The loads and the responses are assumed to vary slowly with respect to
time. The system supports 2D coupled, structural thermal, structural acoustics, and structural electric
physics.

This system is configured in Ansys Mechanical, using the Mechanical APDL solver to compute the
solution.

To work through a Coupled Field Static system:

1. To add a Coupled Field Static analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

Once the analysis type is selected, the following prompt displays.
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This prompt informs you that you can automatically create a Physics Region (object) in the
downstream Mechanical system by selecting physics types in the Setup cell properties. Both the
Structural and Thermal properties, as illustrated below, are read-only properties that are always
active. The Acoustics and Electric properties are also read-only and are off by default.

2. To ensure the prompt is not displayed again, select the Do not show me this again check box.

3. To close the prompt, click OK.

4. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

5. To import the model, double-click the Setup cell or right-click the Setup cell and select Edit
from the context menu.

6. In the Mechanical application window, complete your analysis using the application's tools and
features.

Coupled Field Transient

The Coupled Field Transient system determines the time-varying displacements, strains, stresses,
and forces as they respond to any transient loads. The system supports 2D coupled, structural
acoustics, structural thermal, and structural electric physics.
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This system is configured in Ansys Mechanical, using the Mechanical APDL solver to compute the
solution.

To work through a Coupled Field Transient system:

1. To add a Coupled Field Transient analysis system, drag the system from the Toolbox to the
Project Schematic or double-click the system in the Toolbox.

Once the analysis type is selected, the following prompt displays.

This prompt informs you that you can automatically create a Physics Region (object) in the
downstream Mechanical system by selecting physics types in the Setup cell properties. Both the
Structural and Thermal properties, as illustrated below, are read-only properties that are always
active. The Acoustics and Electric properties are also read-only and off by default.

2. To ensure the prompt is not displayed again, select the Do not show me this again check box.

3. To close the prompt, click OK.

4. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.
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5. To import the model, double-click the Setup cell or right-click the Setup cell and select Edit
from the context menu.

6. In the Mechanical application window, complete your analysis using the application's tools and
features.

Eigenvalue Buckling

The Eigenvalue Buckling system predicts the theoretical buckling strength of an ideal elastic structure.
This method corresponds to the textbook approach of elastic buckling analysis; for instance, an Eigen-
value Buckling analysis of a column matches the classical Euler solution. However, imperfections and
nonlinearities prevent most real-world structures from achieving their theoretical elastic buckling
strength. The Eigenvalue Buckling analysis often yields quick but non-conservative results.

This analysis is configured in Ansys Mechanical, using the Ansys or the Samcef solver to compute the
solution.

An Eigenvalue Buckling analysis must follow a prestressed static structural analysis. Follow the instruc-
tions in Static Structural (p. 98) to build a prestressed Static Structural system, and then complete
the following instructions to build and link an Eigenvalue Buckling system.

To work through an Eigenvalue Buckling system:

1. From the Static Structural system, right-click the Solution cell and select Transfer Data to New
→ Eigenvalue Buckling.

A new Eigenvalue Buckling system is created, with the Engineering Data, Geometry, Model,
and Setup cells linked from the static structural system.

2. To open the Mechanical application, from the Eigenvalue Buckling system, right-click the Setup
cell and select Edit from the context menu or double-click the Setup cell.

3. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Eigenvalue Buckling Analysis in the Mechanical User's Guide for more information on conduct-
ing this analysis.

4. On the Project tab toolbar, click Update Project.

Electric

The Electric system supports steady-state electric conduction. Primarily, this analysis type is used to
determine the electric potential in a conducting body created by the external application of voltage
or current loads. From the solution, other results items are computed such as conduction currents,
electric field, and joule heating.

This analysis is configured in Ansys Mechanical, using the Ansys solver to compute the solution.

To work through an Electric system:

1. To add an Electric analysis system, drag the system from the Toolbox to the Project Schematic
or double-click the system in the Toolbox.
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2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To open the Mechanical application, right-click the Setup cell and select Edit from the context
menu or double-click the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Electric Analysis in the Mechanical User's Guide for more information on conducting this
analysis.

Explicit Dynamics

The Explicit Dynamics system can perform a variety of engineering simulations, including the mod-
eling of nonlinear dynamic behavior of solids, fluids, gases and their interaction.

This analysis is configured in Ansys Mechanical.

To work through an Explicit Dynamics system:

1. To add an Explicit Dynamics analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To open the Mechanical application, right-click the Setup cell and select Edit from the context
menu or double-click the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See the Explicit Dynamics Analysis Guide for more information on conducting this analysis.

Fluid Flow - Icing (CFX)

The Fluid Flow - Icing (CFX) system performs a complete Icing analysis. It contains cells to connect
to a Ansys CFX component system and run airflow with the CFX solver, set up and run droplets with
the DROP3D solver, set up and run icing with the ICE3D solver, displace the grid due to ice accretion,
and visualize the results in CFD-Post or Viewmerical.

To display this system in the Toolbox, install the FENSAPICE-WB extension located in the [Install-
Directory]\ANSYS Inc\v222\fensapice\workbench folder, then load it using the Extension
Manager.

For more details, see Creating CFX/Fluent-based Icing Systems in the Ansys FENSAP-ICE in Ansys
Workbench User's Guide.
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Fluid Flow - Icing (FENSAP)

The Fluid Flow - Icing (FENSAP) system performs a complete Icing analysis. It contains cells to set
up and run airflow with the FENSAP solver, set up and run droplets with DROP3D solver, set up and
run icing with ICE3D solver, displace the grid due to ice accretion, and visualize the results in CFD-
Post or Viewmerical.

To display this system in the Toolbox, install the FENSAPICE-WB extension located in the [Install-
Directory]\ANSYS Inc\v222\fensapice\workbench folder, then load it using the Extension
Manager.

For more details, see Creating FENSAP-ICE Based Systems in the Ansys FENSAP-ICE in Ansys Workbench
User's Guide.

Fluid Flow - Icing (Fluent)

The Fluid Flow - Icing (Fluent) system performs a complete Icing analysis. It contains cells to connect
to a Ansys Fluent component system and run airflow with the Fluent solver, set up and run droplets
with the DROP3D solver, set up and run icing with the ICE3D solver, displace the grid due to ice ac-
cretion, and visualize the results in CFD-Post or Viewmerical.

To display this system in the Toolbox, install the FENSAPICE-WB extension located in the [Install-
Directory]\ANSYS Inc\v222\fensapice\workbench folder, then load it using the Extension
Manager.

For more details, see Creating CFX/Fluent-based Icing Systems in the Ansys FENSAP-ICE in Ansys
Workbench User's Guide.

Fluid Flow (CFX)

The Fluid Flow (CFX) system performs fluid-flow analysis of incompressible and compressible fluid
flow and heat transfer in complex geometries.

This system is also used as part of the FSI: Fluid Flow (Ansys CFX) > Static Structural (p. 225) custom
system.

This analysis is configured in Ansys CFX.

For detailed information on working with Ansys CFX, see Ansys CFX in Ansys Workbench.

To work through a Fluid Flow (CFX) system:

1. To add a Fluid Flow (CFX) analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select one of the following options from
the context menu:

• New SpaceClaim Geometry

• New DesignModeler Geometry

• Import Geometry
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3. To create a mesh, right-click the Mesh cell and select Edit from the context menu.

4. Right-click the Setup cell and select one of the following options from the context menu:

• To specify the Ansys CFX physics definitions in CFX-Pre, select Edit.

• To import a previously saved case file, select Import Case → Browse.

5. Right-click the Solutions cell and select one of the following options from the context menu:

• To start the solver immediately, select Update.

• To set the solver execution controls in CFX-Solver Manager select Edit.

• To import an existing CFX-Solver Results file, select Import Solution → Browse.

6. To analyze the results of the calculations in CFD-Post, right-click the Results cell and select Edit
from the context menu.

Note:

If you import a CFX-Solver Input File into a CFX Setup cell and the reload file format is not
a CFX-Solver Input File (for example, a DEF file) and the Reload Options were not defined
or did not contain a replacetype option, you may need to modify the definition of the
Mesh Reload Options.

If a definition file contains a mesh from a GTM file and is imported into a Setup cell, the
original mesh type is automatically changed to CFX-Solver Input file. If the remeshing process
is not explicitly told to import the GTM file as a GTM file, the remeshing process assumes
that the mesh is also a CFX-Solver Input file, rather than a GTM file.

This fails when the remeshing process runs. This is a limitation and must be modified by
hand. To do this, add a line similar to the following to the DEF file:

Mesh Reload Options = "replacetype=GTM,notransform=false"

See Remeshing Tab in the CFX-Pre User's Guide for details.

Resuming a Failed Run

If your CFX run fails and a backup file is available, you can resume a run from the latest standard
or essential backup, or equivalent transient results file. This capability is especially useful for cases
with very long runtimes to avoid restarting from initial conditions or, if the solver failed due to an
error, reviewing backed up results to diagnose and correct the issue.

To take advantage of this capability, follow these steps when starting your run:

1. Import a case file or begin with an existing CFX setup definition.

2. Open Setup and define backups:
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a. From the menu bar, select Insert → Solver → Output Control.

b. Switch to the Backup tab.

For more information on output controls and the Backup tab in CFX-Pre, see Output
Control.

c. Define your backup settings.

Note that only Essential or Standard backup files provide sufficient data for a clean restart.
Additional backup files using the Smallest or Selected Variables option can be included,
but are not available for restarting a solution.

d. Close CFX-Pre.

3. In the Workbench Project Schematic, update the system (p. 244) to start the solution.

4. If the solver fails to write a results file, right-click the Solution cell and select Resume Solution
from Backup from the context menu to resume the solution or Copy Backup to New Solution
to review the results in CFD-Post or keep the backup to use as initial conditions.

• If you selected Resume Solution from Backup, the update continues from the last
completed backup.

• If you selected Copy Backup to New Solution, a new CFX system with only a Solution
cell and a new Results cell is created in the Project Schematic. You can review the
results from this system to determine the status of the solution at the last completed
backup point. From there, you can choose to resume the original interrupted run or
you can choose to revise your original case as necessary.

Note:

The solution is restarted directly from the backup file and includes any modifications
made through the Command Editor. Also, if the setup is modified, Resume Solution
from Backup is not available. To modify the setup and restart from a backup, first
copy the backup to a new solution using Copy Backup to New Solution and link
this backup solution to your solution cell to use it as an initial guess.

Fluid Flow (Fluent)

The Fluid Flow (Fluent) system performs fluid-flow analysis of incompressible and compressible fluid
flow and heat transfer in complex geometries.

This analysis is configured in Ansys Fluent.

You can use a Fluent fluid flow analysis system to apply a computational mesh to a geometry within
Workbench, then use Fluent to define pertinent mathematical models (for example, low-speed, high-
speed, laminar, turbulent, and so on), select materials, define boundary conditions, and specify solution
controls that best represent the problem to be solved. Fluent solves the mathematical equations, and
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the results of the simulation can be displayed in CFD-Post for further analysis (for example, contours,
vectors, and so on).

For detailed information on working with Fluent, see the Fluent User's Guide, the Fluent in Workbench
User's Guide, and the other online documentation available under the Help menu within Fluent.

To work through a Fluid Flow (Fluent) system:

1. To add a Fluid Flow (Fluent) analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select one of the following options from
the context menu:

• New SpaceClaim Geometry

• New DesignModeler Geometry

• Import Geometry

3. To create a mesh, right-click the Mesh cell and select Edit from the context menu.

4. Right-click the Setup cell and select one of the following options from the context menu:

• To specify the Fluent settings, select Edit.

• To import a previously saved Fluent case file, select Import Fluent Case.

• To import previously saved Fluent case and data files, select Import Fluent Case And Data.

5. To analyze the results of the calculations in CFD-Post, right-click the Results cell and select Edit
from the context menu.

Fluid Flow (Fluent with Fluent Meshing)

The Fluid Flow (Fluent with Fluent Meshing) system performs fluid-flow analysis of incompressible
and compressible fluid flow and heat transfer in complex geometries.

This analysis is configured in Ansys Fluent.

You can use a Fluent fluid flow analysis system to apply a computational mesh to a geometry using
Fluent’s Watertight Meshing workflow, then use Fluent to define pertinent mathematical models (for
example, low-speed, high-speed, laminar, turbulent, and so on), select materials, define boundary
conditions, and specify solution controls that best represent the problem to be solved. Fluent solves
the mathematical equations, and the results of the simulation can be displayed in CFD-Post for further
analysis (for example, contours, vectors, and so on).

For detailed information on working with Fluent, see the Fluent User's Guide, the Fluent in Workbench
User's Guide, and the other online documentation available under the Help menu within Fluent.

To work through a Fluid Flow (Fluent with Fluent Meshing) system:
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1. To add a Fluid Flow (Fluent with Fluent Meshing) analysis system, drag the system from the
Toolbox to the Project Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select one of the following options from
the context menu:

• New SpaceClaim Geometry

• New DesignModeler Geometry

• Import Geometry

3. To create a mesh, right-click the Mesh cell and select Edit from the context menu.

4. Right-click the Setup cell and select one of the following options from the context menu:

• To specify the Fluent settings, select Edit.

• To import a previously saved Fluent case file, select Import Fluent Case.

• To import previously saved Fluent case and data files, select Import Fluent Case And Data.

5. To analyze the results of the calculations in CFD-Post, right-click the Results cell and select Edit
from the context menu.

Fluid Flow (Polyflow)

The Fluid Flow (Polyflow) systems analyze fluid flows with free surfaces, complex rheology (including
non-Newtonian behavior with viscoelasticity), heat transfer, and chemical reactions.

This analysis is configured in Ansys Polyflow.

There are three Polyflow fluid flow analysis systems available in Workbench:

• The Fluid Flow (Polyflow) system provides the full simulation capabilities of Polyflow.

• The Fluid Flow - Blow Molding (Polyflow) system provides only the application-specific capabilities
of Polyflow that are suited to blow-molding simulations.

• The Fluid Flow - Extrusion (Polyflow) system provides only the application-specific capabilities
of Polyflow that are suited to extrusion simulations.

Use a Polyflow, Blow Molding (Polyflow), or Extrusion (Polyflow) fluid flow analysis system to apply a
computational mesh to a geometry within Workbench, then use Polydata to define pertinent math-
ematical models (for example, Generalized Newtonian, Viscoelastic, and so on), select materials, define
boundary conditions, and specify solution controls that best represent the problem to be solved.
Polyflow solves the mathematical equations, and the results of the simulation can be displayed in
CFD-Post for further analysis (for example, contours, vectors, and so on).

For detailed information on working with Polyflow, see the online help in Polyflow, the Polyflow User's
Guide, and the Polyflow in Workbench User's Guide.
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SpaceClaim Meshing

SpaceClaim mesh transfer to the Mesh cell of the Fluid Flow systems (Fluent, CFX, and Polyflow)
now uses a .uns file to handle the import.

The recommended method of transferring SpaceClaim meshing is to connect a Geometry component
system to the Setup cell of either a Fluent, CFX, or Polyflow component system, instead of using
the Fluid Flow system.

If you choose to use the Fluid Flow system, enable meshing in SpaceClaim then display the Properties
pane for the Fluid Flow system Mesh cell. Control the import using the mesh conversion options.

Harmonic Acoustics

The Harmonic Acoustics system determines the steady-state response of a structure and the sur-
rounding fluid medium to loads and excitations that vary sinusoidally (harmonically) with time.
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This system is configured in Ansys Mechanical, using the Mechanical APDL solver to compute the
solution.

To work through a Harmonic Acoustics system:

1. To add a Harmonic Acoustics analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

Once the analysis type is selected, the following prompt displays.

This prompt informs you that you can automatically create a Physics Region (object) in the
downstream Mechanical system by selecting physics types in the Setup cell properties. The
Acoustics property, as illustrated below, is a read-only property that is always active.

2. To ensure the prompt is not displayed again, select the Do not show me this again check box.

3. To close the prompt, click OK.

4. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

5. To import the model, double-click the Setup cell or right-click the Setup cell and select Edit
from the context menu.
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6. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Harmonic Acoustics Analysis in the Mechanical User's Guide for more information on conducting
this analysis.

Harmonic Response

The Harmonic Response system determines the steady-state response of a linear structure to loads
and excitations that vary sinusoidally (harmonically) with time.

Use this system to verify whether or not your designs successfully overcome resonance, fatigue, and
other harmful effects of forced vibrations. This analysis technique calculates only the steady-state,
forced vibrations of a structure, typically at a number of discrete points within a range of frequencies.
The transient vibrations, which occur at the beginning of the excitation, are not accounted for in a
harmonic response analysis.

This system is configured in Ansys Mechanical, using the Ansys solver to compute the solution.

To work through a Harmonic Response system:

1. To add a Harmonic Response analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu or double-
click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

A mode-superposition harmonic analysis automatically runs the modal portion of the solution
and cannot transfer data from a separate modal system in the Project Schematic.

See Harmonic Response Analysis in the Mechanical User's Guide for more information on conducting
this analysis.

Hydrodynamic Diffraction

The Hydrodynamic Diffraction system calculates wave forces and structure motions in regular or
irregular waves.

Use this system to apply a computational mesh to a geometry within the Aqwa application and produce
a solution.

This analysis is configured in DesignModeler and solved in Ansys Aqwa.

Optionally, you can connect a Hydrodynamic Diffraction system Solution cell to a Static Structural
system (p. 98) Setup cell and transfer the data to the Static Structural system.
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You can also import a previously saved Aqwa .aqdb file (p. 50) and navigate to the database file.

For detailed information on working with Aqwa in Workbench, see the Aqwa User's Manual.

1. To add a Hydrodynamic Diffraction analysis system, drag the system from the Toolbox to the
Project Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu or select New Geometry from the context menu to create it in DesignModeler.

3. To specify the Aqwa settings, right-click the Setup cell and select Edit from the context menu.

4. In the Aqwa application window, complete your analysis using the application's tools and features.

5. To start the solution, in the Aqwa application select Solve, or right-click the Solution cell and
select Update from the context menu.

Hydrodynamic Response

The Hydrodynamic Response system calculates wave forces and structure motions in regular or ir-
regular waves.

Use this system to apply ocean environment forces (wind, wave, current) to a structure.

This analysis is configured in DesignModeler and solved in Ansys Aqwa.

You can also import a previously saved Aqwa .aqdb file (p. 50) and navigate to the database file.

For detailed information on working with Aqwa in Workbench, see the Aqwa User's Manual.

1. To add a Hydrodynamic Diffraction analysis system, drag the system from the Toolbox to the
Project Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu or select New Geometry from the context menu to create it in DesignModeler.

3. To add a Hydrodynamic Response analysis system, drag the system from the Toolbox onto the
system added in step 1, sharing the Geometry, Model, and Solution cells.

4. To specify the Aqwa settings, right-click the Hydrodynamic Response system Setup cell and
select Edit from the context menu.

5. In the Aqwa application window, complete your analysis using the application's tools and features.

6. To start the solution, in the Aqwa application select Solve, or right-click the Solution cell and
select Update from the context menu.

LS-DYNA

LS-DYNA is a general-purpose finite element program capable of simulating complex real world
problems. It is used by the automobile, aerospace, construction, military, manufacturing, and bioen-
gineering industries. The LS-DYNA solver is optimized for shared and distributed memory Unix, Linux,
and Windows based platforms. The code's origins lie in highly nonlinear, transient dynamic finite
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element analysis using explicit time integration. The LS-DYNA system takes the power of the LS-DYNA
solver and wraps it up into the familiar and easy to use environment of Ansys Workbench and Ansys
Mechanical.

See the LS-DYNA User's Guide for more information on conducting this analysis.

LS-DYNA Restart

The LS-DYNA Restart system allows you to restart an LS-DYNA analysis. Restarting means performing
an analysis which continues from a previous analysis. A restart can begin from either the conclusion
of or the middle of a prior analysis.

For detailed steps on using this system, see Restarting an LS-DYNA Analysis in the LS-DYNA User's
Guide.

Magnetostatic

The Magnetostatic system performs 3D static magnetic field analysis. You can model various physical
regions including iron, air, permanent magnets, and conductors.

This system is configured in Ansys Mechanical, using the Ansys solver to compute the solution.

To work through a Magnetostatic system:

1. To add an Magnetostatic analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu, or
double-click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Magnetostatic Analysis in the Mechanical User's Guide for more information on conducting
this analysis.

Modal Acoustics

The Modal Acoustics system models a structure and the surrounding the fluid medium to determine
frequencies and standing wave patterns within a structure.

This system is configured in Ansys Mechanical, using the Mechanical APDL solver to compute the
solution.

To work through a Modal Acoustics system:
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1. To add a Modal Acoustics analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

Once the analysis type is selected, the following prompt displays.

This prompt informs you that you can automatically create a Physics Region (object) in the
downstream Mechanical system by selecting physics types in the Setup cell properties. The
Acoustics property, as illustrated below, is a read-only property that is always active.

2. To ensure the prompt is not displayed again, select the Do not show me this again check box.

3. To close the prompt, click OK.

4. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

5. To open the Mechanical application, right-click the Setup cell and select Edit from the context
menu or double-click the Setup cell.

6. In the Mechanical application window, complete your analysis using the application's tools and
features.
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See Modal Acoustics Analysis in the Mechanical User's Guide for more information on conducting
this analysis.

Modal

The Modal system determines the vibration characteristics (natural frequencies and corresponding
mode shapes) of a structure or a machine component. It can serve as a starting point for other types
of analyses by detecting unconstrained bodies in a contact analysis or by indicating the necessary
time-step size for a transient analysis, for example. In addition, the modal-analysis results may be
used in a downstream dynamic simulation employing mode-superposition methods, such as a har-
monic response analysis, a random vibration analysis, or a spectrum analysis. The natural frequencies
and mode shapes are important parameters in the design of a structure for dynamic loading conditions.

This analysis is configured in the Mechanical application, which uses either the Ansys, ABAQUS, or
Samcef solver to compute the solution, depending on which system you selected.

To work through a Modal system:

1. To add a Modal analysis system, drag the system from the Toolbox to the Project Schematic
or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu or double-
click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Modal Analysis in the Mechanical User's Guide for more information on conducting this ana-
lysis.

Random Vibration

The Random Vibration system determines the response of structures to vibration loads that are
random in nature. The loads on a structural system may not always be known or quantifiable with
certainty. Sensitive electronic equipment mounted in an automobile, for example, may experience
slightly-different conditions each day, due to changes in engine vibration or pavement roughness,
even if the same road is traveled. Since the input loads are described using statistical quantities, the
outputs are said to be non-deterministic, meaning that the results can be known only within a certain
probability.

This analysis is configured in the Mechanical application, which uses either the Ansys solver to compute
the solution.

A Random Vibration analysis must follow a Modal analysis that extracts the natural frequencies and
mode shape. Follow the instructions in Modal (p. 95) to build a Modal analysis system and then
complete the following instructions to build and link a Random Vibration system.
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Alternatively, you can select the Random Vibration (p. 226) custom system. This option creates a Random
Vibration system template that includes both the Modal analysis and Random Vibration analysis system
templates with the links pre-defined.

To work through a Random Vibration system:

1. From the Modal analysis system, right-click the Solution cell and select Transfer Data to New
→ Random Vibration.

Workbench creates a new Random Vibration system. The Engineering Data, Geometry, and
Model cells are linked, and the Modal system Solution cell is linked to the Random Vibration
system Setup cell.

2. To open the Mechanical application, right-click the Setup cell in the Random Vibration system
and select Edit, or double-click the Setup cell.

3. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Random Vibration Analysis in the Mechanical User's Guide for more information on conducting
this analysis.

4. On the Project tab toolbar, click Update Project.

Response Spectrum

The Response Spectrum system calculates the maximum response for a given excitation based upon
the input response spectrum and the method used to combine the modal responses. The combination
methods available are the Square Root of the Sum of the Squares (SRSS), the Complete Quadratic
Combination (CQC) and the Rosenblueth’s Double Sum Combination (ROSE). A response spectrum
analysis has similarities to a random vibration analysis. However, unlike a random vibration analysis,
responses from a response spectrum analysis are deterministic maxima.

This analysis is configured in the Mechanical application, which uses either the Ansys solver to compute
the solution.

A Response Spectrum analysis must follow a Modal analysis that extracts the natural frequencies and
mode shape. Follow the instructions in Modal (p. 95) to build a Modal analysis system and then
complete the following instructions to build and link a Response Spectrum system.

To work through a Response Spectrum system:

1. From the Modal analysis system, right-click the Solution cell and select Transfer Data to New
→ Response Spectrum.

Workbench creates a new Response Spectrum system. The Engineering Data, Geometry, and
Model cells are linked, and the Modal system Solution cell is linked to the Response Spectrum
system Setup cell.

2. To open the Mechanical application, right-click the Setup cell in the Response Spectrum system
and select Edit or double-click the Setup cell.
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3. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Response Spectrum Analysis in the Mechanical User's Guide for more information on conducting
this analysis.

4. On the Project tab toolbar, click Update Project.

Rigid Dynamics

The Rigid Dynamics system determines the dynamic response of an assembly of rigid bodies linked
by joints and springs. You can use this type of analysis to study the kinematics of a robot arm or a
crankshaft system, for example.

This analysis is configured in the Mechanical application, which uses the Ansys Rigid Dynamics solver
to compute the solution.

To work through a Rigid Dynamics system:

1. To add a Rigid Dynamics analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu or double-
click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Rigid Dynamics Analysis in the Mechanical User's Guide for more information on conducting
this analysis.

Speos

The Speos system lets you design and optimize light and systems.

For more detailed information, see Creating a Speos system in Ansys Workbench in the Speos User's
Guide.

Static Acoustics

The Static Acoustics system determines displacements, stresses, strains, and forces in your structure
or structural components that are caused by loads that do not induce significant inertia and damping
effects. Steady loading and response conditions are assumed. The loads and the structure's response
are assumed to vary slowly with respect to time.

it is used as a pre-stress environment for future downstream Modal Acoustics or Harmonic Acoustics
analyses.
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This analysis is configured in the Mechanical application, which uses the Mechanical APDL solver to
compute the solution.

To work through a Static Acoustics system:

1. To add a Static Acoustics analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu or double-
click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Static Acoustics Analysis in the Mechanical User's Guide for more information on conducting
this analysis.

Static Structural

The Static Structural system determines the displacements, stresses, strains, and forces in structures
or components caused by loads that do not induce significant inertia and damping effects. Steady
loading and response conditions are assumed. The loads and the structure's response are assumed
to vary slowly with respect to time.

This analysis is configured in the Mechanical application, which uses the Ansys, ABAQUS, or Samcef
solver to compute the solution, depending on which system you have selected.

To work through a Static Structural system:

1. To add a Static Structural analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu or double-
click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Static Structural Analysis in the Mechanical User's Guide for more information on conducting
this analysis.
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Steady-State Thermal

The Steady-State Thermal system determines temperatures, thermal gradients, heat flow rates, and
heat fluxes in an object that are caused by thermal loads that do not vary over time. A steady-state
thermal analysis calculates the effects of steady thermal loads on a system or component. Engineers
often perform a steady-state analysis before performing a transient thermal analysis, to help establish
initial conditions. A steady-state analysis also can be the last step of a transient thermal analysis,
performed after all transient effects have diminished.

Important:

By default, the application does not write thermal gradient results to the result file. To
have these results written to the results file, use a Command object and insert the command
OUTRES,ERASE.

This analysis is configured in the Mechanical application, which uses the Ansys, ABAQUS, or Samcef
solver to compute the solution, depending on which system you have selected.

To work through a Steady-State Thermal system:

1. To add a Steady-State Thermal analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu or double-
click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Steady-State Thermal Analysis in the Mechanical User's Guide for more information on con-
ducting this analysis.

See the Thermal Analysis Guide for more information on thermal analyses using the Mechanical
APDL application.

Structural Optimization

See the Structural Optimization Analysis section of the Mechanical User's Guide for the steps to conduct
this type of analysis.

Substructure Generation

The Substructure Generation system supports the preliminary computation (Generation Pass) for
top-down substructuring of condensed geometry. It also supports load vectors and constraints for
super element Generation Pass.
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For a more detailed overview of substructures, see Substructure Analysis in the Mechanical User's
Guide.

This analysis is configured in the Mechanical application, which uses the Mechanical APDL solver to
compute the solution.

To work through a Substructure Generation system:

1. To add a Substructure Generation analysis system, drag the system from the Toolbox to the
Project Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu or double-
click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Condensed Part in the Mechanical Object Reference for more information on conducting this
analysis.

Thermal-Electric

The Thermal-Electric system allows for a simultaneous solution of thermal and electric fields. This
coupled-field capability models joule heating for resistive materials as well as Seebeck, Peltier, and
Thomson effects for thermoelectricity.

This analysis is configured in the Mechanical application, which uses the Ansys solver to compute the
solution.

To work through a Thermal-Electric system:

1. To add a Thermal-Electric analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu or double-
click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Thermal-Electric Analysis in the Mechanical User's Guide for more information on conducting
this analysis.
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Throughflow and Throughflow (BladeGen)

The Throughflow system contains cells for conducting a study with Vista TF starting with the geometry
and ending with a report. Throughflow is a Vista TF system with an added Geometry cell and
Throughflow (BladeGen) is a Vista TF system with an added Blade Design cell.

For details on the Vista TF system, see Vista TF (p. 222).

Transient Structural

The Transient Structural system determines the dynamic response of a structure under the action
of any general time-dependent loads. You can use it to determine the time-varying displacements,
strains, stresses, and forces in a structure as it responds to any transient loads. The time scale of the
loading is such that the inertia or damping effects are considered to be important. If the inertia and
damping effects are not important, you might be able to use a static analysis instead.

This analysis is configured in the Mechanical application, which uses the Ansys, ABAQUS, or Samcef
solver to compute the solution, depending on which system you have selected.

To work through a Transient Structural system:

1. To add a Transient Structural analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu or double-
click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Transient Structural Analysis in the Mechanical User's Guide for more information on conducting
this analysis.

Transient Thermal

The Transient Thermal system determines temperatures and other thermal quantities that vary over
time. The variation of temperature distribution over time is of interest in many applications such as
with cooling of electronic packages or a quenching analysis for heat treatment. Also of interest are
the temperature distribution results in thermal stresses that can cause failure. In such cases the tem-
peratures from a transient thermal analysis are used as inputs to a static structural analysis for thermal
stress evaluations. Many heat transfer applications (such as heat treatment problems, electronic
package design, nozzles, engine blocks, pressure vessels, and so on) involve transient thermal analyses.

This analysis is configured in the Mechanical application, which uses the Ansys, ABAQUS, or Samcef
solver to compute the solution, depending on which system you have selected.

To work through a Transient Thermal system:
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1. To add a Transient Thermal analysis system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To load the geometry, right-click the Geometry cell and select Import Geometry from the
context menu.

3. To view the geometry, right-click the Model cell and select Edit from the context menu or double-
click the Model cell.

Alternatively, you can complete this step using the Setup cell.

4. In the Mechanical application window, complete your analysis using the application's tools and
features.

See Transient Thermal Analysis for more information on conducting this analysis.

See the Thermal Analysis Guide for more information on thermal analyses using the Mechanical
APDL application. For more information on time stepping, see the discussion on General Options.

Turbomachinery Fluid Flow

The Turbomachinery Fluid Flow system contains cells for conducting a study with Ansys CFX starting
with the mesh and ending with a report. Turbomachinery Fluid Flow is a CFX system with an added
Turbo Mesh cell.

For details on the CFX system, see CFX (p. 106).

Component Systems

Component systems enable you to launch and use familiar stand-alone editors to build a project, but
represent only a subset of a complete analysis. They usually do not include all components and steps
necessary to achieve an analysis system; however, if you are familiar with a particular application, you
can use your product knowledge to complete an analysis.

For example, you can use a geometry component system to define your geometry and then connect
the component system to several downstream systems, so component system can then be connected
to several downstream systems, so that the downstream systems share the same geometry source.

Component systems also include applications that open outside of Workbench (rather than as a tab),
allowing you to use Workbench to manage your analysis data and files. This can be useful for products
such as Mechanical APDL, which uses numerous files during an analysis.

The following component systems are available:

ACP-Pre and ACP-Post

Autodyn

BladeGen

CFX

Chemkin

Discovery
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Engineering Data

EnSight (Forte)

External Data

External Model

Fluent

Fluent (with Fluent Meshing)

Forte

Geometry

GRANTA MI

GRANTA Selector

ICEM CFD

Icepak

Injection Molding Data

Material Designer

Mechanical APDL

Mechanical Model

Mesh

Microsoft Office Excel

Performance Map

Polyflow

Results

Sherlock Pre and Post

System Coupling

Turbo Setup

TurboGrid

Vista AFD

Vista CCD and Vista CCD with CCM

Vista CPD

Vista RTD

Vista TF

ACP-Pre and ACP-Post

The ACP-Pre and ACP-Post systems launch Ansys Composite PrepPost (ACP) for the modeling and
postprocessing of composite models.

For detailed usage instructions and example workflows, see Implementation in Workbench in the ACP
User's Guide.
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Autodyn

The Autodyn system launches Ansys Autodyn, an explicit analysis tool for modeling nonlinear dynamics
of solids, fluids, gas, and their interaction. This system supports the full range of Autodyn capabilities
including the Explicit Eulerian solvers, mesh free SPH solvers, and explicit solver coupling (FSI).

Note:

The Explicit Dynamics (p. 83) analysis system supports the FE components of the Autodyn
solver.

The system takes the binary database (.ad) file as input and produces the following output files:

• Results file (.adres) for postprocessing

• Save file (admodel_cycle.adres) for postprocessing and database modification during a run

• History data files (.his, .sum) that record time dependent data at gauge locations and summary
data for materials/parts

• Print file (.prt) recording a text summary of the model definition and results

• Log file (.log) listing solution information and warnings or errors encountered

For detailed information on using Autodyn, see Autodyn User's Manual.

To work through an Autodyn system:

1. To add an Autodyn component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To connect other systems, right-click the Setup cell, select Transfer Data From New from the
context menu, then select one of the following options:

• Mesh: Inserts a Mesh component system and generates a link between its Mesh cell and the
Autodyn system Setup cell. This option enables the transfer of a mesh from the Ansys Meshing
system into the Autodyn system.

• Explicit Dynamics: Inserts an Explicit Dynamics analysis system and generates a link between
its Setup cell and the Autodyn system Setup cell. This option enables the transfer of the initial
model defined in the Explicit Dynamics system or the Autodyn system. The initial model in-
cludes materials, mesh, connections, coordinate systems, initial conditions, loads, constraints,
and analysis settings.

3. Right-click the Mesh cell of the Mesh component system, or the Setup cell of the Explicit Dy-
namics analysis system, and select Update from the context menu.
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A CAERep.xml file is produced, and then consumed by the Autodyn Setup cell.

Note:

Any modifications made in Autodyn to a model that originated from an Explicit Dy-
namics system are likely to be overwritten during the update process. Items defined
in the Explicit Dynamics or Mesh system represent the main version of the data.

The files generated during the previous transfer or solve are not deleted during the
update. As good practice, you can right-click the Analysis cell and select Clear Gener-
ated Data to clear the previously generated files.

4. To launch Autodyn interactively, right-click the Autodyn Setup cell and select one of the following
options from the context menu:

• New Model: Opens the Autodyn editor where you can set up a new 2D or 3D Autodyn model,
solve, or postprocess results.

• Edit Model: Opens the Autodyn editor and loads in the database currently associated with
system. You can then further edit the model, solve, or postprocess results.

5. To launch Autodyn with input and reference files specified:

a. Right-click the Autodyn Setup cell and select Import Model from the context menu.

This action imports an existing Autodyn database (.ad file) into the system. Any existing
database associated with the system is replaced. If the import detects that there are other
files in the source directory for the model that is being imported, you are presented with
the option to import all the associated files.

b. Right-click the Autodyn Setup cell and select Edit Model from the context menu.

Autodyn launches in interactive mode, and the input files specified are loaded.

6. To select a user-customized executable, right-click the Autodyn Setup cell and select Select
User Executable from the context menu.

This action selects the Autodyn executable file (autodyn.exe) you want to associate with the
system and use for subsequent preprocessing, solving, and postprocessing.

BladeGen

The BladeGen system launches Ansys BladeGen, a component of Ansys BladeModeler. The Blade-
Modeler software is a specialized, easy-to-use tool for the rapid 3D design of rotating machinery
components.

With BladeGen, you can re-design existing blades to achieve new design goals or create completely
new blade design. BladeGen imports blade geometry interactively or through files you supply.
BladeGen allows sculpted or ruled element blades with linear or compound lean leading or trailing
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edges. Over/Under-Filing can be applied, and leading and trailing edge shapes are easily specified as
a full radius, an ellipse ratio, or a simple cutoff.

For more information on Ansys BladeGen, see BladeGen User’s Guide.

To work through a BladeGen system:

1. To add a BladeGen component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To launch BladeGen interactively, right-click the Blade Design cell and select Edit from the
context menu.

3. To launch BladeGen with existing files:

a. Right-click the Blade Design cell and select Import Existing Case from the context menu.

b. Right-click the Blade Design cell and select Edit from the context menu.

CFX

The CFX system launches Ansys CFX, a general-purpose Computational Fluid Dynamics (CFD) software
suite that performs fluid-flow analysis of incompressible and compressible fluid flow and heat transfer
in complex geometries. You import meshes, specify the materials, boundary conditions, and solution
parameters, solve the calculations, view the results, then create reports using built-in tools.

For detailed information on working with Ansys CFX, see Ansys CFX in Ansys Workbench.

For information on submitting Ansys CFX jobs to Remote Solve Manager, see Submitting CFX Jobs
to Remote Solve Manager (p. 337).

To work through a CFX system:

1. To add an CFX component system, drag the system from the Toolbox to the Project Schematic
or double-click the system in the Toolbox.

2. To Import a previously saved case file, right-click the Setup cell and select Import Case → Browse.

3. To read a mesh and specify the Ansys CFX physics definitions in CFX-Pre, Right-click the Setup
cell and select Edit from the context menu.

4. To start the solver:

• Right-click the Solution cell and select Update from the context menu.

• Right-click the Solution cell and select Edit from the context menu, set the solver execution
controls in CFX-Solver Manager, and start the solver.

• To import an existing CFX-Solver Results file, right-click the Solution cell and select Import
Solution → Browse.
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5. To analyze the results of the calculations in CFD-Post, right-click the Results cell and select Edit
from the context menu.

Chemkin

The Chemkin system launches Ansys Chemkin-Pro, allowing you to employ both an array of reactor
models that include 0-D, 1-D, and 2-D models and complex detailed chemical kinetics mechanisms
to investigate concepts in combustion, emissions, and materials synthesis.

For detailed information on working with Chemkin-Pro, see the Chemkin-Pro Getting Started Guide,
as well as the other online documentation available in the Help menu within Chemkin-Pro.

To work through a Chemkin system:

1. To add a Chemkin component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. Right-click the Setup cell and select one of the following options from the context menu:

• To specify the Chemkin-Pro settings, select Edit.

• To import a previously saved Chemkin-Pro project, select Import Chemkin Project.

Discovery

The Discovery system launches Ansys Discovery, allowing you to transfer the geometry model bid-
irectionally, with parametric updates. It is also used when you start Workbench from Discovery using
the Geometry Transfer tools.

For more details, see Geometry Transfer.

Engineering Data

The Engineering Data system launches the Engineering Data tab, allowing you to define or access
material models for use in an analysis. You can also use the Engineering Data (p. 447) cell with
Mechanical systems.

For more information, see Overview.

To work through an Engineering Data system:

1. To add an Engineering Data component system, drag the system from the Toolbox to the
Project Schematic or double-click the system in the Toolbox.

2. To add or modify material data, double-click the Engineering Data cell.

EnSight (Forte)

The Ensight (Forte) system launches EnSight, a full-featured postprocessing and analysis tool that
supports visualization and quantitative analysis of simulation results. You can run EnSight as a com-
ponent from within Workbench by activating the EnSight Forte extension. You must have already
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installed EnSight as part of the unified installation in order to access the extension. This system uses
Forte solvers for analysis and reads the results into EnSight.

To work through an EnSight (Forte) system:

1. If EnSight (Forte) does not appear in the Toolbox:

a. From the menu bar, select Extensions  → Manage Extensions.

b. In the Extensions Manager dialog, select the EnSight Forte extension name.

c. Right-click and select Load from the context menu to run once or Load as Default to load
the extension every time you start Workbench.

Once you've loaded the extension, EnSight (Forte) is listed in the Toolbox as a component
system.

2. To add a Forte component template, drag the template from the Toolbox to the Project
Schematic or double-click the template in the Toolbox.

3. To add an EnSight (Forte) component template, drag the template from the Toolbox to the
Project Schematic, dropping it onto the Solution cell of the Forte system.

4. If required, to connect the EnSight (Forte) system to a structural system, drop the structural
system on the Results cell of the EnSight (Forte) system.

5. Right-click the EnSight (Forte) system header and select Update from the context menu.

6. To launch EnSight with the results loaded, double-click the EnSight (Forte) system Results cell
or right-click the Results cell and select Edit.

External Data

The External Data system enables you to import data from text files into a Mechanical system or a
System Coupling component system.

You can link an External Data system with the following Mechanical analysis types:

• Coupled Field Static.

• Coupled Field Transient. Supported loads include Imported Thermal Condition and Imported
Temperature.

• Explicit Dynamics. Note that, at this time, the Explicit Dynamics system and the LS-DYNA ACT ex-
tension provide only limited support for External Data Import.

• Modal. Supported loads include Imported Body Temperature.

• Static Structural and Transient Structural. These analysis types do not support the use of the
Rigid Dynamics solver for External Data import.
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• Steady-State Thermal, Transient Thermal, and Thermal-Electric.

Note:

There are certain limitations and/or requirements for some of the analysis types. See Ex-
ternal Data Import in the Mechanical User's Guide for additional information about defining
and processing your source data once you have imported it into Mechanical.

You must specify the data format in order to process the files in the External Data tab. This inform-
ation can then be transferred to a downstream Mechanical system where the data can be applied as
loads in an analysis.

Note:

If the project has an External Data system that consumes files stored within the design
point path and multiple design points, updating the multiple design points can cause the
project to fail or produce inaccurate data. When a different design point is run, the External
Data system does switch to the new design point's file path for the files it requires, and
cannot be made to do so within an update of multiple design points.

For more details, see the following topics:

Importing External Data

Importing a Trace File

Importing a CDB File as Input

Importing an Ansys External Data File as Input

Importing Multiple Data Sets

Applying Source Point Analytical Transformations

Performing System Coupling Simulations Using External Data

Importing External Data

To import external data using an External Data system:

1. To add an External Data component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To open the External Data tab, double-click the Setup cell or right-click the Setup cell and
select Edit from the context menu.

3. In the Outline of Schematic pane, in the Location column, click .

4. Browse to the location of the file to add.

Note:

Importing files from design point folders within the same project directory (with
the exception of the Current design point) is not supported.
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5. Select the file and click Open.

The selected file name, location, and identifier are automatically displayed in the Data Source
column. The identifier is a string that can be used to identify the file in the downstream
Mechanical application.

6. If required, click the cell in the Description column and type a description for the file.

7. Optionally, to duplicate an existing file, right-click the file in the Data Source column and select
Duplicate from the context menu.

8. To assign a main file, select the check box next to the required file.

Set a main file so that the system displays and uses the Properties for this file only. The nodal
coordinate data for the selected main file is processed by the mapping utility. Any nodal co-
ordinate data contained in non-main files is skipped.

You can select only one file to be the main file. If you multi-select a main file and non-main
files, the Dimension, Length Unit and Transformation properties in the Definition pane are
hidden. If you duplicate the main file, only one instance is designated as the main file.

9. In the Properties of File pane, input the information required to process the file and apply
the data in Mechanical.

If you select multiple files in the Data Source column, the Properties of File pane displays:

• A value when that value is the same for all selected files

• A blank field when values differ between selected files

• A yellow field when a value is required, but not currently specified for at least one of
the files

If you edit any field in the Properties of File pane when multiple files are selected, your change
is applied to all files.

Note:

Although you can multi-select files in the Data Source pane, when you click away
from that pane the highlighting applied to those files disappears. However, the files
remain selected and operations subsequently performed will be applied to all of
the selected files.

DescriptionProperty

Imports data from 2D or 3D models. If the 2D option is selected, you can
import data only at the X and Y coordinates. The Z coordinate is not
supported for the 2D option.

Dimension

Sets the line number at which you want the data import to start. Line
numbers start at 1.

Start Import at
Line
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DescriptionProperty

Sets the format specification used for the file.

If you select Delimited, specify the character that delimits data
elements in a line in the Delimiter Character field. The options are

Format Type

Comma, Semicolon, Space, Tab, or User-Defined. The latter choice
enables you to specify any character as the data delimiter.

If you select User-Defined, specify the format using the following
allowed format specifiers:

• Decimal floating point: F or f

• Scientific notation (exponent) using E/e character: E or e

• Signed decimal integer: D or d

• Signed integer: I or i

• Character: A or a

• Ignore flag: X or x

For External Data files that include trace mapping, selecting this option
enables you to import trace data belonging to the dummy net of the file.

Dummy Net Data

Specifies the unit system in which source point locations are defined.Length Unit

Specifies the nature of the source point locations. Options include Cartesian
(X, Y, Z) or Cylindrical (R, theta, Z). The default value is Cartesian.

Coordinate
System Type

If set to Yes, the data at Midside nodes, if not specified, is calculated as
average of data specified at corner nodes.

Note:

This property is only available when Format Type is Delim-
ited or User Defined and .cdb file is chosen as the main
file.

Average Data at
Midside Nodes

When selected, maps values from an external user-defined file to the nodes
or elements of your mode. Once active, Field Variables become available
in the Data Type drop-down menus in the Table of File pane.

Material Field
Data

Enables you to apply scaling factors or functions to the corresponding
column Data Type selected in the Table of File pane. For example, to scale

X/Y/Z Coordinate

all values for the X Coordinate column by 90%, change the X Coordinate
text entry to x*0.9.

When the Coordinate System Type is cylindrical, the X Coordinate will
refer to the radius and the Y Coordinate refers to the angle. By default,
each X, Y, and Z Coordinate is set to x, y, and z.
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DescriptionProperty

For a complete list of supported functions, see Working with
Parameters (p. 289). For an example, see Applying Source Point
Analytical Transformations (p. 123).

Note:

When the Dimension type is 2D, the Z Coordinate is not
shown.

Rotations, resulting from specified analytical transformations, do not
get applied to mapped data (pressure, displacement, force) in a
downstream Mechanical system.

In the example below, the line has one integer followed by four exponential data types.

385 8.333333333E-003 9.375000000E-003 3.375000000E-001 0.000000000E+000

In the example below, the line has one integer followed by four exponential data types.

385 8.333333333E-003 9.375000000E-003 3.375000000E-001 0.000000000E+000

The corresponding format is

1i3,4e17.9

Where:

• The first entry is the number of occurrences

• The second entry is the format specifier

• The third entry is the number of characters of data in the definition (including numeric values
(0-9), the letter 'e' (for instances of scientific notation), and any white space and + or - signs)

• The fourth entry is the number of digits after the decimal point.

Tip:

By default, Excel puts a minus sign at the beginning of a negative number but it
does not put a plus sign at the beginning of a positive number, which changes the
number of characters in the negative version of a number. However, if you select
a column in Excel and apply a custom format, you can have a plus sign added to
positive numbers. In Excel's Format Cells dialog box, set the Type with an example
of the format for a positive number and a negative number, separating the two
types with a semicolon. For example:

+00.00E+00;-00.00E+00
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10. Based on the format details you specified in the Properties pane, you must define the data
types and their corresponding units in the Table of File pane. The allowed Data Type values
include:

• Temperature• Heat Generation• Body Force
Density

•• ThicknessHeat Transfer
Coefficient• Displacement

• Velocity
•• Node IDElement ID

• X Coordinate
•• Not UsedElement

Orientations • Y Coordinate
• Pressure

• Z Coordinate• Force
• Strain

• Heat Flux
• Stress

• Heat Rate

Note:

• The Node ID field is useful when the nodal locations and values on nodes are
specified in different files, as is the case when one of the files is specified as the
main file. They are not meant to apply the values directly on the nodes of the
target mesh. If a file is set up without specifying the nodal locations (X/Y/Z), all
the points from the file default to (0,0,0). Similarly, the Element ID field is useful
only when used in conjunction with a CDB file.

• Thickness uses the Length Data Unit and the Data Identifier should start with
Thickness.

Tip:

You can multi-select rows (from the left-most column in the Table of File pane),
then right-click to set all highlighted Data Type values or Data Unit values (where
applicable) at the same time.

Column data is ignored if the Data Type is set to Not Used.

When Coordinate System Type is set to Cartesian in the Properties pane, the Data Unit cell
for the X, Y, and Z Coordinates is read-only in the Table of File pane. When Coordinate System
Type is set to Cylindrical, the Data Unit cell for the Y has a combo box that can specify its
Data Unit string (either as Degrees or Radian).

You can change the data identifier from the default string for allowed data types. The data
identifiers are appended to the file identifier, specified in the Properties pane, so that you can
pick the correct source data in the downstream Mechanical application.

A preview of the file is shown in the Preview pane. The first ten imported lines are shown.
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When you multi-select files, the Preview pane is disabled and the Table of File pane displays
data in columns that you can sort and filter from the down arrow beside each column heading.

11. To delete files that you have selected (or multi-selected) right-click one of the files in the
Outline of Schematic pane and select Delete from the context menu.

12. To modify any file in the Outline of Schematic pane, in the Location column, click  and
select a new file.

13. Switch to the Project tab.

14. Display the properties for the Setup cell of the External Data system by right-clicking on the
cell and selecting Properties. Specify the Files Import Type property as needed. Options include
By Copy and By Reference (default). The By Reference option instructs the application to
directly reference the External Data file instead of transferring the file to the project folder. For
large size files, this action can drastically reduce disk storage requirements and improve per-
formance.

Note:

When you specify the By Reference option and wish to archive your project using
the option Imported files external to project directory of the Archive Options
dialog, the application automatically copies the External Data files to the archived
project.

Important:

The By Reference option cannot be used with the System Coupling feature.

15. If required, link (p. 60) the Setup cell of the External Data to a Model cell or to a Setup cell
of a Mechanical system (except for Rigid Dynamics Systems).

You can modify any file in the Outline pane by browsing to a new file using the browse option
provided in the Location column

Note:

If you modify an External Data system's data file outside of Workbench, you must re-
read the data file. To do so:

1. Right-click the Setup cell

2. Select Re-read Input Files from the context menu.

The Re-read Input Files operation causes Workbench to regard the file as having
changed, whether the file has changed or not, and the status of the Setup cell is updated
appropriately.
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To add a downstream Mechanical system, either drag a valid analysis system from the Toolbox and
drop it on the appropriate Setup cell of the External Data system, or right-click the Setup cell and
choose the Transfer Data To New context menu option.

For additional information for using the data in a downstream Mechanical application, refer to Ex-
ternal Data Import.

Importing a Trace File

You can import a circuit board’s trace layout file (ODB++ TGZ, Ansoft ANF, BOOL + INFO, or
Icepak COND + INFO) into the Model cell of aMechanical system.

To import a trace file:

1. To add an External Data component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To open the External Data tab, double-click the Setup cell or right-click the Setup cell and
select Edit from the context menu.

3. In the Outline of Schematic pane, in the Location column, click .

4. Browse to the location of the trace file.

5. Select the file and click Open.

The External Data component enables you to perform rigid transformations to the trace file. When
any required transformations are complete, drag the External Data Setup cell to a Mechanical
system’s Model cell.

Note:

• If you import a project from Release 16 that has an External Data system, you will
not immediately be able to load in trace files. In order to import a trace file, you must
delete the connection between the External Data Setup cell and the downstream
Model cell, and then recreate the connection. The new connection will support the
transfer of trace files.

• For trace-file imports, the Table and Preview panes are disabled.

Importing a CDB File as Input

You can import a Mechanical APDL-generated CDB file as a source file.

To import a CDB file:

1. To add an External Data component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To open the External Data tab, double-click the Setup cell or right-click the Setup cell and
select Edit from the context menu.
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3. In the Outline of Schematic pane, in the Location column, click .

4. Browse to the location of the CDB file.

5. Select the file and click Open.

The Format Type property is automatically set to .cdb.

CDB files have certain restrictions:

• The Start Import at Line setting is disabled as the entire file is read as data. Delimiter Type,
Delimiter Character, and Format String are also disabled.

• The data is always in the Cartesian global frame-of-reference.

• The Table and Preview panes are disabled, so you cannot specify data types or preview data.

Mechanical APDL CDB files can be added as a parent mesh in the External Data system. The file
must be generated using ‘blocked’ formatting (see CDWRITE in the Command Reference). Files
generated in unblocked format are not supported. Only NBLOCK and EBLOCK data will be read
from the file. Elements defined in the EBLOCK command should also have a corresponding element
type and number (ET command) defined in the CDB file. No load/data transfer information is read.

The following element types are ignored during reading of the file:

• Solid168

• Targe169,170

• Conta171,172,173,174,175,176,177,178

• SURF152,153,154,156

Data transfer information must be defined in separate files, which also must be added to the same
External Data system. These files must have a column providing node identifiers that match the
node IDs defined in the Mechanical APDL CDB file. If the data transfer file contains element nodal
values, then both node and element identifier columns need to be defined. Element values are not
supported.

Note:

• An element defined in the CDB file is ignored by the common mapping utility if any
of the below conditions exist. The ignored elements are not used when data is mapped
in the downstream application.

– One or more of the nodes forming the element are not defined in the NBLOCK
command.

– The element does not have a corresponding element type and number (ET command)
defined in the CDB file.

• CDB files must contain only solid elements or shell elements, but not both.
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• For nodal data transfers, the number of nodes in the Mechanical APDL CDB file must
match the number of data transfer items in all child files.

• If data is not available at midside nodes, then the Average Data at Midside Nodes
property can be used to specify the data at midside nodes as an average of data at
corner nodes.

Importing an Ansys External Data File as Input

You can import an Ansys external data file (.axdt) as a source file.

To import an Ansys external data file:

1. To add an External Data component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To open the External Data tab, double-click the Setup cell or right-click the Setup cell and
select Edit from the context menu.

3. In the Outline of Schematic pane, in the Location column, click .

4. Browse to the location of the Ansys external data file.

5. Select the file and click Open.

The Format Type property is automatically set to Ansys External Data File.

The Length Unit property is not available because this information is specified in the file. All length
unit information in the .axdt file must be the same (all meters, for example).

The Start Import at Line setting is disabled as the entire file is read as data. Delimiter Type, De-
limiter Character, and Format String are also disabled.

Ansys External Data File Format

CFD-Post and the Mechanical application can export external data files (.axdt) that can be used
by the External Data system.

Note:

The Mechanical application does not export temperature data in units of K.

The following is an example of an .axdt file that has been exported from CFD-Post:

[Name]
Plane 1 

[Data]
X [m] (X coordinate), Y [m ] (Y coordinate), Z [ m ] (Z coordinate), 
Wall Heat Transfer Coefficient [W m^-2 K^-1] (Heat Transfer Coefficient), 
Wall Adjacent Temperature [K] (Temperature)
-1.77312009e-02, -5.38203605e-02, 6.00000024e-02, 7.12153496e-06, ...
-1.77312009e-02, -5.79627529e-02, 5.99999949e-02, 5.06326614e-06, ...
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.

.

.
[Faces]
369, 370, 376, 367
350, 374, 367, 368
.
.
.

This file contains three blocks, each with one of the labels: [Name], [Data] and [Faces]. The [Name]
block contains the name of the region contained/defined in the file.

The [Data] block contains node coordinates and values. The first line following the [Data] label is
a header that contains a comma separated list of unique labels, units and quantity type for coordin-
ates and values at each node. Units are contained in square brackets and quantity types are contained
in parentheses. Subsequent lines, one per node, contain a comma separated list of data defined in
the header. The [Data] block ends in the line before the [Faces] block label.

The [Faces] block contains definitions for topologically two-dimensional faces (small surfaces), each
by 3 (triangle) or 4 (quadrilateral) points. The points must be ordered to trace a path going around
the face. For proper rendering, the faces should have consistent point ordering, either clockwise
or counterclockwise. Each face is automatically closed by connecting the last point to the first point.
Face connectivity data is listed in the [Faces] block and references the points in the [Data] block,
where the latter are implicitly numbered, starting with 0.

Importing Multiple Data Sets

External data can be configured to efficiently import multiple data sets (for example, from a transient
analysis). It can handle multiple sets through a single file or from multiple files.

To import multiple data sets:

1. To add an External Data component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To open the External Data tab, double-click the Setup cell or right-click the Setup cell and
select Edit from the context menu.

3. In the Outline pane, select the data files using one of the following methods:

StepsMethod

Add
one or 1. In the Outline of Schematic pane, in the Location column, click .

more
files to
the
Out-
line
pane.

2. Browse to the location of the files.

3. Select one or more files and click Open.
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StepsMethod

To paste from a flat-text editor (for example, Notepad):Copy a list
of

1. List the paths to the files in the editor. Ensure that there are no trailing
spaces in the lines.

fully-qualified
paths from
a text file

2. Select all the files and copy them (Ctrl+A, then Ctrl+C).or an Excel
file and

3. In the Outline pane, click the row number
paste it

The line becomes highlighted, and the text Click here to add a file
remains visible.

into the
Outline
pane's
Data
Source
field.

4. Press Ctrl+V to add the files.

4. In the Properties pane, set the properties of the files.

If the files are of the same or similar format, you can multi-select the files to set common
properties.
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When you multi-select the files in the Outline pane, you see:

• A value when that value is the same for all selected files.

• A blank field when values differ between selected files.

• A yellow field when a value is required, but is not currently specified for any of the files.

If you edit any field in the Properties pane when multiple files are selected, your change is
applied to all files.

If the X, Y, Z locations of the source points is common between all the files, you can make use
of the main file designation. By designating a main file, all other files use that file's values for
the X, Y, Z locations. This leads to faster user interface set up, as well as much faster mapping
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times as the mapping weight calculations need to be done only once and then are shared for
all child files.

5. Use the Table pane (which is populated from the Format String field in the Properties pane)
to specify the Column data in the file.

You can multi-select the files to fully populate the Table pane. You can span data from all se-
lected files and use various right-mouse button actions to efficiently define the column data.

a. In the Outline pane, multi-select the desired files.

b. In the Table pane, sort the table by Column to order the file data. For example, if you
have four data fields and the first three specify the X, Y, Z locations, sorting by column
places the remaining data-field entries together at the bottom of the column.

c. Select the first row to be changed by clicking on the row number (which is in the table
boundary).

d. Press and hold Shift key.

e. Select the last row to be changed by clicking on the row number.

f. Right-click anywhere over the selected cells, select Set Data Type To from the context
menu, and set the desired data type.

Repeat as required to set the data units using the Set Unit To option.

Tip:

If Set Data Type To or Set Unit To are not available, ensure that your mouse
cursor is over the body of the table, not on the table boundary.
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6. Select and copy the cell entries in the Combined Identifier column that correspond to the
multiple data sets (using Ctrl+C or right-click and select Copy). These data-identifier strings
are used to specify which data set will be imported at each load step inside Mechanical.

7. Link the External Data system into the desired Mechanical system/cell.

8. Update the External Data system.

9. Edit (or, if editor is already open, refresh) the Mechanical system.

10. Set the required Number Of Steps in the Mechanical Analysis Settings object. Set the step
end times as required (you can copy and paste).

11. As needed, create the desired Imported Load/Thickness in Mechanical.
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12. Select the Imported Object, then paste the data identifier text into the appropriate cells inside
the Data pane on the imported object.

13. As required, copy and paste the desired step end times on the Analysis Settings Object and
the Imported Data Object (in the Analysis Time(s) column).

14. Right-click Import Load to invoke the mapping calculations.

15. After mapping has completed, you can review the various mappings by adjusting the Active
Row entry. The graphics render a contour plot of the imported data at the specified row. Ad-
ditionally, this data can be exported out of Mechanical by right-clicking the tree object and
selecting Export.

Applying Source Point Analytical Transformations

Analytical transformation options can be applied to the source nodal locations. You can enter
constant or functional values that are applied to the x, y, and z (or r, theta, z for cylindrical) values
read from the input file from within the External Data User Interface. For a complete list of supported
functions, go to Expressions, Functions, Quantities, and Units (p. 291). The order of operations for
conversion of the original node locations into a format the common mapping utility uses must be
taken into consideration when setting up analytical transformation functions, rotation, and translation
information.

The nodal data, as well as any unit system information, is read into the common mapping utility.
If any nodal analytical transformation values or functions are provided, they are applied directly to
the nodal coordinates as they are read in from the file. If the data is provided in a cylindrical system,
it is converted into Cartesian coordinates. Once the nodes are in Cartesian, all nodal data is converted
into MKS, so that the mapping utility stores all data in the same unit system. If any rotational in-
formation is provided, this is applied next, followed by any translations.

The following example takes nodal data, written in a cylindrical system, from a ring with an inner
radius of 8 mm and an outer radius of 10 mm and allows an analytical transformation value to be
applied to the radius of the source data, such that it aligns with a smaller ring with an inner radius
of 7.2 mm and an outer radius of 9 mm.

Thermal results on an expanded or stretched ring (inner radius is 8 mm and outer radius is 10 mm)

123
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Component Systems



Sample cylindrical nodal data:

Temperature
(–C)

Z Location (mm)Theta (radians)Radius (mm)Node Number

99.9831.6–0.2475351058.9145230651

99.9841.2–0.2475351058.9145230652

99.9840.8–0.2475351058.9145230653

99.9830.4–0.2475351058.9145230654

99.9831.6–0.1926476088.9178738035

99.9841.2–0.1926476088.9178738036

99.9840.8–0.1926476088.9178738037

99.9830.4–0.1926476088.9178738038

99.9831.6–0.1379160298.9271665759

If we simply import the nodal data, you can see how the source nodes are not contained within
the target volume.
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Imported temperature load with unmodified source points displayed:

Within the External Data System user interface, you can enter analytical transformation values as
either constants, or as functions of x, y, or z. For our example, we want to scale the source radius
(that is, X Coordinate) by 90%.

Applying a constant analytical transformation scale factor to the radius (that is, X Coordinate) of
the cylindrical source nodal locations:
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Updating the schematic and looking at the imported load we see the analytical transformation
value has been applied to the nodal locations and now coincides with the target model.

Imported temperature load with "transformed" source points displayed:
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Importing the load generates the following imported load:
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Performing System Coupling Simulations Using External Data

You can use Workbench to perform coupled simulations using multiple analysis or component
systems. The External Data system may be used as a source of static (that is, unchanging) data for
other co-simulation participants such as Ansys Forte or Ansys Mechanical, as described in the System
Coupling User 's Guide

External Data System and System Coupling Configuration

Each External Data system that is connected to the System Coupling system is represented as a
coupling participant in the System Coupling setup. The name of this participant is the name of the
External Data system specified in the Workbench Project Schematic. Since the External Data
system acts as a source of static data, it can only be defined as the source in System Coupling's
Data Transfer definition.

Each input file added to an instance of the External Data system is represented as a coupling region
for the associated coupling participant in the System Coupling setup.

Supported Input File Formats

To use the External Data system as a coupling participant, the Ansys external data file format
should be used. For information regarding use of this file format, see Importing an Ansys External
Data File as Input (p. 117).
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Supported Data Types

Data types provided by external data that are currently consumable by the System Coupling system
include temperature and heat rate.

In the XML file transferred from the External Data system to System Coupling, if the units of the
coordinates in are not all consistent, an error is reported.

External Model

The External Model component system enables you to import finite element files created outside
of Workbench into Workbench. Supported file formats include:

• Mechanical APDL common database (.cdb)

• Workbench mesh data file (.acmo)

• Abaqus Input (.inp)

• NASTRAN Bulk Data (.bdf, .dat, .nas)

• Fluent Input (.msh, .cas)

• ICEM CFD Input (.uns)

• LS-DYNA Input (.k and .key)

Important:

The External Model system only supports .cdb files archived from the Mechanical APDL
application using the Blocked format. As needed, you can import your model into the
Mechanical APDL application and properly archive the model. Use the PREP7 command
CDWRITE,DB to create a compatible file. Or, there is a python script available: <in-
stall_dir>\Addins\ExternalLoad\Scripts that will automatically convert files
to the Blocked CDB format. Execute the script using the File menu (p. 453) option Script-
ing (p. 251).

Requirements and Restrictions

Review the following processing requirements and restrictions:

• Only data included in the selected External Model file is imported. Furthermore:

– Model assembly is not supported for Ansys data. That is, the /INPUT and CDREAD
commands are not supported for Mechanical APDL files.

– The *include command for NASTRAN, Abaqus, and LS-Dyna files are supported.

– For Abaqus files, if you are using the *Instance command, only the data from the very
first command contained in the file is read. All other data from any additional *Instance
command is ignored. The element and node sets, as well as the materials, that are as-
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sociated with the first *Instance command are processed. Any data that follows the first
*End Part of *End Instance commands is ignored.

• Scripting commands used to loop over data or generate additional items are not supported.

• The Abaqus scripting command *NGEN is not supported. The commands *NSET, *ELSET, and
*NODAL THICKNESS are the only commands that support the GENERATE parameter.

• Only the first load step of the Abaqus file is read by the External Model system.

• The following capabilities are not supported on the Linux operating systems:

– Data transfer from the Engineering Data workspace.

– Import of LS-DYNA input (.k and .key) files is not supported on Linux.

Geometry

For the listed file types, you can import solid, shell, and line body finite element meshes. The geometry
is automatically synthesized and made available inside Mechanical.

See the Importing Mesh-Based Geometry section in the Mechanical User's Guide for additional inform-
ation about how to process and work with imported geometry data.

Finite Element Data

For Mechanical APDL common database (.cdb), Abaqus Input (.inp), and Nastran Bulk Data (.bdf, .dat,
.nas) files, you can import the following finite element data for use within your simulation.

• Flexible Remote Connections• Bolt Pretensions and
Premeshed Bolt
Pretensions • Named Selections

• Nodal Orientations• Boundary Conditions

• Point Masses• Composite Plies

• Rigid Remote Connections• Constraint Equations and
Couplings

• Shell Thicknesses

• Contact
• Spring Connectors

• Coordinate Systems

• Cross Sections

• Element Orientations

See Importing Mesh-Based Databases in the Mechanical User's Guide for additional information about
the data types and how to use the data in Mechanical.
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Working with the External Model System

Select a link below to jump to steps for working with finite element data from the External Model
system:

Creating and Configuring an External Model System

Transferring Data to Mechanical

Transferring Data to Engineering Data

Note:

If you open Mechanical in such a way that the simulation does not yet include a mesh,
you can use the Open option of the File tab to import an External Model file.

Creating and Configuring an External Model System

To specify an External Model system:

1. To add an External Model component system, drag the system from the Toolbox to the
Project Schematic or double-click the system in the Toolbox.

Note:

You can drag and drop your mesh file directly onto the Workbench Project
Schematic. The application automatically creates an External Model system linked
to a Mechanical Model system. Any further specification is still required.

2. Double-click the Setup cell or right-click the Setup cell and select Edit from the context menu.
This opens the External Model tab in order to select a desired file or files.

3. In the Outline of Schematic pane, in the Location column, click the icon to add a data source

file ( ).

4. Browse to the location of your source files.

5. Select one or more files and click Open. The selected file names and locations are automatically
displayed in the Data Source column and an entry appears in the Identifier column.

Note:

The application does not copy input files specified in External Model into the
project folders of downstream systems. The application references these files by
absolute path only. Be sure you don’t move or rename these files.

6. If required, update the name in the Identifier column. By default this is Filen.

7. If required, enter descriptions for the files in the Description column.
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8. For the ABAQUS (.inp), NASTRAN Bulk Data (.bdf, .dat, .nas), and LS-DYNA Input (.k and .key)
file, a row labeled Click here to add a supporting file is added to the schematic that enables
you to select and attach additional files to the parent file, such as node and element files.
These attached files are included in the same import group as the parent file and Mechanical
treats them as a package. There is no limit on the number of files you can add and/or attach.

If your parent file contains an "Include" command, property formatted, that references the
desired supporting files, the application software can automatically complete the supporting
files list for you if you update the Setup cell (RMB > Update) of the External Model system. The
supporting file list is auto-filled only if it is empty. In addition, if the parent file references a
file that is not found in the target directory, a warning message is issued. Note that you can
also delete files from the supporting files list. Any supporting file that appears in the parent
file (as "included") but not in the supporting file list will be ignored.

9. Optionally, you can right-click a file (or files) in the Outline pane and use the context menu
to duplicate them.

All files (whether imported or duplicated) can be sorted or filtered.

10. Once you have opened your files, use the Properties pane to modify the unit system, compon-
ents, and/or coordinate system transformation properties. These properties transform the mesh
coordinate systems of the sub-assemblies for proper alignment in Mechanical.

11. If you select multiple files in the Data Source column, the Properties of File pane displays:

• A value when that value is the same for all selected files

• A blank field when values differ between selected files

• A yellow field when a value is required, but not currently specified for at least one of
the files.
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If you edit any field in the Properties pane when multiple files are selected, your change is
applied to all files.

Caution:

Although you can multi-select files in the Data Source pane, when you click away
from that pane the highlighting applied to those files disappears. However, the files
remain active and any subsequent operations that are applied affect the files.

Table 1: Properties Pane: Description Section

DescriptionProperty

This property provides a drop-down list of available file types.Application
Source

Table 2: Properties Pane: Definition Section

DescriptionProperty

The unit system in which the file is defined. Source points are interpreted in
these units.

Important:

When you import a project from a previous release that contains
an External Model system, the Length Unit from that project is

Unit System

converted to a compatible Unit System. You must confirm that
the Unit System chosen is appropriate; if it is not, choose the
correct system from the dropdown list of consistent unit systems.

The External Model system must have a consistent unit system
before you can perform an update.

Enables the External Model system to import node-based components defined
in the mesh files. The application transfers the data to downstream Mechanical

Process
Nodal
Components systems as node-based Named Selections. The application renames the

node-based Named Selection objects in Mechanical based on the selection made
in the Object Renaming property.

This entry field enables you to filter and import only those node-based
components that start with a specified name/string value in the mesh files. For

Nodal
Component
Key example, you want to import only node-based components that start with the

prefix string "nodal_*." Enter that string into this field and the application
filters through all component names and returns only the components that
begin with this key string value.

Enables the External Model system to import any element-based components
defined in the mesh files. The application transfers data to downstream

Process
Element
Components Mechanical systems as elemental-based Named Selections. The application

renames the element-based Named Selection objects in Mechanical based on
the selection made in the Object Renaming property.
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DescriptionProperty

This entry field enables you to filter and import only those element-based
components that start with a specified name/string value in the mesh files. For

Element
Component
Key example, you want to import only element-based components that start with

the prefix string "elemental_*." Enter that string into this field and the
application filters through all component names and returns only the components
that begin with this string value.

Enables the External Model system to import any face components defined in
the mesh files. The application transfers data to downstream Mechanical systems

Process Face
Components

as face-based Named Selections. The application renames the face-based Named
Selection objects in Mechanical based on the selection made in the Object Re-
naming property.

This entry field enables you to filter and import only those face components
that start with a specified name/string value in the mesh files. For example, you

Face
Component
Key want to import only face components that start with the prefix string "face_*."

Enter that string into this field and the application filters through all component
names and returns only the components that begin with this string value.

When you uncheck/deactivate this option, the application will only process
data directly needed for the creation of the mesh and geometry of the

Process
Model Data

external file. All other data from the external file will be skipped. This includes
data such as Connections and engineering abstractions such as plies, bolt
pretensions, boundary conditions, etc. By default, this the option is
active/checked and the application processes all data.

This option supports .cdb files only. When selected, Mesh200 elements present
in your mesh file are included with your geometry in Mechanical.

Process
Mesh200
Elements

This property displays when the Application Source property is set to MAPDL
(default). This property instructs the application to verify that the specified file

Check Valid
Blocked CBD
File is a valid Blocked .cdb file. External Model only supports Blocked format. If

the property is checked and the file is not a valid blocked file, an error message
displays. As needed, you can import your model into the Mechanical APDL
application and properly archive the model. Use the PREP7 command
CDWRITE,DB to create a compatible file. You can also automatically convert
files to the Blocked CDB format using the script file contained in this directory:
<install_dir>\Addins\ExternalLoad\Scripts. Execute the script
using the File menu (p. 453) option Scripting (p. 251).note

Important:

If you unselect this property and your file is not a valid Blocked
cdb file, the application may not properly import your model.

When you connect the Setup cell of an External Model to a Mechanical system,
this property controls whether mesh nodes and elements are automatically
renumbered to prevent conflicts.

The property's options include Automatic (default) and Offset. The
application does not renumber nodes and elements if you specify Offset.

Node and
Element
Renumbering
Method
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DescriptionProperty

In this case, and in order to avoid conflicts, use the Node Offset and Ele-
ment Offset fields to prepend your node and element IDs with the positive
number of your choice.

This property requires that the Number of Copies property is set to 0. If
you enter a value in the Number of Copies property, other than zero, the
application requires automatic node and element ID renumbering.

Use this property to apply a transformation to your upstream model. The
transformation options for this property include Rotation and Translation
(default) and Mirroring.

The Rotation and Translation option enables you to translate the origin
of the upstream model along the X, Y, or Z axis or to rotate the model about
its origin in the XY, YZ, or ZX plane.

Transformation
Type

Using the Mirroring option enables you to import your upstream model
as well as a mirror copy of the model about a specified plane.

Table 3: Properties Pane: Rigid Transformation Section

DescriptionProperty

When set to zero (default), only the source mesh is transformed. If you specify
a number of copies greater than zero, these will be in addition to the source

Number Of
Copies

mesh. For example, if you import a .cdb file with a single part and set Number
Of Copies to 2, you will get 3 parts in Mechanical.

This property is available only when Number Of Copies is set to 1 or greater.
Select the check box if you want to apply the specified transformation to the
source mesh as well as any copies.

Transform
Original

These properties allow you to translate the origin of the model along the X, Y,
or Z axis. If you specify any copies, the translation will be applied relative to the
previous copy (or source mesh in the case of the first copy).

Origin X/Y/Z

These properties allow you to rotate the model about its origin in the XY, YZ,
or ZX plane. If you specify any copies, the rotation will be applied relative to the
previous copy (or source mesh in the case of the first copy).

Theta
XY/YZ/ZX

Note:

For the Rotation and Translation option, transformations are applied in the follow-
ing order:

1. Rotation about the Y Axis

2. Rotation about the X Axis

3. Rotation about the Z Axis
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4. Translations

Note:

The application does not apply Rigid Transform values if they expand to the "identity
transformation." The identity transformation is when the values for Origin X, Origin
Y, Origin Z are all zero (within a tolerance) and Theta XY, Theta YZ, Theta ZX are all
multiples of 360 degrees (within a tolerance). The application uses an absolute and
relative tolerance equal to the 2D Tolerance specified in the Geometry category of
the Options preferences. You can change the specified default value (1e-5) using
the preference dialog.

Table 4: Properties Pane: Mirror Transformation Section

DescriptionProperty

These properties enable you to define the coordinates of a point on the mirroring
plane.

Plane Point
X/Y/Z

These properties enable you to define a vector that is normal (orthogonal) to the
mirroring plane.

Plane
Normal
X/Y/Z

Note:

The Plane Point Z and Plane Normal Z properties are hidden for 2D models.

12. To modify any file in the Outline of Schematic pane, in the Location column, click  and
select a new file.

13. To delete files that you have selected (or multi-selected) right-click one of the files in the
Outline of Schematic pane and select Delete from the context menu.

14. Return to the Project tab.

15. Update the project (p. 243).

16. If required, link (p. 60) the Setup cell of the External Model to the following cells of a Mech-
anical Model or a Mechanical analysis system:

• Model

• Engineering Data (Windows Platform Only)

Transferring Data to Mechanical

Once the External Model system is created, open your mesh files in Mechanical.
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To add a downstream Mechanical system:

1. Drag a valid analysis system from the Toolbox onto the Project Schematic.

2. Link (p. 60) the External Model system Setup cell to the Mechanical system Model cell to
complete the connection.

This action deletes the Geometry cell. Multiple model cells in the Project Schematic can link
to one analysis system. See Assembling External Models and Mechanical Models in the Mech-
anical User's Guide for more details.

3. Modify the Mesh Conversion Options associated with the Mechanical Model cell as required.

See the Importing Mesh-Based Geometry section in the Mechanical User's Guide for more details.

4. Launch Mechanical.

Associativity between External Model and Mechanical

Geometry from External Model (.cdb) files is partially associative. When you have geometry from
multiple External Model system assembled, and you refresh upstream model data into the down-
stream system, any geometry scoping that you have performed on an object in the downstream
analysis is lost for the modified External Model system only. That is, only External Model systems
that you change lose scoping. For example, if you have two External Model systems assembled,
System 1 and System 2, and you have objects scoped to geometry in the assembled system. If you
modify System 1 and then refresh the upstream system, geometry scoping on objects is lost only
for System 1. System 2 experiences no scoping losses. A more robust way to maintain scoping is
to properly define imported named selections or criterion-based named selections. These scoping
features automatically update when the upstream model updating is complete.

Re-reading Modified External Mesh Files

If you change your mesh file, such as making a manual change or as a result of an automated tool,
these types of changes are not automatically updated in Workbench. You must reread your external
data file and update the system to re-import the changed data.

To re-read modified external mesh files:

1. Right-click the Setup cell

2. Select Re-read Input Files from the context menu.

3. Right-click the Setup cell

4. Select Update from the context menu.

The Re-read Input Files operation causes Workbench to regard the file as having changed
whether the file has changed or not, and the status of the Setup cell changes appropriately.

Transferring Data to Engineering Data

As required, you can incorporate Engineering Data.

To add a downstream Engineering Data system:
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1. Drag a valid analysis system, or an Engineering Data system, from the Toolbox onto the Project
Schematic.

2. Link (p. 60) the External Model system Setup cell to the Engineering Data system.

You can link the Setup cell to multiple Engineering Data cells.

3. Launch Engineering Data.

Note:

• Review the supported MAPDL, NASTRAN, and ABAQUS material commands listed
in the following subsections.

• The application creates material names in the Engineering Data workspace based
on the material identifier in the imported file (.cdb, ABAQUS Input, or NASTRAN
Bulk Data). The names include the corresponding (linked) Workbench cell and
number as well as the value in the Identifier column in the External Model setup
interface.

MAPDL Material Commands

The following MAPDL material commands are supported when importing material data into the
Engineering Data workspace.

DescriptionCommand

The following temperature-dependent material property labels are supported for
these commands:

ALPX, ALPY, ALPZ, C, DENS, EX, EY, EZ, GXY, GYZ, GXZ, KXX, KYY, KZZ, NUXY,
NUYZ, NUXZ, PRXY, PRYZ, PRXZ, REFT, MU, MURX, MURY, MURZ, RSVX, RSVY,
RSVZ, MGXX

MPTEMP

MPDATA

Bilinear isotropic hardening (BISO) is the only non-linear material property and
label supported.

TB

TBDATA

NASTRAN Supported Material Specifications

The following NASTRAN material properties are supported when importing material data into
the Engineering Data workspace.

PropertiesCard

MAT1
(Material 1)

• Young's Modulus

• Shear Modulus

• Poisson's Ratio

• Mass Density

• Thermal Expansion Coefficient
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PropertiesCard

• Reference Temperature

MAT2
(Material 2)

• 3 X 3 symmetric material property matrix

• Mass density is supported

• Thermal expansion coefficient vector

• Reference temperature for thermal expansion, if thermal expansion is
defined

No data is supported. Only the material ID is maintained.MAT3
(Material 3)

MAT4
(Material 4)

• Thermal Conductivity

• Specific Heat

No data is supported. Only the material ID is maintained.MAT5
(Material 5)

MAT8
(Material 8)

• Moduli of elasticity

– Modulus in the Z direction uses the value in the Y direction.

• Poisson’s ratio

– Ratio in the YZ directions uses the value in the XY direction.

– Ratio in the XZ direction uses the ½ the value in the XY direction.

• Shear moduli

• Mass density

• Thermal expansion coefficients

• Reference temperature for thermal expansion, if thermal expansion is
defined

MAT9
(Material 9)

• 6 X 6 symmetric material property matrix

• Mass density is supported

Note:

The stiffness terms must be positive (which requires that all
determinants to be positive). Otherwise, the properties are not
imported.

No data is supported. Only the material ID is maintained.MAT10
(Material 10)
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ABAQUS Supported Materials Keywords

The following ABAQUS Materials Keywords are supported when importing material data into the
Engineering Data workspace.

DescriptionKeyword

The NAME parameter is supported.*MATERIAL

*ELASTIC • Supported for TYPE = ISOTROPIC, ENGINEERING CONSTANTS, and
LAMINA.

• The DEPENDENCIES parameter is not supported.

Material property definition is not processed.

• For TYPE = ISOTROPIC:

– Young's Modulus and Poisson's Ratio are supported.

– If Poisson's Ratio is not specified, 0.3 is the value that is used.

– Temperature is dependency supported.

• For TYPE = ENGINEERING CONSTANTS:

Young's Moduli, Poisson's Ratios, and the Shear Moduli in the principal
directions is supported.

• For TYPE = LAMINA:

– Young's Moduli, Poisson's Ratios, and the Shear Moduli in the
principal directions is supported.

Modulus in the Z direction uses the value in the Y direction.

Ratio in the YZ directions uses the value in the XY direction.

Ratio in the XZ direction uses the ½ the value in the XY
direction.

– Temperature dependency is not supported. The data for the first
temperature is used.

The following mutually exclusive parameters (material models) are supported:*HYPERELASTIC

• MOONEY-RIVLIN

• NEO HOOKE: This parameter is equivalent to *HYPERELASTIC, REDUCED
POLYNOMIAL and as a result, is imported as Yeoh 1st Order.

• OGDEN: Supports parameter N = 1 (default), 2, or 3.

• POLYNOMIAL (default): Supports parameter N = 1 (default), 2, or 3.

• REDUCED POLYNOMIAL: Supports parameter N = 1 (default), 2, or 3.
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DescriptionKeyword

• YEOH

Note:

Temperature dependence is not supported.

*DENSITY • The DEPENDENCIES parameter is not supported.

Material property definition is not processed.

• Temperature dependency is supported.

*EXPANSION • TYPE = ISOTROPIC only

• The DEPENDENCIES parameter is not supported.

Material property definition is not processed.

• Temperature dependency is supported.

*PLASTIC • HARDENING = ISOTROPIC only.

• The RATE parameter is not supported.

These stress-strain curves are ignored.

• Curve must have a positive slope.

*CONDUCTIVITY • Supported for TYPE = ISOTROPIC and ORTHO.

• The DEPENDENCIES parameter is not supported.

Material property definition is not processed.

• For TYPE = ISOTROPIC, temperature dependency is supported.

• For TYPE = ORTHO, temperature dependency is not supported; the
data for the first temperature is used.

*SPECIFIC
HEAT

• The DEPENDENCIES parameter is not supported.

Material property definition is not processed.

• Temperature dependency is supported.

Fluent

The Fluent system launches Ansys Fluent, allowing you to complete fluid flow analysis of incompress-
ible and compressible fluid flow and heat transfer in complex geometries.
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Within Fluent, a computational mesh is applied to a geometry, pertinent mathematical models are
applied (for example, low-speed, high-speed, laminar, turbulent, and so on), materials are chosen,
boundary conditions are defined, and solution controls are specified that best represent the problem
to be solved. Fluent solves the mathematical equations, and results of the simulation can be displayed
in Fluent for further analysis (for example contours, vectors, and so on).

To work through a Fluent system:

1. To add a Fluent component system, drag the system from the Toolbox to the Project Schem-
atic or double-click the system in the Toolbox.

2. Right-click the Setup cell and select one of the following options from the context menu:

• To specify the Fluent settings, select Edit.

• To import a previously saved Fluent case file, select Import Fluent Case.

• To import previously saved Fluent case and data files, select Import Fluent Case And Data.

Fluent (with Fluent Meshing)

The Fluent (with Fluent Meshing) system (also known as Fluent Meshing or Fluent in meshing mode)
launches Ansys Fluent, allowing you to complete fluid flow analysis of incompressible and compressible
fluid flow and heat transfer in complex geometries.

Within Fluent in meshing mode, a computational mesh is imported and manipulated. Switch to Fluent
in solution mode where pertinent mathematical models are applied (for example, low-speed, high-
speed, laminar, turbulent, and so on), materials are chosen, boundary conditions are defined, and
solution controls are specified that best represent the problem to be solved. Fluent solves the math-
ematical equations, and results of the simulation can be displayed in Fluent for further analysis (for
example, contours, vectors, and so on).

For detailed information on working with Fluent Meshing, see the Fluent User's Guide as well as the
other on-line documentation available under the Help menu within Fluent Meshing. In addition, see
the Fluent in Workbench User's Guide.

For information on submitting Fluent jobs to Remote Solve Manager, see Fluent (p. 141).

To work through a Fluent (with Fluent Meshing) system:

1. To add a Fluent (with Fluent Meshing) component system, drag the system from the Toolbox
to the Project Schematic or double-click the system in the Toolbox.

2. To open Fluent in meshing mode and import a computational mesh, double-click the Mesh cell.

3. Right-click the Setup cell and select one of the following options from the context menu:

• To specify the Fluent settings, select Edit.

• To import a previously saved Fluent case file, select Import Fluent Case.

• To import previously saved Fluent case and data files, select Import Fluent Case And Data.
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Forte

The Forte system launches ANSYS Forte, allowing you to complete fluid flow analysis of engines and
other detailed reacting systems, employing heat transfer and advanced spray models in complex
geometries and using automated mesh generation.

Import a mesh or allow Forte to mesh on-the-fly with automated mesh generation. Within Forte, a
computational mesh is applied to a geometry, pertinent mathematical models are applied (for example,
low-speed, high-speed, laminar, turbulent, and so on), chemistry and reaction condition are selected,
boundary conditions are defined, and solution controls are specified that best represent the problem
to be solved. Forte solves the mathematical equations, and the results of the simulation can be dis-
played in Forte for further analysis (for example contours, vectors, and so on).

For detailed information on working with Forte see the Ansys Forte User's Guide as well as the other
on-line documentation available under the Help menu within Forte.

To work through a Forte system:

1. To add a Forte component system, drag the system from the Toolbox to the Project Schematic
or double-click the system in the Toolbox.

2. Right-click the Setup cell and select one of the following options from the context menu:

• To specify the Forte settings, select Edit.

• To import a previously saved Forte project, select Import Forte Project.

• To import previously saved Forte replay file, select Replay Journal.

Geometry

The Geometry system launches either Ansys Discovery, SpaceClaim, or DesignModeler, allowing you
to create and import a model. It also allows you to import an existing geometry file.

Note:

When creating or importing geometry from SpaceClaim, there are user interface and
functional differences between SpaceClaim and SpaceClaim Meshing.

The Geometry cell has a different icon.

SpaceClaim MeshingSpaceClaim

Downstream systems like Mechanical recognize the different types.
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There are also different transfer types. For more details, see Transferring a Mesh to Down-
stream Systems in in the Discovery SpaceClaim documentation.

You can also import BladeGen model files into DesignModeler using the BladeEditor feature.
BladeEditor provides a seamless path to both structural and fluid analysis, which enables you to effi-
ciently transition from preliminary blade design, to full 3D viscous flow analysis, and finally to your
native CAD system. BladeEditor features are available in DesignModeler depending on your license
preferences. For more information on Ansys BladeEditor, see Ansys BladeEditor help.

You can set your user preferences to select your preferred editor as default. For more information,
see Geometry Import (p. 433).
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For more information on the geometry capabilities in Workbench, see DesignModeler Project
Schematic Operations in the Ansys DesignModeler User's Guide

To work through a Geometry system:

1. To add a Geometry component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

You can also drag a geometry file to the Project Schematic. A Geometry component system is
created with the geometry file attached.

2. Right-click the Geometry cell and select one of the following options from the context menu:

• To open SpaceClaim, select New SpaceClaim Geometry.

You can then build a model using its features. When you save the geometry, the file becomes
an .scdoc file.

• To open DesignModeler, select New DesignModeler Geometry.

You can then build a model using its features. When you save the geometry, the file becomes
an .agdb file.

• To import an existing geometry file, select Import Geometry.

GRANTA MI

The GRANTA MI system launches GRANTA MI:Materials Gateway, an application that can be embedded
in a variety of CAD and CAE environments, allowing you to directly access your company’s GRANTA
MI database. You can then search and browse the GRANTA MI database, find materials, view their
datasheets, choose applicable CAE materials models, and then import these models directly to Ansys
projects, complete with full traceability information.

For more information, see GRANTA MI Support.

To work through a GRANTA MI system:

1. 1. To add a GRANTA MI component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. Right-click the MI Materials Gateway cell and select Edit from the context menu.

GRANTA Selector

The GRANTA Selector system launches GRANTA Selector, a suite of software tools and materials
property data that supports systematic materials selection.

For more information, see GRANTA Selector Support.

To work through a GRANTA Selector system:
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1. 1. To add a GRANTA Selector component system, drag the system from the Toolbox to the
Project Schematic or double-click the system in the Toolbox.

2. Right-click the GRANTA Selector cell and select Edit from the context menu.

ICEM CFD

The ICEM CFD system launches Ansys ICEM CFD. This application extends Ansys meshing capabilities
with robust and varied geometry import, the ability to efficiently mesh large or complex models with
extended meshing controls, advanced interactive blocking tools for structured or unstructured mesh
generation, extended mesh diagnostics, advanced interactive mesh editing, and output to a wide
variety of solver formats including CFD, FEA, and neutral formats.

Ansys ICEM CFD can input geometry in almost any format, whether a commercial CAD design package,
third-party universal database, scan data, point data, or even combinations of CAD, facets, and mesh.
It includes a variety of "patch independent" meshing methods which are able to work with dirty cad
and does not require that surfaces be formed into solids or that flow volumes be extracted. It does
include a wide range of interactive geometry, blocking and mesh editing tools that can be used to
generate advanced or high quality meshes for any application.

The data-integrated ICEM CFD component system, or "Ansys ICEM CFD Add-in", enables you to launch
ICEM CFD from Ansys Workbench and use it to build a project, with the option of adding upstream
data from Geometry, Mesh, Mechanical Model, or combined Geometry and Mesh system components.
You can also use ICEM CFD to provide data to downstream component systems, such as Ansys Forte,
Ansys CFX, Ansys Polyflow, FENSAP-ICE, and Mechanical APDL.
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Elements of the ICEM CFD Component

The ICEM CFD component system contains the following cells.

DescriptionCell

Identifies the component type and provides access to standard Workbench context menu
options (p. 457).

System
header

Modifies some aspects of the project and opens the project in ICEM CFD.

The Model cell context menu items include the following:

Model

• Edit: Opens the ICEM CFD application and loads an existing Geometry/ICEM CFD
file.

• Duplicate: Copies the entire geometry and mesh data, enabling you to edit the
Model cell in the duplicate system to investigate an alternative modeling approach.

• Transfer Data From New: Enables the transfer of data from upstream Geometry,
Mesh, Mechanical Model, or combined Geometry and Mesh components.

Note:

If the Geometry cell option Use Associativity is On (its default setting),
Part Reference IDs are stored in a Workbench database and remain
persistent in ICEM CFD even if the topology of the geometry is changed.

• Transfer Data to New: Enables the transfer of data from an ICEM CFD project to
downstream data-integrated system projects, such as:

– Forte

– CFX

– Polyflow

– FENSAP-ICE
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DescriptionCell

– Mechanical APDL

• Update, Refresh, Reset, Rename, Properties, and Add/Edit Note. These standard
actions are described in System Header Context Menu Options (p. 457).

• Create Subset(s) from Named Selection: Transfers overlapping named selections
to multiple subsets instead of to exclusive parts if this option is set. This creates
geometry subsets instead of parts, allowing you determine the part where the
geometry entity (point/curve/surface) should be associated. When this option is
disabled, each geometry is assigned to only one part, losing association with other
named selections (which are mapped to parts).

Displays and allows you to edit input and output parameters for ICEM CFD.Parameters
(optional)

Note:

Scripts written in ICEM CFD may not be parametric with upstream or downstream projects.
Care should be taken to write scripts whose functions do not exceed the capabilities of
the upstream or downstream component systems.

Creating an ICEM CFD Component

You can create an ICEM CFD component system in Workbench using any of the following methods:

• Double-click the ICEM CFD system template in the Toolbox.

• Drag-and-drop the ICEM CFD system template onto the Project Schematic.

• Right-click a Geometry or Mesh system and select Transfer Data to New → ICEM CFD.

• Import (p. 49) a standalone ICEM CFD project into Workbench.

Updating ICEM CFD Projects

Updating a project in Workbench brings the entire ICEM CFD system up to the most current status,
including upstream and downstream data.

Changes that require you to update your ICEM CFD project include changes to upstream data and
changes you make in the ICEM CFD editor. When changes are made, the cell in the Project
Schematic window indicates that an update is required. Note, however, that changes made in the
ICEM CFD editor will not cause the system to go out of date until the project, tetin file (geometry),
blocking file, and/or Replay file are saved.

The actions taken by Workbench depend on whether the following conditions are met:

• Blocking exists.

• A Replay file exists.
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• Blocking parameters are set.

• Other input parameters are set.

The following table describes the actions performed by ICEM CFD according to these conditions:

Actions performed by ICEM CFDOther
Input
Parameters

Blocking
Input
Parameters

Replay
File

Blocking

NoNoNoNo 1. Runs tetra default meshing.

2. Saves the unstructured mesh.

3. Saves the project

NoNoNoYes 1. Runs hexa default meshing.

2. Saves the unstructured mesh.

3. Saves the project.

YesNoNoNo 1. Sets all input parameters.

2. Runs tetra meshing. Runs prism meshing if any Part
PART_NAME: Prism input parameters exist. (See
Setting Parameters for Prism Meshing (p. 157).)

3. Saves the unstructured mesh.

4. Saves the project.

YesNoYesNo 1. Sets all input parameters.

2. Runs the Replay file.

3. Saves the unstructured mesh.

4. Saves the project.

YesYesYesNo 1. Sets all input parameters except blocking
parameters.

2. Runs the Replay file.

3. If blocking now exists:

a. Sets blocking input parameters.

b. Runs hexa meshing.

c. Converts pre-mesh to unstructured.

d. Saves the unstructured mesh
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Actions performed by ICEM CFDOther
Input
Parameters

Blocking
Input
Parameters

Replay
File

Blocking

4. Saves the project.

YesYesNoYes 1. Sets all input parameters.

2. Sets blocking input parameters.

3. Runs hexa meshing.

4. Converts pre-mesh to unstructured.

5. Saves the unstructured mesh.

6. Saves the project.

YesYesYesYes 1. Sets all the input parameters except blocking.

2. Runs the Replay file.

3. If blocking still exists:

a. Sets blocking input parameters.

b. Runs hexa meshing.

c. Converts pre-mesh to unstructured.

d. Saves the unstructured mesh.

4. Saves the project.

ICEM CFD saves the unstructured mesh and project only if the ICEM CFD project is closed and you
update from Workbench. If the ICEM CFD project is open, you must manually save the unstructured
mesh and project.

Meshing input parameters are set before the Replay file is run; blocking Input parameters are set
after a replay file is run, but only if blocking exists after the replay file is run.

If no Replay file exists, the default mesher is determined by the presence or absence of blocking:
if no blocking exists in the project, tetra is the default. Conversely, if blocking exists in the project,
hexa is the default mesher.
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Updating a Project

To update a project and refresh upstream and downstream data, right-click the Model cell and
select Update.

Note:

If available, Update uses the ICEM CFD Replay file to update the ICEM CFD project.

Interface Differences in the Data-Integrated ICEM CFD

The data-integrated ICEM CFD interface has been modified to provide additional functionality that
enhances the integration of ICEM CFD and Workbench.

• One-click menus that enable you to control basic project and Replay Recording functions.

Note:

If you create Workbench input parameters and want to step through the script
line-by-line or using a line range, you must open the Workbench Replay Control
dialog from this menu.

• The Workbench Replay Control dialog enables you to test and edit Replay scripts created
within Workbench.

You can ensure that you are working within the data integrated environment by checking the
Message window within ICEM CFD. The first line identifies that the application is integrated in the
Workbench framework.

One-Click Menus

The following one-click menu options are available in the Toolbar when you open ICEM CFD from
Workbench:

• Save Project: Saves the entire project, including Workbench data.

• Refresh Project: Refreshes the upstream data in the ICEM CFD project.
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• Update Project: Brings the entire ICEM CFD system up to the most current status, including
upstream and downstream data.

• Start Replay Recording: Begins recording the commands needed to generate a custom
meshing process. All of the steps in the mesh development process are recorded, including
blocking, mesh size, edge meshing, boundary condition definition, and final mesh generation.
See Replay Scripts in the Ansys ICEM CFD Help Manual. After you click the Start Replay Re-
cording icon, the icon changes to the Stop Replay Recording icon. You can click this icon
to stop recording.

You can also click the arrow to choose Pause Replay Recording, Run Replay File, Delete
Replay File, and Replay Control, which opens the Workbench Replay Control dialog.

Note:

If you create Workbench input parameters and want to step line by line or using
a line range through a replay file, you must use the Replay Control item from
this menu to start the Workbench Replay Control dialog.

• Output Mesh: You can choose to save the ICEM CFD mesh output to one of several formats
including Forte, CFX, Polyflow, Ansys Meshing, or FENSAP-ICE projects.
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Workbench Replay Control Dialog

The Replay Control dialog helps you create, test, and edit script files by performing operations in
Ansys ICEM CFD and recording the equivalent Tcl/Tk commands in a Replay file. You can then use
the dialog to step through and edit the script.

The Workbench Replay Control dialog works exactly the same as the standalone Replay Control
dialog, with two key exceptions:

• The Workbench Replay Control dialog supports Workbench input parameters and allows
you to step through them.

• The dialog automatically loads the current Replay script file (ICM.rpl) instead of opening
a file browser.

For more information, see the Replay Scripts in the Ansys ICEM CFD Help Manual.

Setting Parameters

Using input parameters in Workbench enables you to pass data to ICEM CFD, while output parameters
allow you to receive data back from ICEM CFD. The interaction of parameters between applications
provides you with greater flexibility and capabilities to run optimization and what-if scenarios. For
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more information about using parameters in Workbench, see Working with Parameters and Design
Points (p. 283).

Parameters may be set globally or individually, with individual parameters taking precedence over
global values.

You can perform the following operations involving parameters:

• Setting Input Parameters (p. 154)

• Setting Workbench Mesh Parameters for Parts (p. 156)

• Setting Parameters for Prism Meshing (p. 157)

• Setting Output Parameters (p. 158)

• Setting User-Defined Parameters (p. 160)

• Deleting Parameters (p. 161)

Setting Input Parameters

Clicking the box to the right of certain Meshing Input parameters enables you to select whether
the parameter is controlled from within ICEM CFD or from within Workbench. A "P" in the check
box indicates that it has been selected as a Workbench input parameter. If the check box is empty,
you can control the input from within ICEM CFD.

You can set the following input parameters in Workbench:

• Global Mesh Size (See Global Mesh Size in the Ansys ICEM CFD Help Manual ).

• Shell Meshing (See Shell Meshing Parameters in the Ansys ICEM CFD Help Manual).

• Volume Meshing (See Volume Meshing Parameters in the Ansys ICEM CFD Help Manual).

• Prism Meshing (See Prism Meshing Parameters in the Ansys ICEM CFD Help Manual).

• Surface Mesh Setup (See Surface Mesh Setup in the Ansys ICEM CFD Help Manual).

• Curve Mesh Setup (See Curve Mesh Setup in the Ansys ICEM CFD Help Manual).

• Edge Params (See Edge Params in the Ansys ICEM CFD Help Manual).
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• Vertex Location (See Set Location in the Ansys ICEM CFD Help Manual).

Tip:

• If you create Workbench input parameters and want to step line by line or using a
line range through a replay file, you must use the Workbench Replay Control item
from the One-Click menu to start the Workbench Replay Control dialog.

• For Surface Mesh Setup, Curve Mesh Setup, and Edge Params, you can set para-
meters for all existing surfaces, curves, or edges at once; in addition to setting a
parameter for a single surface, curve, or edge.

• Parameterized edges and vertices (location) can be easily located in the graphics
display. Use Edges → Show Parameterized Edges, under Blocking in the Display
Tree to color all parameterized edges red. Similarly, Vertices → Show Parameterized
Vertices will color the parameterized vertex number red.

Setting General Input Parameters

To set input parameters in Workbench:

1. In ICEM CFD, select an input parameter.

2. Select the check box next to the parameter.

3. To confirm the selection, click Yes.

A P in the check box indicates that the parameter has been created for Workbench.

Note:

You will not be able to edit the parameter within ICEM CFD unless you click the
check box again and deselect the parameter.

4. In Workbench, double-click the project’s Parameters cell.

5. Edit the parameter values in the Outline of Schematic: Parameters pane.

6. Switch to the Project tab.

You can now update the project using the new parameter settings.
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Setting the parameters for a single curve, surface, or edge

To set single curve, surface, or edge parameters in Workbench:

1. In ICEM CFD, open the Surface Mesh Setup, Curve Mesh Setup, or Edge Params parameters
from the Tab menu.

2. At the top of the Parameters window, click Select.

3. To select the curve, surface, or edge for which you want to set parameters, click the Left
Mouse button

4. Click the Middle Mouse button to complete the selection.

The surface, curve, or edge you selected are listed in the selection entry.

5. Select the check box next to the parameter you want as the input parameter.

6. To confirm the selection, click Yes.

A P in the check box indicates that the parameter has been created for Workbench.

Setting the Parameters for All Existing Curves, Surfaces, or Edges

To set single curve, surface, or edge parameters in Workbench:

1. In ICEM CFD, open the Surface Mesh Setup, Curve Mesh Setup, or Edge Params parameters
from the Tab menu.

2. Leave the surface, curve or edge selection field empty (do not select any surface, curve or
edge).

3. Select the check box next to the parameter you want as the input parameter.

4. To confirm the selection, click Yes.

A P in the check box indicates that the parameter has been created for Workbench.

Setting Workbench Mesh Parameters for Parts

The Part Mesh Setup parameters allow you to specify the mesh parameters for different parts
of a geometry.

For more information, see Part Mesh Setup in the Ansys ICEM CFD Help Manual.

To create a Workbench mesh parameter for a part:

1. Switch to the Mesh tab.
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2. Click the Part Mesh Setup icon.

3. In the Part Mesh Setup dialog, select a part and assign non-zero values to one or more of
its parameters.

4. Click the  Parameter column for the part.

5. A dialog asks you to confirm that you want to create a Workbench parameter for each value
you have changed.

Note:

If any Workbench parameters are already set for the part, a dialog will ask if you
want to delete that Workbench parameter.

Parameters assigned as Workbench parameters are highlighted in blue.

To delete a parameter, click in the Parameter column. A dialog asks you to confirm that you
want to delete each individual Workbench parameter in the row.

As with ICEM CFD, the Apply inflation parameters to curves and Remove inflation parameters
from curves options affect Workbench parameter behavior as well. The current value of Apply
inflation parameters to curves  is saved to the project file/.aienv_options file, so it
is always available in GUI or Batch mode.

Setting Parameters for Prism Meshing

You can add prism meshing parameters using the Part Mesh Setup dialog box.

To set parameters for prism meshing:

1. Switch to the Mesh tab.

2. Click the Part Mesh Setup icon.

3. In the Part Mesh Setup dialog box, select a part and select the check box in the Prism
column.

4. Click the Parameter column for the part.
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5. A dialog asks you to confirm that you want to create a Workbench parameter for Part
PARTNAME: Prism.

Note:

If any Workbench parameters are already set for the part, a dialog asks if you
want to delete that Workbench parameter.

Setting Output Parameters

You can set Workbench output parameters to:

• List unstruct mesh and pre-mesh blocking quality metrics

• List the number of mesh errors and possible problems

• List the number of element and block types created.

You set the output parameters within the ICEM CFD application, then view them in either Work-
bench or ICEM CFD.

Setting Output Parameters

To set the output parameters:

1. In ICEM CFD, select Settings → Workbench Parameters → Workbench Output Parameters.
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2. Optionally, select the Output quality metrics check box to select quality metrics.

a. Use the Quality Metrics drop-down menu to select the metric you want to set.

b. Click the radio buttons to select the mesh types to check for the metric.

3. Optionally, select the Output number of elements check box and select the check boxes
next to the element types where you want an output.

4. Optionally, select the Output Check Mesh check box and select the check boxes next to
the errors you want to have tallied in the output results.

ICEM CFD performs an analysis as part of the meshing process and list the results in the
Output window and in the Workbench Parameters window.

5. To set the blocking output parameters, select the Output Pre-Mesh Quality and Output
Number of Blocks check boxes.

For more information about pre-mesh quality, see Determining the Pre-Mesh Quality in the
Ansys ICEM CFD User's Manual.

For more information about Hexa Block types, see Hexa Block Types in the Ansys ICEM CFD
User's Manual.

Deleting Output Parameters

To set the output parameters:

1. In ICEM CFD, select Settings → Workbench Parameters → Workbench Output Parameters.

2. In the Workbench Output Parameters window, select one or more of the following options,
as required:

• Delete all quality metrics output parameters

• Delete all number of elements output parameters

• Delete all Pre-Mesh Quality output parameters

• Delete all Number of Blocks output parameters

3. Click OK.
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Setting User-Defined Parameters

Setting user-defined parameters provides flexibility and control over the meshing operation. For
example, parameters that cannot be applied as single input parameters can be individually set
with user-defined parameters.

Note:

See the Ansys ICEM CFD Programmer's Guide for information about using user-defined
parameters with replay scripting.

Setting User-Defined Input Parameters

To set user-defined input parameters:

1. In ICEM CFD, select Settings → Workbench Parameters → Workbench User Defined
Parameters.

2. In the Workbench User Defined Input/Output Parameters window, select the Create Input
Parameter check box.

3. Enter a value for Parameter name.

4. Enter a value for Parameter. This field must not be empty.

5. Click Apply or OK.

You can edit this value in the Outline of Schematic: Parameters pane.

Setting User Defined Output Parameters

To set user-defined output parameters:

1. In ICEM CFD, select Settings → Workbench Parameters → Workbench User Defined
Parameters.
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2. In the Workbench User Defined Input/Output Parameters window, select the Create
Output Parameter check box.

3. Enter a value for Parameter name.

4. Enter a value for IC Function.

The IC Function must start with ic_geo_ or ic_uns_ or ic_hex_ and must return an
integer or a float value.

Note:

See the Ansys ICEM CFD Programmer's Guide for information about IC functions.

5. Click Apply or OK.

Deleting Parameters

Use this procedure to delete any input or output parameter, whether user-defined or otherwise.

To delete parameters:

1. In ICEM CFD, select Settings → Workbench Parameters → Workbench User Defined
Parameters.

2. In the Workbench User Defined Input/Output Parameters window, select the Delete In-
put/Output Parameter check box.

3. Using the drop-down menu, select the name of the parameter you want to delete.

4. Click Apply or OK.
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User-Defined Parameters Example

This example illustrates how you can use user-defined parameters to test different meshing scen-
arios for a simple box:

1. To add a data-integrated ICEM CFD component system to the Workbench Project Schematic,
in the Toolbox, double-click ICEM CFD.

2. To open ICEM CFD, double-click the Model cell.

3. First, create an input parameter, ZSIZE, that you can manipulate from Workbench.

a. Select Settings → Workbench Parameters → Workbench User Defined Parameters.

b. Click Create Input Parameter.

c. Name the parameter ZSIZE and set Parameter Value to 2.

d. Click OK.

4. Now create a box model to perform a meshing operation on. Record the process so the oper-
ation can be performed again when you update it from Workbench.

a. Click Start Replay.

b. Switch to the Geometry tab.

c. Select Create/Modify Surface.

d. In the Create/Modify Surface window, select Standard Shape.

e. Select Box and click Apply.

f. Switch to the Mesh tab.
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g. Select Compute Mesh.

h. Select Volume Mesh and click Compute.

i. To use autosizing for the mesh size, click Yes.

j. Click Stop Replay Recording.

k. To save the project, select File → Save Project.

5. Next, edit the script to use the input parameter.

a. From the One-Click Replay Recording menu, select Workbench Replay Control.

b. Click Edit.

c. Change Line 16 (or whichever line is appropriate) from ic_vid_objectbox8 GEOM
00 {0 0 0} 1 1 1 to ic_vid_object box8 GEOM 00 {0 0 0} 1 1
[ic_wb2_get_parameter user_defined ZSIZE]

d. Select File → Save.

e. Close the Edit window.

f. Click Save save the file as ICM.rpl.

g. Click Done.

Do not close ICEM CFD.
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6. Now you can change the input parameter through Workbench.

a. In the Workbench Project Schematic, double-click the Parameters cell of the ICEM CFD
component.

b. Change the value of ZSIZE to 5.

c. Return to the Project tab.

d. Right-click the Model cell and select Update.

You can watch the Replay script run using the new parameter in the ICEM CFD interface. Each time
you change the ZSIZE parameter in Workbench, a new part will be generated and meshed with
the new ZSIZE parameter value.

Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.164

Working Through a System



Transferring an ICEM CFD Project to Static Structural

When you create a project that transfers ICEM CFD data downstream to a Static Structural system,
data that is applied to the geometry, such as load data, is not transferred to the structural system.
To work around this limitation, you can use an External Model system as a bridge between the two
systems and then manually set the connections between them.

To transfer an ICEM CFD project to Static Structural:

1. To start with an ICEM CFD component, do one of the following:

• To select an existing ICEM CFD project, select File → Import.

• Drag an ICEM CFD component system onto the Project Schematic and then click the
model to open the ICEM CFD Add-In and create your model.

2. Drag an External Model system from the Toolbox and drop it on the ICEM CFD system.

Note that they are connected through the Model cell.

3. Drag a Static Structural system from the Toolbox and drop it on the Project Schematic as
a standalone system.

Tip:

If you drag the Static Structural system and drop it on the External Model system,
the two cells link Model to Engineering Data, and model information is not passed
downstream.

4. Drag the Model cell from the External Model system and drop it on the Model cell of the
Static Structural system.

5. Right-click the Model cell of the ICEM CFD system and select Update from the context menu.

6. Right-click the Model cell of the External Model system and select Update from the context
menu.

The model is now ready to use within Static Structural.

Icepak

The Icepak system launches Ansys Icepak. This application allows engineers to model electronic
designs and perform heat transfer and fluid flow simulations. You can construct your model geometry
or import model data from other CAD and CAE packages. Icepak then creates a mesh for your model
geometry and passes the mesh and model definition to the solver for computational fluid dynamics
simulation. The resulting data can then be postprocessed using Icepak and/or CFD-Post.

Workbench has the capability of coupling Ansoft steady-state to Icepak steady-state cases and Ansoft
transient to Icepak steady-state cases.

To work through an Icepak system:
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1. To add an Icepak component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. Right-click the Setup cell and select Edit or double-click the Setup cell. This launches Icepak.

3. Create a geometry within the Icepak application.

After creating a geometry, the system displays the cell state as Unfulfilled (p. 449).

The Update Required icon ( ) indicates the system has not been solved.

4. In Icepak, set up the problem and complete your analysis using Icepak's tools and features.

After solving, the Icepak system displays an up to date cell state as shown below.

The Up to Date icon ( ) indicates that all necessary files are loaded and up to date.

5. Load or import an existing Icepak model by selecting one of the following options:

• To load an existing Icepak model, right-click the Setup cell and select Import Icepak Project.

• To import an existing Icepak model:

1. Right-click the Setup cell and select Import Icepak Project From .tzr.

2. Click Browse

3. In the dialog box, browse the directory structure and select the model to load.

The system displays an incomplete cell state.
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The Update Required icon ( ) indicates the system has not been solved.

Icepak project files are located in the system directory under IPK. All Icepak projects saved in
Workbench follow this naming convention which is described in Project Directories (p. 278). All
other Icepak projects can be saved anywhere. Note, there are no special icons for Icepak projects
to differentiate them from other files.

Note:

You can only import one Icepak project per system.

6. In Icepak, set up the problem and complete your analysis using Icepak's tools and features.

After solving, the Icepak system displays an up to date cell state as shown below.

The Up to Date icon ( ) indicates that all necessary files are loaded and up to date.

Note:

If you load an Icepak project that already has a solution, the Solution cell state will
show an up to date cell state after the model is loaded.

7. You can also import geometry into Icepak from DesignModeler. See the DesignModeler to Ice-
pak (p. 170) section for details on importing geometry from DesignModeler into Icepak or loading
a geometry.

Workbench Menu Options Overview for Icepak Projects

Many Icepak options remain the same when running Icepak from the Workbench framework.
However, there are a few changes that should be noted.

DescriptionMenu
Item

Saves all changes to your project. The Save button in Workbench works the same way as
Save project in Icepak, you can use either one. All Icepak projects saved in Workbench will

Save
project

follow the directory structure described in Project Directories (p. 278). See Saving a Project
File (p. 269) for a description of Save and Save as options in Workbench.

Generate a single archive file that contains all project files. This archive includes the project
file and all files in the project_name_files directory, not just Icepak files. The archive is saved

Archive
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DescriptionMenu
Item

as a zip file. Icepak users familiar with the Pack option in the standalone Icepak application
will find this option works in a similar fashion except that all Workbench files are archived.
See Archiving a Project (p. 270) for a complete description of the Archive option in Workbench.

Note:

Previously imported external files from a restored archive directory are treated
as internal files if archived again.

Icepak Context Menu Options

When the Icepak system is active in the Project Schematic, use the right mouse button to initiate
the following Setup cell actions.

DescriptionMenu
Item

Launches Icepak. This is the default operation.Edit

Opens a Browse dialog box to add an input file, then launches Icepak and reads the input
files. This is the default action. This option is available only when a project is empty.

Import
Icepak
Project
From
.tzr

Opens a Browse For Folder dialog box to add an input file, then launches Icepak and
reads the input files. This is the default action. This option is available only when a project
is empty.

Import
Icepak
Project

Creates a duplicate of the Icepak system and any upstream data. If the duplicate operation
is performed on a system containing a solution, the solution is transferred and you must
re-solve. The system cell state indicates the need to re-solve.

Duplicate

Creates a second, dependent (connected) system with the existing system.Transfer
Data
From
New

Updates the system if data is changed or modified. You have the option to incorporate
the changes in the Refresh Input Data pane and initiating the solver inside Icepak. See

Update

DesignModeler to Icepak (p. 170) for a further description of the update option and how
the Refresh Input Data panel is used.

Note:

You must open the Icepak editor before doing an update.
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DescriptionMenu
Item

Refreshes the system if data is changed or modified. You have the option to incorporate
the changes in the Refresh Input Data panel. See DesignModeler to Icepak (p. 170) for a
further description of the refresh option and how the Refresh Input Data panel is used.

Note:

You must open the Icepak editor before doing a refresh.

Refresh

Renames the system or cell.Rename

Displays applicable cell properties in the Properties pane.Properties

Allows you to run the solution if data is unchanged. This changes the Setup cell icon from
a green check mark to the Update lightning icon.

Enable
Update

Displays a quick help panel for the cell. Quick help provides a brief description of how to
use the cell in its current state. You can also click the blue triangle in the lower right corner
of a cell to view quick help.

Quick
Help

The Solution cell actions are similar to those of the Setup cell; however, there are additional actions
and functions. These are described in the list below. Use the right mouse button to initiate the
following Solution cell actions.

DescriptionMenu
Item

Opens an Open dialog box where you can specify an Icepak solution file to load. This option
is used primarily to view multiple solutions for a project. If the you re-solve in Icepak, the
solution case file is overwritten with the latest solution.

Set
Case
File...

Creates a downstream system that can accept data from the selected cell. Only those systems
that can provide valid data to the selected cell are shown. When you select a system from

Transfer
Data

the options shown here, that system is displayed to the right of the currently-selected
system, with all appropriate connections drawn.

to
New

Performs an update if solution data is changed or modified. You can bring in the latest
solution case file into the solution cell for consumption.

Update

System Names

You can enter an Icepak system name for your project as described in Naming Systems (p. 233). In
addition, you can use the Rename option to change the name of a system or cell. In the Icepak
application, the system coordinate, system name, and application name are displayed in the top
left corner.
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Icepak Properties

Select or enable Use Workbench Color Scheme to keep the Workbench background graphics
colors and display defaults in Icepak.

To enable this option:

1. Right-click the Setup cell and select Properties from the context menu.

2. In the Value column, select the Use Workbench Color Scheme check box.

DesignModeler to Icepak

CAD models created or edited in DesignModeler can be imported into Icepak. Icepak instructs
DesignModeler to export the current DesignModeler geometry into Step file format so it is readable
by Icepak.

To transfer geometry upstream to Icepak:

• To add a Geometry component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

The Attention Required icon ( ) indicates that an input file is required.

1. To launch the DesignModeler application, double-click the Geometry cell or right-click the
Geometry cell and select New Geometry from the context menu.

You can import any geometry or load an existing DesignModeler geometry by right-clicking
the Geometry cell and selecting Import Geometry from the context menu.
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The Up to Date icon ( ) indicates that all necessary files are loaded and up to date.

2. Establish the connection to Icepak using one of the following options:

• Drag and drop an Icepak system on top of the Geometry cell.

• In the Toolbox, double-click Icepak to add the Icepak system to the Project Schematic,
then click the Geometry cell and drag it to the Icepak Setup cell.

• Right-click the Geometry cell and select Transfer Data From New from the context
menu, then select a system that uses DesignModeler.

• Right-click the Geometry cell and select Transfer Data to New from the context menu,
then select a connection to Icepak.

3. To launch the Icepak application, double-click the Setup cell.

If the geometry is different from DesignModeler’s native format (.agdb), you must edit the
geometry first before exporting into Icepak.

A new project is created and DesignModeler geometry is imported into Icepak as STEP geometry.

4. If the geometry has been modified, refresh the Icepak Setup cell to bring in the new geometry.
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After you refresh the data, you must either replace the entire model in Icepak or update indi-
vidual geometries that have changed. You are prompted with the following dialog box.

If you select Update model, the Icepak model is updated to match the existing model in
DesignModeler which may result in creating objects that are not currently present in the Icepak
model, the geometries of modified objects will be updated, and the thermal and material
properties of the updated objects are retained. Objects created separately in Icepak will not
be updated.

If you select Replace model, the entire Icepak model will be replaced with the latest input
CAD data from DesignModeler.

See the sample session in Chapter 2 of the Icepak documentation for an example on how to
use Icepak. See Understanding Cell States (p. 449) for a complete list of all cell states.

5. Perform an analysis on the model if you have not yet done so.

6. If the geometry has changed after you have solved, update the Solution cell (p. 244) to bring
in the new changes.
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You can choose to not overwrite the solution using the dialog box shown below, and the update

is cancelled ( ).

Note:

See Workbench Menu Options Overview for Icepak Projects (p. 167) for information on
how to save your project.

Postprocessing Icepak Results

Icepak provides two methods for examining the results of your simulation; you can postprocess
results inside of Icepak or by using CFD-Post.

To postprocess results in Icepak, add an Icepak system to the Project Schematic and perform an
analysis on the model. You can then create graphical displays and examine your results in Icepak.
For details, see Examining the Results in the Icepak User's Guide

To postprocess Icepak results in CFD-Post:

1. Connect the Icepak system to a CFD-Post Results system using one of the following options:

• Drag and drop a Results system on top of the Icepak Solution cell.

• In the Toolbox, double-click Results to add the Results system to the Project
Schematic, then click the Icepak Solution cell and drag it to the Results cell.

• Right-click the Results cell and select Transfer Data From New from the context menu,
then select the Icepak system.

• Right-click the Geometry cell and select Transfer Data to New from the context menu,
then select the Results system.
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2. Icepak results can be postprocessed in CFD Post by double-clicking the Results cell. If you
have more than one solution or your solution has changed, you need to update the Results
cell. If solution data is not transferred, then Results cannot be launched. See CFD-Post help for
more details.

Thermal Results from Icepak to Mechanical

Icepak results can be transferred to the following analysis types within Workbench: Static Structural,
Steady-State Thermal, Transient Structural, or Transient Thermal.

To add an analysis type:

1. Add an Icepak system to the Project Schematic and perform an analysis on the model inside
Icepak.

2. Connect the Icepak system to a Mechanical system using one of the following options.

• Drag and drop an Analysis cell on top of the Icepak Solution cell.

• In the Toolbox, double-click a Mechanical analysis system to add it to the Project Schem-
atic, then click the Icepak Solution cell and drag it to the analysis Setup cell.

• Right-click the analysis Setup cell and select Transfer Data From New from the context
menu, then select the Icepak system.

• Right-click the Icepak Solution cell and select Transfer Data to New from the context menu,
then select a Mechanical analysis system.
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3. Load geometry to satisfy the system.

4. Double-click the Setup cell to launch Mechanical.

5. While in Mechanical insert the appropriate loads based on the type of analysis. See Icepak to
Mechanical Data Transfer for a detailed description of how to import an external load.

Design Explorer to Icepak Coupling in Workbench

The exploration of a given design can be performed by using optimization algorithms in Ansys
DesignXplorer. Parameters exposed from Icepak provide a method for solving an optimization
and/or parameterization problem.

To publish Icepak variables:
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1. In Icepak, define input and output parameters. See Overview of Parameterization for a descrip-
tion on how to define parameters.

Note:

The Design variables tab of the Parameters and optimization panel displays all
the parameters names that are currently defined, along with their associated values.

2. In the Setup tab of the Parameters and optimization panel, select Single trial (current values)
for Trial type if not already selected.

3. At the bottom of the Parameters and optimization panel, click Publish to WB to display the
Publish to WB panel.
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4. In the Publish to WB panel, select the input and output variables to publish to Workbench.

Note:

Variables can be selected independently. In the case of multiple variables, click the
green check mark to toggle all variables on and off.

5. Click Accept to publish variables to Workbench, click Done to publish variables and close the
panel, or click Cancel to withdraw the request.

Workbench recognizes the parameters defined and exposes them in a parameter set bar that
can be shared by multiple systems.

6. To access the Parameters tab, double-click the parameter bar or right-click and select Edit
from the context menu.

For information on defining parameters, refer to Working with Parameters and Design
Points (p. 283).
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Important:

You cannot create, edit, delete, or rename parameters in Icepak if any iterations (or
time-steps) have been performed. If you want to create, edit, delete, or rename
parameters in Icepak for a case with an existing solution, you must first initialize
the solution.

7. To create a new design point, either duplicate an existing design point (p. 305) or add a new
one by entering values (p. 305).

8. Update the design points (p. 306).

Important:

Only the data from the design point in the row labeled Current is saved with the
project. If you want to postprocess the results from a different design point in either
Ansys Icepak or Ansys CFD-Post, click the box in the Exported column for that
design point before you update that design point. Otherwise, the data for that
design point is automatically deleted after the output parameters for that design
point are updated. If you choose to export a design point, the data associated with
that design point is exported to a new project. The new project is located in the
same directory as the original project. The name of the project is the same as the
name of the original project, except that it is appended with _dpn, where n is the
row number that corresponds to the design point in the original project’s Table of
Design Points.

9. Optimization of an Icepak system can be performed in Ansys DesignXplorer. Ansys DesignXplorer
provides various optimization methods with parameters as its fundamental components. These
parameters can come from any supported analysis system, such as Icepak, DesignModeler, and
various CAD systems. Responses can be studied, quantified and graphed. For information on
how to set up an Ansys DesignXplorer analysis, see the DesignXplorer User's Guide.
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Ansoft to Icepak Coupling in Workbench

Icepak can be coupled with Ansoft applications within Workbench in order to perform a one-way
or two-way electromagnetic-thermal interaction problem. Coupling between Ansoft and Icepak
applications within Workbench can be used for simulating fluid flow around or inside electromech-
anical (EM) devices when the temperature of the device is influenced by electromagnetic losses.

The coupling involves solving an electromagnetic problem in the Ansoft application, and mapping
the resulting volumetric heat loss and/or surface loss information into Icepak. Volumetric loss is
mapped onto the solid cell zones as a heat source (load) at the cell centroids that is then added
to the energy equation. Surface loss is applied to the adjacent cells of the solid zones at the surface
that contribute to the source terms of these cells.

Note:

Surface loss is highly concentrated near the surface of the solid zone, so you should
have a fine layer of good quality hexahedral or prism mesh elements located where
surface loss occurs.

You can analyze the results of volumetric or surface losses using the heat flow postpro-
cessing variable under Summary report.

When surface losses are enabled, the double precision solver is recommended.

One-way Coupling between Ansoft and Icepak Within Workbench

To work through an Icepak- HFSS/Maxwell/Q3D Extractor analysis:

1. Connect Ansoft to Icepak using one of the following options:

• Add a HFSS/Maxwell/Q3D Extractor system to the Project Schematic.

1. To add a HFSS/Maxwell/Q3D Extractor system, drag the system from the Toolbox to the
Project Schematic or double-click the system in the Toolbox.

2. Import/create the geometry in the Ansoft application.

3. Set up the problem and solve to obtain a solution for transfer into an Icepak system.

4. Connect the HFSS/Maxwell/Q3D Extractor Solution cell to the Icepak Setup cell.
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• Transfer data from the Icepak system:

1. On the Icepak system, right-click the Solution cell and select Transfer Data From New
from the context menu.

2. Select a connection to a HFSS/Maxwell/Q3D Extractor system.

• Transfer data to an Icepak system:

1. On the Geometry system, right-click the Geometry cell and select Transfer Data to
New from the context menu.

2. Select the Icepak system.

2. To launch the Icepak application, double-click the Icepak cell.

A new project is created in the name of the project cell. If a DesignModeler system is used the
geometry is imported into Icepak automatically. Otherwise, the geometry must be created in
Icepak using Icepak primitive objects.

Note:

The geometry can be exported from the HFSS/Maxwell/Q3D Extractor cell to a
Geometry cell and imported to the Icepak cell using DesignModeler Electronics.
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3. In Icepak, go to the File menu and select EM Mapping and Volumetric heat losses or Surface
heat losses.

The Volumetric heat losses panel contains the following inputs:

• A list of solid objects onto which the loss information can be mapped. For these objects,
Icepak requests the heat source (loss) terms from the Ansoft application. Click the Objects
button to toggle your current object selections. Right-click Objects and select All or None
to select all or none of the objects.

• Solution ID contains available solution sets. Since the HFSS/Maxwell/Q3D Extractor application
may have multiple solutions, Icepak requests the generated heat source data for the selected
solution.

• Frequency (steady-state only) contains available frequencies. Icepak will request that the
HFSS/Maxwell/Q3D Extractor application provide the heat source data for the selected fre-
quency.

• Start time(s) and End time(s) (transient only) contains the available time steps. Icepak will
request that the HFSS/Maxwell/Q3D Extractor application provide an averaged heat loss for
the selected time steps.

Note:

The Start time(s) and End time(s) specified are applied to both volumetric
and surface heat losses.

• Temperature feedback option is used in two-way coupling problems. This option is explained
below.
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Figure 1: Volumetric heat losses - Steady-state
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Figure 2: Volumetric heat losses - Transient

4. Click Accept to close the panel.

5. In Icepak, click Start solution to solve the project.

During solving, HFSS/Maxwell/Q3D Extractor is launched in the background and the volumetric
losses calculated and mapped onto the selected Icepak solid objects. This loss mapping from
HFSS to Icepak is conservative. This is especially important for accurate temperature calculation.

Two-Way Coupling Between Ansoft and Icepak Within Workbench

Two-way coupling enables thermal feedback to be provided between the systems so that you can
exchange temperature data from Icepak to Ansoft applications within Workbench.

To enable two-way coupling between Icepak and Ansoft:

1. Open the Maxwell (or HFSS/Q3D Extractor) project and define temperature–dependent mater-
ial properties (enabling the Thermal Modifier field in the View/Edit Material dialog box and
editing the material’s thermal property definition).
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This makes sure that the Ansoft and Icepak applications generate the temperature–dependent
data.

2. In the Temperature of Objects dialog box, select Enable Feedback.

The Temperature of Objects dialog box is displayed when selecting Set Object Temperature
in the Maxwell 3D /HFSS/Q3D Extractor menu.
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Note:

In Maxwell/HFSS/Q3D Extractor, you can have different losses (Ohmic loss, Core loss,
Hysteresis loss) depending on the type of simulation. Maxwell/HFSS/Q3D Extractor
can also compute the "total loss" which is the sum of all the losses when appropriate.
All the different losses mentioned above including the "total loss" are a function of
space and they are also a function of time in the Maxwell/HFSS/Q3D Extractor
transient solver. When doing the coupling simulation, the "total loss" is mapped to
Icepak for the temperature calculation. For transient simulations, the total loss is
time averaged between two times that you specify before it is mapped to Icepak.

3. Connect Ansoft to Icepak using one of the following options:

• Transfer data from the Icepak system:

1. On the Icepak system, right-click the Solution cell and select Transfer Data From New
from the context menu.

2. Select a connection to a HFSS/Maxwell/Q3D Extractor system.

• Transfer data to an Icepak system:

1. On the Geometry system, right-click the Geometry cell and select Transfer Data to
New from the context menu.

185
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Component Systems



2. Select the Icepak system.

4. To launch the Icepak application, double-click the Icepak cell.

A new project is created in the name of the project cell. If a DesignModeler system is used the
geometry is imported into Icepak automatically. Otherwise, the geometry must be created in
Icepak using Icepak primitive objects.

Note:

The geometry can be exported from the HFSS/Maxwell/Q3D Extractor cell to a
Geometry cell and imported to the Icepak cell using DesignModeler Electronics.

5. In Icepak, go to the File menu and select EM Mapping and Volumetric heat losses or Surface
heat losses.

The Volumetric heat losses panel contains the following inputs:

• A list of solid objects onto which the loss information can be mapped. For these objects,
Icepak requests the heat source (loss) terms from the Ansoft application.

• Solution ID contains available solution sets. Since the HFSS/Maxwell/Q3D Extractor application
may have multiple solutions, Icepak will request the generated heat source data for the se-
lected solution.

• Frequency contains available frequencies. Icepak will request that the HFSS/Maxwell/Q3D
Extractor application provide the heat source data for the selected frequency.

• Temperature feedback enables the writing of temperature data by the Icepak solver to be
sent to the Ansoft application to perform two-way coupling. This option must be enabled
for two-way coupling.

Note:

When volumetric heat losses are not available, two-way coupling can still be per-
formed for surface heat losses by enabling the Temperature feedback option in
the Volumetric heat losses panel.

6. Click Accept to close the panel.
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7. After solving in Icepak, to send temperature data back to the Ansoft application to solve again,
right-click the Ansoft application’s Solution cell and select Enable update from the context
menu.

8. Solve Icepak again using this newly generated data. This process can go on indefinitely until
you are satisfied with the results.

Handling Coupling Iterations Between Ansoft and Icepak

You can also perform manual cyclic updates of individual system components until the solution
stops changing within a desired level of tolerance. For example:

• Coupling Iteration 1

– Update Maxwell/HFSS/Q3D Extractor Solution cell

– Perform EM Mapping on solid zones in Icepak

– Update Icepak Solution cell

– Perform Enable update on Maxwell/HFSS/Q3D Extractor Solution cell

– Update Maxwell/HFSS/Q3D Extractor Solution cell

• Coupling Iteration 2

– Update Icepak Setup cell

– Update Icepak Solution cell

– Perform Enable update on Maxwell/HFSS/Q3D Extractor Solution cell

– Update Maxwell/HFSS/Q3D Extractor Solution cell

• Coupling Iteration 3

– Update Icepak Setup cell

– Update Icepak Solution cell

– Perform Enable update on Maxwell/HFSS/Q3D Extractor Solution cell

– Update Maxwell/HFSS/Q3D Extractor Solution cell

• Coupling Iteration 4

– Update Icepak Setup cell

– Update Icepak Solution cell

– Perform Enable update on Maxwell/HFSS/Q3D Extractor Solution cell

– Update Maxwell/HFSS/Q3D Extractor Solution cell

• and so on.
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You can perform automatic system updates (coupling iterations) using the Ansoft Feedback Iterator.
Refer to Ansoft help documentation for more information on Feedback Iterator.

Icepak and Workbench Integration Tutorial

To access the Ansys Icepak - Ansys Workbench integration tutorial, go to http://support.ansys.com/
training and download the Ansys Icepak Tutorial Guide.

Injection Molding Data

The Injection Molding Data system allows you to take the data from result-files of injection molding
simulations and import it into a Mechanical system. Supported analysis types include Static and
Transient Structural; Steady-State and Transient Thermal; Modal and Harmonic Response. File
formats of the most popular injection molding software tools are supported. The following quantities
can be imported:

• Residual stresses (before ejection)

• Weld lines

• Fiber orientation tensor (for reinforced materials)

• Fiber volume fraction (for reinforced materials)

The input data is parsed, processed, and then transferred to a downstream Mechanical system where
it can be applied in the form of element orientations, material fields, and initial stresses.

When simulating the thermo-mechanical behavior of short fiber reinforced composites, the Injection
Molding Data system allows you to import injection molding simulation results from other software
tools. It's part of a streamlined workflow in Workbench which also employs Material Designer and
Mechanical. You will find detailed instructions and a sample workflow in the Short Fiber Composites
Guide.

Supported Formats

In the table below, you will find a list of software tools, their file-types, and whether they are sup-
ported.

Weld Lines
File Format

Fiber
Volume

Initial
Stress file

Format

Fiber Orientation
Tensor File Format

Mesh File
Format

Fraction
File

Format

.xml, .nodNot
supported

.ist (only for
3D

meshes)[b]

For 3D Meshes:Patran
Neutral file
(.pat) or CDB

Autodesk
Moldflow[a]

• Patran
node-based(generated
(.nod) andwhen
element-basedexporting
(.ele)
formats.

initial
stresses)

Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.188

Working Through a System

http://support.ansys.com/training
http://support.ansys.com/training


• Node and
element-based
XML (.xml)
formats.

For Midplane
meshes:

• Element-based
XML (.xml)
format.

.nwd.fcd.ist.o2d.cdb, .ansMoldex3D

Not
supported

.sac.sac.ans, .sac.ans, .sacSigmaSoft[c]

Not
Supported

Not
supported

Not
supported

.cof.cofCadmould[c]

Only the 3D and Midplane mesh options are supported. Dual Domain meshes are not
supported.

[a]

Importing an .ist file in combination with the Patran mesh format is only valid for data in
SI units.

[b]

To import results from SigmaSoft and Cadmould, you must specify the same file as the
Mesh and Fiber Orientation Tensor File.

[c]

Procedure

To import injection molding simulation results, do the following:

1. Drag and drop an Injection Molding Data system onto the project schematic. The Injection
Molding Data System is available under the Component systems group of the Workbench
application.

2. Right-click the Setup cell and select Edit (see A, below) to display the Injection Molding Data
properties (B, below). Alternatively, right-click the cell and select Properties.
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3. Browse to and select the location of the Mesh File.

4. Optional: Browse to and add the Fiber Orientation Tensor File.

5. Optional: Specify the location of the Initial Stress File.

6. Optional: Specify the location of the Fiber Volume Fraction File.

7. Optional: Specify the location of the Weld Lines File.

8. If needed, apply a Rigid Transformation to the input data by specifying the translation and/or
rotation components. Transformations are applied in the following order:

• Rotation about the Y Axis (Theta ZX)

• Rotation about the X Axis (Theta YZ)

• Rotation about the Z Axis (Theta XY)

• Translations

Because of the order of rotations, the angles Theta XY/YZ/ZX can be considered as intrinsic ZXY
Euler angles.

9. Connect to Mechanical:
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• To transfer fiber orientation tensor, volume fraction, and weld lines data to Mechanical, drag
the Setup cell of the Injection Molding Data system and drop it onto the Model cell of a
Mechanical system.

• To transfer initial stress data to Mechanical, drag the Setup cell of the Injection Molding
Data system and drop it onto the Setup cell of a Mechanical System.

You can combine the two transfers by right-clicking the Setup cell of the Injection Molding
Data cell and choosing Transfer Data to New in the context menu.

Material Designer

The Material Designer system launches Ansys Material Designer, allowing you perform material ho-
mogenization. You can simulate the micro-structure of composite materials and lattice structures as
well as user-defined materials. Material Designer generates a representative volume element (RVE)
and analyzes it in order to compute homogenized (averaged) material properties. The computed
materials can then be used in subsequent analyses as any predefined or user-defined materials would
be.

Example workflows can be found in Workbench Workflow Examples. For more general information
about Material Designer, see the Material Designer User's Guide.

191
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Component Systems



Mechanical APDL

The Mechanical APDL system launches Mechanical APDL (formerly known as the Ansys software),
allowing you to manage the various files often used and created by Mechanical APDL, especially when
working with a linked analysis (for example, thermal-stress, substructuring, submodeling, and so on).
It is important that you understand the types of files that the Mechanical APDL application uses and
generates, because the actions you take in Workbench act on these files. These files fall into three
broad categories: input, reference, and output.

Input Files

Files that are consumed directly by the Mechanical APDL application. Examples include:

• Files consisting of Mechanical APDL commands, generated manually or by Mechanical APDL
(log files) or by the Mechanical or Meshing applications.

• Coded input files, such as .cdb files, generated by Mechanical APDL and third-party prepro-
cessors

• Mechanical APDL geometry files (.anf), generated by Mechanical APDL or DesignModeler

Note:

In some cases, the Mechanical APDL solver overwrites one of its input files with its generated
output (for example, the .rst file from a Modal system in a Modal to Response Spectrum
analysis linked to a Mechanical APDL component system). If this occurs, subsequent updates
of the Mechanical APDL component system will fail. To copy the correct input from an
upstream system, perform a reset operation on the Mechanical APDL component system.

Referenced Files

Files that are referenced by the execution of an input file. Examples include:

• Database files

• Results files

• Command macro files

• Superelement files

• Solver files

• CAD geometry files

Output Files

Files that are produced by all Mechanical APDL application runs. Primary output files include:

• Results file (.rst, .rth, etc.)

• Output file (.out) of the command echoes, solution information, and requested data listings
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• Log file (.log) of the commands issued to the Mechanical APDL application

• Error file (.err) listing any warnings or errors encountered

Creating a Mechanical APDL Analysis

Use the following procedure to create a Mechanical APDL analysis.

To work through a Mechanical APDL system:

1. To add a Mechanical APDL component system, drag the system from the Toolbox to the
Project Schematic or double-click the system in the Toolbox.

2. If required, connect other systems to a Mechanical APDL system by using the Transfer Data
From New or Transfer Data To New context menu options. You can also drag systems from
the toolbox, or manually create links between systems.

When transferring data to a Mechanical APDL system from another system, you can transfer
data from the following cell sources:

• Geometry: transfers just the geometry in the form of an .anf file. This option is only sup-
ported for geometry that is represented as DesignModeler geometry.

• Model (Mesh cell if a meshing system): transfers an input file containing only the mesh,
contact, coordinate system, and named selections data.

• Setup (Mechanical Systems): transfers an input file containing all data necessary to solve
the analysis, including geometry, model, loads, materials, etc. Any supporting files needed
to execute the input file will be transferred as well. Examples include pre-stress modal or
random vibration.

• Setup (Finite Element Modeler): Transfers input file containing any finite data recognized
inside Finite Element Modeler, such as mesh, materials, components, constraints, etc.

• Solution (Mechanical Systems): transfers the database file (.db) if it exists and result file
only.

Note:

For Model, Setup (Mechanical Systems), and Solution transfer cells, if you solve
within Mechanical, you must run an update on the appropriate cell in the Mechan-
ical system to obtain the correct state on the schematic.

In most cases, Model and Setup components from the same Mechanical system
should not be linked to one Mechanical APDL system. Doing so will cause the
Mechanical system to provide two different (and possibly conflicting) input files to
the Mechanical APDL system.
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Named selections and coordinate systems that are added to a solved Mechanical
system are not immediately reflected in downstream Mechanical APDL systems.
They will be available in future solution attempts.

Important:

The Mechanical APDL system consumes all input data without unit system know-
ledge. You must assure that all input data being used by the Mechanical APDL system
is in a consistent unit system. See Solving Units for more information on unit system.

When transferring data from a Mechanical APDL system to another Mechanical APDL system,
you can transfer four types of data:

• Results: transfers all results files (including .rst, .rth, etc.)

• Database: transfers all database files (.db)

• Solver: transfers all files in the system folder

• CDB: transfers .cdb files

You can also transfer data to a new Finite Element Model system, which uses the .cdb file(s).

These files are simply copied to the new system if they exist; Workbench does not generate
the files. Before transferring data to a new system, be sure that you have an input file that
generates the necessary files from the existing Mechanical APDL system.

When you transfer data to or from another system, right-click the link connecting the systems
and select Properties from the context menu. The Properties pane opens, detailing the nature
of the transfer (such as Transfer CDB File).

3. To open the Components workspace to select Mechanical APDL parameters, double-click the
Analysis cell or right-click the cell and select Edit from the context menu.

From the Components workspace, you can select Mechanical APDL parameters or specify setup
properties (p. 425) (such as command line options, memory settings, number of processors,
etc.).

When you add an input file using the context menu, Workbench automatically searches the
file for potential parameters (for example, *SET, *GET, = assignments). Those parameters are
then displayed in the Properties pane when that input file is selected in the Outline pane.
To use one of those parameters, select that parameter's check box and indicate whether it
should be used as an input or an output parameter. Input parameters are sent to Mechanical
APDL with the value specified when updating. After the update, Workbench retrieves the
output values from Mechanical APDL and sets those values in Workbench.

Note:

The presence of a /EXIT command in the input file causes state and parameters to
malfunction. Make sure you remove this command before adding the input file.
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4. Launch the Mechanical APDL application using one of the following options:

• To launch the Mechanical APDL application interactively, right-click the Analysis cell and
select Edit in Mechanical APDL or Open in Mechanical APDL from the context menu.

• To launch the Mechanical APDL application with input and reference files specified, right-
click the Analysis cell and select Add Input File or Add Reference File from the context
menu. Then select Edit in Mechanical APDL

The Mechanical APDL application launches in interactive mode, and the input file(s) specified
will be sent to the Mechanical APDL application and processed in the order listed. After all
of these files are processed, the Mechanical APDL application remains active and you can
continue your analysis using the standard Mechanical APDL application interface. Any action
you take in the Mechanical APDL application will not be reflected in Workbench state indic-
ators or parameters.

Be aware that any time you launch the Mechanical APDL application, Workbench does not log or
record the actions that occur in the Mechanical APDL application. If you make changes in the
Mechanical APDL application, be sure that the changes are reflected appropriately in the input files.
To maintain connectivity (such as to read output parameters), complete an update, either at the
project level or at the appropriate system/cell level.

To save Mechanical APDL changes from an open session, you must include a SAVE command in
one of your input files. The Workbench save capability does not invoke the Mechanical APDL SAVE
command.

When you add an input file, the files are processed in the order shown. You can change the order
in which the files are processed by dragging the files into the proper order. To delete files, right-
click the file to be deleted and select Delete from the context menu.

To stop a Mechanical APDL batch run, you can interrupt the update progress (p. 245).

Mechanical APDL Context Menu Options

When the Mechanical APDL system is active in the schematic, use the right mouse button to initiate
the following Analysis cell actions.

DescriptionMenu
Item

Opens the Components workspace, where you can specify Mechanical APDL parameters
and setup properties. This is the default action.

Edit

Launches the Mechanical APDL application interactively and reads the input files. If the
state is currently up to date, Workbench sets the state to Update Required at this time,
even if you do not make any changes in the Mechanical APDL application.

Edit in
Mechanical
APDL

Launches the Mechanical APDL application interactively without reading any input files.
Any action you take in the Mechanical APDL application are not be reflected in Workbench
state indicators.

Open in
Mechanical
APDL

Opens a dialog box where you can browse to an input file. When you add an input file,
the file is immediately copied into the project directory. To make changes to this file,

Add
Input
File change the file in the project directory, not the original file. If you have a large input file

195
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Component Systems



DescriptionMenu
Item

and have disk space concerns, keep the file in the directory of your choice and use a
separate input file to reference it (using the /INPUT command).

Opens a dialog box where you can browse to a referenced file. When you add a referenced
file, the file is immediately copied into the project directory. To make changes to this file,

Add
Referenced
File change the file in the project directory, not the original file. If you have a large reference

file and have disk space concerns, keep the file in the directory of your choice and
reference it manually.

Launches the Results Tracking tool during an update, allowing you to monitor diagnostics
results of interest in real time during the solution. For more information, see the NLHIST
command.

Track
Solution

Runs the Mechanical APDL application in batch mode, processing all input files in the
order listed. If you make changes in the Mechanical APDL application, be sure that the

Update

changes are reflected appropriately in the input files before running an update. If you
do not, an update could potentially overwrite the work you have done in the Mechanical
APDL application.

Note:

An update launches the Mechanical APDL application in batch mode,
using all input and referenced files in the order shown in the Outline
pane. After all files are processed, the Mechanical APDL application exits.
Updating captures any output parameters generated in the Mechanical
APDL application and allows you to continue working in Workbench.

Copies the latest transfer files into the project directory. Input and referenced files are
not re-copied from their original locations. If you change an upstream system after you

Refresh

make changes to the Mechanical APDL application, a refresh could potentially overwrite
your Mechanical APDL application changes. Be sure that any changes you do in the
Mechanical APDL application are reflected appropriately in the input files before running
a refresh. Only changes that occur within the schematic are captured with a Refresh
Required state (p. 449); Workbench does not indicate Refresh Required for changes made
directly to a file (such as manually editing an input file).

Deletes all files on disk in the system directory except input or reference files. It will not
affect any input or reference files.

Clear
Generated
Data

Standard actions as described in Common Context Menu Options (p. 456).Rename,
Reset

Launches the Properties pane, where you can define graphics settings, command line
options, database and tab memory, and other settings. Be aware when selecting graphics

Properties

settings that some options are potentially platform-specific and must be changed when
switching platforms before running the project with Mechanical APDL in interactive mode.

Solver Input File Generated from the Setup cell of a Mechanical APDL System

The solver input file transferred from the Setup cell contains all the commands needed to execute
a complete run, including any SOLVE commands that are necessary. However, the input also contains
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a conditional /EOF statement to halt reading of the file and therefore not execute the solve. This
conditional statement will be executed when the Mechanical APDL application is invoked from the
Edit in Mechanical APDL context menu option, therefore running the analysis to the point just
prior to the SOLVE command. If a different behavior is desired, you can edit the input file in the
Mechanical APDL system folder to obtain a different behavior or to add an additional input file
containing the SOLVE command.

Mechanical Model

The Mechanical Model system launches the Mechanical application, allowing you to create an ana-
lysis using a single model and multiple system analysis branches. You can also create other Mechan-
ical Model systems that share data at any cell level (Engineering Data, Geometry, or Model).
Mechanical Model Model systems are unfiltered (physics and solver).

The system consists of Engineering Data, Geometry, and Model cells. In the Mechanical application,
this system corresponds to that of a Model-only system.

This system is created when you resume a legacy database that does not have an analysis environment
already defined. It can also be used as a system replacement for a Mesh system.

Working Through a Mechanical Model system

To work through a Mechanical Model system:

1. To add a Mechanical Model component system, drag the system from the Toolbox to the
Project Schematic or double-click the system in the Toolbox.

2. Create or attach a geometry using the Geometry cell context menu.

3. If required, right-click the Model cell and select Edit to edit the model.

4. To add a connected system, either drag a valid analysis system from the Toolbox and drop it
on the appropriate target location, or right-click the Geometry or Model cell and select Transfer
Data To New from the context menu.

5. To create multiple system analysis branches, repeat step 4 with other analysis systems.

Resuming an Existing Legacy Database

To resume an existing legacy database that contains no physics environment:

1. From the menu bar, select File → Import.

2. Browse to the legacy database, select it, and click Open.

A Mechanical Model system appears in the Project Schematic, with the legacy database loaded.

3. To open the Mechanical application, double-click the Model cell, or right-click the cell and select
Edit from the cell context menu.

4. In the Mechanical application, complete any necessary model updates.
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5. To add a connected system, either drag a valid analysis system from the Toolbox and drop it
on the appropriate target location, or right-click the Geometry or Model cell and select Transfer
Data To New from the context menu.

6. Continue with the analysis in the analysis system as you normally would.

Replacing a Mesh System with a Mechanical Model System

To replace an existing Mesh system with a Mechanical Model system (or vice-versa), right-click the
system header and select Replace with → Mechanical Model or Replace with → Mesh (respectively)
from the context menu. When a Mesh system is replaced with a Mechanical Model system, the
Mechanical Model system can then be shared with any analysis system as described above.

The units setting specified in an existing system is not maintained in the replacement system. In the
replacement system, you must select the units setting that you want to use.

Model-to-Model Connections

Multiple Mechanical Model component systems can be merged together by creating a connection
between the Model cells of each component system. This allows you to build up more complicated
models from smaller, simpler models. This behaves in the same way as Mesh-to-Mesh Connec-
tions (p. 203). More detailed information can be found in Assembling External Models and Mechan-
ical Models in the Mechanical User's Guide.

Solution-to-Model Connections

You can transfer a deformed geometry from a Static/Transient/Modal/Buckling/Explicit Dynamics
system to a Mechanicall Model or to a Mechanical analysis system. You might want to do this to
introduce imperfections to an otherwise perfect geometry to overcome convergence issues when
running a nonlinear simulation.

To use the deformed mesh from a solved analysis as the initial geometry/mesh for a follow-on
analysis:

1. Drag a connection from the Mechanical Solution cell to a downstream Model cell in a Mech-
anical system.

You can create connections to multiple downstream Model cells.

2. To share Engineering Data between the systems, link the Engineering Data cells as required.

Note:

If you are incorporating a deformed geometry into Model Assembly systems, you
need to share the Engineering Data cell of the deformed geometry system with one
or more of the Model Assembly systems in order to have the materials automatically
transferred and set for the deformed geometry in the downstream system.

3. Optionally, in the Properties pane:
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a. Adjust the amount and direction of the deformation by setting a Scale Factor (a negative
value reverses the direction of the deformation).

b. Adjust the upstream Time settings (for Transient, Static Structural, or Explicit Dynamics
systems) or the Mode (for Eigenvalue Buckling or Modal systems) for each connection to
a downstream Model cell.

If you set a User Defined Time, the value is always interpreted as being in seconds.

c. Adjust the transfer input settings on downstream Model. The transfer settings are the
same as those for Mesh-to-Mesh Connections (p. 203).

For more detailed information, see Geometry from Deformation Results in the Mechanical User's
Guide.

Controlling Node and Element Numbering when Model Cells Share Data

When you connect the Model cell of a Mechanical system to the Model cell of a downstream
Mechanical system, you can use the Renumber Mesh Nodes and Elements Automatically property
in the downstream Mechanical Model cell to control whether mesh nodes and elements are auto-
matically renumbered to prevent conflicts. You can set the Renumber Mesh Nodes and Elements
Automatically property on a transfer-by-transfer basis. By default automatic renumbering occurs,
but you can disable the property for as many of the transfers as you want—as long as their element
numbers will not conflict downstream and the Number Of Copies is set to 0.

Preview Assembled Geometry

You can quickly preview the orientation of your parts in an assembly by right-clicking on the
downstream model cell and selecting Preview Assembled Geometry. When using this feature,
Mechanical assembles the geometry only (computationally expensive items such as the mesh are
not assembled), allowing you to review the assembled geometry quickly. This feature is useful if
you are unsure about the relative positioning of your subassemblies and some transformations are
required for proper alignment.

Example Workflow

To start, you must have fully updated upstream Model cells connected to a downstream Model
cell. The downstream Model cell is in a state of refresh required. In this demonstration, Box1 and
Box2 are both the same model, a rectangular prism, and you would like to have them oriented
into a “T” (one oriented 90 degrees from the other). However, a translation in the positive y-direction
is also needed to ensure a smooth contact between the parts. To accomplish this, enter a value of
10 m in the Properties pane of the Project Schematic to translate the Y-origin of Box1. As opposed
to issuing a full update on the downstream Model cell, which loads the mesh data as well as the
geometry, you first perform a geometry-only assembly by right-clicking on the downstream model
cell and selecting Preview Assembled Geometry.
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This opens the assembly in Mechanical for you to inspect. When you activate Mechanical in this
way, no meshing or physics options are available.
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Upon viewing the preview, you discover that the geometry is not in the proper orientation. After
inspecting the gap between the parts, you determine the proper y-translation is 9.35 m. After en-
tering this data in the Properties pane of the Project Schematic, you can again right-click the
downstream Model cell and select Preview Assembled Geometry. Mechanical will quickly update
to show you the change in orientation.
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You confirm that the orientation of the two parts is correct. At this point, you can issue a full update
so that Mechanical loads in the mesh data and you can continue your analysis.

Mesh

The  Mesh system launches multiple meshing and geometry applications, allowing you to create
and/or open geometry or mesh files.

To work through a Mesh, add it to the Project Schematic using any of these methods:

• Double-click the  Mesh component system template in the Toolbox.

• Drag-and-drop the  Mesh component system template onto the Project Schematic.

• Drag-and-drop a .meshdat or .cmdb file from Windows Explorer onto the Project Schematic.

• From the menu bar, select File → Import or click the Import button and select a .meshdat
or .cmdb file.

Mesh Context Menu Options

For standard context menu options, see System Header Context Menu Options (p. 457) and Geo-
metry (p. 448). The following table describes the context menu actions specific to the  Mesh system.

DescriptionMenu Item

System Header
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DescriptionMenu Item

Replaces the Mesh component system with a Mechanical Model component system.Replace
With >
Mechanical
Model

Mesh Cell

Opens the Meshing application and loads an existing geometry or mesh file.Edit

Imports read-only meshes for downstream application use. For more information see
Importing Read-only Meshes for Downstream Application Use

Import
Mesh File

Duplicates the Mesh system. The Geometry cell is shared, and all data associated with
the Mesh cell is copied to the second system.

Duplicate

Transfers a mesh into one of the following downstream systems:Transfer
Data To
New • Autodyn: Inserts a downstream Autodyn system and generates a data transfer

connection (.cmdb file) from the Mesh cell to the Setup cell of the Autodyn
system.

• CFX: Inserts a downstream CFX system and generates a data transfer connection
(.cmdb file) from the Mesh cell to the Setup cell of the CFX system.

• External Model: Inserts a downstream External Model system and generates
a data transfer connection (.cmdb file) from the Mesh cell to the Model cell
of the External Modelsystem.

• Forte: Inserts a downstream Forte system and generates a data transfer
connection (.msh file) from the Mesh cell to the Setup cell of the Forte system.

• Mechanical APDL: Inserts a downstream Mechanical APDL system and generates
a data transfer connection (.inp file) from the Mesh cell to the Analysis cell
of the Mechanical APDL system.

• Polyflow: Inserts a downstream Polyflow system and generates a data transfer
connection (.poly file) from the Mesh cell to the Setup cell of the Polyflow
system.

Mesh-to-Mesh Connections

Multiple Mesh component systems can be merged together by creating a connection between the
Mesh cells of each component system. This allows you to build up more complicated meshes from
smaller, simpler meshes.
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For every upstream Mesh cell connected to a downstream Mesh cell, a new set of properties called
Transfer Settings for [Mesh component name] appears in the Properties pane of the downstream
Mesh cell. In the above example, with two upstream Mesh components connected to single,
downstream Mesh component, the Properties pane of the downstream Mesh (cell B3) has two
new groups of properties.

Similarly, a Renumber Mesh Nodes and Elements Automatically property appears for each
transfer. This property in the downstream mesh cell controls whether mesh nodes and elements
are automatically renumbered to prevent conflicts. You can set the Renumber Mesh Nodes and
Elements Automatically property on a transfer-by-transfer basis. By default, automatic renumbering
occurs but you can disable the property for as many of the transfers as you want—as long as their
element numbers do not conflict downstream and the Number Of Copies is set to 0.
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Table 5: Properties Pane: General Properties

DescriptionProperty

This property sets the units for the downstream mesh assembly. After the meshes
are initially assembled, this property becomes read-only. You must reset the
downstream mesh cell in order to change the Length Unit.

Length Unit

Table 6: Properties Pane: Transfer Settings Section

DescriptionProperty

When set to zero (default), only the source mesh is transformed. If you specify aNumber
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DescriptionProperty

number of copies greater than zero, these will be in addition to the source mesh.
For example, if you import a .cdb file with a single part and set Number Of Copies
to 2, you will get three parts in Mechanical.

Of
Copies

When Mesh cells are connected, this property in the downstream Mesh cell controls
whether mesh nodes and elements are automatically renumbered to prevent conflicts.

If the Number Of Copies is set to 1 or greater, automatic renumbering occurs.

Renumber
Mesh Nodes
and Elements
Automatically

This property is available only when Number Of Copies is set to 1 or greater. Select
the check box if you want to apply the specified transformation to the source mesh
as well as any copies.

Transform
Original

These properties allow you to translate the origin of the model along the X, Y, or Z
axis. If you specify any copies, the translation is applied relative to the previous copy
(or source mesh in the case of the first copy).

Origin X/Y/Z

These properties allow you to rotate the model about its origin in the XY, YZ, or ZX
plane. If you specify any copies, the rotation is applied relative to the previous copy
(or source mesh in the case of the first copy).

Theta
XY/YZ/ZX

Any change in these properties will put the downstream mesh in a Refresh Required state (p. 449).

You can preview the mesh transformations by right-clicking on the Mesh cell and selecting Preview
Assembled Geometry. Use this feature to confirm that the correct mesh transformations have
been applied. For more details and an example workflow, see Preview Assembled Geometry (p. 199).

Microsoft Office Excel

The Microsoft Office Excel system launches Microsoft Office Excel 2013 or 2016, allowing you to use
it as a calculator in Workbench This feature exposes Excel ranges as input and output parameters to
Workbench. You can use these ranges to create design points and Design Exploration studies.

Note:

• The Excel add-in is included with Workbench. It does not require DesignXplorer or any
other specific Ansys product, but it must connect to a locally installed seat of Microsoft
Excel (purchased separately).

• In the Trust Center options for Excel, the File Block Settings page specifies the older
versions of Excel files to block. If Workbench is unable to open an Excel file formatted
in an older version, on the File Block Settings page, clear the check boxes for the older
Excel versions that you use and click OK. After you close and reopen Workbench, it
should be able to open Excel files formatted in these older versions.

Related topics:

Preparing the Excel File

Setting Up the Excel Calculator

Support of Units

File Management and Modification of the Worksheet
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Preparing the Excel File

To be exposed as parameters in Workbench, the ranges must be named in Excel. The names are
filtered during the addition of the Excel file to the project; only the ranges matching the prefix
defined by the Named Range Key property in the Properties pane of the Analysis cell are made
visible in Workbench.

Note:

By default, no filtering prefix is defined at either the Workbench or the project level. You
set a filter by either of the following methods:

• Set a default prefix that will be used for all new projects (see Microsoft Office
Excel (p. 433)).

• Set a prefix at the project level by entering it in the Named Range Key property
in the Properties pane of the Microsoft Office Excel Analysis cell.

To name a range in Excel:

1. Open the file in the Microsoft Office Excel application.

2. Right-click a cell and select Define Name from the context menu.
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3. Enter the name.

4. To review and modify all the defined names in Excel, select Formulas → Name Manager.

A named range can contain several cells. Workbench expects the named ranges to contain either
one or two cells, the first cell being reserved for the value and the second cell being reserved for
the unit string, if any. If a named range contains more than two cells, it is ignored.

Note:

If you added the file to the Excel system in Workbench before naming the ranges, or if
you want to edit the names of the ranges after the addition of the file, you can right-
click the Analysis component or the file node in the Outline and select Open file in
Excel. This opens the Excel file used by Workbench in Excel.

All changes performed in Excel impact the state of the data in Workbench and invalidate
the results; make sure you save your changes and reload the file afterwards (when editing
the Analysis cell, right-click the file node and select Reload).

Setting Up the Excel Calculator

Complete the following procedure to set up Excel as a calculator in Workbench.

To add a file and set macro property usage:

1. To add a Microsoft Office Excel component system, drag the system from the Toolbox to
the Project Schematic or double-click the system in the Toolbox.
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2. Right-click the Analysis cell and select Add File to the context menu.

3. Browse to the Excel file that you have prepared.

4. Select the file and click Open.

5. To review the list of named ranges retrieved from the Excel file, right-click the Analysis cell
and select  Edit Configuration from the context menu.

6. For each listed named range, select the check boxes in the Input or Output column to publish
the range as an input parameter or an output parameter in the Workbench project.

7. If the calculation in Excel requires the execution of a macro:

a. In the Outline pane, select the added file.

b. In the Properties pane, select the Use a Macro check box.
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c. In the Macro Name field, enter the name of the macro.

Note:

If a button is used to start the calculation and you do not know the name of
the macro associated with it, right-click the button and select Assign Macro
to discover the name to use.

8. Switch to the Project tab.

On the Project Schematic, the Microsoft Office Excel system is linked to the Parameter Set
bar.

The project is ready to create design points and Design Exploration studies.

Support of Units

Units are handled by the Excel system. A valid Workbench unit string must be used and included
in the named range.

For instance, if an input parameter is a length in millimeters, you can name WB_Length the range
A1:B1 where the cell A1 contains the length value (for example, 120.5) and the cell B1 contains the
unit string (mm). When selecting the WB_Length range in the Outline pane, the Properties pane
looks like the following image. In this case, the Quantity Name is automatically identified as a
Length.

If there are several possible Quantity Names for the same unit string, you have to select the
Quantity Name in the properties of the range for the unit conversion to be performed as expected.
For instance, if A1:B1 was actually a temperature in degree Celsius, the Quantity Name could be a
Temperature or a Temperature Difference.
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For detailed information on working with units in Workbench, see Configuring Units in Work-
bench (p. 26)

File Management and Modification of the Worksheet

When the Excel file is added to the Analysis cell of the Microsoft Office Excel system, it is copied
inside the Workbench project files. Any modification made to the original file is not seen by Work-
bench except if you delete and add the file again.

To modify the file copied in the Workbench project files, right-click the Analysis cell, or the file
node in the Outline pane, and select Open file in Excel. Once modifications are done, save the
file. The state of the file in Workbench changes to Refresh Required (p. 449), which indicates that
data is not synchronized anymore. Results such as design points and Design Exploration systems
in the Workbench project are outdated. Refresh the project to synchronize all the pieces of the
project.

If a change in the Excel file was not detected by Workbench, you can force a reload of the file (right-
click the file node and select Reload).

It is not necessary to close the workbook or the Excel application to proceed with design points or
Design Exploration updates. Interaction with the Excel application are frozen, but you can see the
performed calculations.

Performance Map

The Performance Map system launches Turbomachinery Performance Map, an application used to
create performance maps for turbomachinery cases.

For more information, see Turbomachinery Performance Maps in the TurboSystem User's Guide

To work through a Performance Map system:

1. To add a Performance Map component template, drag the template from the Toolbox to the
Project Schematic or double-click the template in the Toolbox.

2. To open Turbomachinery Performance Map, double-click the Performance Map cell.

Polyflow

The Polyflow system launches Ansys Polyflow, allowing you to analyze fluid flows with free surfaces,
complex rheology (including non-Newtonian behavior with viscoelasticity), heat transfer, and chem-
ical reactions. Using Polyflow involves specifying the computation models inside Polydata, which is
the module for problem setup; and running the calculations using the Polyflow solver. Polyflow also
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comes with several useful utilities, which can be accessed from the context menu on the Setup and
Solution cells. For example, Polymat can be used to calculate material properties, including viscoelastic
parameters based on experimental data. For more details, see the product documentation.

There are three Polyflow fluid-flow analysis systems available in Workbench:

• Polyflow: Provides the full simulation capabilities of Polyflow.

• Polyflow - Blow Molding: Provides only the application-specific capabilities of Polyflow that are
suited to blow molding simulations.

• Polyflow - Extrusion: Provides only the application-specific capabilities of Polyflow that are suited
to extrusion simulations.

To work through a Polyflow system:

1. To add a Polyflow, Polyflow - Blow Molding, or Polyflow - Extrusion component system, drag
the system from the Toolbox to the Project Schematic or double-click the system in the Toolbox.

2. To import a mesh, right-click the Setup cell and select Import Mesh from the context menu.

3. To merge, scale, translate, and rotate the mesh, right-click the Setup cell and select Polyfuse
from the context menu.

4. To define your preferences for Polydata, right-click the Setup cell and select Preferences →
Polydata from the context menu.

5. To open Polydata, double-click the Setup cell.

In Polydata, you can specify the computational models, materials, boundary conditions, and
solution parameters.

Alternatively, to import a previously saved Polyflow data file, right-click the Setup cell and select
Import Polyflow Dat... from the context menu.

6. Optionally, to specify material data, right-click the Setup cell and select Polymat from the context
menu.

7. To define your preferences for Polyflow, right-click the Solution cell and select Preferences →
Polyflow from the context menu.

8. To run the Polyflow calculation, right-click the Solution cell and select Update from the context
menu.

9. To check the status of the solver during or after the calculation, right-click the Solution cell and
select Polydiag from the context menu.

10. To open the listing file to see what Polyflow has done during or after the calculation, right-click
the Solution cell and select Listing Viewer from the context menu.

11. To generate plots of the solution data, right-click the Solution cell and select Polycurve from
the context menu.
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12. To statistically postprocess the results of the solution data, right-click the Solution cell and select
Polystat from the context menu.

For detailed information on working with Polyflow, see the online documentation available under
the Help menu within Polyflow. In addition, see Polyflow in Workbench User's Guide.

For information on submitting Polyflow jobs to Remote Solve Manager, see Submitting Polyflow Jobs
to Remote Solve Manager (p. 338).

Results

The Results system launches Ansys CFD-Post, a flexible, state-of-the-art postprocessor that enables
easy visualization and quantitative analysis of the results of CFD simulations.

For detailed information on working with Ansys CFD-Post, see CFD-Post in Ansys Workbench in the
CFD-Post User's Guide.

To work through a Results system:

1. To add a Results component system, drag the system from the Toolbox to the Project Schem-
atic or double-click the system in the Toolbox.

2. To open CFD-Post, right-click the Results cell and select Edit from the context menu.

3. In CFD-Post, to load a results file from the Ansys CFX-Solver, Ansys Forte, or Ansys Polyflow, select
File → Load Results.

Sherlock Pre and Post

The Sherlock Pre and Sherlock Post systems launch Ansys Sherlock, a Java-based application that
allows you to analyze the reliability of circuit card assemblies based on their design files.

For more details on working with Sherlock, see the Sherlock User's Guide.

To work through a Sherlock system workflow:

1. To add a Sherlock (Pre) component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. Add a Sherlock project to the system.

• Import a Project

1. Right-click the Project cell and select Import Project → Browse from the context menu.

2. Browse to the Sherlock project file, select it, and click Open.

The Sherlock GRPC console opens as the project is loading.

• Create a Project in Sherlock

1. Right-click the Project cell and select Edit from the context menu.

2. In Sherlock, in the Project menu, select Add Project.
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3. Create a Sherlock project as described in the Sherlock User's Guide.

4. In Workbench, to sync the Sherlock project changes without closing Sherlock, right-click
the Project cell and select Sync from the context menu.

Note:

This step is optional. When you close Sherlock, Workbench automatically syncs
the project.

5. Save the project and close Sherlock.

3. Right-click the Setup cell and select Properties from the context menu.

4. In the Properties pane, from the Export Type list, select the type of model to export.

5. From the Board list, select the board to use for the analysis.

6. From the Analysis Type list, select the analysis type to use.

Note:

If the analysis selected is Random Vibration, set the following three options to Yes
in Mechanical, under Random Vibration → Analysis Settings → Output Controls:

• Keep Modal Results

• Calculate Velocity

• Calculate Acceleration
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If these settings are not set correctly, the upstream Modal system's data is not trans-
ferred to the Sherlock (Post) system.

7. Right-click the Setup cell and select Transfer to Mechanical System from the context menu.

A Mechanical system corresponding to the analysis type selected in the previous step is added
to the Project Schematic.
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8. For multi-assembly projects, you can add other systems to the Project Schematic as required.

An example multi-assembly project is shown in the following image.

Note:

When you want to use the same base Sherlock project with different analysis or dif-
ferent boards, create the project in the Sherlock (Pre) system and then duplicate it.
Use the Properties fields of each copy of the system to set up one analysis.

9. Drag a Sherlock (Post) system from the Toolbox and drop it onto the Project cell of the Sherlock
(Pre) system
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10. Drag the Solution cell of the Mechanical system onto the Life Protection cell of the Sherlock
(Post) system.

11. Right-click the Setup cell of the Sherlock (Pre) system and select Update from the context menu.

12. Right-click the Geometry cell of the Mechanical system and select Update from the context
menu.

13. To view the Mechanical system geometry, right-click the Model cell and select Edit from the
context menu or double-click the Model cell.

Alternatively, you can complete this step using the Setup cell.

14. In the Mechanical application window, complete your analysis using the application's tools and
features.

15. Right-click the Project cell of the Sherlock (Post) system and select Update from the context
menu.
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16. Right-click the Life Prediction cell of the Sherlock (Post) system and select Update from the
context menu.

The Sherlock GRPC console opens as the cell is updating.

17. Right-click the Life Prediction cell and select Properties from the context menu.

18. Select the appropriate Life Cycle events from the available lists.

Note:

• The available Life Cycle events depend on what is created in the Sherlock project.
They are also filtered by the analysis systems connected to the Sherlock (Post) system.

• If you have an older Workbench project created before 2022 R2, right-click the
Project cell of the Sherlock (Pre) system and select Edit from the context menu to
open Sherlock and pull in the new mappings.

• For more details on Sherlock Life Cycles, see Life Cycle Management in the Sherlock
User's Guide.
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19. To view the 2D or 3D results in Sherlock, right-click the Life Prediction cell and select one of
the following options from the context menu:

• View 2D Results

• View 3D Results

Note:

The Sherlock 3D Viewer may run slowly when analyzing large projects even if the
computer has ample amounts of memory. This is likely a Java issue.

If you encounter an error message that the 3D Viewer has run out of memory, you
can allocate more memory to the 3D Viewer in the Launcher Settings. From Sherlock's
Main Menu, click Settings →  Launcher. Refer to Launcher Settings for additional
information.

System Coupling

The System Coupling system launches the System Coupling tab, allowing you to model one-way
and two-way multiphysics couplings for your project. To run a coupled analysis using System Coupling
in Workbench, connect a System Coupling system to two coupling participant systems. The System
Coupling system will synchronize and manage the participants' data transfers and the coupled solution.

Tip:

For detailed information on creating and running coupled analyses using the Workbench
interface, see Using System Coupling in Workbench in the System Coupling User's Guide.

To work through a System Coupling system, perform the following steps:

1. Add two supported participant systems to the Project Schematic and complete their physics
setups.

2. Add a System Coupling component system by dragging the system from the Toolbox and
dropping it onto the Project Schematic.

3. Connect the System Coupling system to the other systems through their Setup or Solution cells.

Note:

• The Command Line Options property located in the System Coupling Solution
cell is for advanced users with a strong understanding of the appropriate command
line arguments that can be used when starting System Coupling. For more inform-
ation, see Command-Line Options in the System Coupling Settings and Commands
Reference.

• Once the systems are connected, you can export the files needed to run the coupled
analysis in one of System Coupling's user interfaces. The export can be performed
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either before or after the coupling setup is completed in Workbench. For details,
see Exporting a System Coupling Setup in the System Coupling User's Guide.

4. Open the System Coupling tab by double-clicking the System Coupling system's Setup cell.
When asked is you want to read upstream data, click Yes.

The System Coupling tab opens, with coupled analysis details shown in the Outline pane's tree
view. To view or edit a given property, select it in the Outline to show its value in the Properties
pane.

5. Complete the coupling setup, as follows:

a. Add data transfers by multi selecting the participant coupling regions, right-clicking, and
selecting Create Data Transfer.

b. Specify data transfer details by selecting the data transfer and editing property values in
the Properties pane.

c. Specify execution controls by selecting a node under Execution Controls and editing
property values in the Properties pane.

6. Once the setup is complete, run the coupled analysis by right-clicking the Solution node and
selecting Update.

Turbo Setup

The Turbo Setup system launches Turbomachinery Data Setup, an application used to rapidly create
the workflows needed for the analysis of centrifugal compressors.

The application offers no design calculation capability itself; it is purely a tool designed to facilitate
the analysis of turbomachinery using the Vista TF and CFX applications.

For more information, see Turbo Setup in the TurboSystem User's Guide.

To work through a Turbo Setup system:

1. To add a Turbo Setup component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To open Turbomachinery Data Setup, double-click the Turbo Setup cell.

TurboGrid

The TurboGrid system launches Ansys TurboGrid, a tool that lets designers and analysts of rotating
machinery create high-quality hexahedral meshes, while preserving the underlying geometry. These
meshes are used in the Ansys workflow to solve complex blade passage problems.

For more information, see Ansys TurboGrid help.

To work through a TurboGrid system:
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1. To add a TurboGrid component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. Optionally, connect an upstream cell to the Turbo Mesh cell to provide the geometry data. To
do this, right-click the Turbo Mesh cell and select Transfer Data from New from the context
menu or drop the TurboGrid system on the Geometry cell of another system.

If you do not complete this step, you can load geometry data using TurboGrid.

3. To open TurboGrid, double-click the Turbo Mesh cell.

Vista AFD

The Vista AFD system launches Vista Axial Fan Design, an application used for the preliminary design
of axial fans. It creates axial fan geometry data for use in BladeGen or BladeEditor. It also provides
estimates of the performance of the axial fan. It may be used to generate a preliminary fan design
before moving rapidly to a full 3D geometry model and CFD analysis.

For more information, see Vista AFD help.

To work through a Vista AFD system:

1. To add a Vista AFD component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To specify the solution parameters, generate a solution, and view the results of a meanline ana-
lysis, double-click the Meanline cell.

3. To perform the design (throughflow) calculation, double-click the Design cell.

4. Optionally, before creating a BladeGen or BladeEditor model, double-click the Analysis cell to
perform an analysis calculation.

This uses a similar throughflow method to the design calculation but simply analyses the design
created in the previous step, rather than adjusting the geometry. A significant difference between
the design and analysis results indicates a potentially flawed design.

Vista CCD and Vista CCD with CCM

The Vista CCD and Vista CCD with CCM systems launch Vista Centrifugal Compressor Design, an
application used for the preliminary design of centrifugal compressors. It can be used in an iterative
fashion to create a 1D design. The resulting geometry can be passed to BladeGen or BladeEditor.
Vista CCD can be used to model an existing compressor and, if known, its measured performance at
single operating points. An accurate 1D model can provide insight into the performance of the machine
that goes beyond the test measurements.

For more information, see Vista CCD help.

To work through a Vista CCD system:

1. To add a Vista CCD or Vista CCD with CCM component system, drag the system from the
Toolbox to the Project Schematic or double-click the system in the Toolbox.
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2. To specify the solution parameters, generate a solution, and view the results, double-click the
Blade Design cell.

3. For Vista CCD with CCM systems, to predict the overall performance of the design compressor
state, double-click the Performance Map cell.

Vista CPD

The Vista CPD system launches Vista Centrifugal Pump Design, an application used for the preliminary
design of pumps. It creates impeller geometry data for use in BladeEditor. It may be used to generate
an optimized 1D pump impeller design before moving rapidly to a full 3D geometry model and CFD
analysis.

For more information, see Vista CPD help.

To work through a Vista CPD system:

1. To add a Vista CPD component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To specify the solution parameters, generate a solution, and view the results, double-click the
Blade Design cell.

Vista RTD

The Vista RTD system launches Vista Radial Turbine Design, an application used for the preliminary
design of radial inflow turbines. It can be used in an iterative fashion to create a 1D design. The res-
ulting geometry can be passed to BladeGen, BladeEditor, and Vista TF. Vista RTD can also be used to
model an existing turbine. An accurate 1D model can provide insight into the performance of the
machine that goes beyond the test measurements.

For more information, see Vista RTD help.

To work through a Vista RTD system:

1. To add a Vista RTD component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To specify the solution parameters, generate a solution, and view the results, double-click the
Blade Design cell.

Vista TF

The Vista TF system allows you to rapidly evaluate radial blade rows (pumps, compressors and turbines)
at the early stages of the design. The Vista TF program is a streamline curvature throughflow program
for the analysis of any type of turbomachine, but has been developed in the first instance primarily
as a tool for radial turbomachinery analysis.

For more information, see Vista TF help.

To work through a Vista TF system:
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1. To add a Vista TF component system, drag the system from the Toolbox to the Project
Schematic or double-click the system in the Toolbox.

2. To open the cell properties and specify the solution parameters, double-click the Setup cell.

3. To generate a solution, double-click the Solution cell.

4. To view the results, double-click the Results cell.

Custom Systems

Workbench provides predefined custom templates for coupled systems, composed of multiple analysis
systems with predefined data connections. Examples include one-way FSI and thermal-stress coupled
analyses.

These templates are provided as a convenience; you can also manually create any of these systems
using system drag-drop operations, context menu operations on cells, or individual cell linking. You
can also create your own templates (p. 228) and add them to the Toolbox to easily build frequently-
used projects.

To use a custom system, double-click the template. Drag and drop is not available.

The following custom systems are available:

• AM DED Process (p. 223)

• AM LPBF Inherent Strain (p. 224)

• AM LPBF Thermal-Structural (p. 224)

• FSI: Fluid Flow (Ansys CFX) > Static Structural (p. 225)

• FSI: Fluid Flow (Fluent) > Static Structural (p. 225)

• Pre-Stress Modal (p. 226)

• Random Vibration (p. 226)

• Response Spectrum (p. 227)

• Thermal-Stress (p. 227)

AM DED Process

This template creates two systems, a Transient Thermal analysis system and a Static Structural analysis
system appropriate for use when performing a Directed Energy Deposition (DED) additive manufac-
turing simulation. The two systems share Engineering Data, Geometry, and Model cells.

Engineering Data is pre-populated with Ansys sample materials for additive manufacturing. Upon
opening the Mechanical application, the project tree is pre-populated with the AM Process for DED,
Manual Clustering, and Build Settings objects that are required for additive simulations, and loads
the DED Process Add-on.
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For more information, see Workflow Through the Project Tree in the Workbench Additive Guide for
DED Simulations.

AM LPBF Inherent Strain

This template creates one Static Structural analysis system appropriate for use when performing a
Laser Powder Bed Fusion (LPBF) additive manufacturing simulation assuming inherent strain. Engin-
eering Data is pre-populated with Ansys sample materials for additive manufacturing. Upon opening
the Mechanical application, the project tree is pre-populated with the AM Process and Build Settings
objects that are required for additive simulations, and the Inherent Strain option (under AM Process,
Build Settings) is set to Yes.

For more information, see Workflow Through the Project Tree in the Workbench Additive Manufacturing
Analysis Guide.

AM LPBF Thermal-Structural

This template creates two systems, a Transient Thermal analysis system and a Static Structural analysis
system appropriate for use when performing a Laser Powder Bed Fusion (LPBF) additive manufacturing
simulation. The two systems share Engineering Data, Geometry, and Model cells, and the Solution
cell in the Transient Thermal system provides temperature load data to the Setup cell in the Static
Structural system.

Engineering Data is pre-populated with Ansys sample materials for additive manufacturing. Upon
opening the Mechanical application, the project tree is pre-populated with the AM Process and Build
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Settings objects that are required for additive simulations, and the Inherent Strain option (under
AM Process, Build Settings) is set to No.

For more information, see Workflow Through the Project Tree in the Workbench Additive Manufacturing
Analysis Guide.

FSI: Fluid Flow (Ansys CFX) > Static Structural

This template performs analyses that couple the physics of Fluid Flow (Ansys CFX) and Static Structural
analyses with results provided (one-way) from the former system to the latter. When this template is
used, a Fluid Flow (CFX) (p. 84) analysis system and a Static Structural (p. 98) analysis system are
automatically created. The two systems share a single geometry, and the fluid-flow Solution cell
provides data that are treated as an Imported Load in the static structural Setup cell.

Similar coupled systems may also be manually created between Fluid Flow (Ansys CFX) analysis and
any of the following analysis systems:

• Transient Structural (p. 101)

• Steady-State Thermal  (p. 99)

• Transient Thermal  (p. 101)

FSI: Fluid Flow (Fluent) > Static Structural

This template creates two systems, a Fluid Flow (Fluent) analysis system and a Static Structural ana-
lysis system. The Geometry cells for the two systems share a single geometry, and the Solution cell
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in the Fluid Flow (Fluent) system provides pressure load data to the Setup cell in the Static Structural
system.

Pre-Stress Modal

This template creates two systems, a Static Structural analysis system that transfers data into a Modal
analysis system. The two systems share Engineering Data, Geometry, and Model cells. The Static
Structural solution provides the necessary solver files as input to the Modal Setup cell.

For more information, see Pre-Stress in the Mechanical Object Reference.

Random Vibration

This template creates two systems, a Modal analysis system that transfers data into a Random Vibration
analysis system. The two systems share Engineering Data, Geometry, and Model cells. The Modal
solution provides the necessary solver files as input to the Random Vibration Setup cell.

For more information, see Random Vibration Analysis in the Mechanical User's Guide.
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Response Spectrum

This template creates two systems, a Modal analysis system that transfers data into a Response
Spectrum analysis system. The two systems share Engineering Data, Geometry, and Model cells.
The Modal solution provides the necessary solver files as input to the Response Spectrum Setup cell.

For more information, see Response Spectrum Analysis in the Mechanical User's Guide.

Thermal-Stress

This template creates two systems, a Steady-State Thermal analysis system that transfers data into a
Static Structural analysis system. The two systems share Engineering Data, Geometry, and Model
cells. The Steady-State Thermal solution provides temperature input to the Static Structural Setup
cell.

For more information, see Steady-State Thermal Analysis in the Mechanical User's Guide and Initial
Temperature in the Mechanical Object Reference.
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Creating a Custom System

You can create a custom system and add it to the Toolbox to easily build frequently-used projects.

To create a custom system:

1. Add systems to the Project Schematic.

2. Right-click the white space on the Project Schematic and select Add to Custom from the context
menu.

3. In the Name field, type a name for the custom system.

4. Click OK.

The new custom template appears in the Toolbox under Custom Systems.

To delete the template, right-click the template name and select Delete from the context menu.

This animation is presented as an animated GIF in the online help. If you are reading the PDF version of
the help and want to see the animated GIF, access this section in the online help. The interface shown
may differ slightly from that in your installed product.
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Design Exploration

DesignXplorer systems can be added beneath the Parameter Set bar, allowing you to perform in-depth
Design Exploration studies.

DesignXplorer is a powerful approach for designing and understanding the analysis response of parts
and assemblies. It uses a deterministic method based on Design of Experiments (DOE) and various op-
timization methods, with parameters as its fundamental components. These parameters can come from
any supported system, DesignModeler, and various CAD systems. Responses can be studied, quantified,
and graphed. Using a Goal Driven Optimization method, the deterministic method can obtain a multi-
plicity of design points. You can explore the calculated Response Surface and generate design points
directly from the surface or transfer data from other analysis systems or components to a Direct Optim-
ization system.

The following Design Exploration systems are available in Workbench:

• 3D ROM

• Direct Optimization

• Parameters Correlation

• Response Surface

• Response Surface Optimization

• Six Sigma Analysis
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These systems are available only if you have installed the Ansys DesignXplorer product and have an
appropriate license.

For an overview of these systems and links to more information about them, see What is Design Explor-
ation?

Submitting Solutions

You can use the Solution Process properties of a system's Solution cell to control where you run the
solution. You can choose from the update options listed here; the defaults for these options are determ-
ined by the settings specified in the Solution Process user preferences (p. 423).

To submit solutions:

1. Right-click the Solution cell of a system and select Properties from the context menu.

2. In the Properties pane, from the Update Option drop-down list, select from the following options:

• Run in Foreground: Runs the solution within the current Workbench session. This option is ap-
propriate for quick-running solutions that fit within the resources of your workstation. This option
is also the most robust as it is not possible to make changes that impact the current solution.
When a solution is executing in the foreground, you cannot change or save the project, but you
can interrupt or stop the solution.

For Polyflow and CFX component or analysis systems, you can switch an update in progress on
the local machine to background mode by right-clicking the Solution cell and selecting Switch
Active Solution to Background.

• Run in Background: Runs the solution in the background on the local machine. This option is
appropriate for solutions that fit within the resources of your workstation but will take longer
to execute. When a solution runs in the background, the cell enters the Pending state (p. 449)
and you can interact with the project to exit Workbench or work with other parts of the project.
If you make changes to the project that are upstream of the updating cell, then the cell is not
in an up-to-date state when the solution completes.

For Mechanical APDL, the Download Distributed Files property is not available and does appear
in the General Property table during foreground and background updates.

Note:

If you choose the Run in Background option for multiple solution components or
for one solution component with multiple design points, your project and design
point updates run multiple instances of the solver at the same time. If you are using
the Share single license between applications when possible option in the license
preferences, only one of the solver runs can succeed. The others fail because they
cannot access the single license. There are two workarounds for this problem:

– Change the license preference to be Use a separate license for each application.
This preference allocates one license for each running solver.
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– Instead of using the Run in Background option, use the Submit to Remote Solve
Manager option and select the Local RSM queue. This is provided that a basic
ANSYS Cluster (ARC) has been configured to restrict the number of cores that can
be used for a job. For more information, see Overview of an Ansys RSM Cluster
(ARC) Configuration and Setting the Maximum Number of Cores to be Used on an
Execution Node in the Remote Solve Manager User's Guide.

• Use application default (Mechanical application only): Runs the solution using the solver settings
specified in the Mechanical application.

• Submit to Remote Solve Manager: Runs the solution in the background by submitting the
solution to RSM. Use this option for long-running solutions that do not fit within your workstation's
resources. When you submit a solution, RSM can send it to a remote compute cluster, or to a
Cloud portal. RSM can also submit jobs to the local machine to allow the queuing of solutions
on your workstation. When a solution is submitted to RSM, the Solution cell enters the Pending
state (p. 449), similar to the Run in Background option.

For more information on submitting solutions to RSM, see Submitting Solutions to Remote Solve
Manager (p. 321).

3. To save the project, from the menu bar, select File → Save.

If you choose not to save the project and any cells are configured to use RSM or run in the back-
ground, you must change the solution process settings of those cells to run in the foreground
before you can update.

4. To start the solution, select the appropriate option from the application, or right-click the Solution
cell and select Update from the context menu.

Opening Mechanical without a License (Read-Only Mode)

You can open the Mechanical application without consuming a license. Two common applications for
using Mechanical in read-only mode are:

• Retrieving data during a Remote Solve Manager (RSM) run in order to monitor its progress.

• Reviewing results of an already solved project.

This option is not available when the cell state is Refresh Required (p. 449) or worse.

To open Mechanical without a license:

1. Right-click one of the following cells in a Mechanical system:

• Model

• Section Data

• Setup
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• Solution

• Results

2. Select Edit in Read-only Mode from the context menu.
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Updating Systems
Once the systems are placed on the Project Schematic, you can update them in various ways.

Related topics:

Naming and Renaming Systems

Duplicating Systems

Moving Systems

Deleting Systems

Replacing Systems

Creating Project, System, and Cell Notes

Updating and Refreshing System Components

Editing Shared Data

Clearing Generated Data

Resetting Data

Naming and Renaming Systems

In general, it is good practice to give each system a descriptive name that is meaningful for you and
that indicates the details of the system. Workbench enables you to specify a name for each system,
either initially when the system is added to your project, or at any time afterward.

Related Topics:

Naming Systems

Renaming Systems

Naming Systems

When a new system is added to the Project Schematic, the default name of the system is in focus
(highlighted), and editable, as shown below.
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To name the system, select from one of the following options:

• To accept the default name for the system (the default name is usually the same as the system
type), press Enter or select any other action in the user interface.

• To enter a name on a single line of text, type the new name and press Enter.

• To enter a name that spans multiple lines of text:

1. Type the first line of text.

2. To start a new line, press Ctrl+Enter.

3. Repeat the previous two steps until the entire name is shown in the text field.

4. To save the name, press Enter.
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After entering a new name or accepting the default name, the focus moves to the system cell requiring
attention first (see Understanding Cell States (p. 449)). By applying focus in this manner, Workbench
draws your attention to the cell where you will most likely begin working with your system (see
Working Through a System (p. 67)).

Renaming Systems

You can change the system name again after it has been named.

To rename a system:

1. Double-click the system name or right-click the system header and select Rename from the
context menu.

2. Type the new single or multiple line name.

3. Press Enter.
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Duplicating Systems

Duplicating a system creates a copy of the selected system. All data associated with unshared cells in
the system is copied to, or shared with, the duplicate system.

Related Topics:

Duplicating a Single System

Duplicating Multiple Systems

Duplicating a Single System

You can duplicate a single system so that the cells can either remain independent of the original
system, or where the cell data is shared.

Creating Independent Duplicate Systems

To create a duplicate system where all cells can be edited independently of the original system, right-
click the system header and select Duplicate from the context menu.

Note:

When a Mechanical system containing a Results cell is duplicated, the results are not
copied to the new system.

The following Show-Me Animations are presented as animated GIFs in the online help. If you are reading
the PDF version of the help and want to see the animated GIF, access this section in the online help. The
interface shown may differ slightly from that in your installed product.
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Creating Shared Duplicate Systems

To create a duplicate system where cell data is shared, right-click a cell and select Duplicate from
the context menu.

All cells above the one selected for duplication are shared. The cell selected for duplication can be
edited independently. For example:

• If you select Duplicate from the Geometry cell, the Engineering Data cell is shared, allowing you
to edit the Geometry cell in the duplicate system to investigate a geometric alternative. Data from
the Model cell and below is copied from the original system and can be modified independently.
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• If you select Duplicate from the Model cell, the Engineering Data and Geometry cells are shared,
allowing you to edit the Model cell in the duplicate system to investigate an alternative modeling
approach. All data in the Setup cell and below is copied from the original system and can be
modified independently.

• If you select Duplicate from the Setup cell, the Engineering Data, Geometry and Model cells are
shared, allowing you to edit the Setup cell in the duplicate system to investigate alternate loads
and constraints. All data in the cells below Setup is copied from the original system and can be
modified independently.

Duplicating Multiple Systems

You can duplicate more than one system at a time.

To duplicate multiple systems:

1. Select all systems to be duplicated using one of the following methods:

• Box-select by clicking and dragging the selection box over the required systems.

• Press Ctrl and click the required systems.

2. Right-click the header of one of the selected systems.

3. Select Duplicate from the context menu.

4. If you are duplicating systems linked to an upstream system by shared and/or data transfer
connections, select from the following options:
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• To keep the duplicate systems linked to the upstream systems, click Yes.

• To delete the upstream connections from the duplicated systems, click No.

Note:

System Coupling and TurboSystem's Performance Map systems do not work with multiple
system duplication.

The following Show-Me animation is presented as an animated GIF in the online help. If you are reading
the PDF version of the help and want to see the animated GIF, access this section in the online help. The
interface shown may differ slightly from that in your installed product.

Moving Systems

You can move an existing system to another position on the Project Schematic.

To move a system:

1. Click the header cell of the system.

2. Drag the system to the new location.

The preview indicates possible target locations for the system.
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Deleting Systems

You can delete a single system or multiple systems on the Project Schematic.

Related Topics:

Deleting a Single System

Deleting Multiple Systems

Deleting a Single System

You can delete a system from the Project Schematic.

To delete a single system:

1. Right-click the system header and select Delete from the context menu.

2. To acknowledge the message and complete the deletion process, click OK.

Deleting Multiple Systems

You can delete more than one system at a time.

To delete multiple systems:

1. Select all systems to be deleted using one of the following methods:

• Box-select by clicking and dragging the selection box over the required systems.

• Press Ctrl and click the required systems.

2. Right-click the header of one of the selected systems.

3. Select Delete from the context menu.

4. To acknowledge the message and complete the deletion process, click OK.

Note:

If you delete an upstream system that is providing equivalent inputs, the system is deleted
and its downstream systems automatically regenerate their deleted containers.
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Replacing Systems

You can replace an existing system with different type of system. This functionality is available only
from systems that use the Mechanical application.

Note:

If you use Replace With to replace a Mechanical system that has a Section Data cell with
another Mechanical system, the new environment is added and the original Mechanical en-
vironment (including boundary conditions and results) is deleted.

To replace a system:

1. Right-click the system header and select Replace With from the context menu.

2. From the list of all system types that are available to replace the existing system, select a new
system.

Note:

The units setting specified in an existing system is not maintained in the replacement system.
In the replacement system, you must specify the units setting you want to use.

Creating Project, System, and Cell Notes

Notes allow you to annotate your projects, systems, and system cells. There is no limit to the amount
of text you can type into a note; as you type, the pane increases in length. The content of notes is also
included in project reports.

To create notes:

1. Right-click the area of the project you want to add a note to and select Add Note from the context
menu.

• To open the context menu for the Project Schematic, right-click the white space of the pane.

• To open the context menu for the system, right-click the system header.

• To open the context menu for a cell, right-click the cell.

2. In the yellow pane, type the note text.

3. To close the note, click outside the pane.

4. To view the note:

• Right-click the area of the project containing the note and select Properties from the context
menu.

• Click the green triangle in the upper right corner of a system or cell to open the note.

241
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Creating Project, System, and Cell Notes



5. To edit the note text:

• Right-click the area of the project containing the note and select Edit Note from the context
menu.

• Click the green triangle in the upper right corner of a system or cell to open the note.

6. To delete a note, open the note in edit mode and delete all text from the yellow pane.

When you click outside of the yellow pane to close it, the note is deleted.

Updating and Refreshing System Components

Updating system components refreshes input data and generates required output data when one or
more components of the project have been changed in some way.
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Refreshing system components reads in all modified upstream data but does not necessarily regenerate
the outputs of the component itself.

You can update or refresh an entire project, a system, or a cell within a system.

Note:

In some cases, the update, update upstream components, and refresh operations may be
available while other operations, such as clear generated data, reset, delete, and duplicate,
are still in progress. If the operation is in progress on a separate system, you can apply the
Update, update upstream components, or refresh operation to the current system. However,
if the operation is in progress on either the current system or a system connected to it, you
cannot initiate the new operation until the in-progress operation has completed.

Related Topics:

Updating a Project

Updating a System

Updating a System Cell

Updating Upstream Components

Interrupting an Update Process

Refreshing System Components

Updating a Project

To update all cells in the project that are in an Update Required (p. 449) state, update the entire project.

If a project contains multiple design points, only the current design point is updated.

If a project contains parametric (DesignXplorer) systems, updating a parametric system updates the
design points within that system, but does not update the design points in the parameter set.

Parametric systems are not updated when a project update is submitted to Remote Solve Manager
(RSM). For more information, see Submitting Workbench Project Updates to Remote Solve Man-
ager (p. 325).

To update a project:

1. To save the project, from the menu bar, select File → Save.

If you choose not to save the project and any cells are configured to use RSM or run in the
background, you must change the solution process settings of those cells to run in the foreground
before you can update.

2. To update the project:

• From the menu bar select Tools → Update Project.

• On the Project tab toolbar click Update Project.
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• Right-click the white space on the Project Schematic and select Update Project from the
context menu.

Updating a System

You can update a system so that all cells within that system contain the most current data.

If a system contains a coupled cell, the update option on the coupled cell is disabled. To update the
system that contains a coupled cell, you must update the coupled system so that both the coupled
cell and all cells dependent on the coupled cell can be updated.

To update a system:

1. To save the project, from the menu bar, select File → Save.

If you choose not to save the project and any cells are configured to use RSM or run in the
background, you must change the solution process settings of those cells to run in the foreground
before you can update.

2. To update the system, right-click the system header and select Update from the context menu.

Updating a System Cell

You can update a cell within a system to ensure it contains the most current data. When you update
the cell, any upstream cells upon which the cell is dependent are also updated. You cannot update
a cell if another update is already running on the cell or on any of the upstream cells.

If you update a cell in a Refresh Required (p. 449) state, the refresh operation is performed before the
update operation.

To update a system cell:

1. To save the project, from the menu bar, select File → Save.

If you choose not to save the project and any cells are configured to use RSM or run in the
background, you must change the solution process settings of those cells to run in the foreground
before you can update.

2. To update the cell, right-click it and select Update from the context menu.

Updating Upstream Components

Updating upstream components ensures that everything upstream of the selected cell is up-to- date
so that the cell is ready to edit or update, without updating the cell itself.

The advantage to updating only the upstream components of a cell is that you are alerted to any
errors or potential effects on downstream cells and can make necessary adjustments before launching
a full update. This option is especially useful when you have a complex system and the cell update
could require a significant time investment and/or computer resources.

To update upstream components:
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1. To save the project, from the menu bar, select File → Save.

If you choose not to save the project and any cells are configured to use RSM or run in the
background, you must change the solution process settings of those cells to run in the foreground
before you can update.

2. Right-click the required cell and select Update Upstream Components from the context menu.

Interrupting an Update Process

After starting an update, you can interrupt, or cancel the process. Be aware that not all processes can
be interrupted and some processes that are interruptible may have periods where they cannot be
interrupted. Because some processes can stop cleanly only at certain checkpoints, the delay between
the interrupt request and the actual interruption can sometimes be lengthy.

Note:

The only Ansys Mechanical systems that can be interrupted are Static Structural and
Transient Structural.

To interrupt an update process:

1. To open the Progress pane, select View → Progress from the menu bar.

2. To the right of the process you want to interrupt, click .

The following dialog box displays:

3. Select from the following options:

• Interrupt: Stops the update at the next point where data can be safely stored for later use.

• Abort: Stops the update immediately without checking if data associated with the current
action can be stored.

When an update is interrupted, the state of the Solution cell becomes Interrupted, Update Re-
quired (p. 449).

Refreshing System Components

Refreshing system components reads in all modified upstream data but does not necessarily regenerate
the outputs of the component itself. For example, if the geometry changed, placing the Mesh cell in
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a Refresh Required (p. 449) state, refreshing the Mesh cell updates the geometry without generating
a new mesh (which could potentially be a lengthy operation).

To refresh system components:

• To refresh all cells in the project that are in a Refresh Required state, from the menu bar select
Tools  → Refresh Project, or on the Project tab toolbar click Refresh Project.

• To refresh a system, right-click the system header and select Refresh from the context menu.

• To refresh a cell, right-click the cell and select Refresh from the context menu.

Editing Shared Data

Links that are blue and drawn with a square terminator indicate that only one instance of the data exists,
and it is shared between the connected systems. In order to edit the details of that data, you must edit
the cell on the upstream system connected by these links.

In the example shown in the figure below, the Geometry cell from system A is shared with the Geometry
cell in system B, which is in turn shared with the Geometry cell of system C. To edit the geometry for
any of these systems, you must initiate the edit operation from the Geometry cell in system A. You can
either double-click the cell or right-click the cell and select Edit from the context menu.
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Clearing Generated Data

Clearing generated data removes or erases any data that the cell has generated, or is prepared to
generate and store, if any such data is present. This data includes mesh, input files, solver files, and
cached solution data. This operation may alter the state of the current cell and cells downstream from
the selected cell.

Important:

For some systems, this operation results in specific behavior depending on the selected cell
and in some cases specific system data (such as existing links). Refer to the following table
for specific actions.

Behavior DescriptionDataCell

Mechanical systems

Deletes mesh, input files, and solver files. Cleans results.Model

Deletes input and solver files. Cleans results.Setup

Deletes solver files. Cleans results. Input files (such as
ds.dat, CARep.xml) are left intact.

Solution

Cleans any solved results. Solver files are left intact.Results

Cleans imported load and deletes transfer xml file. User
specifications (such as scoping) are intact.

Imported
Temperature:

Setup

One-way FSI
input

Cleans imported load and deletes transfer xml file. User
specifications (such as scoping) are intact.

Imported
Temperature:
Thermal stress

Setup

Deletes SYS.cmdb.Link to CFXModel

Deletes SYS.cdb.Link to
Mechanical
APDL

Model

No additional action required (ds.dat is the natural output
from the Setup cell).

Link to
Mechanical
APDL

Setup

No additional action required (file.rst is the natural
output from the Solution cell).

Link to
Mechanical
APDL

Solution

Mechanical APDL

Deletes Ansys-generated files (created during Update or
Edit). Files added using input links or Add xxx File are left
intact.

Analysis

Fluent

Closes the session without saving data. Deletes all files
currently associated with the cell (latest available solution
data). Any schematic input links remain intact.

Internal, link to
initialization
data

Solution
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To clear generated data:

1. Right-click the cell to clear and select Clear Generated Data from the context menu.

2. To complete the operation, click OK.

Resetting Data

Resetting data removes or erases both input and output data to the cell and sets the cell state back to
the default. Any reference files are removed.

Reset may alter the state of cells downstream from the selected cell. If you have two systems that share
cells, reset is not available from the cells that are shared, only from the source (the cell that is being
shared from).

Reset clears all solution state data and cache data for all design points in the project.

Important:

For some systems, this operation results in specific behavior depending on the selected cell
and in some cases specific system data (such as existing links). Refer to the following table
for specific actions.

Behavior DescriptionDataCell

Mechanical systems

Clears the geometry source and resets geometry properties to the defaults.Geometry

Closes the Mechanical session (if open) and deletes the .mechdb from disk.
The system is in a state as if the geometry was never attached.

Model

Deletes any objects under the Environment (such as loads and supports).Setup

Sets the values in Analysis Settings back to the defaults.Solution

Deletes any results, probes, or post tools from Mechanical.Results

Deletes the Import Load from Mechanical and also deletes CFD result file
from disk. State on Setup cell goes to Refresh Required.

Imported
Temperature:

Setup

One-way FSI
input

No additional action required.Imported
Temperature:
Thermal stress

Setup

No additional action required.Link to CFXModel

No additional action required.Link to
Mechanical
APDL

Model

No additional action required.Link to
Mechanical
APDL

Setup
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Behavior DescriptionDataCell

No additional action required.Link to
Mechanical
APDL

Solution

Mechanical APDL

Deletes all files in the Mechanical APDL System directory and resets any
properties (as set in the Properties pane) back to the default. Any schematic

Analysis

input links remain intact and the needed files are copied back into the
system upon Refresh. Any manually- added files (Add Input/Reference) are
deleted and removed from the Outline pane.

Fluent

When the Use Workflow option enabled, a Reset on the Mesh cell removes
the generated mesh (if any) and resets the workflow completely. The default

Mesh

template for the workflow (specified in the Mesh cell) is then initialized and
all the workflow task states remain as Update Required. Since the workflow
state is stored in a mesh file, the mesh file is not removed, it is present and
is registered with the Mesh cell even after the Reset operation.

Closes the Fluent session without saving data. Deletes all internal files. Links
to imported files are deleted (but the file is not deleted.) If Mesh is coming

Link to imported
case and other

Setup

from an upstream simulation Mesh cell, the file is unregistered and mightinput files,
get deleted if the upstream Mesh cell no longer refers to it. All associated
input parameters are deleted. Launcher settings are set to the default value.

settings, and
possibly other
input files

Closes the session without saving data. Deletes all files currently associated
with the cell (the latest available solution data). Any schematic input links

Internal, link to
initialization
data

Solution

remain intact. Any imported initial solution data file is unregistered. (Only
the link is removed; the file is not deleted.) All associated output parameters
are deleted. Launcher settings are set to the default values.

To reset data:

1. Right-click the cell to reset and select Reset from the context menu.

2. To complete the operation, click OK.

249
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Resetting Data



Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.250



Using Journals and Scripts
Workbench offers the ability to record the actions you perform in the user interface, also known as
journaling. Journals are recorded as Python-based scripts. You can modify these scripts or create new
ones by scripting. Together, these capabilities allow you to quickly and easily replay analyses you've
already run using recorded journals, as well as to extend functionality, automate repetitive analyses,
and run analyses in batch mode.

For detailed instructions on using journaling and scripting, as well as a complete list of all available
data containers, namespaced commands, and data types, see the Workbench Scripting Guide.

Journaling

A journal is a record of all operations that have modified data during your session. Based on your
preferences setting, a journal of your full session is automatically saved to the location you specify (see
Setting Journaling Preferences (p. 251)). You can also choose to record part of a session to a journal file,
capturing a specific set of actions. Playing back the journal recreates the recorded actions exactly.
Journaling and scripting tools (including recording and playback) are available through the scripting
menu and can be performed by anyone using Workbench. Use journaled sessions to restore work after
a crash.

Journals are platform independent and portable, subject to file location consistency between accounts
(see File Path Handling in Ansys Workbench for details on file path handling within journals and scripts).
They can be used with any Ansys installation (release 12.1 or higher).

Scripting

A script is a set of instructions to be issued to Workbench. The script can be a modified journal, or it
can be a completely new set of instructions that you write directly.

The creation of scripts requires a general understanding of programming constructs and paradigms.
Workbench uses an object-based approach, similar to object-oriented programming.

Related topics:

Setting Journaling Preferences

Recording a Journal

Playing Back a Recorded Journal

Using the Command Window

Setting Journaling Preferences

You can set journaling preferences such as the default directory where journals will be written and how
long to keep a journal file.
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To set journaling preferences:

1. From the menu bar, select Tools → Options → Journals and Logs.

2. To have Workbench automatically write journal files, select Record Journal Files.

3. Specify the default location where journal files are written.

This is the location that the browser opens to automatically when you choose to begin recording
a journal. You can also browse to a different location before saving a particular journal.

4. Specify the number of days to keep a journal file.

5. Specify how long (in seconds) to pause between each command when running a journal file.

6. To save your settings, click OK.

Recording a Journal

Follow the steps described below to record a journal and then to playback a journal interactively. To
use the command window, see Using the Command Window (p. 253).

To record a journal:

1. From the menu bar, select File → Scripting → Record Journal.

2. Specify the name and location of the journal file and click Save.

3. Use the user interface to work through your analysis as you normally would.

Note:

Not all actions are journaled—only actions that change project data. Some examples of
actions that are not journaled include:

• Interface-only actions, such as:

Interrupting a Solve operation

Launching help (including quick help and the Sidebar Help pane)

Running the View Solver Output option from VistaTF's Solution cell.

• Actions taken in some data-integrated applications; see Scripting and Data-Integrated
Applications.

4. From the menu bar, select File → Scripting → Stop Recording Journal.

5. A message appears informing you that the recording will stop. Click OK.
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Playing Back a Recorded Journal

You can replay all of the previously recorded actions by playing back the journal file.

To play back a recorded journal:

1. From the menu bar, select File → Scripting → Run Script File.

2. Select the journal file to be played back and click Open.

Using the Command Window

The command window allows you to invoke commands, access data entity properties, and invoke data
entity and data container methods interactively, one at a time.

Note:

The console window is the same as the command window but is present when running in
batch mode to provide a way of working directly with commands outside of the user interface.

To use the command window:

1. From the menu bar, select File → Scripting → Open Command Window.

2. Enter the commands you want to run, one at a time.

As you enter each command, the appropriate action is triggered in Workbench.
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Working with the Chart Pane
The Chart pane is available for Workbench applications. Applications can display data using a number
of different basic chart types. Each chart type has editable display properties.

Related topics:

Chart Types

Setting Chart Properties

Changing the Display of a 3D Chart

Using the Triad

Saving a Chart

Chart Types

Although the content of a chart will be tailored to the application that is displaying it, there are a
standard set of charts that you might see in Workbench.

XY Plot

Plots lines, points, steps, bars, splines, scatter, or shaded regions in two dimensions.
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XYZ Plot

Plots lines, points, steps, bars, splines, scatter, or shaded regions in three dimensions.
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Pie Chart

Displays variables as proportionally sized segments of a circle. If a variable to be displayed has no value,
that variable displays as a ring around the circle.

Spider Chart

Displays variables as proportionally sized segments of a circle, in multiple dimensions. Good for displaying
between three and ten variables. Can usually be displayed as a parallel coordinate plot also.

257
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Chart Types



Parallel Coordinate Plot

Displays variables (for example, design points.) using parallel Y axes to represent all of the inputs and
outputs. Selecting an axis allows you to filter the variables shown by dragging the arrows at the ends
of the axis. Variables with points outside of the axis range are eliminated from the chart. Can usually
be displayed as a spider chart also.

Correlation Matrix

Displays how closely the various input and output parameters are coupled. The strength of correlation
is indicated by color in the matrix.
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Setting Chart Properties

Each chart has properties that can be set for chart data and chart display. This section describes chart
display properties, common to charts displayed by any Workbench application. For more information
about chart data properties, refer to the help for the individual applications displaying the chart.

The various chart properties are displayed in the Properties pane (p. 444).

Note:

Only the properties that are applicable for the current chart type are displayed when you
edit a chart component (an axis, for example).

To set chart properties:

1. Right-click a part of a chart and select Edit Properties from the context menu.

• To set axis properties, right-click on, or outside of, an axis.

• To set legend properties, right-click the border or background of the legend.

• To set variable properties, right-click the variable plot on the chart or right-click the variable
name in the legend.

• To edit chart properties, right-click the background of a chart.

2. Set the required properties.

DescriptionProperty

Axis Properties

The axis properties that are available depend on whether the chart axis is discrete or continuous.

Sets the name for the axis (defaults to variable name).Title

Sets the background color used for the axis name.Title Background
Color

Show Grid • When selected, displays a grid for this chart axis

• When cleared, hides the grid

Automatic Range • When selected uses automatic scaling for the axis

• When cleared uses Range Minimum and Range Maximum for axis
scaling if they fall within the data bounds

Sets the minimum range of the axis and is displayed when Automatic Range
is cleared.

Range Minimum

Sets the maximum range of the axis and is displayed when Automatic Range
is cleared.

Range Maximum

Is Logarithmic • When selected, sets axis scaling to be logarithmic
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DescriptionProperty

• When cleared, sets axis scaling to be linear

Is Usability • When selected, displays a line/bar plot of the cross-section data in a
perpendicular direction to the axis direction

• When cleared, hides the line/bar plot

Legend Properties

Legend properties can also be set as part of general chart properties. If you click a legend variable,
the variable properties are displayed instead of the legend properties.

Visible • When selected, displays the legend for the chart

• When cleared, hides the legend for the chart

Note:

If there are too many entries in the legend, the legend does
not display, even if Visible is selected.

Displays the legend entries either horizontally or vertically and allows the
legend to be expanded in the same direction, if it provides any benefit
(defaults to vertical).

Style

Sets the color of the legend border. The legend border default is to have no
color. You can apply a new color from the color wheel or click More and
change the Alpha channel to 0 for transparent or 255 for opaque.

Foreground Color

Sets the color of the legend background. The legend background default is
to have no color. You can apply a new color from the color wheel or click
More and change the Alpha channel to 0 for transparent or 255 for opaque.

Background Color

Variable Properties

Sets the name for the selected variable plot.Label

When selected, adds the selected variable plot to the legend.Is Included in
Legend

Sets the shape for the selected variable plot.Display As

Automatic Range • When selected uses automatic scaling for the variable values

• When cleared uses Range Minimum and Range Maximum for variable
value scaling if they fall within the data bounds

Sets minimum range of variable values displayed.Range Minimum

Sets maximum range of variable values displayed.Range Maximum

Style Display Properties

When plot rendering is controlled per variable, the style display properties appear when you
edit the variable properties. When plot line rendering is controlled generally rather than per
variable (for example, spider charts), the style display properties appear when you edit the chart
properties.
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DescriptionProperty

Renders lines and surfaces with anti-aliasing set on so that the line or surface
appears to be smooth.

Smoothed Edges

Sets the type of line used for the plot.Line Style

Sets the fill style for objects in the plot that use a fill.Fill Style

Sets the color sequence for multiple lines displayed on the chart.Line Colors

Sets the color sequence for sequential symbols or gradient used for plot
display.

Fill Colors

When set to 0, the gradient is displayed as a smooth graduation between
values, rather than banded, where a single color is shown for a range of
values.

Number of Color
Bands

Sets the width of a bar as a proportion of available space [0 - 1], determined
by the maximum size bar that can be displayed without overlapping any

Relative Bar Width

adjacent bars of the same variable (if other variables appear between bars
of this variable, making the bar wider may overlap those intervening variables).

Sets the start position of a bar, proportional to the minimum point where
the bar could be placed to the maximum point where the bar could be placed

Relative Bar Offset

[0 - 1], with the maximum size based on the same criteria as Relative Bar
Width.

When selected, causes the ends of a line plot to extend to the edge of
the chart, when the plot is not against a discrete axis.

Note:

In most cases, properties are not shown if they are not
applicable to the item selected. However, Show Linear

Show Linear
Interpolation of Lines

Interpolation of Lines is displayed whether the axis is discrete
or continuous, but it only applies in cases of continuous axes.
The option will have no effect if you set it when the plot is
displayed on a discrete axis.

Sets the color used to outline displayed symbols.Symbol Outline
Colors

Sets the size of displayed symbols in pixels [1 - 16].Symbol Size

Sets the width of lines (including lines outlining bars), in pixels [1 - 10].Line Width

Chart Properties

When plot line rendering is controlled generally rather than per variable (for example, in spider
charts), the style display properties also appear when you edit the chart properties.

Sets the chart title that appears in the Chart pane title bar.Title

Allows some charts to be displayed as another chart type.Chart Type

Turns on percentage values on pie charts.Display Percentages
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Changing the Display of a 3D Chart

You can manipulate the display of a 3D chart using the zoom, pan, and rotate features.

To change the display of a 3D chart:

• To zoom in or out of the entire chart, click the chart and use the scroll wheel or press Shift + middle
mouse button.

The chart expands or shrinks as you roll the wheel (or move the mouse) toward you or away from
you, remaining centered in the pane. The chart can be panned or rotated when it is magnified.

• To magnify a particular area of a chart, right-click and drag a box top to bottom over the area you
want to view.

The contents of the box you draw are magnified, so the smaller the box you draw, the closer the
magnification on a particular area.

• To reduce the chart to a particular size, right-click and draw a box bottom to top over the chart.

The chart zooms out to roughly correspond to the size of the box that you have drawn, so a very
small box gives you a tiny chart.

• To pan, press Ctrl + middle mouse button and move the mouse left or right.

Using the Triad

On three dimensional charts, the triad appears in the lower left corner showing the orientation of the
three axes for the current view of the chart. The x axis is red, the y axis is green, and the z axis is blue.
There is a light blue ball in the triad that indicates the orientation ISO z axis up position of the chart.
If you click this ball, it sets your chart to be ISO z axis up, fit to window.

If you move your cursor around the triad, a yellow arrow shows the direction that corresponds to the
position of your cursor (+x, -x, +y, -y, +z, -z). If you click the arrow, it changes your chart so that the
chart axis indicated by the arrow is facing out.

There are several shortcut keys that can be used when you are viewing a 3D chart:

• f – fits the chart to the window

• x – displays the x+ view, fit to window

• y – displays the y+ view, fit to window

• z – displays the z+ view, fit to window

• i – displays the chart in the ISO z axis up position, fit to window

Saving a Chart

You can save the chart that you are viewing as a graphic.
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To save a chart:

1. Right-click the background of the chart and select Save Image As from the context menu.

2. From the Size drop-down list, select the image resolution to use when saving the chart.

3. To the right of the File field, click the ellipses .

4. In the File Name field, type a name for the image.

5. From the Save as type drop-down list, select either PNG image or BMP image.

6. To save the settings, click Save.

7. To save the image, click OK.
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Working with Project Reports
Workbench project reports generate a visual snapshot of your project. The contents and organization
of the report reflect the layout of the Project Schematic, with sections for global project information,
analysis system information, system cell information, and where applicable, content provided by applic-
ations in the project.

The report contains basic project information, including:

• Export time and date

• Workbench version number

• A graphic of the systems as shown in the Project Schematic

• File information

• Parameter and design point information

• System and cell information

• Contents of notes

The specific information provided varies depending on the contents of the project.

Note:

At this time, DesignXplorer and CFD-Post are the only applications that provide the project
report with detailed report content. Content for other applications is limited to the data
visible at the project level (for example, in the Properties pane for the associated cell in the
Project Schematic).

The report is written to the user_files directory under the project directory by default.

If the project includes parameters and report content has been provided by an application in the project
during a design point update, then the design points table contains links to sub-reports for each design
point. Detailed report content for each design point can be accessed by a hyperlink in the Report
column of the design points table in the project report. Clicking the link opens a sub-report that contains
the application-specific content for that design point (if available).

Related topics:

Setting Project Report Options

Including CFD-Post Data in the Project Report

Exporting a Project Report

Editing Project Reports
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Viewing Report Images

Setting Project Report Options

You can control whether the report opens by default using the project reporting settings.

To configure project report options:

1. From the menu bar, select Tools → Options.

2. In the Options dialog, select Project Reporting from the navigation tree.

3. To launch your default browser and load the report immediately after it is generated, select the
After exporting report, automatically open in default browser check box.

If you do not select this option, you must navigate to the report file and open it manually.

4. Click OK.

Including CFD-Post Data in the Project Report

You can set whether or not to include CFD-Post data in the project report.

To include CFD-Post data:

1. In the Project Schematic, right-click the Results cell for an Ansys CFD analysis system or Results
system and select Properties.

2. In the Properties pane, select the Publish Report check box.

3. Repeat the previous two steps for each Results cell to be included in the project report.

Note:

• Only 2D content such as graphs and figures are supported in the project report. If interactive
3D content exists, it is displayed in 2D format.

• The format/style of CFD-Post reports produced from Workbench are consistent with gen-
eral Workbench-produced reports; reports from standalone CFD-Post use the standard
CFD-Post format.

Exporting a Project Report

You can export a report of the current project in .html/.htm format.

To export a project report:

1. From the menu bar, select File → Export Report.

2. To change the default file name, type a new name in the File name field.
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3. Click Save.

Editing Project Reports

Once you have generated a project report, you can edit its contents.

To edit a project report:

1. To open the report file with an HTML-adapted editor (such as Microsoft Word), right-click the file
and select Open with.

2. Edit the report contents and formatting as needed.

3. Save the file to a location outside Workbench.

Viewing Report Images

When you have a solved project that has design points, if a project report has been generated, you can
preview design point images from the report in the Parameter Set tab.

To view report images:

1. In the Project Schematic, right-click the Results cell and select Properties.

2. In the Properties pane, select the Publish Report check box.

3. In the toolbar, click Update All Design Points.

4. When the project has updated, click the Parameter Set bar.

5. In the Properties pane, under Design Point Report, note the list of PNG files that are available
for design points in the Report Image field.

The image files are located in the following directory:

[project_location]\dp[current_design_point]\[system_type]\Post\Report\Re-
port

6. Double-click the Parameter Set bar.

7. In the design points table, click a thumbnail in the Report Image column to open the image file.

To clear the images, in the Properties pane, set Report Image to None.

Note:

The image in the Report Image column is the default image for a CFX or Fluent report
(Generic Report Figure 1). To have a different image:

1. Set up CFD-Post to display the image you want in the report.

2. Click the Figure icon in the toolbar.
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3. In the Outline pane, disable Generic Report Figure 1 and enable Figure 1.

4. In Workbench, click Update All Design Points.
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Saving and Managing Project Files
The file management system in Workbench stores several different files under a single project, using
directory trees to organize files relevant to each system and the applications used in the system.

When the project file (<filename>.wbpj) is created, Workbench creates a project folder named
<filename>_files where <filename> is a name you provide. All files relevant to the project are
saved within this folder.

The primary subdirectories within the project folder are dp0, dpall, and user_files.

We strongly recommend that you use caution when directly modifying any of the content in any of the
Workbench project directories or subdirectories other than user_files. You should work through
the Workbench user interface to manage your project as much as possible. Workbench may not recognize
or be aware of any changes that you make directly in the file system (such as adding or removing a
file).

Important:

If you are resuming a project in Mechanical on the Linux platform, there is a restriction that
the path to the project, as well as the project name, include ASCII characters only, otherwise,
the project cannot open.

Related topics:

Saving a Project File

Archiving a Project

Saving an Archive File

Exporting Systems to a New Project

Working in the Files Pane

Recovering Projects

Unlocking Project Files

Project Directories

Understanding Project File Management

Saving a Project File

To create a project file and folder, save the project.

To save the project:

1. Select one of the following options:
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• To save the current project, from the menu bar, select File → Save or from the main toolbar,

click .

• To save the current project under a different name or location, from the menu bar, select File

→ Save As or from the main toolbar, click .

2. If prompted:

a. Browse to the location where you want to save the file.

b. Type a name for the project.

c. Click Save.

Archiving a Project

If you want to send a project to a colleague or to Ansys Technical Support, or need to package all of
the files, you can archive the project.

To archive a project:

1. Optionally, specify the compression level (p. 418) for the archive file.

2. If you have imported an external file into the project, and that external file refers to other files (for
example, when a CAD assembly is linked to the CAD parts), copy the referenced files into the
user_files directory to ensure they are added to the archive.

3. To save the project, from the menu bar, select File → Save.

If you do not save the project before archiving, you are prompted to save before proceeding.

4. From the menu bar, select File → Archive.

5. In the Save Archive dialog box, navigate to the directory where you want to save the file.

Note:

The initial default save location depends on your project management (p. 418) user
preferences. Also, the location you select is remembered and used as the default location
the next time you archive a project. Review the default location carefully before saving
the archive file.

6. From the Save as type list, select the archive type:

• Archive Files (*.wbpz)

• Zip File (*.zip)
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7. Click Save.

8. In the Archive Options dialog box, select the optional items to archive:

• Result/solution and retained design point files

• Imported files external to project directory

• Items in the User_files folder

Note:

– If your project contains Imported Boundary Conditions in the Mechanical application,
you must include result/solution items so that the necessary upstream files are
archived. Failure to archive these files prevents you from importing data or accessing
features that involve reading upstream data, when the project is restored.

– If you are using an External Model system, select the Imported files external to
project directory option. External Model systems do not copy files to the project
folders of downstream systems.

9. Click Archive.

Saving an Archive File

On Windows systems, you can double-click .wbpz archive files from the directory they are saved in to
open the archive. If you open an archive file this way and then make changes to the project, when you
save the file you are prompted to either overwrite the archive, create a copy of the archive, or cancel
the save operation.

To save an archive file:

1. From the menu bar, select File → Save.

2. To overwrite the archive file:

a. In the dialog box, click Overwrite.

b. In the Archive Options dialog box, select the optional items to archive.

• Result/solution and retained design point files

• Imported files external to project directory

• Items in the User_files folder

Note:

If your project contains Imported Boundary Conditions in the Mechanical applic-
ation, you must include result/solution items so that the necessary upstream files
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are archived. Failure to archive these files prevents you from importing data or
accessing features that involve reading upstream data, when the project is re-
stored.

c. Click Archive.

After saving, you are returned to Workbench, working in the updated archive. Use Save As
to restore the project to a .wbpj file.

3. To save a copy of the archive file:

a. In the dialog box, click Save a Copy.

b. Browse to the location to save the file.

c. Type a name for the archive copy.

d. Click Save.

After saving, you are returned to Workbench, working in the new (copy) archive. The original
archive remains unchanged. Use Save As to restore the project to a .wbpj file.

Exporting Systems to a New Project

You can reuse systems from a previously created project file by exporting one or more of them to a
new project.

Important:

To export systems, Workbench temporarily removes the systems not being exported from
the Project Schematic, saves the resulting schematic as a new project, and then restores the
original project. These systems are not being deleted, they will be restored after the export
project is saved.

Depending on how many systems are contained in the original project, and how many you
are exporting, this process can take a long time.

To create the new project:

1. If you have not saved your current project, from the menu bar, select File → Save.

2. Select all systems to be exported using one of the following methods:

• Click the header cell of a single system.

• Box-select by clicking and dragging the selection box over the required systems.

• Press Ctrl and click the required systems.
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3. Right-click the header of one of the selected systems.

4. Select Export System(s) from the context menu.

5. If you did not save your project in step 1, the Unsaved Project dialog box is displayed:

a. Click Save and Proceed.

b. In the File name field, type a name for the current project.

c. Click Save.

6. In the Export As dialog box, type the name of the new export project into the File name field.

7. From the Save as type drop-down list, select .wbpj to save the export project as a new Workbench
project, or .wbpz to save the export project as an archive file.

8. Click Save.

9. If you are saving the export project as an archive file:

a. In the Archive Options dialog box, select the optional items to archive.

• Result/solution and retained design point files

• Imported files external to project directory

• Items in the User_files folder

Note:

If your project contains Imported Boundary Conditions in the Mechanical applic-
ation, you must include result/solution items so that the necessary upstream files
are archived. Failure to archive these files prevents you from importing data or
accessing features that involve reading upstream data, when the project is re-
stored.

b. Click Archive.

The export project can be opened directly, or imported into another project (p. 49).

Working in the Files Pane

The Files pane shows a list of all files associated with the project. It enables you to see the name and
type of file, the IDs of the cells the file is associated with, the size of the file, the location of the file, and
other information.
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Workbench File Types

The following file types are created by the various Ansys applications and are shown in the Files pane.

Database Files

Ansys applications create the following types of database files:

• Ansys Workbench project database file (.wbpj)

• Mechanical APDL (.db)

• Fluent (.cas, .dat, and .msh)

• CFX (.cfx, .def, .res, .mdef and .mres)

• DesignModeler (.agdb)

• CFX-Mesh (.cmdb)

• Mechanical (.mechdb)

• Meshing (.cmdb)

• Engineering Data (.eddb)
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• Mesh Morpher (.rsx)

• Ansys Autodyn (.ad)

• DesignXplorer (.dxdb)

• BladeGen (.bgd)

Workbench Journal and Log Files

Workbench writes journal and log files for each Workbench session. For more information on journal
and log file options, see Journals and Logs (p. 421).

Design Point Log Files

During a design point update, the parameter values of each successfully updated design point are
written to a CSV log file in the user_files directory. For more information, see Exporting Design
Point Parameter Values to a Comma-Separated Values File (p. 316).

Sorting and Filtering the Files List

Files added to the project appear in the Files list.

To sort and filter the files list:

1. To sort individual column data, click the arrow ( ) to the right of a column name and select
from the following options:

• To sort the column data in ascending order, select Ascending.

• To sort the column data in descending order, select Descending.

• To cancel the current sorting option, select Cancel sorting.

2. To sort multiple columns at the same time:

a. Click the arrow ( ) to the right of a column name and select Sort Settings.

b. From the Column drop-down list, select the name of the column to sort.

c. To sort the column in ascending order, leave the Ascending check box selected. To sort the
column in descending order, clear the check box.

d. Repeat the previous steps until you have created a list of all of the columns you need to
sort.

To remove all of the columns from the list, click Remove All.

e. To save the changes, click OK.

3. To select the types of files that appear in the Files list:
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a. Right-click any of the cells and select File Type Filter from the context menu.

b. From the Select to Display column, select or clear any check boxes to display or hide the
indicated file type.

c. To save the changes, click OK.

Repairing or Removing Deleted Files

Files missing or deleted from the project are shown in red text and are marked with a deleted icon.

You can either repair the missing files by adding them back into the project from another location,
or you can remove them from the Files list.

To repair or remove deleted files:

1. In the Files list, select a cell on the line containing the deleted file or press Ctrl and click on
multiple cells to select multiple files.

2. To repair the deleted files:

a. Right-click the selection and select Repair filename from the context menu.

b. Browse to the location where a copy of the files are stored.

c. Click Open.

The deleted files are copied into their original directory, and the name of the files are shown
in black text.

3. To remove the deleted files from the list, right-click the selection and select Remove filename
from List from the context menu.

Opening the Folder Containing Project Files

You can select a file from the Files list and open the operating system's file manager to the folder
containing that file. In most cases, you should not edit, add, or delete a file from the operating system
file manager. Workbench does not recognize or is aware of any changes that you make directly in
the file system (such as adding or removing a file). However, if used with caution, this pane can be
a useful way to edit files such as application input files (for example, the Mechanical APDL application
input files).

To open the folder containing project files, right-click a cell and select Open Containing Folder from
the context menu.
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Copying Cell Text

You can copy the text from one or more of the Files list cells to paste into a different program, such
as Microsoft Excel.

To copy cell text:

1. In the Files list, select the cell you want to copy the text from or press Ctrl and click multiple
cells to select them.

2. Right-click the selection and select Copy from the context menu.

Recovering Projects

Workbench creates backup files of projects that are currently active and in progress. In the event of a
crash, Workbench can use these backup files to restore your project to the last saved event.

As with any computer program, it's important that you save your work frequently to minimize data loss
in the event of a crash. Do not move or otherwise alter the backup directory.

If a project save operation fails (for example, an application is busy and cannot execute the save), you
will be given the following options:

• Revert to the last saved project.

• Make a copy of the last saved project before continuing with the partially saved project. The project
is copied into a new location that you specify.

• Exit Workbench and decide later. Use this option if you want to handle the save failure manually. As
a result, the backup directory is not cleared so that you can manually recover files from that directory
later.

• Continue with the partially saved project, discarding the last saved project (not recommended). This
option results in the backup directory being cleared. Use this option with caution, as it could result
in corrupt project files.

Note:

Recovering from a save failure occurs only when saving a previously saved file and not when
saving as a new file, or when saving the project for the first time.

Unlocking Project Files

Workbench implements a project locking mechanism in order to help prevent the project from being
loaded into more than one session at a time. When the project is opened, a .lock file is created in
the project files directory. The project is unlocked by deleting the .lock file.

An improperly unlocked project can occur in situations such as program crash where the .lock file is
not deleted, or if the project files directory is duplicated and the .lock file is copied with it.
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If you open a locked project, you are asked how to proceed:

• If the file is locked because of an abnormal termination, such as a program crash, click Unlock.

• If the file is locked because the project is already open in another Workbench session, click Cancel.

Opening the same project in multiple sessions can result in corrupted project files.

Project Directories

The project directory structure includes the follow folders:

• dp0 Folder (p. 278)

• dpn Subdirectories (p. 279)

• user_files Folder (p. 279)

Important:

If you are resuming a project in Mechanical on the Linux platform, there is a restriction that
the path to the project, as well as the project name, include ASCII characters only, otherwise,
the project cannot open.

dp0 Folder

Workbench designates the active project as design point 0 and creates a dp0 folder that always
corresponds to the active project files. For more information on design points, see Working with
Design Points (p. 303).

Within the folder are system folders for each system in the project. Within each system folder are
folders for each application used in the system (for example, the Mechanical application, Fluent, and
so on). These folders contain application-specific files and folders, such as input files, model directories,
engineering data, and resources. System folders for each system type are named as follows.

Folder nameSystem Type

ATDAutodyn

BGBladeGen

DXDesign Exploration

ENGDEngineering Data

FFF (analysis system), FLU (component system)Fluid Flow (Fluent)

PFL (Polyflow), PFL-BM (Blow Molding), PFL-EX (Extrusion)Fluid Flow
(Polyflow)

CFXFluid Flow (CFX)

GeomGeometry

ETKoptiSLang

SYS (top level) / MECH (subdirectory)Mesh
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Folder nameSystem Type

SYS (top level) / MECH (subdirectory)Mechanical

APDLMechanical APDL

SC (top level) / SC (subdirectory) / SyC (subdirectory)System Coupling

TSTurboGrid

VTFVista TF

IPKIcepak

The Mechanical application and Mesh system folders are labeled SYS. Both the Mechanical application
and Mesh files are written to MECH subdirectories, because both are generated by Mechanical-based
applications.

In addition to the system folders, the dp0 folder also contains a global folder. This folder contains
subdirectories for all systems in the project. These subdirectories may be shared by more than one
system in the project and contain all database files, as well as any files that are associated directly
with the database files. For example, the Mechanical application writes figures, images, and contact
tool data to the appropriate system subdirectory under the global folder.

dpn Subdirectories

While a design point update is running, Workbench creates temporary design point folders. If the
Retain check box has been selected for a design point, its data is saved to a dpn subdirectory (where
dpn indicates the number of the design point) that is a sibling to the dpn folder and contains the
same sub-structure. For more information on retaining design point data, see Retaining Design Point
Data (p. 312).

user_files Folder

Under the project folder is a user_files folder. This folder contains any files (such as input files
and referenced files) that you supply to a project or any output (images, charts, movie clips, and so
on) generated by Workbench that you want to have associated with the project. In most cases, you
are responsible for placing required files into this folder. In other cases, such as the export of design
point update data from a design exploration system to a CSV log file, data is written directly to a file
created in this folder. For details, see Exporting Design Point Parameter Values to a Comma-Separated
Values File (p. 316).

Along with other project files, all of the files contained in the user_files folder appear in the Files
pane (p. 443) in Workbench.

Workbench also protects this folder and ensures that it is managed and archived appropriately with
the rest of the project; therefore, you can safely store additional files (such as PowerPoint or Excel
files, or other files from separate applications that are associated with this project) here without the
risk of losing data. If you save files in any other folder in the project structure and then exit without
saving, Workbench deletes any files saved there since the last Workbench save.

Example Project

A finished project that includes a Fluid Flow (Polyflow) system (FFF), a Mechanical application system
(MECH), and parameters (DesignXplorer) might look like this:
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The corresponding directory structure would look like this:

Myworkbenchproject_files
 dp0
   FFF
     DM
     Fluent
     MECH
     Post
   global
     MECH
       FFF
       SYS
   SYS
     ENGD
     MECH
 dpall
   global
     DX

Understanding Project File Management

The project system may delete, back up, or restore files when:

• Deleting, duplicating, or replacing systems in the schematic

• Opening an application for a cell

• Closing a project without saving

• Archiving a project

• Switching to the next design point when updating all design points
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While the project system is performing one of these operations, you cannot have project files open in
other applications (such as a text editor) or have the directories open in Windows Explorer. Doing so
may cause these file management operations to fail.

You cannot move a project or any of its associated files to another machine while a background run is
in progress. File information for the background run is, by necessity, machine-specific. You cannot
package or modify the background run while it is in progress.

Moving a project that has references to files outside of the project directory to a different machine or
location creates errors. By opening the project from a different machine or location, those file references
do not resolve, unless the file is still available under the same absolute path.

Copied images exist in only one location on disk that is referenced and do not exist as physical copies.
If you delete an image that has been copied, all pointers to the copies of that image will contain broken
links.

281
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Understanding Project File Management



Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.282



Working with Parameters and Design Points
In Ansys applications you can define key simulation properties to be parameters. You can then manip-
ulate the parameters at the project level in Workbench to investigate design alternatives. A set of
parameter values representing one design alternative is called a design point. You can create a set of
design points in tabular form and run them automatically to perform a what-if study.

For the most part, you work with parameters and design points on the Parameters tab and the Para-
meter Set tab. However, you can also use parameters and design points in Ansys DesignXplorer for
automated design exploration studies. DesignXplorer supports the insertion of the following Design
Exploration systems from the Workbench Toolbox into the Project Schematic:

• 3D ROM

• Direct Optimization

• Parameters Correlation

• Response Surface

• Response Surface Optimization

• Six Sigma Analysis

Note:

For large parametric studies, you should use AnsysDesign Point Service (DPS), which is part
of Distributed Compute Services. DPS provides for quickly and efficiently evaluating tens of
thousands of design points using multiple compute resources. For more information, see
the DCS for Design Points Guide.

Related topics:

Parametrization Basics

Working with Parameters

Working with Design Points

Parametrization Basics

Parameters can be defined not only in Workbench applications but also in numerous external CAD
packages. Applications that allow for parametrization include the following:

• DesignModeler

• Mechanical
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• Mechanical APDL

• Fluent

• CFX

• Polyflow

• SpaceClaim

• ExplicitSTR

• CFD-Post

• Vista TF

• Meshing

• Engineering Data

• Microsoft Excel

Parameterizing CAD Dimensions

To parameterize CAD dimensions, you must first enable parameters in Workbench:

1. From the Workbench menu, select Tools → Options → Geometry Import.

2. For Filtering Prefixes and Suffixes, specify any keys that must appear at the beginning or end
of a CAD parameter name for it to display in Workbench.

The default is ANS;DS. However, you can specify any number of prefixes or suffixes as keys. For
example, to expose a CAD parameter named Length in Workbench, you could rename it to
something like dslength, Lengthds, ds_Length, or Length_ds. The order, underscore, and case
do not matter. All of these would be recognized as matching the key DS.

Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.284

Working with Parameters and Design Points



Parameterizing Workbench Dimensions

The process for parameterizing Workbench dimensions depends on the application. The following
figures show different methods for parameterizing model data. For more information, see the docu-
mentation for the application that you are using.

Input and Output Parameters Created in DesignModeler and Mechanical
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Parameter Definition Based on a Mechanical APDL Input File

Input Parameters Created from an Expression in CFX
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Input Parameter Created from an Expression in Fluent
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Output Parameters Created from an Expression in CFD-Post

Derived Parameters

Derived parameters are created using analytical expressions composed of input parameters, output
parameters, or both input and output parameters. As the definition suggests, derived parameters are
calculated from other parameters by using equations that you provide.

Some examples of derived parameters include:

• Cost Function: Product of mass and cost per mass

• Normalized Stress: Stress response divided by an applied stress

• Average Value: Average of the first three frequencies

• Mesh Sizing: Mesh parameter set as a function of a geometric parameter

Note:

Derived parameters cannot reference other derived parameters.

Defining Derived Parameters

You can define derived parameters using various built-in arithmetic, trigonometric, and statistical
functions. They are created in the analysis system and passed into DesignXplorer as output parameters.
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To create a derived parameter:

1. Double-click the Parameter Set bar to open it.

2. Enter the expression in either of these locations:

• Value field in the Outline pane

• Expression field in the Properties pane (after selecting the parameter in the Outline pane)

Note:

You can add both derived parameters and constant values in the Outline pane. However,
once derived parameters are added, they become read-only in the Outline pane. To edit
them, you must use the Properties pane.

Working with Parameters

A parameter is a numerical or other measurable factor that helps to define a particular system. A para-
meter is linked to a data model property within an application. You can have input and output para-
meters. Parameter values can be numeric or non-numeric (string or Boolean). Non-numeric parameters
are ignored for charting purposes. An input parameter can be modified at the project level and drives
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a change within the data model. The value of an output parameter is set by the application, based on
the current results or state.

Input parameters define the geometry or inputs to the analysis for the system under investigation. Input
parameters have predefined values or ranges that may be changed. These include CAD parameters,
analysis parameters, and DesignModeler parameters. CAD and DesignModeler input parameters include
length and radius. Analysis input parameters include pressure, material properties, and sheet thickness.

Output parameters result from the geometry or are the response outputs from the analysis. These include
volume, mass, frequency, stress, velocities, pressures, forces, and heat flux.

Custom Parameters are project-level parameters that are not directly associated with a data model
property. They can be a custom input or custom output parameter that is defined by a constant value,
such as 12.5 [cm] or sin(pi/2). Or, they can be a derived parameter, defined by an expression
of other parameters, such as P2+3*P3. For more information, see Expressions, Functions, Quantities,
and Units (p. 291).

All parameters have a quantity, preferably with a quantity name. The quantity name is used to define
preferred and available units for the quantity. If the value does not have a quantity name defined,
Workbench displays the value without units.

You can add parameters to or delete them from the current project. However, this may set existing
design points and design exploration systems to an out-of-date state and can result in several hours of
recalculation time, depending on the project. Be aware that deleting a parameter referenced in the
expression of another parameter invalidates the driven data model, resulting in an error.

Note:

• Negative dimension values can invert the direction vector of SpaceClaim operations with
which they are associated. This change is applied to the current and subsequent design
point updates. As a result, when a Workbench input parameter is used as a driving dimen-
sion for a SpaceClaim geometry, negative dimension values can result in unexpected
geometric changes.

• When dimensional geometry parameters are imported into Workbench from SpaceClaim
or a bi-directional CAD interface, design point updates may fail when dependencies exist
between the parameters or when the parametric update in the CAD system or SpaceClaim
cannot be realized with the parameter values specified in Workbench.

• When you define a derived parameter in the Parameter Set bar, Workbench keeps the
unit specified at the moment of its creation as the native unit. You can select Units →
Display Values as Defined to see the native unit. For example, if meter is the unit specified
when a derived parameter is created, meter is the native unit. If you want the derived
parameter to use inch as the native unit, you must specify inch before you create the
derived parameter.

Related topics:

Expressions, Functions, Quantities, and Units

Creating or Editing Parameters

Chaining an Output Parameter to an Input Parameter
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Expressions, Functions, Quantities, and Units

The Workbench expression parser supports standard math functions and operators, as well as units
for quantities. Dimensional quantities are defined in units that are a combination of one or more
separate units.

Workbench expression and mathematical function evaluation is based on the Python 2.6 programming
language (See the Python website) and inherits some behavior as described here. All Python numeric
and function capabilities can be used. For example, Python provides support for hexadecimal (base
16) numbers. Appending a zero and an x to the front of a number tells Python to treat the number
as a hexadecimal numeric literal.

Expressions

When entering expressions, you must use the list and decimal separators defined in your locale settings.
For example, if a comma is defined as a decimal separator and a semicolon defined as a list separator,
use these when you type in an expression.

The expression defined for a custom Boolean parameter can be the Python values True or False, or
it can be a Python logical expression such as P1 > P2 or P1 == 10 and P2 == 10. For a
parameterized Boolean parameter, you can select True/False from the drop-down in the Value
column.

The expression defined for a custom string parameter must be quoted with single or double quotes,
such as ‘string value’ or "string value".

Do not start expression definitions with an = operator. Given existing parameters P1, P2, and P3 to
define a derived parameter P4 such that P4=P1*P2*P3, type the expression P1*P2*P3 in the Value
field.

When you click away from the field, the expression is solved.
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Functions

Expressions support the following intrinsic functions, which support both standard numeric values
and quantities as arguments.

sinh(arg)nint2(quantity,
reference)

int2(quantity,
reference)

cos(arg)abs(arg)

sqrt(arg)pow(value, exponent)log(arg)cosh(arg)acos(arg)

tan(arg)round(arg)loge(arg)exp(arg)asin(arg)

tanh(arg)round2(quantity,
reference)

log10(arg)fabs(arg)atan(arg)

PI, pi − constantsign(arg)max(arg list)floor(arg)atan2(arg1,arg2)

E, e − constantsign2(quantity,
reference)

min(arg list)floor2(quantity,
reference)

ceil(arg)

sin(arg)nint(arg)int(arg)ceil2(quantity,
reference)

Rounding Functions

The following rounding functions are designed to perform with, and restricted for use with, dimen-
sionless quantity arguments for which the results are in the same unit system:

• ceil

• floor

• int

• nint

• round

• trunc
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If these functions are used on quantities with units, an error message is displayed.

To perform rounding operations on quantities, use the following functions:

• ceil2

• floor2

• int2

• nint2

• round2

• trunc2

These functions support both numeric values and quantities. When used for quantities, the format is
func(quantity, reference). The quantity argument is converted to the unit of the reference
argument, then the resultant quantity value is rounded to the nearest reference value.

For example, to calculate a ceiling value rounded up to the nearest whole meter, enter
ceil2(quantity, 1[m]).

Sign Function

Like the rounding functions, the sign function is designed for dimensionless quantities and numbers.
To perform this operation on quantities, use the sign2 function.

The format is sign2(quantity, reference), but in this case the value of the reference argument
has no significance in the calculation, only the unit used for conversion matters.

For example, both sign2(3 [cm], 1 [in]) and sign2(3 [cm], 10 [in]) return 1, indic-
ating that the value of 3 cm converted into inches is a positive number.

Trigonometric Functions

The arguments for trigonometric functions are evaluated as follows:

• If the argument is a real number or integer, the argument is evaluated as radians.

• If the argument is a quantity (which has a value and units), the argument must be of type Angle.
The evaluation is based on the supplied units ([deg] or [rad]).

Quantities

Expressions that involve quantities must be dimensionally consistent. The + and − operators require
that the two operands have compatible units. For example, you cannot add an Area parameter to
a Length parameter. Both units must be Length or both units must be Area. The * and / operators
do not have this limitation. They allow one operand to be a quantity with a unit and the other operand
to be a dimensionless factor. Or, they allow both operands to be quantities with units where the
result is a different quantity type. For example, Length/Time results in a quantity with a Velocity
unit.

293
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Working with Parameters



If the expression defining a custom parameter results in a quantity, Workbench infers its quantity
name from the value produced by the expression evaluation. Consequently, if the expression is a sum
of multiple terms, every term must be using the same quantity name. For example, if the resulting
quantity is 3.4[m^2], the new custom parameter must have its Quantity Name property set to
Area. In some cases, more than one quantity name may be valid for the expression. In these cases,
the Quantity Name property is not set, but you can select from a list for the Quantity Name property
in the Properties pane for the parameter. Once the quantity name is determined from the unit of
the value, it can be subsequently changed only by changing the Quantity Name property for the
parameter. For example, you cannot change the expression from Area to Volume without changing
the Quantity Name property.

Once the value quantity name (such as Area) is determined from the unit of the value, it can only
be subsequently changed by changing the Quantity Name property for the parameter. You cannot
change the expression (for example, from area to volume) without changing the Quantity Name
property. Automatic unit conversion is only done when the quantity name is known. If you want to
express a temperature difference, start with temperature in absolute units.

Units

You can include units, assuming that the unit makes sense in context of the expression. For example,
P2+3[mm]*P3 is valid if mm is a valid unit expression for P2 and P3. For example, mm is a valid unit
expression if P2 is torque and P3 is force, or if P2 is area and P3 is length.

The project unit system is used to evaluate the expressions. For temperatures, absolute temperature
values are used in expression evaluation. All quantity values in an expression are converted to the
project unit system.

The general units syntax in Workbench is defined as multiplier|unit|^power, where:

• multiplier is a multiplying quantity or its abbreviation, such as mega (M) or pico (p)

• unit is the unit string or abbreviation, such as gram (g), pound (lb), foot (ft), or meter (m)

• power is the power to which the unit is raised

The following tables are examples of multipliers and commonly used units

Table 7: Unit Multipliers

Multiplier
Abbreviation

Multiplier
Value

Multiplier
Name

E1018exa

P1015peta

T1012tera

G109giga

M106mega

k103kilo

h102hecto

da101deca

d10-1deci
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Multiplier
Abbreviation

Multiplier
Value

Multiplier
Name

c10-2centi

m10-3milli

u10-6micro

n10-9nano

p10-12pico

f10-15femto

a10-18atto

Table 8: Example Quantities and Units

Example UnitsDimensionalityQuantity

Length Time^-2Acceleration m s^-2

ft s^-2

in s^-2

um ms^-2

CurrentCurrent A

mA

pA

Mass Length^-3Density kg m^-3

g cm^-3

lb ft^-3

slug in^-3

slinch in^-3

Current TimeElectric Charge A s

coulomb

pA s

Mass Length^2 Time^-2Energy J

BTU

erg

lbf ft

slug in^2 s^-2

Mass Length Time^-2Force dyne

N

pdl

lbf

slug in s^-2
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Example UnitsDimensionalityQuantity

LengthLength m

cm

foot

in

mm

micron

ft

um

yard

Mass Length^-1 Time^-2Pressure Pa

MPa

N m^-2

bar

torr

mm Hg

psi

psf

atm

dyne cm^-2

Mass Length^2 Time^-3Power W

BTU s^-1

HP

erg s^-1

lbf ft s^-1

TemperatureTemperature K

C

R

F

TemperatureTemperature
Difference

K

C

R

F

Temperature^2Temperature
Variance

K^2

C^2

R^2

F^2
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When typing units in an expression, you must enclose the units in square braces [...]. You generally
do not see the braces when selecting units from a list of commonly used units. In general, units de-
clarations must obey the following rules:

• A units string consists of one or more units quantities, each with an optional multiplier and optional
power. Each separate units quantity is separated by one or more spaces.

• Abbreviations for multipliers and unit names are typically used, but full names are also supported.

• Powers are denoted by the ^ (caret) symbol. A power of 1 is assumed if no power is given. A neg-
ative power is typically used for unit division. For example, [kg m^-3] corresponds to kilograms
per cubic meter.

• If you enter units that are inconsistent with the physical quantity being described, then an expression
error occurs.

• Units do not have to be given in terms of the fundamental units, which are mass, length, time,
temperature, angle, and solid angle. For instance, Pa (Pascals) and J (Joules) are both acceptable
as parts of unit strings.

• Units strings are case sensitive. For example, Kg and KG are invalid units strings; kg is correct.

Caution:

When the specified project unit system uses the relative temperature units (C or F), the
evaluation of expressions involving temperature, temperature differences, or temperature
variances is a special case.

For the unit conversion of a specific temperature value, 1 degC = 274.15 K. However,
the unit conversion for a temperature interval (delta T) is 1 degC = 1 K. The expression
evaluator takes any temperature value and treats it as a specific temperature (not a tem-
perature interval) by converting it to the absolute unit of the project unit system (either
K or R). If the intent is to perform the evaluation in terms of temperature intervals, you
need to start with temperatures in absolute units.

Similarly, any expressions to be evaluated in terms of temperatures or temperature differ-
ences are converted to absolute units for calculation. In an expression with a temperature
unit raised to a power other than 1 or a unit involving both temperatures and other units
(for example a temperature gradient [C/m]), the temperature is assumed to be a temperature
difference.

Table 9: Scenarios in which temperature-related units are converted before and during expression
evaluation

ExampleScenario

10[C] * 2 = 566.3[K] = 293.15[C]Temperature unit conversion

10[C/m] * 50 [m] = 500[K]Temperatures appearing as part of a mixed unit are
converted as temperature intervals

10[C^3] * 10[C] = 2831.5[K^4]Temperatures raised to a power other than 1 are
converted as temperature intervals
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Sound Pressure Level and A Weighted Sound Pressure Level are dimensionless quantities with units
dB and dBA, respectively.

• Math operations between these two units or either of these and a numerical value will result
in a value with no unit. For example, 10 db x 10 = 100. (no unit)

• Math operations between either of these units and a dimensional unit will result in a value
with the dimensional unit. For example, 10 db x 10 m = 100 m.

Creating or Editing Parameters

The process of working with parameters begins when you define a parameter in an application, such
as your CAD system, Mechanical, or Fluent. For information on defining parameters, refer to the
documentation for each application in which you are working.

Workbench recognizes parameters defined in the individual applications and exposes them in the
Parameter Set bar, which can be shared by multiple systems. The Parameter Set bar is the visual
representation of the project's full parameter set. Double-clicking it opens the Parameter Set tab,
which displays all parameters defined for all systems in your project. Each parameter is identified by
its system of origin.

Additionally, each system with parameters has a Parameters cell, which you can double-click to open
the corresponding Parameters tab. The Parameters tab for a given system displays all of the para-
meters defined for this system.

Each of these tabs has an Outline pane and a Properties pane for viewing and working with your
parameters.
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The Outline pane lists the parameters, grouping them into Input Parameters and Output Parameters.
Input parameters affect the definition of the data model. Output parameters are analysis results that
are quantities of interest for the design.

Note:

On a Parameters tab, the title in the header for the Outline pane displays the ID of the
corresponding Parameters cell to indicate the source of the parameters. On the Parameter
Set tab, the title is Outline of All Parameters.

For each parameter, the Outline pane shows an ID, name, current value, and unit system. You can
edit most of these properties. The exceptions are the parameter IDs and the units for parameters with
quantity values. When you select a parameter, its properties are shown in the Properties pane.

The Properties pane displays information for the object selected in the Outline pane. The objects
available for selection include parameters, expressions, and charts.

To create or edit parameters:

1. To view the parameters, double-click the Parameters cell of a system or the Parameter Set bar.

2. To add a new custom input parameter:

a. In the Outline pane, to the right of New input parameter, click the New name cell and
type a name for the parameter.
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b. Click the New expression cell and type either a constant value or expression for the para-
meter.

3. To add a new custom output parameter, in the Outline pane, to the right of New output para-
meter, click the New expression cell and type either a constant value or expression for the
parameter.

Note:

When you define a derived parameter in the Parameter Set bar, Workbench keeps
the unit specified at the moment of its creation as the native unit. You can select
Units → Display Values as Defined to see the native unit. For example, if meter is
the unit specified when a derived parameter is created, meter is the native unit. If
you want the derived parameter to use inch as the native unit, you must specify inch
before you create the derived parameter.
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4. If you have parameterized the Assignment property of the Body or Part objects or the Material
Name property of a Material Assignment object in the Mechanical application, select the desired
material from the drop-down list in the Value cell next to the parameter name.

5. To edit the name of a parameter, in the Outline pane, click the Parameter Name cell and type
the new name.

6. To delete custom parameters:

a. In the Outline pane, click the ID cell for a parameter to select it, or press Ctrl and click the
ID cell of multiple parameters to delete.

b. Right-click the selection and select Delete Selected Unlinked Parameters from the context
menu.

7. To show the properties for a parameter, click the ID cell for that parameter.
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8. To add or edit an expression, in the Properties pane, click the Expression Value cell and type
the new expression.

9. For an expression, once the quantity name (such as area) is determined from the unit of the
value, it can only be changed by changing the Quantity Name property for the parameter. In
the Properties pane, from the Quantity Name drop-down list, select a new value.

10. To add or edit the parameter description, in the Properties pane, click the Description Value
cell and type the new description.

11. Once you have finished adding and editing parameters, update the project, system, or Parameters
cell (p. 242) to register the changes and return the values of the output parameters. Note that an
update operation can be lengthy, depending on the analysis details.

Chaining an Output Parameter to an Input Parameter

You can chain an output parameter to an input parameter to allow an input to be driven directly
from the current value of an output, provided that the chaining does not create a circular dependency.

To chain an output parameter to an input parameter:

1. To view the parameters, double-click the Parameters cell of a system or the Parameter Set bar.
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2. In the Outline pane, to the right of New input parameter, click the New name cell and type a
name for the parameter.

3. Click the New expression cell and type either a constant value or expression for the parameter.

4. Update the project, system, or Parameters cell (p. 242) to register the changes and return the
values of the output parameter. Note that an update operation can be lengthy, depending on
the analysis details.

Working with Design Points

Each design point is a single set of parameter values representing one design alternative. Basically, you
can think of a design point as a snapshot of your design given a set of input parameter values, where
output parameter values are calculated by an update of the project. Design points allow you to perform
what-if studies and can be created in the Parameter Set bar or generated with ANSYS DesignXplorer.

You manage design points in the Table pane for the Parameter Set tab or on a Parameter tab. The
Table pane displays the design points.

From the Table pane, you can see existing design points and perform the following operations:

• Add new design points

• Duplicate existing design points

• Enter or change the input parameter values for design points

• Delete existing design points except for the current one

• Specify the design point update order

• Update design points, either locally or through Ansys Remote Solve Manager

• Retain design point data within the project for design points other than the current, which by default
has retained data
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• Preview the image from the project report (p. 265), assuming that the project has design points, is
solved, and a saved project report exists

• Set a design point with retained data as the current design point

• Export selected design points to separate projects

• Export a CSV file of the design points table

The design point that you interact with on the Project Schematic is always the current design point.
Initially, the current design point is DP 0. However, you can set any design point that has retained results
to be the current design point. You cannot rename or delete the current design point.

If you add a new design point, change its input parameter values, and update the project, you calculate
output parameter values for this new design point. You can then perform what-if studies to compare
this design to other designs.

Related topics:

Multiple Design Points Workflow

Adding a New Design Point by Duplicating an Existing Design Point

Adding a New Design Point by Entering Values

Updating Design Points

Retaining Design Point Data

Reviewing the Retained Data Column

Retaining Parameter Data for Solved Design Points with DesignXplorer

Setting a Different Design Point as Current

Copying Input Parameter Values to the Current Design Point

Exporting Design Points to New Projects

Exporting Design Point Parameter Values to a Comma-Separated Values File

Performing and Retaining Partial (Geometry-Only) Updates

Design Point States

Multiple Design Points Workflow

Workbench allows you to create multiple design points and generate comparison studies (what-if
studies) of input and output parameters.

To analyze your simulation across several design points:

1. In Ansys applications, generate input parameters for the current project (and, if appropriate,
specify output parameters to be created).

A Parameters cell is added to the relevant systems and a Parameter Set bar is added to the
project. The current project is designated as design point 0, or DP 0.

2. Create or edit the input parameters (p. 298).

3. Create multiple design points by duplicating an existing design point or by entering values.
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4. Set whether you want to retain the files generated during the design point update for further
analysis.

Workbench saves the data for the current design point, any retained design points, and the values
of the output parameters computed for each design point.

5. Update the design points.

Adding a New Design Point by Duplicating an Existing Design Point

When you duplicate a design point, all parameters, parameter values, design point states, and design
point export settings are copied. You can then modify any of these values as required.

To duplicate an existing design point:

1. To open the Table pane, double-click the Parameters cell of a system or the Parameter Set
Bar.

2. Right-click a design point in the Table pane and select Duplicate from the context menu.

The following Show-Me animation is presented as an animated GIF in the online help. If you are reading
the PDF version of the help and want to see the animated GIF, access this section in the online help. The
interface shown may differ slightly from that in your installed product.

Adding a New Design Point by Entering Values

You can add a new design point by entering parametric values in the Table pane.

To enter values:
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1. To open the Table pane, double-click the Parameters cell of a system or the Parameter Set
bar.

2. In the bottom row of the table, below the existing design points, type a parametric value in one
or more of the cells.

The following Show-Me animation is presented as an animated GIF in the online help. If you are reading
the PDF version of the help and want to see the animated GIF, access this section in the online help. The
interface shown may differ slightly from that in your installed product.

Updating Design Points

Output parameter values for a design point are calculated when you update the design point. You
can update only the current design point, a set of selected design points, or all design points. Updating
design points updates solution data only where output parameters have been defined.

You have several options for updating design points. The settings specified by the Design Point
Initialization property apply. For more information, see Specifying the Initialization Conditions for a
Design Point Update (p. 311).

When you update multiple design points, you can choose the order in which design points update.
You can also choose the initial conditions with which they update.

You may want to specify the order for design point updates to improve efficiency. For instance, if
several design points use the same geometry parameter values, it is more efficient to process them
together so as to update the geometry only once.

By default, when each design point is updated, the design point is initialized with the data of the
design point designated as current. Retained design points with valid retained data are exceptions
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because they do not require initialization data. In some cases, it may be more efficient to update each
design point starting from the data of the previously updated design point, rather than restarting
from current design point each time.

To update design points in Remote Solve Manager (RSM), see Updating Design Points in Remote
Solve Manager (p. 352).

Non-parametric changes made to a project with up-to-date design points may cause all existing
design points to go out-of-date, if the change is related to the parametric study being performed.
Any change not relevant to the parametric study, such as adding a standalone system or making a
change downstream of the study, should not cause design points to go out-of-date. For changes that
invalidate the design points table, you must update the project, which can require significant time
and computing resources. You should always save your project after updating all design points and
before further modifying the project.

In most cases, a design point update applies only to cells affected by parameter changes and to cells
downstream. Cells without associated parameters or cells whose associated parameters did not change
are not updated.

Related topics:

Setting the Design Point Update Option

Updating Only the Current Design Point

Updating Selected Design Points

Update All Design Points

Fixing an Interrupted Design Point Update

Changing the Design Point Update Order

Specifying the Initialization Conditions for a Design Point Update

Setting Systems using CFD-Post to Update with Design Points

Setting the Design Point Update Option

Before updating design points, you must set the location where the updates are processed.

To set the design point update option:

1. On the Project Schematic, right-click the Parameter Set bar and select Properties from the
context menu.

2. In the Properties pane, from the Update Option drop-down list, select from the following
options:

• Run in Foreground: Runs the design point update within the current Workbench session.
This option is appropriate for quick-running updates that fit within the resources of your
workstation. This option is also the most robust as it is not possible to make changes that
impact the design points. When a design point update is executing in the foreground, you
cannot change or save the project, but you can interrupt or stop the update.

• Remote Solve Manager: Runs the design point update in the background by submitting it
to RSM using HPC shared licensing features.
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Use this option for long-running updates that do not fit within your workstation's resources.
When you submit an update, RSM can send it to a remote compute cluster or to a Cloud
portal. RSM can also submit jobs to the local machine to allow the queuing of updates on
your workstation.

For more information on submitting design point updates to RSM, see Updating Design
Points in Remote Solve Manager (p. 352).

• Submit to Design Point Service (DPS): Runs the design point update in the background
by submitting it to DPS. Use this option to quickly and efficiently evaluate large numbers
of design points simultaneously using multiple compute resources, including ad-hock net-
works, Amazon web services, and Remote Solve Manager.

For more information on submitting design point updates to DPS, see Working with Design
Point Service (p. 363).

Updating Only the Current Design Point

To update just the current design point, update the project (p. 243).

Updating Selected Design Points

You can choose a set of design points from the table to update.

To update selected design points:

1. To open the Table pane, double-click the Parameters cell of a system or the Parameter Set
bar.

2. Press Ctrl and click each design point in the table to update.

3. Right-click the selection and select Update Selected Design Points from the context menu.
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If the update for one of the design points fails, the Update Failed, Update Required ( ) icon is
displayed for the failed design point, but the next design point update begins immediately. The
Messages pane opens, showing the error message for the one or more design points that failed.
When the update process is complete, a failure summary dialog box opens. Review the error mes-
sages for details on which design points failed to update.

Update All Design Points

You can update all design points in the table.

To update all design points:

1. To open the Table pane, double-click the Parameters cell of a system or the Parameter Set
bar.

2. To update the design points:

• From the menu bar select Tools → Update All Design Points.

• On the Project tab toolbar click Update All Design Points.

• Right-click the white space on the Project Schematic and select Update All Design Points
from the context menu.

If the update for one of the design points fails, the Update Failed, Update Required ( ) icon is
displayed for the failed design point, but the next design point update begins immediately. The
Messages pane opens, showing the error message for the one or more design points that failed.
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When the update process is complete, a failure summary dialog box opens. Review the error mes-
sages for details on which design points failed to update.

Fixing an Interrupted Design Point Update

If the update of a design point is interrupted, the partially updated icon ( ) is displayed beside
the values of the output parameters for the interrupted component. The next time that this design
point is selected for update, a dialog box opens.

To continue, select from the following options:

• Use Partially Updated: Accepts output parameters that are only partially updated as up-to-date,
using the existing results to update design points.

• Update All: Restarts the interrupted update, recalculating results for all output parameters that
are partially updated and then updating all design points. The dialog box notes that this can be
a lengthy process.

Changing the Design Point Update Order

By default, design points are updated in the order in which they appear in the design points table.
The Update Order column shows the order number for each design point. To view the column,
right-click in the table and select Show Update Order from the context menu.

To change the order that design points are updated in, select from the following options:

• Right-click the table and select Optimize Update Order from the context menu.

An optimal update order is determined by an analysis of parameter dependencies in the project
and a scan of parameter values across all design points. The Update Order value for each design
point is updated automatically.

Note:

The primary goal of Optimize Update Order is to reduce the number of geometry
and mesh system updates. In general, the optimized order is driven by the order of
the update tasks, which means that the components are updated depending on their
order in the system, their data dependencies, their parameter dependencies, and the
state of the parameters. This works best in a horizontal schematic with geometry as
the first separate system. In a single vertically-integrated system project, the parameters
defined in the upper components are considered the most important. In some cases,
because of the order of parameter creation or the presence of engineering data
parameters, you may find that the first columns are not geometry parameters. In this
case, we recommend that you use the Optimize Update Order option to sort by
geometry parameters.

• Edit the values in the Update Order column.

• Sort the table by one or several columns and then right-click in the table and select Set Update
Order by Row.
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The Update Order value for each design point is regenerated to match the sorting of the table.

The following Show-Me animation is presented as an animated GIF in the online help. If you are reading
the PDF version of the help and want to see the animated GIF, access this section in the online help.
The interface shown may differ slightly from that in your installed product.

Specifying the Initialization Conditions for a Design Point Update

When a design point is updated, the solver is initialized with data. Design points with valid retained
data use that as their initialization data. Other design points either:

• Initialize with the data of the design point designated as current (From Current)

• Initialize starting from the data of the previously updated design point (From Previous Updated).

Using the From Previous Updated initialization value works best when:

• Sequential design points share the same geometry. For example, if DP 2 has the same geometry
as DP 1, but both of these differ from DP 0, changing the default behavior saves the computa-
tional cost of updating both the geometry and the mesh for DP 2.

• You have modified the design point update order in the Update Order column, either by editing
the values manually or by generating them with the Set Update Order by Row option.

• The design point update order has been optimized, either by the Optimize Update Order option
or by a DesignXplorer optimization.

To set how design points are initialized:
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1. On the Project Schematic, right-click the Parameter Set bar and select Properties from the
context menu.

2. From the Design Point Initialization drop-down list, select the required initialization value.

Setting Systems using CFD-Post to Update with Design Points

For systems using CFD-Post results, you can specify that the results cell is always updated with a
design point update operation, even when the update does not affect parameter values.

To set systems using CFD-Post to update with design points:

1. On the Project Schematic, right-click a CFD-Post Results cell and select Properties from the
context menu.

2. In the Properties pane, select the Always Include in Design Points Update check box.

Retaining Design Point Data

By default, Workbench does not retain design points after they are solved. It saves the calculated
data only for the current design point. For other design points, only the parameter values are saved.

In some cases, you might want to switch back and forth between multiple designs within the same
project. To do this, select one or more design points and retain their calculated data within the project.

To retain design points data:

1. To open the Table pane, double-click the Parameters cell of a system or the Parameter Set
bar.

2. For each design point you want to retain data for, select the Retained check box.

Note:

When this check box is selected, data for all systems inside the Workbench project
are stored for the design point, regardless of whether a system has connection to the
parameters. When only a small portion of the system is parameterized, retaining the
data is not efficient. This is a known limitation.

3. To generate retained design point data, update the design points (p. 306).

Once design point data has been retained:

• You can verify that the data has been retained and see the availability and state of the retained
data. For more information, see Reviewing the Retained Data Column (p. 313).

• You can view multiple designs by setting different design points as current. For more information,
see Setting a Different Design Point as Current (p. 314).
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Reviewing the Retained Data Column

You can verify that data has been retained by viewing the icon in the Retained Data column for
each design point. This icon indicates the availability, validity, and state of the retained data for the
design point.

Different kinds of changes to the project have different impacts on retained data. Changes to the
parameter values for the design point cause the retained data to become out-of-date but still valid.
Non-parametric changes cause the retained data for non-active design points to become invalid.

Note:

During a local design point update, only the design point being updated is active. When
no update is in progress, only the current design point is active.

The state of the design point and the validity of its retained data do not necessarily match. It is possible
for a design point to be up-to-date while its retained data is invalid or vice versa.

When used in the Retained Data column, icons have slightly different meanings than they do else-
where in Workbench. The following table describes the meaning of each icon within the context of
retained design point data.

DescriptionState/ValidityIcon

The design point has valid retained data that is up-to-date.
The retained data is available to be exported.

Valid and up-to-date

The design point has valid retained data, but the retained
data is out-of-date because of a change to the design

Valid but out-of-date

point's parameter values. The retained data is available to
be exported.

The design point either does not have retained data or
previously retained data has been invalidated by a

Invalid or
non-existing

non-parametric change. The retained data is not available
to be exported.

Each state is illustrated in the image below, as follows:

• DP 0 (Current) has retained data that is valid and up-to-date. The current design point always
has valid retained data and the Retain check box is disabled.

• DP 1 has valid retained data that is current and up-to-date.

• DP 2 either does not have retained data or has retained data that is invalid.

• DP 3 has retained data that is valid but out-of-date.
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Retaining Parameter Data for Solved Design Points with DesignXplorer

When design points are updated, DesignXplorer provides the following methods of retaining para-
meter data for solved design points:

• It saves design point data to the design point cache. DesignXplorer reuses data from the cache
when you preview or update a Design Exploration system. For more information, see Cache
of Design Point Results in the DesignXplorer User's Guide.

• It exports design point data into design point log files. You can import the log file back into
DesignXplorer as needed. For more information, see Design Point Log Files in the .

• It allows you to export all design point values to an ASCII file. This functionality is available for
DesignXplorer charts or tables containing design point data, including the design points table.
You can then use the parameter values in the file with other programs for further processing
or import into DesignXplorer.

Note:

Both the design point log files and the ASCII file are formatted in the extended CSV
file format. For details, see Exporting Design Point Parameter Values to a Comma-
Separated Values File (p. 316).

Setting a Different Design Point as Current

Once multiple design points have retained data, you can switch back and forth between these multiple
designs within the project. To view the design associated with a given design point, you set it as the
current design point. Only design points with retained data can be set to current, and only one design
point can be set to current at a time.

To set a design point as the current design point:

1. To open the Table pane, double-click the Parameters cell of a system or the Parameter Set
bar.

2. In the Table pane, right-click a design point that has retained data (p. 312) and select Set as
Current from the context menu.
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The design point becomes the current design point for the project. In the Name column, (Current)
displays after the name of the current design point. Setting a design point as current does not auto-
matically update it.

Note:

In a project that includes a Microsoft Office Excel system and uses retained design points,
switching to a different up-to-date design point automatically updates the Excel system.
This can be time-consuming if the spreadsheet contains macros or extensive calculations.

Copying Input Parameter Values to the Current Design Point

An alternate method to switching design points is to copy a different design point's input values to
the current design point. Copying the input values does not automatically update the design points.

To copy input parameter values to the current design point:

1. To open the Table pane, double-click the Parameters cell of a system or the Parameter Set
bar.

2. In the Table pane, right-click a design point and select Copy inputs to Current from the context
menu.

Exporting Design Points to New Projects

To work with the calculated data for a design point other than the current design point, you can export
the design point to a separate project. A new project is created for each design point that is exported.

When you export a design point, if the design point has already been exported, the existing exported
files are overwritten.

Note:

DesignXplorer data is not a part of design points and is not exported. DesignXplorer is a
consumer of design points but does not define design points. Consequently, it is not in-
volved when a design point is updated, or by extension, exported.

To export design points:

1. To open the Table pane, double-click the Parameters cell of a system or the Parameter Set
bar.

2. In the Table pane, select the design points.

3. Right-click the selection and select Export Selected Design Points from the context menu.

The data of each design point is saved to a new project, named filename_dpn (where dpn indicates
the number of the exported design point), with a project file named filename_dpn.wbpj. Working
files are saved to a filename_dpn_files directory that is a sibling to the original file-
name_files project folder.
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The content of the new project depends on the state of the design point's retained data at the time
of the export:

• If valid retained data is available for an exported design point, the retained data is used to
create the new project. This retained data can be either up-to-date or out-of-date.

• If no valid retained data is available for an exported design point, the project exported is an
out-of-date project based on the current design point with the parameter values for this design
point applied. No valid retained data exists if the design point is either not selected to retain
data or is selected but retained data is not yet generated or has become invalid. You are asked
to confirm before the export of such a design point is performed. When you open the exported
project, it is out-of-date and requires an update to solve for the exported design point.

After an export, you must save the parent project before you can export design points again.

If a design point fails to export, the files for this design point remain in the project_files\dpn
directory until you delete them manually or attempt to update the design point again.

Exporting Design Point Parameter Values to a Comma-Separated Values
File

From the design points table, you can export the design point parameter values to a Comma-Separated
Values (CSV) file, which you can then use with other software tools for further processing. This file is
created in an extended file format. In addition to supporting standard CSV formatting, it supports
several Workbench-specific formatting conventions. The values are always exported in units as defined
in Workbench.

The file format includes the following components:

• Values are separated by commas.

• The optional header line indicates the name of each column.

• Each line is an independent record made of fields separated by commas.

• The format is not dependent on the locale, which means that the real number 12 and 345 one-
thousandths is always written as 12.345, regardless of the regional settings of the computer.

• If a line starts with the character #, it is considered a comment line rather than a header or data
line and is ignored.

• The header line is mandatory. It is the line where each parameter is identified by its ID (P1, P2, ...,
Pn) to describe each column. The IDs of the parameters in header line match the IDs of the para-
meters in the project.

• The first column is used to indicate a name for each row.

• A file can contain several blocks of data, with the beginning of each block being determined by a
new header line.

To export design point parameter values to a CSV file:
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1. To open the Table pane, double-click the Parameters cell of a system or the Parameter Set
bar.

2. In the Table pane, right-click a cell and select Export Table Data as CSV from the context menu.

A file similar to the following is generated:

# 
# 10/1/2012 10:38:01 AM 
# The parameters defined in the project are: 
# P1 - WB_B [mm], P2 - WB_D [mm], P3 - WB_L [mm], P4 - WB_P [N], P5 - WB_E [MPa], 
# P10 - WB_SIG [MPa], P8 - WB_DIS [mm], P9 - WB_BUCK [N] 
# 
# The following header line defines the name of the columns by reference to the parameters.
Name, P1, P2, P3, P4, P5, P10, P8, P9
DP 0, 2, 5, 100, 1000, 200000, 12000, 80, 1028.91145833333 
DP 1, 3, 5, 150, 1000, 200000, , , 
DP 2, 5, 5, 20, 1000, 200000, , , 

Performing and Retaining Partial (Geometry-Only) Updates

To check your geometry for parametric failures, you can perform a geometry-only design point update.
When the partial results have been calculated, you can save them to the project to be used in sub-
sequent design point updates. You might do this if you want to generate the geometry updates on
one machine and then move the project to a machine that cannot update geometry.

To perform a geometry-only update:

1. On the Project Schematic, right-click the Parameter Set bar and select Properties from the
context menu.

If the Properties pane is already visible, click the Parameter Set bar to refresh the Properties
pane with the design point settings.

2. In the Properties pane, from the Update Option drop-down list, select Run in Foreground.

3. From the Partial Update drop-down list, select Geometry.

4. To retain the results from the partial update, from the Retain Partial Update drop-down list,
select Geometry.

Note:

This setting causes the geometry results to be saved whether you perform a partial
update or a full update.

Partial update data can exist from either a partial or full design point update. To remove existing
partial update data, set Retain Partial Update to None. The partial retained data is deleted from the
project the next time that design points are updated.
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Design Point States

On the Parameters Set tab and any Parameters tab, the Outline and Table panes display icons on
output parameters to indicate their states.

• An output parameter that is up-to-date displays no icon. Only the value of the output parameter
is shown.

• An output parameter that is out-of-date displays the Update Required icon ( ). Either the output
parameter has not been solved or requires an update because local data has changed.

• An output parameter that has failed to update displays the Update Failed, Update Required icon

( ).

• An output parameter that has partially updated values because of an interruption to either a project

update or a design point update displays the Partially Updated icon ( ).

During cell, system, project, and both local and remote design point updates, the Outline and Table
panes update the states of the output parameters.

Changes elsewhere in the project could cause the state of some, but not all, output parameters to
go out-of-date and require update. In those cases, only those output parameters affected by the
changes are shown as requiring an update. Output parameters that are not affected by the changes
remain up-to-date.

Changes to derived parameters or associated expressions are recalculated immediately rather than
requiring an update. If you add or change derived parameters, other parameters are not affected by
this change and so do not require an update.

Design points that are being updated using RSM display the Pending icon ( ) in the design points
table while the remote design point update is in progress. When each updated design point is retrieved,
associated output parameters reflect the results of the update.
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Working with Ansys Remote Solve Manager
Ansys Remote Solve Manager (RSM) provides the central framework for job submission to an established
cluster or third-party Cloud. This enables you to access powerful compute resources when needed.

To enable job submission to a cluster or Cloud portal, an administrator must create configurations in
RSM. An RSM configuration contains information about the HPC resource where jobs are submitted
(such as the name of the cluster submit host, or URL of the web portal), file transfer methods, and the
queues that are available for job submission. (See RSM Configuration in the Remote Solve Manager User's
Guide.)

RSM configurations enable RSM to integrate with the following types of HPC resources:

• Commercial clusters. Includes Microsoft HPC, LSF, PBS Pro, UGE (SGE), TORQUE with Moab, and
custom clusters.

• Ansys Cluster (ARC). An ARC operates in the same way that a commercial cluster does, running Ansys
applications in local or distributed mode, but uses its own scheduling capability rather than that of
a third-party job scheduler.

Every RSM installation includes a default localhost ARC configuration that enables you to run
solutions and updates on your local machine, essentially making your machine a single-node cluster.

• Third-party Cloud. Through RSM customization, provides access to Cloud-hosted compute services.

Note:

• For a Microsoft HPC cluster, PSSH is not supported on Microsoft Windows for job submission.

• PBS, LSF, UGE and TORQUE clusters on Windows are not supported.

Once the configurations have been created, the administrator must share them with users. You must
then either copy the configurations into your default RSM configuration directory, or, if they reside in
a shared directory, change the path of your RSM configuration directory to the path of the shared dir-
ectory. (See Sharing and Accessing RSM Configurations in the Remote Solve Manager User's Guide.)

Once RSM configurations have been made available to your local machine, the RSM queues that are
defined in those configurations are listed in the RSM Queue drop-down menu when you select the
Submit to Remote Solve Manager option for updates and solutions. Each RSM queue is associated
with a specific HPC queue that has been created on the cluster/portal side. An HPC queue determines
the machine(s) where jobs are run.
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Depending on the RSM queue chosen, jobs can be run locally in the background on your local machine,
sent to a remote machine, or distributed across multiple machines.

Note:

The naming scheme for jobs sent to RSM is as follows:

• For Mechanical jobs:

[client machine name]-[Workbench project name]-[design point name]-[Model node name
(including cell ID)]-[Environment node name (including cell ID)]-[Solution node name (in-
cluding cell ID)]

Example: MyWorkstation-MyProject-DP0-Model (A4)-Static Structural (B5)-Solution (B6)

• For CFX/Fluent/Polyflow/Mechanical APDL jobs:

[client machine name]-[Workbench project name]-[design point name]-[System name]-
[Component name (including cell ID)]

Example: MyWorkstation-MyProject-DP0-CFX-Solution (C3)

Jobs submitted to RSM can be monitored using the Workbench Job Monitor (see Monitoring and
Controlling Remote Solve Manager Jobs in Workbench (p. 348)).

This chapter assumes that RSM has been set up according to the instructions in the Remote Solve
Manager User’s Guide (see RSM Installation and Startup and RSM Configuration).

Related topics:

Specifying Credentials for Remote Solve Manager Job Submission

Submitting Solutions to Remote Solve Manager

Submitting Workbench Project Updates to Remote Solve Manager

Submitting System Coupling Jobs to Remote Solve Manager

Submitting Mechanical Application Jobs to Remote Solve Manager

Submitting Mechanical APDL Jobs to Remote Solve Manager

Submitting Fluids Jobs to Remote Solve Manager

Monitoring and Controlling Remote Solve Manager Jobs in Workbench

Updating Design Points in Remote Solve Manager

Specifying Credentials for Remote Solve Manager Job Submission

Remote Solve Manager (RSM) needs to acquire and cache your credentials to be able to submit jobs to
an HPC resource on your behalf. RSM's direct integration with Workbench and built-in caching capability
automates this process to a great extent.

When you submit a job to RSM from Workbench for the first time, and your credentials have not yet
been cached for the RSM queue in RSM, or the cached password does not validate because your OS
password has changed or expired, you are prompted to specify credentials for that queue:

Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.320

Working with Ansys Remote Solve Manager



If the credentials validate, the job is submitted to the HPC resource. If the credentials do not validate,
the job is aborted.

Submitting Solutions to Remote Solve Manager

You can use the Solution Process properties of a system's Solution cell to submit the solution to Remote
Solve Manager (RSM).

Use this option for long-running solutions that do not fit within your workstation's resources. When
you submit a solution, RSM can send it to a remote compute cluster, or to a Cloud portal. RSM can also
submit jobs to the local machine to allow the queuing of solutions on your workstation.

Note:

• When submitting solve jobs to the remote cluster, the license preferences set for your
local machine (the RSM client) may not be the same as the license preferences set for the
cluster. In this case, the cluster license preferences are used for all jobs.

• Solution cell updates via RSM are not supported for System Coupling; System Coupling
jobs must be sent to RSM either as project updates or design point updates. For more in-
formation, see Submitting System Coupling Jobs to Remote Solve Manager (p. 327).

To submit solutions to RSM:

1. Right-click the Solution cell of a system and select Properties from the context menu.
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2. In the Properties pane, from the Update Option drop-down list, select Submit to Remote Solve
Manager.

Important:

When design points are configured to be updated in RSM, the Solution cell cannot also
be updated in RSM. In this case, change the Solution cell update settings by setting
the Update Option Solution Process property to Run in Foreground.

3. Set the following additional properties:
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• Solve Process Setting (Mechanical application only): Select the solving configuration defined
in Mechanical.
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• RSM Queue: Specifies a queue defined in RSM that maps to a specific HPC queue on the
cluster/portal side. Any RSM queues currently defined in RSM appear in this drop-down list. The
RSM Queue Details section displays the HPC Configuration, HPC Queue, and HPC Type (for
example, ARC, WinHPC, or LSF) that the RSM queue is associated with.

If a queue has been recently added in RSM and you do not see it in the list, select Refresh
Queues to update the queue list.

• Job Name: Displays the name reported in the RSM job log. The default name for a Workbench
job is Workbench, or whatever is set for the Default Job Name in your Workbench options.
The default name for a Mechanical job submitted from the Mechanical application is Mechan-
ical. The job name provides a traceable piece of data that administrators can use to track job
submissions to a cluster (for billing purposes, for example).

To override the default job name, double-click the Job Name Value cell and type the required
name.

Job name overrides must adhere to the following conventions:

– Can only use alphanumeric characters and ~ # % ^ , & * ' ( ) - _ + = / < >

– Cannot exceed 15 characters

– The first character must be one of the alphanumeric characters (a-z, A-Z, 0-9)

• Download Progress Information: Specifies that the solver monitor should periodically query
RSM for output files in order to display progress (where applicable). Queries begin when you
initiate an action to display the solution progress (such as choosing the Display Monitors option
in CFX). This option, available for Fluent and CFX systems, is enabled by default.

For CFX systems, select from the following options:

– Always Download Progress Information: Causes queries to RSM to begin immediately. This
option is enabled by default.

– Download Progress Information on Demand: Causes queries to RSM to begin when you
initiate an action to display the solution progress (such as choosing the Display Monitors
option in CFX).

For all other systems, select or clear the Download Progress Information check box.

• Progress Download Interval: Specifies the periodic time interval, in seconds, that the solver
queries RSM for output files to display progress. The default is 30. Setting this value to 0 results
in continuous queries; that is, as soon as files are downloaded from the execution node, Work-
bench immediately queries again. This option is available for Fluent and CFX systems.

• Execution Mode: Specifies the serial or parallel solver execution mode. The parallel option is
available only if the selected solver supports parallel execution mode. This option may not be
available with all systems.

When performing a design point update in RSM with component update in the foreground, the
Parameter Set properties override the parallel-process settings in individual components. For
details on updating design points, see Updating Design Points in Remote Solve Manager (p. 352).
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• Number of Processes: Specifies the number of processes to use for the solution if parallel exe-
cution mode is selected. The default is 2. Must be set to a number greater than or equal to 2.

4. To save the project, from the menu bar, select File → Save.

If you choose not to save the project and any cells are configured to use RSM or run in the back-
ground, you must change the solution process settings of those cells to run in the foreground
before you can update.

5. To start the solution, select the appropriate option from the application, or right-click the Solution
cell and select Update from the context menu.

The Solution cell enters the Pending state (p. 449).

Submitting Workbench Project Updates to Remote Solve Manager

You can submit a project to Remote Solve Manager (RSM) for remote update of the project. Depending
on how RSM is configured, the update can be submitted to an HPC cluster or Cloud portal for execution
(see Working with Ansys Remote Solve Manager (p. 319)).

Note:

If you are sending solve jobs to a remote cluster, the license preferences set for your local
machine (the RSM client) may not be the same as the license preferences set for the remote
cluster. In this case, the cluster license preferences are used for all jobs.

To submit a project update to RSM:

1. To open the project properties, from the menu bar select View → Properties or right-click the
white space of the Project Schematic and select Properties.

2. Under Solution Process, set the Update Option property to Submit to Remote Solve Manager.
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3. Additional properties are displayed. Use these properties to specify your remote submission settings.

• RSM Queue: Select the queue to be used for the remote solution. Any queues currently defined
for RSM appear in the drop-down list. If you have added a queue and it does not appear in the
list, click Refresh Queues.

Every RSM queue is associated with a particular configuration that is defined in RSM. In the RSM
configuration, the RSM queue is mapped to a specific HPC queue that has been defined on the
cluster/portal side.

• Job Name: Displays the name reported in the RSM job log. The default name for a Workbench
job is Workbench, or whatever is set for the Default Job Name in your Workbench options.
The default name for a Mechanical job submitted from the Mechanical application is Mechan-
ical. The job name provides a traceable piece of data that administrators can use to track job
submissions to a cluster (for billing purposes, for example).

To override the default job name, double-click the Job Name Value cell and type the required
name.

Job name overrides must adhere to the following conventions:

– Can only use alphanumeric characters and ~ # % ^ , & * ' ( ) - _ + = / < >

– Cannot exceed 15 characters

– The first character must be one of the alphanumeric characters (a-z, A-Z, 0-9)

• Pre-RSM Foreground Update:

– To update your geometry locally before submitting project updates to RSM, select Geometry.

Select this option if the execution node does not have a license to perform geometry updates.

– To submit project updates to RSM without first updating the geometry locally, .select None.

• Component Execution Mode: Specifies the serial or parallel solver execution mode. The parallel
option is available only if the selected solver supports parallel execution mode. This option may
not be available with all systems.

When performing a design point update in RSM with component update in the foreground, the
Parameter Set properties override the parallel-process settings in individual components. For
details on updating design points, see Updating Design Points in Remote Solve Manager (p. 352).

• Remote Job Status Check Interval in Seconds

Sets the number of seconds between each query to Remote Solve Manager for the Mechanical
solution update job status. The default is 20. This setting only takes effect when the Mechanical
solution is submitted to RSM.
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The Project Update properties specified here are shared with the Parameter Set as Design Point
Update Process properties. Changes to the values of these properties here are reflected in the Para-
meter Set properties, and vice versa.

Note:

In most cases, the Update Project button or menu item updates all systems and cells in a
project. When a project update is submitted to RSM as described, however, only those systems
above the Parameter Set bar are sent to RSM for remote update. If needed, DesignXplorer
systems can be further updated once the remote project update is completed.

Submitting System Coupling Jobs to Remote Solve Manager

Tip:

For remote execution of a co-simulation created in Workbench, the recommended workflow
is to export the coupling setup from Workbench and then run the co-simulation in System
Coupling's GUI or CLI, using System Coupling's parallel processing capabilities to submit jobs
for remote execution.

A System Coupling co-simulation may be sent to Remote Solve Manager (RSM) for remote execution
either as a full project update or a design point update.

Note:

• Solution cell updates via RSM are not supported for System Coupling; for a System
Coupling system's Solution cell, Run in Foreground is the only option available for the
Solution Process | Update Option property. As such:

– If you attempt to solve the coupled analysis by updating System Coupling's Solution
cell, then the update will not be sent to RSM, regardless of the Update Option
setting for the project or the  Parameter Set.

– Because coupling participant solutions are tied to the update of System Coupling's
Solution cell, participant setups should be consistent with System Coupling's setup.
Ensure that all participant Solution cells are also set to solve in the foreground.

• When submitting a job on a machine that uses Microsoft HPC Pack 2019, you may receive
an error message indicating that the coupling process failed to start. To address this issue,
submit the job on another resource, either by using an earlier version of HPC Pack or by
submitting the job on a Linux system.

For more information on working with RSM, see:

Submitting a Coupled Analysis Project Update to RSM

Submitting a Coupled Analysis Design Point Update to RSM

Distribution of Computing Resources Across System Coupling Participants

Restricting Solve Processes for System Coupling Updates
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Monitoring System Coupling Solution Information

Restarting an Interrupted Remote Update

Submitting a Coupled Analysis Project Update to RSM

To send a coupled analysis project update to RSM, perform the following steps:

1. Set the project's Solution Process and Project Update properties as described in Submitting
Workbench Project Updates to Remote Solve Manager (p. 325).

2. Click the Update Project button in the Workbench toolbar.

All the systems on the Project Schematic, including the System Coupling system, are updated
through RSM.

Submitting a Coupled Analysis Design Point Update to RSM

To send a coupled analysis design point update to RSM, perform the following steps:

1. On the Project Schematic, right-click the Parameter Set bar and select Properties.

Corresponding settings are shown below in the Properties pane.

2. Use the steps outlined in Updating Design Points in Remote Solve Manager (p. 352) to set the
following properties:

a. Solution Process

b. Design Point Update Process

Note:

Because design point updates are performed only on output parameters, a
System Coupling system that does not affect outputs may not be updated
during a design point update. However, when updating retained design
points (including Current), you can ensure that all project systems are up-
dated. To do so, set the Retained Design Point property to Update full
project, then right-click the Current design point and select Update selected
design points.

3. Save the project.

If you are working in an archived project, save the project to a permanent location.

4. Update the design point(s), using any of the methods documented in Updating Design
Points (p. 306) (that is, updating the Current design point, selected design points, or all design
points).
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The project is archived and submitted to a cluster using RSM. The remote data is retrieved periodically
as the design point updates complete. Should a design point update fail, an error is reported to the
Messages pane.

Distribution of Computing Resources Across System Coupling Participants

In a project with System Coupling, the individual components (such as Fluent, Mechanical, or CFX)
share resources. By default, when design points from a project containing a System Coupling system
are submitted to RSM, available computing resources are distributed equally across all coupling par-
ticipants according to the number of compute nodes available and the number of processes requested.
Component-level parallel settings (such as the Execution Mode and Number of Processes properties)
are disregarded during the design point update.

Example 1: Six Processes

If a coupled simulation requests six processes to be executed on a cluster that has six nodes with
one processor per node, then participant solvers will start six processes, with one on each compute
node. The participant solvers alternate their processing, so that only one participant is actively using
computing resources at a time.

Solver Processes for Participant
2

Solver Processes for Participant
1

Node

111

112

113

114

115

116

Example 2: Ten Processes

If a coupled simulation requests 10 processes to be executed on a cluster that has 4 nodes with 8
processors per node, then each participant solver will start 10 processes.

Solver Processes for Participant
2

Solver Processes for Participant
1

Node

881

222

003

004

Restricting Solve Processes for System Coupling Updates

When submitting an update for parallel processing, you can limit the number of solve processes that
a coupling participant can use when updates are submitted to Remote Solve Manager (RSM). To do
so, set the Restriction for Project / Remote Design Point Update properties for the participant's
Solution cell, as described in Updating Design Points in Remote Solve Manager (p. 352).
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The solve process limitations are applied only to that component, and resources are otherwise allocated
equally across participants. Resource allocation for the restricted participant is as follows:

• If the component's Specify Number of Processes Restriction is enabled and the Number of
Processes Used Not to Exceed (or Max Number of Utilized Cores) value is less than or equal to
the number of processes requested by the project, then the component is limited to the component-
specified number of processes.

• If the component's Specify Number of Processes Restriction is enabled and the Number of
Processes Used Not to Exceed (or Max Number of Utilized Cores) value is set to a value greater
than the number of processes requested by the project, then the component is limited to the
project-specified number of processes.

• If the component's Serial Execution Only is enabled, then the component is limited to a single
process.

Monitoring System Coupling Solution Information

As the remote design point update progresses, a single System Coupling Transcript/Log file
(scLog.scl) is generated for the coupling project and displayed in the Solution Information pane
of the System Coupling workspace. It is updated intermittently so you can use it to monitor the design
point update.

Note:

When multiple design points are being updated simultaneously, you cannot switch between
the log files for the different design points. During and after completion of the updates,
System Coupling displays the log file for the design point with the highest ID. To display
the log file for the Current design point, you must save and reopen the project.

For more information, see the following sections in the System Coupling User's Guide:

• Monitoring Solution Progress

• Transcript and Log File

Restarting an Interrupted Remote Update

When a remote System Coupling update has been interrupted:

• For a project update, the Solution cells in your project are given a state of Interrupted, Up to

Date ( ):

• For a design point update, the output parameters for the interrupted component are given a

state of Partially Updated ( ).

To restart the update:

1. In the Workbench toolbar, click the Update Project or Update All Design Points button.

2. In the dialog box that opens, click one of the following buttons:
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Use Partially Updated: Accepts the partially updated solution as Up-to-Date ( ) and
uses it to restart the update.

•

• Update All: Restarts the interrupted run, updating all solutions to completion before re-
starting the update.

Submitting Mechanical Application Jobs to Remote Solve Manager

Use the following steps to submit Mechanical jobs to a cluster or Cloud portal using Remote Solve
Manager (RSM).

1. Configure your remote solution settings in Remote Solve Manager.

See RSM Configuration in the Remote Solve Manager User's Guide.

2. To launch the Mechanical application, on the Project Schematic, double-click the Solution cell in
your Mechanical system.

3. In the Mechanical application, on the Home tab, select Solve Process Settings.

Alternatively, switch to the File tab and select Solve Process Settings.

4. Follow the instructions in Using Solve Process Settings to configure your solution settings.

The settings established here are visible in the Solution Process properties in Workbench.
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5. In Workbench, select the Solution Process settings that you want to use for this solution and update
the Solution cell (p. 244).

Alternatively, in the Mechanical application, on the Home tab select Solve then select a configur-
ation from the drop-down list.

Note:

• You can interrupt or abort an update by right-clicking the Solution cell. These options
are available during foreground, background, Portal and RSM updates.

• The Workbench Options allow you to control the Mechanical application's license
handling. As described in Mechanical (p. 430), you can configure the license to always
be released during batch run or to be released when you perform an Update All
Design Points run. A third option is On Demand, which makes a Release License
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option available on the Solution cell's context menu when the cell is in the pending
state during a batch run.

Workbench/RSM Integration with the Mechanical Application

The properties associated with a Mechanical system's Solution cell include a Solution Process section.
This section allows you to specify the Solve Process Setting for the Mechanical application to use
when an update operation is initiated from Workbench. You can select only an existing solve process
setting, but new solve process settings can be added (and existing solve process settings can be
modified) by selecting Tools → Solve Process Settings in the Mechanical application.

Note:

Any solve initiated in the Mechanical application ignores the solution component properties
selected in Workbench and continues to work as it has in previous versions.

Example 3: Default Update with My Computer Set as the Default Solve Process Setting

In this case, the default Solve Process Setting in the Mechanical application is My Computer.

In Workbench, the Solution Process property Update Option is set to Use application default,
which causes Mechanical to use its default solve process setting.
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Results:

Solve Process Setting UsedSolve Initiated From

My ComputerWorkbench

My ComputerMechanical

Example 4: Default Update with My Computer, Background Set as the Default Solve Process
Setting

In this case, the default solve process setting in the Mechanical application is My Computer, Background.

In Workbench, the Solution Process property Update Option is set to Use application default,
which causes Mechanical to use its default solve process setting.

Results:

Solve Process Setting UsedSolve Initiated From

My Computer, BackgroundWorkbench

My Computer, BackgroundMechanical

Example 5: RSM Update Using My Computer, Background, with My Computer Set as the Default
Solve Process Setting

In this case, the default solve process setting in the Mechanical application is My Computer.
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In Workbench, the Solution Process property Update Option is set to Submit to Remote Solve
Manager. The solve process setting selected in Workbench is My Computer, Background.

Results:

Solve Process Setting UsedSolve Initiated From

My Computer, BackgroundWorkbench

My ComputerMechanical

Submitting Mechanical APDL Jobs to Remote Solve Manager

You can use Remote Solve Manager (RSM) as a serial or parallel solution for Mechanical APDL jobs. If
your RSM configuration directory contains configurations for a cluster or a Cloud portal, you can access
cluster/portal queues that act as a parallel solution option.

Note:

Mechanical APDL has the following limitations when used with Remote Solve Manager:

• Reconnect does not work after moving a project to another machine.

• Only one copy of a saved project that is in the pending state can reconnect successfully.

• You must manually save a project after a reconnect.

• Reference files must be in the same directory as the Ansys input file.

• Restarts of solves to a cluster are not supported from Workbench.
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In the Solution Process pane:

1. Configure your remote solution settings in Remote Solve Manager. For more information see RSM
Configuration in the Remote Solve Manager User's Guide.

2. In Workbench, right-click the Solution cell and select Properties.

3. In the Solution Process settings, set the Update Option to Submit to Remote Solve Manager.

4. Select a RSM Queue.

5. Set the Execution Mode to either Serial or Parallel.

6. Set the number of Utilized cores. For a serial solution, select 1; for a parallel solution, specify the
number of partitions.

You should have at least 100,000 elements or nodes per partition to compensate for the overhead
associated with the partition. The cluster job scheduler automatically controls where the partitions
are solved.

7. Update the project (p. 243).

When the Mechanical APDL job is submitted to RSM, some options in the Properties pane (Pro-
cessors, Distributed, MPI Type, Machine List, and Custom Executable Path) become read-only
and their values are ignored.

Note:

If Download Distributed Files is checked, all files involved in a distributed solve are
downloaded.

Submitting Fluids Jobs to Remote Solve Manager

Use the following instructions to submit various fluid jobs to Remote Solve Manager (RSM).

Submitting CFX Jobs to Remote Solve Manager

Submitting Polyflow Jobs to Remote Solve Manager

Submitting Fluent Jobs to Remote Solve Manager

Submitting Icepak Jobs to Remote Solve Manager

Submitting Forte Jobs to Remote Solve Manager

Exiting a Project During a Remote Solve Manager Solution Cell Update
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Submitting CFX Jobs to Remote Solve Manager

You can use Remote Solve Manager (RSM) as a serial or parallel solution for CFX jobs. If your RSM
configuration directory contains configurations for a cluster or a Cloud portal, you can access
cluster/portal queues that act as a parallel solution option.

Note:

CFX has the following limitations when used with Remote Solve Manager:

• RIF (Flamelet) cases are not supported.

• Reconnect does not work after moving a project to another machine.

• Only one copy of a saved project that is in the pending state can reconnect successfully.

• You must manually save a project after a reconnect.

• You cannot edit a run that is in progress.

• You cannot perform a remote backup.

• For runs that are submitted to a remote machine:

– Serial and local parallel runs are always supported.

– Other local parallel modes must be supported on the job host.

– Distributed parallel is supported only for multi-node clusters.

• The default update interval for display monitors is 120 seconds. Use the Download
Progress Information and Progress Download Interval options under Tools → Options
→ Solution Process to enable/disable polling or to change the polling interval. The
settings established here are also visible in the Solution Process properties pane in
Workbench.

In the Solution Process pane:

1. Configure your remote solution settings in Remote Solve Manager. For more information see
RSM Configuration in the Remote Solve Manager User's Guide.

2. In Workbench, right-click the Solution cell and select Properties.

3. In the Solution Process settings, set the Update Option to Submit to Remote Solve Manager.

4. Select a RSM Queue.

5. Set the Execution Mode to either Serial or Parallel.

For a parallel solution:
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• You can specify the Number of Processes that you want to use to create the results file. You
should specify a number that is less than or equal to the number of cores available in the
cluster, and you should ensure that each process contains at least 100,000 nodes or elements.

• UGE and PBS clusters must be configured to use the SSH communication protocol; RSH is not
supported. If you are using the Submit to Remote Solve Manager option, see Configuring
RSM to Use SSH for Job Submission and/or File Transfers to a Remote Linux Cluster in the Re-
mote Solve Manager User's Guide.

6. Update the project (p. 243).

You can interrupt or abort an update by right-clicking the Solution cell. These options are
available during foreground, background and RSM updates.

Note:

The monitoring of solution updates submitted to RSM has the following limitations:

• When you use the Solution cell's properties field to set the frequency at which you poll
the data, this represents a maximum frequency. In cases of network congestion or where
large files are involved, the observed monitor update frequency is less.

• Solution monitor data is transferred using the CFX Solver-Manager, which has a limited
capacity to handle monitor data transfer requests. In situations where multiple users are
using the same CFX Solver-Manager to monitor runs, or where multiple runs are being
monitored by a single user, the update frequency of monitor data may decrease or be-
come sporadic.

• When monitoring RSM updates, CFX Solver-Manager does not report run completion.
The Out File window displays the completed run information; however, CFX Solver-
Manager's workspace still displays Running. Note that in these cases, Workbench accur-
ately reports update completion.

Submitting CFX Jobs with Design Points to Remote Solve Manager

When performing a Design Point update with a CFX system using Remote Solve Manager (RSM),
the Component Execution Mode and Max. Number of Processes Per Job settings on the Para-
meter Set Properties pane control the parallel-processing settings that the CFX Solver uses. For
details, see Updating Design Points in Remote Solve Manager (p. 352).

Submitting Polyflow Jobs to Remote Solve Manager

Use the following steps to submit Polyflow jobs to Remote Solve Manager (RSM).

Note:

Polyflow has the following limitations when used with Remote Solve Manager:

• Reconnect does not work after moving a project to another machine.
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• Only one copy of a saved project that is in the pending state can reconnect successfully.

• You must manually save a project after a reconnect.

• The RSM interrupt option performs an abort operation, not an interrupt.

• Parallel design point submissions to batch queue clusters only run on the head node
and with the number of cores allocated by the batch queue scheduler.

In the Solution Process pane:

1. Configure your remote solution settings in Remote Solve Manager. For more information see
RSM Configuration in the Remote Solve Manager User's Guide.

2. In Workbench, right-click the Solution cell and select Properties.

3. In the Solution Process settings, set the Update Option to Submit to Remote Solve Manager.

4. Select a RSM Queue.

5. Update the project (p. 243).

You can interrupt or abort an update by right-clicking the Solution cell. These options are
available during foreground, background and RSM updates.

Submitting Fluent Jobs to Remote Solve Manager

You can use this feature to queue multiple jobs to run on the local machine (overnight, for example,
or during other low-usage times), or to submit a job to a remote cluster or Cloud portal.

Note:

Fluent has the following limitations when used with Remote Solve Manager:

• Only one copy of a saved project that is in the pending state can reconnect successfully.

• System Coupling is not supported.

• UDFs are supported but you must have a supported compiler on Windows 64-bit ma-
chines. Supported compilers for Windows are Microsoft Visual Studio 2008 Standard and
Microsoft Visual Studio 2010 Professional.

• On Linux, UDFs are supported. You can always send UDFs between Linux machines and
make use of the auto-compile feature; if the machines have compatible compilers, you
can send precompiled UDFs.

For additional information about compiling Fluent UDFs, see Compiling UDFs in the Fluent
Customization Manual.

In the Solution Process pane:
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1. Configure your remote solution settings in Remote Solve Manager. For more information see
RSM Configuration in the Remote Solve Manager User's Guide.

2. In Workbench, right-click the Solution cell and select Properties.

3. In the Solution Process settings, set the Update Option to Submit to Remote Solve Manager.

4. Select a RSM Queue.

5. Set the Execution Mode to either Serial or Parallel.

For a parallel solution, specify the Number of Processes that you want to use to create the
results file. You should specify a number that is less than or equal to the number of cores available
in the cluster, and you should ensure that each process contains at least 100,000 nodes or ele-
ments.

6. Update the project (p. 243).

An update of the Solution cell submits the job to RSM, moves into Pending mode for the duration
of the solution, and then automatically reconnects at the end of the run.

You can interrupt or abort an update by right-clicking the Solution cell. These options are
available during foreground, background and RSM updates.

Solution Properties: Use Setup Launcher Settings

The Properties pane of the Fluent Solution cell has a toggle that controls whether the solution
uses settings from the setup launcher. When Use Setup Launcher Settings is checked, the
launcher settings are copied from Setup component to Solution component. This copying also
happens any time you change the launcher settings in setup. When Use Setup Launcher Settings
is cleared, the Solution cell's launcher settings are available:

Applicable to Remote Solve
Manager (RSM)

DefaultSetting Name

General

YesSingle PrecisionPrecision

NoEnabledShow Launcher at
Startup

YesEnabledDisplay Mesh After
Reading

YesEnabledEmbed Graphics
Window

YesEnabledUse Workbench Color
Scheme

NoEnabledSet up Compilation
Environment for UDF

NoDisabledUse Job Scheduler

YesThe initial default execution mode
(Serial / Parallel) is based on the

Run Parallel Version
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Applicable to Remote Solve
Manager (RSM)

DefaultSetting Name

run settings. The initial number of
processes in RSM is based on the
Number of Processors option in
the run settings: if it is > 1, that
value is used, otherwise 2 is used.
If Run Parallel Version is not
enabled, then serial mode is
forced.

No$(FLUENT_ROOT)\$(ARCH)\udf.batUDF Compilation Script
Path

NoEnabledUse Remote Linux Nodes

Remote

NoNoneRemote Polyflow Root
Path

NoEnabledUse Specified Remote
Working Directory

NoNoneRemote Working
Directory

NoRSHRemote Spawn
Command

NoEnabledUse Remote Cluster
Head Node

NoNoneRemote Host Name

Parallel Run Settings

No1Number of Processors

No

Note:

You can enable Inter-
connect to be

NoneInterconnect

available for
Polyflow RSM runs
by enabling Tools →
Options → Solution
Process → Show
Advanced Solver
Options. This setting
requires you to
ensure that the
remote Compute
servers can accept
the interconnect
that you
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Applicable to Remote Solve
Manager (RSM)

DefaultSetting Name

specify—there is no
automatic checking
for such
compatibility.

To learn what values
are available, see
Starting Parallel
Ansys Fluent on a
Windows System
Using Command
Line Options in the
Fluent User's Guide.

No

Note:

You can enable MPI
Type to be available

NoneMPI Type

for Polyflow RSM
runs by enabling
Tools → Options →
Solution Process →
Show Advanced
Solver Options. This
setting requires you
to ensure that the
remote Compute
servers can accept
the MPI Type that
you specify—there
is no automatic
checking for such
compatibility.

To learn what values
are available, see
Starting Parallel
Ansys Fluent on a
Windows System
Using Command
Line Options in the
Fluent User's Guide.

NoDisabledUse Shared Memory

NoFile containing the machine listMachine Specification
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Applicable to Remote Solve
Manager (RSM)

DefaultSetting Name

NoNoneMachine Filename

Solution Process

The Solution cell's Solution Process setting is always displayed; when Use Setup Launcher Settings
is checked, the option is read-only:

You can choose to Run in Foreground, Run in Background, or Submit
to Remote Solve Manager. When Submit to Remote Solve Manager is

Update Option

chosen, options that are not applicable to RSM are hidden. Also, fluent-
launcher.txt does not contain options that conflict with RSM.

Submitting Icepak Jobs to Remote Solve Manager

You can use this feature to queue multiple jobs to run on the local machine (overnight, for example,
or during other low-usage times), or to submit a job to a remote cluster or Cloud portal.

Note:

Icepak has the following limitations when used with Remote Solve Manager:

• You cannot submit jobs containing parametric trials to RSM.

• Convergence data is not plotted in Icepak on the local computer. The .res and
.uns_out files are written at the frequency specified in RSM settings. You must open
them in Icepak to view them.

In the Solution Process pane:

1. Configure your remote solution settings in Remote Solve Manager. For more information see
RSM Configuration in the Remote Solve Manager User's Guide.

2. In Workbench, right-click the Solution cell and select Properties.
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An update of the Solution cell submits the job to RSM, moves into Pending mode for the duration
of the solution, and then automatically reconnects at the end of the run.

3. In the Solution Process settings, set the Update Option to Submit to Remote Solve Manager.

4. Select a RSM Queue.

5. Set the Execution Mode to either Serial or Parallel.

For a parallel solution, specify the Number of Processes that you want to use to create the
results file. You should specify a number that is less than or equal to the number of cores available
in the cluster, and you should ensure that each process contains at least 100,000 nodes or ele-
ments.
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Note:

RSM updates Icepak with convergence plot data at the Progress Download Interval
specified in Workbench. Set the Progress Download Interval as needed prior to
starting the solution.

6. Update the project (p. 243).

An update of the Solution cell submits the job to RSM, moves into Pending mode for the duration
of the solution, and then automatically reconnects at the end of the run. To re-run a solution
with the same model, run another solution in the same project, or run a restart solution, right-
click the Setup cell in Workbench and select Enable Update.
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You can interrupt or abort an update by right-clicking the solution in the Workbench Job Monitor.
These options are available during background and RSM updates. To display the Job Monitor,
select Jobs → Open Job Monitor.

Submitting Forte Jobs to Remote Solve Manager

Use the following steps to submit Forte jobs to Remote Solve Manager (RSM).

Note:

Forte has the following limitations when used with Remote Solve Manager:

• If solving on a Linux RSM queue, upstream geometry changes must be configured to
occur before the RSM job. Select Pre-RSM Foreground Update to Geometry in the Project
Update settings of the Project Schematic.

• Forte's Monitor component does not provide live updates.

• You must specify at least two parallel processes.

1. Configure your remote solution settings in Remote Solve Manager. For more information see
RSM Configuration in the Remote Solve Manager User's Guide.

2. In Workbench, right-click the white space of the Project Schematic and select Properties.

3. In the Solution Process settings, set the Update Option to Submit to Remote Solve Manager.

4. Select a RSM Queue.

5. Set the Execution Mode to Parallel.
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6. Specify the Number of Processes that you want to use to create the results file.

The number of process must be equal to or greater than two.

7. Update the project (p. 243).

Exiting a Project During a Remote Solve Manager Solution Cell Update

You can exit a project while a Solution cell update using Remote Solve Manager (RSM) is in progress
(one or more RSM jobs are running in the background and the Progress pane displays a project
status of Waiting for background task).

Note:

You cannot exit Workbench while job files are being uploaded. You can abort the job
during the upload by using the Stop button in the Progress bar.

The project must be saved at least once after the Solution cell update job was initiated for RSM jobs
to continue to run after you exit the project.

If you attempt to exit a project while a Solution cell update job is still running, the following scenarios
cause a dialog box to open, allowing you to specify whether you want to save the project before
exiting:

• You have never saved the project at any time after the same Solution cell update job was initiated.

• You have saved the project at least once after the same Solution cell update was initiated, but
results have been retrieved since your last save.

In either of these cases, if you do not save the project before exiting:

• All results retrieved since the last save operation are lost. You must save the project before
exiting if you want to keep any of results retrieved since the last save of the background
Solution cell update.

• If the project has never been saved after the Solution cell update job was initiated, all RSM

jobs are aborted and display a status of Cancelled and the cancelled icon ( ) in the RSM List
pane; the asterisk on the icon indicates that the job has also been released. When you reopen
the project, it is in the state of your last manual save.

• If the project has been saved at least once after the Solution cell update job was initiated,
RSM jobs that are queued and running continue to run after you exit. When you reopen the
project, you can resume the update of the pending jobs to reconnect and download the results.

If you do save the project before exiting:

• Retrieved results are saved to the project.

• RSM jobs that are queued and running will continue to run after you exit.

• Jobs where the results have been saved display a Status of Finished and the finished icon ( ) in
the RSM List pane; the asterisk on the icon indicates that the job has also been released.
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• Jobs where results have not yet been saved are not released upon exit. When you reopen the
project, you can resume update of the pending jobs to reconnect and download the results.

Monitoring and Controlling Remote Solve Manager Jobs in Workbench

If you have chosen to submit project updates, design point updates, or component updates using the
Submit to Remote Solve Manager option, you can monitor their progress by displaying the Job
Monitor in Workbench.

To display the Job Monitor, select Jobs → Open Job Monitor, or click  on the status
bar.

The Job Monitor provides a live view of what is happening in Remote Solve Manager (RSM) with the
current Workbench project.
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The following information for each job is displayed:

• Job name

• Status (Running, Finished, Failed, and so on)

• Submission date/time

• Owner

• RSM queue

• HPC configuration

• HPC queue

Clicking on a job displays a detailed job log in the lower pane.

You can perform the following actions:

• To hide design point updates in the job list, disable the Include Design Point Jobs check box.

• To view a job report for a specific job, select the job in the Jobs pane. The report is displayed in the
Details pane.

• To save a job report to a file, click  in the Details pane, then accept or specify the save location,
filename, and content to include:

You can use the context-sensitive menus in the Jobs pane and Details pane to perform a variety of
actions. For example, you can customize the job list display, and perform actions on a job such as Abort
or Interrupt.

Related topics:

Using the Taskbar Icon

Viewing the Status of Jobs

Controlling the Display of the Job List

Performing Job Actions

Controlling the Display of Job Details
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Using the Taskbar Icon

When you launch the Job Monitor, a job monitor icon is also displayed on your Windows taskbar. If
you subsequently minimize the Job Monitor window, you can quickly restore it by clicking the taskbar
icon.

Viewing the Status of Jobs

The status of each job is indicated in the Status column in the Jobs pane, and by a unique icon at
the beginning of the job entry. For jobs that have completed, the Status column and icon indicate
the final status of the job. The addition of an arrow symbol to the final status icon indicates that the
job has been released.

Released IconIconDescriptionStatus

Job is being uploaded to the cluster.Input
Pending

The job has been placed in the cluster queue and is
waiting to run.

Queued

Job is running.Running

Job has been terminated using the Abort option.

Also applies to jobs that have been aborted
because you exited a project without first
performing one of the following actions:

Cancelled

• Saving the project since the update was
initiated

• Saving results retrieved since your last save

Job has completed successfully.

Also applies to jobs that have been terminated
using the Interrupt option or for which you have
saved results prior to exiting the project.

Finished

Job has failed.

May be applied to jobs that cannot be cancelled
due to fatal errors.

Failed

Controlling the Display of the Job List

You can sort the job list by job name, status, owner, and so on by clicking on the appropriate column
header in the Jobs pane. Clicking on the same column header again reverses the sort order.

If you right-click any column header, a context menu is displayed which contains the following options:
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Selects all jobs in the list.Select All
(Ctrl+A)

Returns you to the beginning of the job list.Scroll to
Top

Takes you to the end of the job list.Scroll to
Bottom

Toggles the display of numbers at the beginning of
each entry in the job list.

View Line
Numbers

Performing Job Actions

If you right-click a job in the Jobs pane, a context-sensitive menu is displayed that contains the fol-
lowing options:

Immediately terminates a running job. Enabled only if a running job is
selected.

Jobs terminated via this option will have a Status of Canceled in the
Jobs pane.

Abort

Terminates a running job. Enabled only if a running job is selected.

Jobs terminated via this option will have a Status of Finished in the
Jobs pane.

Interrupt

Deletes the selected job or jobs from the Jobs pane. Enabled only if a
completed job is selected.

Cannot be used on a running job.

Remove

Controlling the Display of Job Details

When you select a job in the Jobs pane, a corresponding job log is displayed in the Details pane.
The log automatically scrolls to the bottom to keep the most recent messages in view.

If you right-click the job log, a context-sensitive menu is displayed which contains the following options:

Copy selected text in the Details pane.

Alternatively, you can use the Ctrl+C key combination.

Copy

Select all of the text in the Details pane.

Alternatively, you can use the Ctrl+A key combination.

Select All

Save the job log to a file.

The job report includes job details and the contents of the job log shown
in the Details pane.

Save Job Report...

To save the job report:

1. Specify the following report preferences:
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• Include Debug Messages: adds debugging messages to the report

• Include Log Time Stamp: adds a log time stamp to the report

• Include Line Numbering: displays line numbering in the report

2. Click Browse

3. In the File name field, type in the name of the report (RSMJob.html
by default).

4. Select the report format (HTML or text)

5. Click Save.

Toggle the display of line numbers at the beginning of each line in the job log.View Line Numbers

Toggle the display of time stamps at the beginning of each line in the job log.View Time Stamps

Only display file-related messages in the job log, such as those relating to file
transfers.

View Exclusively
File Messages

Toggle the display of debugging information in the job log.View Debug
Messages

Filters the content of the job log by design point sub-task. This option is only
displayed when the job contains design points.

SubTask Filters

Go to the top of the job log.Scroll to Top

Go to the bottom of the job log.Scroll to Bottom

Updating Design Points in Remote Solve Manager

Remote Solve Manager (RSM) can integrate with established compute clusters or a third-party Cloud
using configurations defined in RSM. When these configurations are made available to the RSM client
(your local computer), the RSM queues defined in those configurations are available in Workbench Each
RSM queue is associated with a specific HPC queue defined on the cluster/portal side, making it possible
for the update to be submitted to remote HPC resources. For more information see Working with Ansys
Remote Solve Manager (p. 319).

Important:

• If you are sending design point update jobs to a remote compute cluster, the license
preferences set for your local machine (the RSM client) may not be the same as the license
preferences set for the remote cluster. In this case, the cluster license preferences are used
for all jobs. For more information, see Setting HPC User Preferences.

• When design points are configured to be updated using RSM, the Solution cell cannot
also be updated using RSM. To update design points in RSM, change the Solution cell
update settings by setting the Update Option property to Run in Foreground.

Related topics:
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Submitting Design Points to Remote Solve Manager

Updating Geometry Locally Before Submitting to Remote Solve Manager

Design Point License Sharing

Tracking Licenses

Using Upfront License Checkouts for Design Point Updates

Aborting or Interrupting an RSM Design Point Update

Exiting a Project during an RSM Design Point Update

Suspending and Resuming Collection of RSM Design Point Results

Product-Specific Limitations

Submitting Design Points to Remote Solve Manager

To submit design points to Remote Solve Manager (RSM):

1. To view the Design Point Update Process settings, right-click the Parameter Set bar and select
Properties.

If the Properties pane is already visible, click the Parameter Set bar to refresh the Properties
pane with the design point settings.

2. In the Properties pane, from the Update Option drop-down list, select Remote Solve Manager.

3. Specify an available RSM Queue.

4. From the Design Point Initialization drop-down list, select one of the following options:

• Update From Current: Causes each design point to be initialized from the Current design
point.

• Update Design Points in Order: Causes each design point to be initialized from the previous
design point.

5. To update your geometry locally before submitting the design points to RSM, from the Pre-RSM
Foreground Update drop-down list, select Geometry.

Otherwise, leave the option as None.

6. If you selected Geometry in the previous step, to retain the results from the geometry update,
from the Retain Partial Update drop-down list select Geometry.

7. For the Component Execution Mode property, select one of the following options:

• Serial: All components participating in the update are run in serial mode.

• Parallel: All components participating in the update that support this setting are run in parallel
mode.

Submitting a design point update to RSM is supported by the Solution (or Analysis) component
update for the Mechanical APDL, Mechanical, Fluent, CFX and Polyflow solvers. These settings
override any parallel or serial settings defined at the component level. When updating a compon-
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ent, system, or project, the Parameter Set properties for a design point update are ignored. The
following product specific settings are overridden for a design point update in RSM:

Ignored PropertiesProduct

CFX-Solver Manager or CFX-Pre Solu-
tion cell

• All settings under the Parallel Environment tab.

• Run mode

• All host information and partition weighting

Fluent Solution cell • Use Job Scheduler

• Run Parallel Version

• Number of Processes

• Use Shared Memory

• Machine Specification

• Machine List

Note:

The following properties remain enabled
in all situations, if set:

• Interconnect

• MPI Type

Advanced section of a Mechanical
Solve Process Setting

• Distributed Solution (if possible)

• Max number of utilized cores

Mechanical APDL Analysis cell • Processors

• Distributed

• MPI Type

• Machine list

Number of ProcessesPolyflow Options accessed by Solu-
tion cell preferences
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8. In the Number of Jobs to be Created field, type the number of RSM jobs to create. The default
is 1.

Note:

License sharing only works within a job. If you create multiple jobs, you cannot share
licenses across them, so we recommend creating multiple tasks within one job to take
advantage of license sharing.

9. In the Number of Tasks Per Job field, type the number of design point update tasks to run per
RSM job. The default is 1.

The numbers you enter in steps 8 and 9 divide the total number of design points you are updating
into individual tasks, with each task running a separate Workbench session. Then the tasks are
divided up into one or more RSM jobs.

For example, you are updating 20 design points and request two RSM jobs and five tasks per
job. Each job will contain five tasks, and each task will update two design points. A total of 10
Workbench sessions will be created.

10. If you selected Parallel in step 6, in the Number of Cores Required Per Task field, type the
number of cores to use on the cluster machine for each task. The default is 2.

The total number of cores requested to run the entire update is calculated using the formula
(Number of tasks * Number of Cores)+1. The additional core is for the head task, which is used
to create all of the sub-tasks.

11. For the Retained Design Point property, select one of the following options:

• Update parameters (default): Only parameters are updated for retained design points. If a
component is not needed to get the value of an output parameter, it is not updated.

• Update full project: Full project is updated for retained design points. Use this setting if you
want to generate reports, or other content, from components that do not produce output
parameters.

12. The Remote Job Status Check Interval in Seconds field sets the number of seconds between
each query to RSM for the design point update job status. To increase or decrease this interval,
enter the number of seconds into the field. The default is 20.

13. To set upfront license checkouts, click Select Licenses. For more details, see Using Upfront License
Checkouts for Design Point Updates (p. 358).

14. Save the project.

If you are working in an archived project, you must save the project to a permanent location.

15. Update the design points.
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The project is archived and submitted to a cluster using RSM. The remote data is retrieved peri-
odically as the design point updates complete. Should a design point update fail, an error is re-
ported to the Messages pane.

Updating Geometry Locally Before Submitting to Remote Solve Manager

You can update your geometry locally before submitting design point updates to Remote Solve
Manager (RSM). Do this when:

• Design points are being updated simultaneously in RSM. The geometry update infrastructure does
not support simultaneous design point updates in the same source geometry.

• The compute cluster cannot access the required CAD licenses.

• The compute cluster does not have a CAD program installed

Performing a Pre-RSM Geometry Update

This is the most common workflow used to update geometry locally.

To perform a pre-RSM geometry update:

1. On the Project Schematic, right-click the Parameter Set bar and select Properties from the
context menu.

If the Properties pane is already visible, click the Parameter Set bar to refresh the Properties
pane with the design point settings.

2. Set the Update Option to Remote Solve Manager and then specify an available RSM Queue.

3. In the Design Point Update Process settings, set Pre-RSM Foreground Update to Geometry.

Note:

If the project includes a Geometry component and you have set Remote Solve Manager
(Legacy) Job Submission to either One Job for Each Design Point or Specify Number
of Jobs (with the value set to greater than 1), the setting does not apply to the geo-
metry update. The geometry is updated locally in the foreground before your design
points jobs are sent to RSM.

4. Update the remaining Design Point Update Process settings as required.

For detailed setting descriptions, see Submitting Design Points to Remote Solve Manager (p. 353).

5. Save the project (p. 269).

If you are working in an archived project, you must save the active project.

6. Update the design points (p. 306).
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The project is archived and submitted to a cluster using RSM. The remote data is retrieved peri-
odically as the design point updates complete. Should a design point update fail, an error is re-
ported to the Messages pane.

Performing a Geometry-Only Design Point Update

This is a non-standard workflow, but it allows you to move the geometry updates to the compute
cluster manually.

To perform a geometry-only design point update:

1. On the Project Schematic, right-click the Parameter Set bar and select Properties from the
context menu.

If the Properties pane is already visible, click the Parameter Set bar to refresh the Properties
pane with the design point settings.

2. In the Properties pane, from the Update Option drop-down list, select Run in Foreground.

3. From the Partial Update drop-down list, select Geometry.

4. To retain the results from the partial update, from the Retain Partial Update drop-down list,
select Geometry.

Note:

This setting causes the geometry results to be saved whether you perform a partial
update or a full update.

5. Save the project (p. 269).

If you are working in an archived project, you must save the active project.

6. Update the design points (p. 306).

7. Transfer the project files from the local machine to the RSM compute cluster.
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Design Point License Sharing

When Workbench design point updates are submitted to Remote Solve Manager on a cluster, you
can specify the number of tasks in a RSM job to update concurrently. You can also specify multiple
jobs to be submitted to reduce the individual job size.

Licenses are not shared between different RSM jobs.

However, licenses are shared between concurrent tasks within the same job using HPC licenses, allowing
you to leverage standard HPC licenses instead of extra solver licenses. Each task requires eight HPC
increments or one HPC Pack increment. Similar to non-parametric simulations, each task includes four
parallel cores. Additional HPC parallel cores are shared across all tasks, using the same HPC rules. All
licenses that are consumed during a RSM job are held for the duration of the job, based on the
maximum count of each license.

You can use the Ansys Parametric Licensing Calculator (https://ansys.com/parametric) to determine
the number of HPC Workgroup or HPC Pack licenses required.

Tracking Licenses

Workbench tracks licenses that are used during an update. You can see what licenses were used for
any component by viewing that component's properties. The Last Update Used Licenses property
displays which licenses were used. You may find it useful to run the update of at least one design
point as you normally would and then review the licenses that were used so that you know which
licenses are needed for a future study. License usage is tracked only for an update operation in a
component. It is not tracked if a component becomes up-to-date as the result of an edit operation.
License usage is not tracked for DesignXplorer components or any parametric components.

License tracking may not return the information in some cases, for example if a component editor
was open for viewing or editing at the time of the update. In this case, Not Applicable is shown for
Last Update Used Licenses, even though a license is used. To ensure that tracking captures inform-
ation for all components, close all component editors before updating.

Note:

License tracking can be turned off by your corporate license administrator. If you run a
study and do not see which licenses were used, contact your license administrator.

Using Upfront License Checkouts for Design Point Updates

Ansys Common Licensing eliminates the need to reserve licenses ahead of the update. The license
sharing based on HPC context automatically starts when design points are updated using Remote
Solve Manager. In some situations, you may need to have your design point RSM job fail on startup
if certain set of licenses are not available. To do this, you can specify licenses that are checked out at
the start of RSM job execution, so that the job fails early if there are insufficient licenses. If more licenses
are required during the update than were checked out upfront, they are checked out automatically
based on HPC context.

To use upfront license checkouts:
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1. To view the Design Point Update Process settings, right-click the Parameter Set bar and select
Properties.

If the Properties pane is already visible, click the Parameter Set bar to refresh the Properties
pane with the design point settings.

2. In the Properties pane, from the Update Option drop-down list, select Remote Solve Manager.

3. Click Select Licenses.

4. In the Select Licenses dialog box:

a. From the Available Licenses list, select one or more licenses.

You can select multiple licenses at one time by holding down the Ctrl key as you click each
license.

The Available Licenses list displays licenses currently available on the license server connected
to the Workbench session, which may or may not be the license server connected to the
RSM cluster.

b. Click Add.

The licenses you have selected appear in the Selected Licenses for Upfront Checkout
pane.

c. To see which licenses were used for this Workbench project in previous updates, switch to
the Used Licenses tab.

You can add licenses to the selection from this list as well.

d. To save the selection and close the dialog, click OK.

The selected licenses are not checked out at this time. License checkout occurs only when
you begin the update.

You may need to include a Geometry license as part of upfront-checkout licenses even when the
Geometry component is not parameterized and is up-to-date, if either of the following situations is
true:

• If the project contains CAD geometry or any other geometry that is not managed by the Geometry
component but rather by a downstream Model or Mesh component, and the geometry is paramet-
erized using the Model or Mesh component.

• If an Engineering Data component is parameterized and shares a model or mesh downstream with
a non-parameterized Geometry component.

Aborting or Interrupting an RSM Design Point Update

You can abort or interrupt an RSM update that is in progress.

To abort or interrupt the update:
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1. In the Progress pane, while the Status column displays the message Waiting for back-

ground task, click the stop button ( ) in the Progress column.

2. In the dialog box, select one of the following options:

• To stop the RSM job and return no data to the project, click Abort.

• To interrupt the RSM job and return any available data to the project, click Interrupt.

• To let the update continue and close the dialog box, click Cancel.

Exiting a Project during an RSM Design Point Update

You can exit a project while an RSM design point update is in progress. During the update, while the
one or more RSM jobs are running in the background, the Progress pane displays a project Status
of Waiting for background task.

Note:

• If you have submitted the Update All Design Points operation to RSM and are unable
to exit the project because Workbench remains busy, see Suspending and Resuming
Collection of RSM Design Point Results (p. 361).

• You cannot exit Workbench while job files are being uploaded. However, you can abort

the job during the upload by clicking the stop button ( ) in the Progress bar.

For RSM jobs to continue to run after you exit the project, the project must be saved at least once
after the design point update job was initiated.

If you attempt to exit a project while a design point update job is still running, the following scenarios
cause a dialog box to open, allowing you to specify whether you want to save the project before
exiting:

• You have never saved the project at any time after the same design point update job was initiated.

• You have saved the project at least once after the same design point update was initiated, but
design point results have been retrieved since your last save.

In either of these cases, if you do not save the project before exiting:

• All design point results retrieved since the last Save operation are lost. However, if the project has
been saved at least once since the update job was initiated, the results can be retrieved again
when the project is reopened.

• If the project has never been saved after the update job was initiated, all RSM jobs are aborted

and show a Status of Cancelled. The cancelled icon ( ) displays in the RSM List pane. The asterisk
on the icon indicates that the job has also been released. When you reopen the project, it is in the
state of your last manual save.
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If you do save the project before exiting:

• Retrieved design point results are saved to the project.

• RSM jobs that are queued and running continue to run after you exit.

• Jobs where the results have been saved show a Status of Finished. The finished icon ( ) displays
in the RSM List pane. The asterisk on the icon indicates that the job has also been released.

• Jobs where results have not yet been saved are not released upon exit. When you reopen the
project, you can resume update of the pending jobs to reconnect and download the results.

Suspending and Resuming Collection of RSM Design Point Results

When the Update All Design Points operation has been submitted to RSM, Workbench may be col-
lecting intermediate and final results and not allow you to exit the session. To pause the data collection
so you can exit the Workbench session, select Tools → Suspend Collection of RSM Results.

When you exit the project, results are saved according to the criteria described in Exiting a Project
during an RSM Design Point Update (p. 360).

Note:

The Suspend Collection of RSM Results option is also available during a project update
in RSM. However, because only the current design point is being updated and RSM collects
results only at the end of the update process, this option has no impact on the project
update.

To resume the collection of design point data, select Tools → Resume Collecting RSM Results. The
project reopens in the same state it was in when it closed. Once all the design points have been up-
dated, all of the suspended results are collected and then updated to the project at the same time.

It is not necessary to use the Resume Collecting RSM Results option. The collection and update
happen automatically when all jobs have been completed.

Product-Specific Limitations

Some products have additional limitations when submitting design points updates to RSM:

Ansoft

Projects that include Ansoft systems return updated parameter values but do not return the detailed
solution for the current design point.

Mechanical

Design point updates in RSM can fail for a class of problems (typically involving a Structural system
linked to a Modal or other type of Mechanical system) that meet the following criteria:

• A non-parameterized upstream Mechanical system provides solution data to a parameterized
downstream Mechanical system and both systems share the same geometry/model.
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• Updates are performed via a pre-RSM local update.

The parameters for some of the design points are not computed and are marked as errors in the
design points table.

Workarounds:

• Select the Enable Legacy Solve check box (Tools → Options → Mechanical).

• In the Parameter Set properties, set Pre-RSM Foreground Update to None and Job Submission
to One Job for All Design Points.

Third-Party CAD Systems

Projects that include geometry parameters that rely on third-party CAD systems do not update the
geometry unless the CAD system is accessible on the execution node.
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Working with Design Point Service
Design Point Service (DPS) is part of Distributed Compute Services (DCS). DPS can quickly and efficiently
evaluate tens of thousands of design points using multiple compute resources. It supports submission
of design point updates on local machines and on HPC clusters using Remote Solve Manager (RSM).

• For information about DPS, see the DCS for Design Points Guide.

• For information about RSM, see Working with Ansys Remote Solve Manager (p. 319).

The following steps provide a quick start for a single-user desktop scenario. They summarize how to
set up a Workbench project to use DPS for design point updates.

1. If DCS is not installed on your machine, install it using the Ansys installer. For more information,
see DCS Installation in the DCS for Design Points Guide.

2. Create a Workbench project, identify input and output parameters for the simulation, and insert
a few design points.

The remaining steps summarize the detailed information given in Setting Up a Workbench
Project to Use DPS (p. 364) and Submitting Design Point Updates to DPS (p. 365).

3. In the Project Schematic, right-click the Parameter Set bar and select Properties.

4. Under Solution Process, set Update Option to Submit to Design Point Service (DPS).

In a single-user desktop scenario, you can use the defaults for the other properties under this
heading to have a local evaluator update the design points that are sent to DPS.

5. Under Design Point Update Process, set Component Execution Mode to Parallel and Number
of Processes to 2 or more, depending on your machine.

6. Click Update All Design Points and, when prompted, enter DCS credentials to sign in and
send the design points to DPS for evaluation. Default system administrator account information
for all DCS services is given in DCS Installation.

7. Either view results as they are written back to the Workbench project or, in the status bar, click
the button for opening the DPS web app ( ), where you can view, filter, sort, and compare
the design points in the connected DPS project. For more information, see DPS Web App in
the DCS for Design Points Guide.

Related topics:

Setting Up a Workbench Project to Use DPS

Submitting Design Point Updates to DPS

Submitting Project Updates to DPS

Accessing the DPS Web App from a Workbench Project
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Importing DPS Design Points into a Workbench Project

Evaluating Design Points or Project Updates in Multiple Process Steps

Setting Up a Workbench Project to Use DPS

In the properties for the Workbench Parameter Set bar or Project Schematic, you set Update Option
to Submit to Design Point Service (DPS). When you update design points or the project, the Workbench
project definition and either unsolved design points or project updates are sent to DPS for evaluation.

1. In the Project Schematic, right-click the Parameter Set bar or the white space of the Project
Schematic and select Properties.

2. In the Properties view, set Update Option to Submit to Design Point Service (DPS) and then
set the other properties appropriately.

See the following descriptions for DPS-related properties:

DescriptionProperty

When set to Submit to Design Point Service (DPS), the request for updating one or
more design points in the Parameter Set bar, any cell in a DesignXplorer system, or a

Update
Option

project update is sent to DPS. For this setting, Workbench checks to see if the URL setting
for the DCS server is valid and if the server is responding. If a problem exists, a dialog
box opens, asking whether you want to start a local server or supply a valid URL to a
remote server.

URL for starting the DCS server.Server URL

• The URL for starting a local DC local server is https://localhost/dcs on
Windows or https://localhost:8443/dcs on Linux.

• The URL for starting a remote DCS server on Windows is https://host-
name/dcs or https://IP_Address/dcs.

• The URL for starting a remote DCS server on Linux is https://host-
name:port/dcs or https://IP_Address:port/dcs.
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DescriptionProperty

Name of the DPS project to which this Workbench project connects. The DPS project
stores and manages the project definition and design points. If you leave this property
blank, the DPS project is given the same name as the Workbench project.

Database
Name

Whether to automatically start an evaluator on the local machine when updates are
requested. This check box is selected by default. If you clear this check box, you can

Auto-Start
Local
Evaluator start the evaluator on the local machine by going to the Windows Start menu and

selecting Ansys 2022 R2 → DC Evaluator (DCE) 2022 R2. You can also start it from the
command line by typing dclauncher.exe start evaluator.

Maximum execution time in which to update one design point or run the project update.
If the update does not complete within this time, the evaluation is terminated. In the

Execution
Time Limit
(seconds) DPS web app, the design point is then assigned to the timeout status filter. For more

information, see DPS Web App in the DCS for Design Points Guide.

Whether to distribute the computing for different tasks between different applications
and evaluators. For example, the project can use Ansys Discovery SpaceClaim to update

Update
Design Points
in Steps the geometry and Ansys Fluent to generate results. SpaceClaim could be running on a

Windows machine while Fluent is running on a Linux cluster, cloud service, or local
machine. For more information, see Evaluating Design Points or Project Updates in
Multiple Process Steps (p. 369).

Specifies whether to run the solution in serial or in parallel.Component
Execution
Mode • When Serial is selected (default), updates are executed on only one CPU core at

a time.

• When Parallel is selected, updates are executed on multiple CPU cores.

Specifies the default number of processes to use if you are running updates in parallel.
This property must be set to 2 or greater.

Number of
Processes

Note:

In Tools → Options → Distributed Compute Services, you must set a default URL for
starting the DCS server and specify whether to auto-start a local evaluator. For more
information, see Distributed Compute Services (p. 427). Here in the Properties pane for
the Parameter Set, you can change these inherited properties for this particular project.

Submitting Design Point Updates to DPS

When the Update Option is set to Submit to Design Point Service (DPS), any update of design points
from either the Parameter Set bar or a DesignXplorer system cell will send the Workbench project
definition and unsolved design points to DPS for evaluation. The Workbench project definition includes
the parameter definitions, workflow definition, and project files.

Clicking Update All Design Points in the Parameter Set bar opens a dialog box. The prompt depends
on if there are design points that require updating and if the DPS project exists.

• If there are no design points that require updating, you are told that the output parameters for
all design points are up-to-date.
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• If the Workbench project has unsaved changes, you are told that you must save the Workbench
project to proceed. Clicking Save and Proceed saves the project and sends the project definition
and unsolved design points to the DPS project.

• If the DPS project exists but is not the same as the last one synced from the Workbench project,
you are asked if you would like to replace the project and its design points, update the project
but keep its design points, or create a new project. If you click Create new, a dialog box opens
for entering a different name for the DPS project. The name can contain only letters and digits.

• If the DPS project cannot be found because it has either been deleted or moved to a different
server, you are asked if you want to create a new DPS project with the same name. Clicking
Create sends the Workbench project and design points to the new DPS project.

As unsolved design points are sent to the DPS project, evaluators pick them up and run the simulation
tasks, writing results back to the Workbench project as the evaluations are completed.

Throughout this process, Workbench displays processing information in the status bar and the Progress
view. In the status bar, you can click the button for opening the DPS web app ( ). The button displays
the name of the connected DPS project. Or, from the Jobs menu, you can select Open Design Point
Service Web App.

In the DPS web app, you can view project information, configure the project, and filter, sort, and compare
design points. For more information, see DPS Web App in the DCS for Design Points Guide.

Note:

If you exit Workbench before the update finishes, evaluators continue to update the design
points in the DPS project. When you next open the Workbench project, it automatically syncs
the design points in the Workbench and DPS projects. If you later make parameter or project
changes in the Workbench project, selecting Jobs → Sync with Design Point Service pushes
these changes to the DPS project.

Submitting Project Updates to DPS

When the Update Option is set to Submit to Design Point Service (DPS) and you update the project,
the Workbench project definition and project updates are sent to DPS for evaluation. The Workbench
project definition includes the workflow definition and project files.

To submit project updates to DPS:

1. To save the project, from the menu bar, select File → Save.

2. Update the project:

• From the menu bar select Tools → Update Project.

• On the Project tab toolbar click Update Project.

• Right-click the white space on the Project Schematic and select Update Project from the context
menu.
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The project update starts. Throughout this process, Workbench displays processing information in the
status bar and the Progress view. In the status bar, you can click the button for opening the DPS web
app ( ). The button displays the name of the connected DPS project. Or, from the Jobs menu, you can
select Open Design Point Service Web App.

In the DPS web app, you can view project information and configure the project. For more information,
see DPS Web App in the DCS for Design Points Guide.

Note:

If you exit Workbench before the update finishes, evaluators continue the process in the DPS
project. When you next open the Workbench project, it automatically syncs the c in the
Workbench and DPS projects. If you later make parameter or project changes in the Work-
bench project, selecting Jobs → Sync with Design Point Service pushes these changes to
the DPS project.

Accessing the DPS Web App from a Workbench Project

When a Workbench project has an established DPS project connection, you can access the DPS web
app to view DPS project information using one of these methods:

• In the status bar, click the button for opening the DPS web app ( ). The button displays the
name of the connected DPS project. If the Workbench project is not connected to a DPS project,
the button displays No DPS Connection.

• Select Jobs → Open Design Point Service Web App.

You are taken to the Design Points tab for this DPS project so that you can view design point inform-
ation.

Note:

• If you try to access the DPS web app before a DPS project connection is established,
you are taken to the DPS web app's Projects page, where you can click the name of
a DPS project to go to its Design Points tab.

• If you want to sign out of DCS from a Workbench project with a DPS connection, select
Jobs → Sign out from Distributed Compute Services.

Importing DPS Design Points into a Workbench Project

If you have evaluated design points in a DPS project, you can import any design points of interest into
the Workbench project for further analysis or review:

1. On the Project Schematic, open either the Parameter Set bar or the DesignXplorer cell into
which to import DPS design points.

2. In the Table pane, right-click and select one of the following, depending on your location:
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Import from Design Point Service: Select to import DPS design points into the design
points table for the Parameter Set bar or into a DesignXplorer custom DOE or parameters
correlation.

•

• Import Refinement Points from DPS: Select to import DPS design points into the re-
finement points table in a DesignXplorer response surface.

• Import Verification Points from DPS: Select to import DPS design points into the
verification points table in a DesignXplorer response surface.

• Import Custom Candidate Points from DPS: Select to import DPS design points into
a custom candidate points table in a DesignXplorer optimization.

Note:

The above options are also available on the context menu for the Outline pane
if you right-click a node that supports importing design points from DPS.

The Import from Design Point Service window opens.

To select the DPS design points to import, you can specify design point IDs, enter a query string,
or enable filters. When you place the mouse cursor over the description for the field in which
you enter IDs or a query string, the tooltip displays usage examples.
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By default, the maximum number of design points returned from a query or from enabled filters
is 1000. However, before querying or filtering, you can change the value for Max Results. This
field appears in the upper right corner, below the Search button.

3. Select the design points to import using one of these methods:

• Specify design points IDs, separating them with commas, and click Search.

• Enter or select a previously entered query string and click Search.

• Click the buttons for filters to switch between enabling and disabling them. Choices are
for the evaluated, timeout, and failed status filters and the star filter.

The heading for the Design Points pane displays the total number of design points selected
in parentheses. The table displays these design points. Below the table, the buttons on the left
clear the table of results and clear the Status pane of processing information. On the right, the
Import button imports the selected design points into the Parameter Set bar.

4. Once the table displays the design points that you want to import, click Import.

The window closes and a progress bar appears.

If the DPS project and Workbench project have differences beyond just design points, a dialog box in-
dicates that imported design points will be set out-of-date and asks if you want to continue. If you click
Yes, before it imports the design points, DesignXplorer parses and validates the design point data. For
more information, see Parsing and Validation of Design Point Data in the DesignXplorer User's Guide.

The design points that are imported into the Workbench project from DPS are not linked to the design
points in DPS. You can perform standard operations on an imported design point, such as setting it as
the current design point.

Although output parameter values for imported design points are read-only, you can set them as editable.
For more information, see Editable Output Parameter Values in the DesignXplorer User's Guide.

Evaluating Design Points or Project Updates in Multiple Process Steps

You can set up a Workbench project to have DCS evaluate design points or project updates in multiple
process steps (tasks) on multiple machines. For example, you might be using standalone SpaceClaim,
third-party geometry and CAE tools plus an Ansys solver tool, and a Python postprocessing tool.

When running simulations in a mixed environment:

1. In the Project Schematic, right-click the Parameter Set bar or the white space of the Project
Schematic and select Properties.

2. In the Properties pane, select the Update Design Points in Steps check box.

3. Select Jobs → Sync with Design Point Service to send the updated simulation workflow
definition to the DPS project.

4. In DPS, go to the project's Design Points table and click the Configurations tab.

5. Open the appropriate configuration's details view.
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In the task pane on the right, two tasks are now visible:

• Workbench_Geometry

• Workbench_Solution

6. Define each of these tasks.

Example

Assume that the geometry step requires SpaceClaim (SCDM), which runs on a Windows machine, and
the solution step requires a custom solver (my_solver), which runs on a Linux machine.

Only an evaluator with the SCDM capability can update the geometry, and only an evaluator with the
my_solver capability can update the solution.

For the geometry step, the default settings sent from the Workbench project should be correct. For the
solution step, because only an evaluator with the my_solver capability on the Linux machine can
update the solution, you would have to add my_solver as a capability and click Save.

After you submit a design point update to DPS, in the design point's Viewing Design Point Details, the
Evaluation area will display information for the two tasks that have been run on two different evaluators.

Note:

While there cannot be more than two tasks when design points are updated from a Work-
bench project, you can use the lightweight DCS Python Client to script any number of process
steps.

When an evaluation has multiple tasks, they run sequentially by default. For example, based on the
example, the geometry is updated first, and the solution is updated second. However, when defining
a task, you can use Execution Level in the Requirements area to specify the sequence for executing
the task when multiple tasks are defined. All tasks set to 0 can be evaluated at the same time, supporting
an interesting workflow if there are multiple unrelated load cases.
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Working with Ansys optiSLang
The Ansys Workbench optiSLang Extension optimizes your product designs by combining the powerful
parametric modeling capabilities of Workbench with the Robust Design Optimization (RDO) methods
of optiSLang. The optiSLang toolbox includes modules for sensitivity analysis, optimization, and robustness
evaluation that you can easily drag and drop into a Workbench project to form an interactive process
chain.

Installing the Ansys Workbench optiSLang Extension

There are three methods to install the extension:

• Installed with optiSLang using the optiSLang standalone installer. For installation details, see the
optiSLang Installation and Licensing Guide.

• Installed using the Ansys unified installer (p. 371) and then activated.

• Installed manually (p. 372) when you have the extension file but no installer.

Installing and Activating the Extension Using the Ansys Unified Installer

You can install optiSLang and the Ansys Workbench optiSLang Extension through the Ansys unified
installer.

When you first open Workbench, the extension is not active. To activate the extension:

1. From the menu bar, select Extensions → Manage Extensions.

2. To load the extension, select the check box to the left of optiSLang.

3. To have the extension load each time you open Workbench, right-click optiSLang and select
Load as Default from the context menu.
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Manually Installing Using the Extension File

If you do not have an optiSLang standalone installer or the Ansys unified installer, but you have the
optiSLang version_number.wbex extension file, you can install it manually.

To install and activate the extension manually:

1. On the Project tab toolbar, click ACT Start Page.

2. On the ACT Start Page tab, click Manage Extensions.
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3. To install the extension, click +.

4. Browse to the location of the optiSLang version_number.wbex and click Open.

5. Activate the extension by clicking it. The box turns green to indicate it is active.
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Migrating Workbench Projects from the SDK to ACT Extension

Earlier versions of the extension were written using an SDK, while the latest version has been written
using Ansys ACT. The following table demonstrates the differences between the two extension versions.

ACTSDKFunction

Save project files generated during design
point update to the optiSLang design

Save project files generated during design
point update to the optiSLang design
directory.

Select files

directory with a separate Data Send
component system.
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ACTSDKFunction

Will be provided in a future version.Exchange of designs between Workbench
design table and optiSLang database file
(*.omdb).

Data import
and export

Displays the general application settings in
optiSLang.

N/AoptiSLang
configuration

Displays all available and used licenses in
optiSLang.

N/ALicense
management
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ACTSDKFunction

Displays the settings of the currently open
project in optiSLang.

N/AoptiSLang
project
settings

Starts and stops the Network Discovery
service to publish the currently opened
project in the local network.

Defines the scope for external access to
open projects.

Network
access

Option to archive or not archive the
optiSLang project directory (*.opd) in the
optiSLang project file (*.opf).

Option to archive or not archive the
optiSLang project directory (*.opd) in the
optiSLang project file (*.opf).

Embed *.opd
files in *.opf
files
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ACTSDKFunction

Preserves dependent parameters from
parameter set as responses by default.

Option to preserve dependent parameters
from parameter set as responses in
optiSLang.

Derived
parameters

Options to preserve the design points and
the generated design point data after an
update.

Options to preserve the design points and
the generated design point data after an
update.

Preserve and
retain data
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ACTSDKFunction

Option to submit a customized Python script
for updating the table of design points. Can
only be set directly on the system properties.

Option to submit a customized Python script
for updating the table of design points.

Update with
journal

Deletes all result data before the next
update by default.

Option to delete all result data before the
next update.

Clear
generated
data
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ACTSDKFunction

Not required.You can set additional environment variables
that are used in the next Workbench process
call.

Set additional
environment
variables

Workbench
node in
optiSLang

• Input and output files located on the Files
tab

• Input and output files located on the
Ansys Workbench tab

• •Cannot edit files New edit function

• Environment tab will be added in a
future version

• Environment tab available
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ACTSDKFunction

• Designs per process option located
inAdditional options• Designs per process option located on

the Execution Settings tab • Use Ansys Workbench as local applica-
tion is no longer available

• Use working copy of WB project is no
longer supported

To migrate a Workbench project:

1. Load the SDK project with the appropriate Workbench version.

2. Right-click a system and select Edit from the context menu.

3. Export the system settings (not results).

Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.380

Working with Ansys optiSLang



Additional steps are required for the following components:

Data Receive / Data Send

1. Open the Files tab.

2. Click the multi-action button to export the files.

381
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Migrating Workbench Projects from the SDK to ACT Extension



Signal Processing

1. Switch to the Variables tab.

2. Right-click the pane and select Export variables from the context menu.
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4. Repeat steps 2 and 3 for all other systems in the project.

5. Create a new project in the most recent version of Workbench.

6. Recreate the projects using the ACT extension components available in the Toolbox.

7. Import the corresponding settings exported in step 3.

Using the Ansys Workbench optiSLang Extension

The Ansys Workbench optiSLang Extension is an ACT extension that offers wizards for sensitivity studies,
multidisciplinary optimization, robustness and reliability analysis as well as Robust Design Optimization
supporting all kinds of Ansys design parameters.

The extension uses much of the same functionality as Workbench. To use the extension tools:

1. From the optiSLang and optiSLang Integrations sections of the Toolbox, add (p. 55) optiSLang
systems and components to the Project Schematic.

See System Connections (p. 387) for descriptions of optiSLang system connections.

2. Complete the optiSLang system wizards (p. 384), configure the optiSLang components (p. 384), and
work through (p. 67) any Workbench systems created.

3. Save the Workbench project (p. 269).

4. Update systems or the project (p. 242).
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Algorithm Systems

Each algorithm is represented by a system consisting of parameters, criteria, algorithm settings, start
designs, nominal designs, and results. The first five components are combined into a wizard that is
launched when you add the system to the Project Schematic. Results can be opened with a post-pro-
cessor during or after calculations.

Optimization

The Optimization system prepares an optimization workflow using the parameter sets provided by
Workbench systems.

For details on the Optimization wizard, see Optimization Wizard. For an example tutorial, see Optimization
of a Damped Oscillator in Ansys Workbench in the optiSLang Tutorials.

Robustness

The Robustness system prepares a robustness or reliability analysis workflow using the parameter sets
provided by Workbench systems.

For details on the Robustness wizard, see Robustness Wizard. For example tutorials, see Robustness
Evaluation of a Damped Oscillator in Ansys Workbench and Reliability Analysis of a Damped Oscillator
in Ansys Workbench in the optiSLang Tutorials.

Sensitivity

The Sensitivity system prepares a sensitivity study workflow using the parameter sets provided by
Workbench systems.

For details on the Sensitivity wizard, see Sensitivity Wizard. For an example tutorial, see Sensitivity
Analysis of a Coupled Function in Ansys Workbench in the optiSLang Tutorials.

Integration Components

You can add the following optiSLang integration components to the Project Schematic.

Data Receive

Manages the data exchange of external files. Registered files can be received from different external
locations like file systems or versioning databases.

Each file entry is made available using a appropriate connection. Supported transfer types are:

• Geometry

• Engineering Data

• Mesh

• optiSLang
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• Turbo Geometry

For more information, see Data Receive.

Data Send

Manages the data exchange of external files. Registered files can be sent to different external locations
like file systems or versioning databases.

In the standard view, the files from the Workbench design point directory are offered hierarchically on
the left, which can be transferred to the optiSLang design working directory. The selected files are listed
with their relative path on the right. This structure is retained during the file transfer.

If the files to be transferred are not known, or not available at the time the workflow is set up, a file
filter can be used. The definition of the filter is identical to that of the purge dialog.
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For more information, see Data Send.

MOP Solver

Uses Metamodel of Optimal Prognosis surrogate models for CAE calculations.

Starting from a reduced number of simulations, a surrogate model of the original physical problem can
be used to perform various design configurations without computing any further analyses. These well-
distributed results are used to create the metamodels. The metamodel with highest Coefficient of Pro-
gnosis (CoP) is taken as the optimal by optiSLang. The MOP results are stored in an optiSLang monitoring
database *.omdb file or in an optiSLang *.bin file. The MOP Solver calls can be used to replace the
original solver process.

For more information, see MOP Solver.

Python

Provides Python scripting for automating tasks. For more information, see Python.

Signal Processing

Extracts scalar and non-scalar response values from Ansys result files and text files and provides the
non-scalar responses to optiSLang algorithm systems and the Ansys Workbench component in optiSLang
if the programs are connected locally. Signal processing in the extension requires access to the file
system so remote connections are not supported.
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The extraction may reduce data, as only the extracted optiSLang raw value (*.orv) files are saved,
not the result file. The raw value files are saved automatically to the respective optiSLang design direct-
ories and are used for providing responses within the optiSLang systems. If you are defining scalar re-
sponses, they are added to the Ansys parameter set.

For more information, see ETK.

System Connections

To create a specific workflow and to exchange data between different systems connections, add the
optiSLang algorithmic systems and integration components to the Project Schematic using the instruc-
tions provided in Adding Systems to the Project Schematic (p. 55).

You can make connections between the following optiSLang systems and components.

MOP Solver to Optimization

Finds improved designs as a result of a metamodel-based sensitivity analysis. Data exchanged is the
information about parameters. You can establish multiple connections between the two systems. This
connection can be established for all optimization strategies except for ARSM which uses its own meta-
modeling approach internally.

Sensitivity to Sensitivity

Enhances an existing sampling by adding further samples. Data exchanged is the information about
parameters, criteria, and the already sampled designs.

Sensitivity to Optimization

Finds improved designs as a result of a sensitivity analysis. If an objective function is defined in the
Sensitivity system, the best design is exchanged as a start design for the optimization. Otherwise, a
connection is not established.

Optimization to Optimization

Checks if any further improved designs can be found in the existing best designs. Data exchanged is
the information about parameters, criteria, and the already sampled designs.

Optimization to Robustness

Analyzes the robustness of optimization results. The best design of the optimization is exchanged to
set the nominal design for the robustness analysis. You establish connections from an Optimization
system to multiple Robustness systems.

optiSLang Extension User Interface Reference

The following components are specific to the Ansys Workbench optiSLang Extension. For general
Workbench interface details, see Workbench Interface Reference (p. 439).
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Menu Bar

File Menu

DescriptionMenu Item

Loads a project from an external data source.Load Archive
From

Saves the current project to an external data source.Save Archive To

optiSLang Menu

DescriptionMenu Item

Opens the application settings dialog.optiSLang Settings

Opens the License Management dialog box and display an overview of all available
and used licenses.

License
Management

Opens the Project Settings dialog box.Project Settings

Opens and displays the optiSLang help.optiSLang Help

Opens the About Ansys optiSLang dialog box containing various product details.About optiSLang

Exports the table of design points to a JSON file and starts the optiSLang
postprocessing with it.

Export Designs

Exports the parameters, designs and optimization criteria of a Design Explorer
system to be selected in an optiSLang readable JSON file. This menu item is only
displayed if there is a Design Explorer system in the Project Schematic.

Export DX Data

Opens a dialog to register remote server connection data, allowing remote access
to the project from the Ansys Workbench node in optiSLang. Enable or disable the
connection by clicking Start or Stop.

Remote Control

Opens the optiSLang application where you can continue to work on the
project. Also available as a shortcut button.

Go To optiSLang

Context Menu

DescriptionMenu Item

Opens a dialog to edit specific system or component settings.Edit

If an algorithm component was stopped, it can be finalized to continue the calculation
of further systems.

Finalize

Reloads the parametric data from Workbench.Refresh
Parameter

If parameters are added to or removed from the parameter set in Workbench,
select Refresh Parameter in all optiSLang systems before updating the project.

All new parameters are added to the system without changing the user-defined
properties of the existing ones.
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DescriptionMenu Item

Parameters removed in Workbench are also removed for the optiSLang system.

Opens the postprocessing dialog for the system.Results

Opens the statistics postprocessing of the Design of Experiment or sampling component
for this system.

DoE Results

Opens a selection dialog for a DX system and transfers the parameters, designs (as
start designs) and optimization criteria to the optiSLang system.

Import DX Data

Exports the metamodel to Functional Mock-up Interface.Export FMU

Properties Pane

DescriptionProperty

Preserves designs belonging to the currently updated system in the
table of design points.

Preserve Design Points After
optiSLang Run

Retains generated design point files during the update in the Workbench
design point directory.

Retain Data for Each Preserved
Design Point

Submits multiple design points in parallel to Remote Solve Manager
(RSM). When selected, optiSLang submits the number of design

Use Simultaneous Execution
Mode

points entered in Number of Design Points sent to Parameter Set at
the same time. If this is not selected, the design points are
submitted to RSM sequentially.

For more details on submitting design points to RSM, see Updating
Design Points in Remote Solve Manager (p. 352).

Submits the listed number of design points to RSM, either in parallel if
Use Simultaneous Execution Mode is enabled, or sequentially if it is not.

Number of Design Points sent
to Parameter Set

The size is automatically adjusted if fewer designs need to be evaluated.
Set this number based on the number of free clients in your RSM setup.

Controls the project, system, or cell update using the selected Python
script or Workbench journal.

Run Journal for Update

Situational Dialogs

The following dialogs can appear, depending on the project state.

DescriptionDialog

Allows you to interrupt the calculation of a project.Interrupt/Abort (p. 245)

Allows you to continue a crashed session.Recovering
Projects (p. 277)

Defines which data can be discarded when resetting the project or component.Reset

Confirms the decision when selecting Remove design directories before
calculating.

Remove Working
Directory

Applies modifications to a component. This might cause a loss of calculated
data. Different scenarios are offered for resetting the component.

Confirm Modifications
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Project File Structure

optiSLang projects in Workbench use the following directory structure and files.

*.wbpj/*.wbpz—Workbench project file or archive

*_files—Workbench working directory

• dp0—The current design point (reference design)

– ETK—Signal Processing (p. 384) working directory

DescriptionFile/Folder

optiSLang working directory*.opd

optiSLang project file*.opf

optiSLang raw value file*.orv

Input file for signal processingInput file

Output file for signal processingOutput
file

• user_files—User or program provided files

– optiSLang protocol file containing project session information (for example, calculations or errors)

• *.opf—optiSLang project file

• *.opd—optiSLang working directory

– Algorithm systems

→*.omdb—optiSLang monitoring database file

→ Design directories—Created for every run started by optiSLang. The numbers of these directories
are equal to the numbers of the designs shown in the history plots. Stores and processes the
modified input files and the result files.

DescriptionFile/Folder

Input file for designInput file

Output file for designOutput file

Solver output files for designSolver
Output

Workbench working directory*_files

– *.omdb—optiSLang monitoring database file

*.optislang—A special folder that optiSLang creates when the Workbench project information is
read for the first time. It contains a JSON file with all relevant data, such as parameters, responses, re-

Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.390

Working with Ansys optiSLang



gistered files and a hash value. Reloading the project information is only necessary if the hash value of
the project has changed.

System Environment

The Ansys Workbench optiSLang Extension uses the system environment and registry to find the com-
patible optiSLang application in the following order:

1. Environment variable OPTISLANG_HOMEXXXX

where XXXX is the Workbench version number, with leading zeros if applicable. For example
OPTISLANG_HOME0810 or OPTISLANG_HOME2110.

2. OPTISLANG_HOMEXXXX entry in

• Windows: %APPDATA%\Dynardo\optiSLangWBExtension.ini

• Linux: %HOME%/.config/Dynardo/optiSLangWBExtension.ini

3. Under AWP_ROOT of the currently running Workbench version.

4. Registry (Windows only)

• HKEY_CURRENT_USER\SOFTWARE\Dynardo\ANSYS optiSLang entry of the Windows registry if
optiSLang was installed for the local user

• HKEY_LOCAL_MACHINE\SOFTWARE\Dynardo\ANSYS optiSLang entry of the Windows registry if
optiSLang was installed for all users
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Working with Workbench and Ansys Minerva
Ansys Minerva is a simulation process and data management (SPDM) software system that enables you
to work with simulation data in a repository. Within Workbench, you can create a connection to an
Ansys Minerva site so that you can transfer projects to and from Ansys Minerva repositories.

You can use Ansys Minerva to:

• Archive completed projects or store works-in-progress in a central repository

• Share your projects and collaborate on those of others

• Retrieve your own projects or those shared by other users

• Change the permissions of projects or place them under version control

• Search projects based on names, dates, simulation type, or other criteria

• Create reports

For more details, see the Ansys Minerva User's Guide.

Related topics:

Creating a Connection to an Ansys Minerva Site

Displaying the Ansys Minerva Toolbar

Launching Ansys Minerva with a Web Browser

Working with Workbench Projects Saved in Ansys Minerva

Creating a Connection to an Ansys Minerva Site

To be able to save a Workbench project to or retrieve a project from Ansys Minerva (directly from
Workbench), you must create a connection between your local Workbench installation and an Ansys
Minerva site.

A connection contains information about the server hosting Ansys Minerva, the database to use, and
the authentication type.

To create a connection in Workbench:

1. From the menu bar, select Tools → Options.

2. From the list, select Ansys Minerva
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3. Specify a Authentication Type for the connection.

Note:

Select the method that matches what is configured for the Ansys Minerva server you
are connecting to.

• Basic—Uses a username and password to authenticate using the internal mechanism within
Ansys Minerva.

• Browser—Uses the browser to authenticate. If you are logged into Ansys Minerva in the browser,
those credentials are used.

• Windows—Uses Active Directory to pass the credentials of the user currently logged into the
Ansys Minerva server.

4. Enter the Server URL address of the Ansys Minerva server.

5. Enter the Ansys Minerva Database to access.

6. Click OK.

Displaying the Ansys Minerva Toolbar

The Ansys Minerva functions available from the Workbench File menu are also available in the Ansys
Minerva toolbar.

To display the toolbar, select View → Toolbars → Ansys Minerva Toolbar.

Launching Ansys Minerva with a Web Browser

To access Ansys Minerva directly, open the web client in your default browser by doing one of the fol-
lowing:

• Select File → Ansys Minerva → Launch Minerva Web Client.

• Click  on the Ansys Minerva toolbar.

Working with Workbench Projects Saved in Ansys Minerva

When working with an Ansys Minerva repository, you must understand the relationship between your
local working version of the project and the copy stored in the repository. Even if a project has been
stored to or opened from a repository, Workbench always operates directly on the local working copy
of the project.

Workbench is aware of the relationship between the local project and the repository copy, and helps
you manage your project and maintain consistency. You can save the local copy of a project to the re-
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pository at any point. If you open a local project, and the copy in the repository is more recent, you
have the option of downloading and updating to the repository version.

When you save a Workbench project to an Ansys Minerva repository, Ansys Minerva always stores it as
a virtual project archive (with the *.wbpz extension) so that you can act on a single object, rather than
on a set of objects.

Related topics:

Saving the Current Workbench Project to an Ansys Minerva Repository

Saving the Current Workbench Project to a New Location in the Repository

Opening a Project from an Ansys Minerva Repository

Claiming a Project

Unclaiming a Project

Saving the Current Workbench Project to an Ansys Minerva Repository

You can save your current Workbench project to an Ansys Minerva repository for archive storage, or
to share with other users.

Note:

The first time the project is saved, all of the files are sent to Ansys Minerva. In subsequent
saves, only the items in the project that have changed are sent.

To save the current project to an Ansys Minerva repository:

1. Save any project changes locally.

2. From the menu bar, select File → Ansys Minerva → Claim or on the Ansys Minerva toolbar, click

.

3. From the menu bar, select File → Ansys Minerva → Save or on the Ansys Minerva toolbar, click

.

4. If you have not authenticated against an Ansys Minerva site, the Connect dialog box appears.
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a. Enter your Username and Password.

b. Click OK.

5. If this is the first time you have saved this project to Ansys Minerva:

a. Browse to the location in the repository to save the files.

• To search for the location, enter the text in the search field. You can include wildcards in
the search terms.
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• To clear the search, right-click the right pane and select Clear Search from the context
menu.

You can also clear the search by clicking on a different location in the tree in the left pane.

• To add a new folder, right-click the right pane and select New Folder from the context
menu.

Note:

This location will be automatically selected in subsequent saves. To save a copy
of the project to a new location, complete a save to operation (p. 397).

b. Click OK.

Saving the Current Workbench Project to a New Location in the Repository

Once you have saved a project to Ansys Minerva, Workbench stores the path to the repository location
and subsequent saves are made to the same location. To switch to a new storage area, you must
complete a save to operation.

To save the project to a new location:

1. Save any project changes locally.
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2. From the menu bar, select File → Ansys Minerva → Claim or on the Ansys Minerva toolbar, click

.

3. From the menu bar, select File → Ansys Minerva → Save To or on the Ansys Minerva toolbar,

click .

4. If you have not authenticated against an Ansys Minerva site, the Connect dialog box appears.

a. Enter your Username and Password.

b. Click OK.

5. Browse to the location in the repository to save the files.

• To search for the location, enter the text in the search field. You can include wildcards in the
search terms.
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• To clear the search, right-click the right pane and select Clear Search from the context menu.

You can also clear the search by clicking on a different location in the tree in the left pane.

• To add a new folder, right-click the right pane and select New Folder from the context menu.

6. Click OK.

Opening a Project from an Ansys Minerva Repository

When you open a project from an Ansys Minerva repository, the archive file is downloaded, extracted,
and opened in Workbench.
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The files are saved automatically to the location you specify in your Workbench user preferences, on
the Project Management page. See Project Management in the Workbench User’s Guide for more in-
formation.

To open a project from an Ansys Minerva repository:

1. From the menu bar, select File → Ansys Minerva → Open or from the Ansys Minerva toolbar,

click .

2. If you have not authenticated against an Ansys Minerva site, the Connect dialog box appears.

a. Enter your Username and Password.

b. Click OK.

3. Browse to the project file location in the repository.

• To search for the location, enter the text in the search field. You can include wildcards in the
search terms.

• To clear the search, right-click the right pane and select Clear Search from the context menu.
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You can also clear the search by clicking on a different location in the tree in the left pane.

4. Select the project file and click OK.

The archive file is downloaded and opened in Workbench.

Claiming a Project

When you have a project opened from the repository that is under version control, you can claim it.
This gives you exclusive control over the project and prevents other users from making any modific-
ations to it while you are working with it.

To claim a project:

1. Open the project from the repository (p. 399).

2. From the menu bar, select File → Ansys Minerva → Claim or on the Ansys Minerva toolbar, click

.

The project is claimed. A flag appears beside the project name in Ansys Minerva.
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Unclaiming a Project

When you are finished editing a project, you release it back to Ansys Minerva by unclaiming it.

To unclaim a project:

1. Open the project from the repository (p. 399).

2. From the menu bar, select File → Ansys Minerva → Unclaim or from the Ansys Minerva toolbar,

click .

The project is released. In Ansys Minerva, the claimed flag is removed from the project name.
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Troubleshooting Workbench
The following topics list issues and error messages that you may encounter while running Workbench.

These topics do not include troubleshooting for data-integrated applications. See the help for the spe-
cific application for troubleshooting information.

For additional troubleshooting information on native applications, see the following:

• Troubleshooting in the DesignXplorer User's Guide

• DesignModeler Frequently Asked Questions in the Ansys DesignModeler User's Guide

• Troubleshooting in the optiSLang User's Guide

Related topics:

General Workbench Issues

Product-Related Issues

Startup or Graphics Issues

Error Messages

Known Issues and Limitations

General Workbench Issues

This topic lists issues that you may encounter in various areas of Workbench.

Error Messages Appear During Workbench Setup

During setup, if you encounter any errors containing 0x8000FFFF, you must install the required in-
stallation prerequisites.

1. To open the Product & CAD Configuration Manager, select Start > Ansys 2022 R2 > Product &
CAD Configuration 2022 R2.

2. Click Install Required Prerequisites.

CAD System Plug-In Menus Do Not Appear for NX or Creo Parametric

On Windows platforms, Workbench appends its information to an existing customization file. If a cus-
tomization file does not exist, a new one is created. For NX, Workbench looks for the custom_dirs.dat
file in the directory specified in the UGII_CUSTOM_DIRECTORY_FILE environment variable. For Creo
Parametric, Workbench looks for the config.pro file in the %HOMEDRIVE%%HOMEPATH% directory.
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When the Creo Parametric Geometry Interface is set up, Workbench also appends its information to the
config.pro file located in the Creo Parametric installation path, under the \text directory (for ex-
ample, Proewildfire2\text\config.pro).

If Workbench encounters a read-only file, it cannot write the necessary information to the file. To display
the Ansys menu in NX or Creo Parametric, you must change the permissions on the file and manually
add the appropriate Workbench-specific information.

Script Errors When Running Workbench

If you encounter script errors such as Error: Unable to create object microsoft.XMLDOM,
you may need to install the latest version of Microsoft Core XML Service (MSXML).

See the MSXML Download Page for more information on downloading and installing MSXML.

Charts Do Not Appear

If you do not see the appropriate charts created after a design point run or other updates (such as re-
sponse surface updates), from the menu bar select View → Reset Workspace.

Applications Do Not Start After Crash

On Linux machines, if Workbench applications do not launch after an abnormal exit such as a crash,
run the following utility:

$INSTALL/v222/aisol/wbcleanup

Wobbly Windows Desktop Effect Causes Crashes

The wobbly windows desktop effect on Linux machines may cause Workbench or its applications to
crash. This effect is on by default on some Linux platforms. Make sure the effect is turned off.

Linux Threading Limit

By default, many Linux systems limit the total number of threads each user can run at once, to avoid
multiple processes overloading the system. If you are running many Ansys jobs concurrently as the
same user (for example, submitting them through Remote Solve Manager), you may hit this limit, pro-
ducing errors such as Thread creation failed.

To view the current thread limit, run the following command:

• ulimit -u (bash)

• limit maxproc (csh)

To increase the thread limit, run the following command:

• ulimit -u [limit] (bash)

• limit maxproc [limit] (csh)
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Where [limit]  is a numerical value (for example, 4096).

To view the administrator-imposed hard limit, run the following command:

• ulimit -H -u (bash)

• limit -H maxproc (csh)

You cannot increase the limit amount beyond this hard limit value. Contact your system administrator
to increase the hard limit.

Communication Errors with Hyper-V Virtual Ethernet Adapter

Running Workbench projects containing System Coupling components through a virtual machine or
VPN connection can cause various errors, for example:

Updated failed for the Solution component in System Coupling. The coupling service failed to start.

This is caused by a Hyper-V virtual ethernet adapter preventing the Message Passing Interface (MPI) (a
method for managing multiple processes) from working correctly.

To solve this issue:

1. Open Control Panel.

2. Click Network and Sharing Center.

3. Click Change adapter settings.

4. Find the adapter that has Hyper-V Virtual Ethernet Adapter in the description.

5. Right-click the adapter and select Disable from the context menu.

6. Repeat step 5 for all other Hyper-V adapters.

Design Point Update Subtask Error When Using UGE Scheduler

When submitting design point updates to Remote Solve Manager, the design points are allocated to
one or more tasks and these tasks are allocated to one or more RSM jobs. This method of job submission
can create an error similar to the following when using an UGE scheduler queue:

executing task of job 3119 failed: execution daemon on host
"testhost.domain.com" didn't accept task

To solve this issue, open the sge_pe file on the cluster and change the daemon_forks_slaves
parameter to FALSE.
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Using 4K Displays with Workbench

Currently, Workbench does not support 4K displays. You may see one or more of the following issues
if you use Workbench on a 4K display:

• Initially launching Workbench displays a tiny window and text is cut off.

• Titles are cut off.

• You must maximize the Workbench window twice before it is set to full screen.

• Various parts of the user interface are scaled incorrectly, including tab titles, drop-down menu text,
toolbars, and the ACT start page.

To improve these issues, complete the following procedure:

1. On the Windows toolbar, select Start > Ansys 2022 R2

2. Right-click the Workbench 2022 R2 icon and select More →  Open file location from the context
menu.

3. In the Ansys 2022 R2 folder, right-click the Workbench 2022 R2 icon and select Properties from
the context menu.

4. Switch to the Compatibility tab.

5. Under Settings, click Change high DPI settings.

6. Select the Override high DPI scaling behavior. Scaling performed by: check box.

7. Select System from the drop-down menu below the check box.
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8. To save the change and close the dialog box, click OK.

System Coupling Crashes Workbench in Remote Session

If you are loading the System Coupling component system user interface during a remote Workbench
session and Workbench crashes, restart the machine.

HDF5 File Locking

The HDF5 version used in 2022 R2 will result in failure when the underlying file system does not support
file locking, or where locks have been disabled. To disable all file locking operations, create an environ-
ment variable named HDF5_USE_FILE_LOCKING and set the value to the five-character string FALSE.

Product-Related Issues

This topic lists issues that may occur in products that integrate with Workbench.
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Installing the Multilingual User Interface Pack of Microsoft Office for your
Language

If you run the 2007 or 2010 English version of Excel and the locale for the current user is configured
for a language other than English, Excel tries to locate the language pack for the configured language.
If the language pack is not found, then the error is reported and the automation of Excel, as used by
the Excel as a calculator feature, cannot be performed. To solve this issue, you must install the Multilingual
User Interface Pack of Microsoft Office for your language. As an alternative, you can also configure the
locale for the current user to English.

This bug is documented by Microsoft. For more information, see http://support.microsoft.com/kb/320369.

Design point Failure when Updating Project with Multiple Excel Systems

If you have Office Excel 365, Office Excel 2013, or Office Excel 2016 installed on your machine and your
Workbench project contains multiple Excel systems and the Excel process window is hidden, updating
the project may cause design points to fail and the following exception message to display:

We found a problem with this formula. We couldn't find a range reference
or a defined name.

Workaround: Before running any update operations, open the Excel process window by right-clicking
and selecting Open File in Excel.

This issue is documented by Microsoft. For more information, see https://support.microsoft.com/en-us/
kb/3083825.

Workbench and optiSLang Crash Dialogs

When you start a Workbench project that contains optiSLang components, you may see some of the
following dialogs depending on the situation.

Workbench Crashed and optiSLang was Saving the Project

Workbench encountered a problem and crashed but optiSLang was able to save the *.opf project
file. In this case, you can recover the project. To see additional information before recovering, click
Show Details. All files that are modified and will be deleted are displayed. We recommend manually
saving a copy of the project files before recovering the project.

To recover the project, click Yes in the dialog.
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Workbench Crashed and optiSLang Crashed without Saving the Project

Both Workbench and optiSLang crashed and the project could not be saved. To continue with the
project, return it to its last saved state. To see additional information before restoring the saved state,
click Show Details. All files that are modified and will be deleted are displayed. We recommend
manually saving a copy of the project files before restoring the saved state.

1. To return the project to its last saved state, click Yes in the dialog.

2. Select which project save version to use.

Note:

We strongly recommend selecting the automatic save point.

optiSLang Crashed

optiSLang encountered a problem and crashed, and the optiSLangAddin.exe file exited. You can
now restart the Workbench extension and continue the project.

1. To restart the extension, click Yes in the dialog.
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2. Select which project save version to use.

Note:

We strongly recommend selecting the automatic save point.

Project Files have been Relocated

Files referenced by the project have been moved and cannot be found. You can automatically relocate
these files by selecting the option in the dialog.
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Failed to Start optiSLang Error when using optiSLang Extension in Workbench

When using the optiSLang extension inside Workbench, the following error can occur:

'NoneType' object has no attribute 'password' & Exception: Failed to
start optiSLang, no executable

To fix this issue, you must edit the optiSLangWBExtension.ini file. You can do this by either using
the Workbench user interface or editing the file directly in a text editor.

Workbench User Interface

1. Set the value of the DYNARDO_VERBOSE_LEVEL environment variable to 1.

2. Start Workbench.

3. If the optiSLang extension is not loaded, activate it (p. 371).

4. From the menu bar, select optiSLang → Extension Settings.
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The optiSLangWBExtension.ini file opens in an editor.

5. In the file, add one or more paths to optiSLang installations.

The structure of each entry is OPTISLANG_HOMEXXXX=/path/to/optislang/ where XXXX
contains the installation path version number. For example, OPTISLANG_HOME2210 points to
the installation path of optiSLang 2022 R1.

Open in Text Editor

1. Navigate to the location of the optiSLangWBExtension.ini file.

• Windows: %APPDATA%\Dynardo

• Linux: $HOME/.config/Dynardo

2. Open the file in a text editor.

3. In the file, add one or more paths to optiSLang installations.
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The structure of each entry is OPTISLANG_HOMEXXXX=/path/to/optislang/ where XXXX
contains the installation path version number. For example, OPTISLANG_HOME2210 points to
the installation path of optiSLang 2022 R1.

Error When Loading Files in TurboGrid Opened Through Workbench

After opening TurboGrid using a TurboGrid component system in Workbench, loading an Init file by
selecting File → Load TurboGrid Init File, and saving the project, the following error message is dis-
played:

Unable to load DLL 'cclapilt.dll': The specified module could not be
found. (Exception from HRESULT: 0x8007007E)

Workaround: Install MS VC++ Redistributable for Visual Studio 2012 Update 4.

Startup or Graphics Issues

This topic lists issues that you may encounter with starting Workbench or Workbench graphics.

To minimize graphics problems, always verify that you are running the latest graphics drivers provided
by your computer's hardware manufacturer. If you are not, you may see the following message:

***An error occurred while setting up the graphics window. Please ensure that you have the latest drivers 
from your graphics card manufacturer. If the error persists, you may need to decrease the graphics 
acceleration. For more information, please see the Troubleshooting section in the Ansys Workbench help.

Linux

If you are running Workbench on Linux and experience problems at startup or with the user interface
or graphics displaying correctly, and you are running in accelerated graphics mode, you may need to
relaunch Workbench using the -oglmesa flag to activate software rendering:

runwb2 -oglmesa

If Workbench detects that graphics problems are causing crashes, it automatically switches to software
rendering. Workbench also uses software rending mode by default when running on a remote display,
or on a local display if the hardware does not appear to be accelerated.

To revert to accelerated graphics mode, launch Workbench using the -oglhw flag:

runwb2 -oglhw
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If you are running under Exceed3D, try the following settings if you are having graphics problems:

• Turn off the graphics (hardware) acceleration option in Exceed3D options.

• If graphics acceleration is on, turn on the GLX 1.3 option.

Any version of Exceed that does not have the GLX 1.3 option is unlikely to function correctly with
graphics acceleration.

Windows

If you experience graphics issues on Windows systems, you can find the details of your graphics card
and the driver that is currently installed by selecting Start → Run and typing the following into the
Open field:

dxdiag

Select the Display tab and review your graphics card information. You can then contact the vendor or
visit the vendor's website for details of the latest graphics drivers available for your specific graphics
card.

You may also have to adjust the hardware acceleration. To adjust the hardware acceleration, Open
Control Panel and select Display → Settings → Advanced → Troubleshoot or your operating system's
equivalent. The hardware acceleration slider should then be visible. You can also select Display →
Settings → Troubleshoot and use the troubleshooting tool to guide you to the Hardware Acceleration
panel. Try turning hardware acceleration off by dragging the slider to None. Try the software again; if
the graphics problems are resolved, then gradually increase Hardware Acceleration as far as you can
before the software fails again.

Error Messages

This topic lists error messages that you may encounter in Workbench.

Unable to connect to Solver Manager

Another application might be using the Solver Manager port (10002 by default). Try changing the port
number by editing the Ansys.SolverManager.exe.config file located in the installation directory
at \AISOL\Bin\<platform>.

If you are having difficulty launching other applications/editors, it is also possible that the Windows
hosts file has been corrupted. Make sure that localhost is specified in the Windows <os
drive>:\Windows\system32\drivers\etc\hosts file.

Warning at File: myxml, line 1, col 40, Encoding (utf-16, from XMLDecl or
manually set) contradicts the auto-sensed encoding, ignoring it

The message is sometimes displayed in the Remote Solve Manager (RSM) log; you can ignore it.
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System.IO.IOException: Too many open files

Many Linux distributions set a default maximum for the number of files a process can have open and
this can be exceeded when solving some cases. You must increase the maximum number of open files
allowed by editing limits.conf, which on most Linux distributions is found in /etc/security/lim-
its.conf.

For example, adding the lines

# ANSYS file handle limits modification
*       soft    nofile  2048
*       hard    nofile  2048

to limits.conf sets the maximum number of open files to 2048 (the default on most Linux distribu-
tions is 1024). Increase the maximum number of open files allowed by powers of 2, trying 2048, 4096,
8192.

Further information can be found in the manual page for limits.conf, which can be accessed using
the command man limits.conf on any Linux machine with the man command installed.

You can check the current limit by using the command ulimit -a in a bash shell session or limit
in a tcsh shell session. In the output, the maximum number of open files is displayed under open files
or descriptors, respectively.

Known Issues and Limitations

The following are known issues at the time of release, as well as system and software limitations:

• KDE is not supported on SuSE Linux Enterprise Server & Desktop 12.

• When a job is submitted that requires the MAPDL solver, and no MAPDL license is available, the job
may appear to be in the 'starting' state in the job monitor for up to 20 minutes before the issue is
reported. Additionally, if you check your system processes (with ps on Linux or Task Manager on
Windows), you may see some solver processes still running after 20 minutes. These may run for up
to 80 minutes, but are small and do not consume significant resources.

• When running or updating a Workbench project on a Linux machine that generates many files, such
as a large number of Design Points running concurrently, the solver can fail with the following excep-
tion:

System.IO.IOException: Too many open files

To prevent this failure, increase the maximum number of files able to be opened at one time by
running the ulimit command ulimit -n [limit] where limit is either a numerical value (for
example, 1000000) or, “unlimited”.

• When running Workbench on a Linux machine, it crashes when you select Extensions → ACT Start
Page from the menu bar or click ACT Start Page on the Project tab toolbar. This crash is caused by
the libtotem-mozplugin.x86_64 version 2.28.6-4.el6 dll package, used for video
playback in browsers. To avoid the crash, uninstall the package.

• The Excel feature in Workbench requires Microsoft Office Excel 2013 or 2016.
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• The Excel feature is only available on Windows systems.

• In a project with retained design points, switching to a different up-to-date design point using the
Set as Current menu option automatically updates the Excel system, which could be time-consuming
if the spreadsheet contains macros or extensive calculations.

• Files written by Ansys products cannot be synchronized with Microsoft's OneDrive file hosting service.

• Workbench products do not support running a network user installation as local root administrator.

• On Linux, transferring DesignModeler geometry from the geometry cell to a downstream HFSS Design
system fails if the upstream geometry is not open in the DesignModeler editor. In this case an OnRe-
freshTransferData failed! error message is displayed. Open the geometry in DesignModeler
before transferring it so that the transfer succeeds.

• When Material Designer is linked to Engineering Data, modifying a material name in Material Designer
does not change the corresponding material in Engineering Data but rather creates a new material
with the new name. The prior material should be deleted from Engineering Data before updating
downstream components.

• Parameterizing a non-integer, non-zero number in a Forte project when your system is set to a
European number format (the decimal separator uses a comma) causes the parameter value to be
displayed as zero in Workbench. Ensure your system is set to a number format that uses a period as
the decimal separator.

• Negative dimension values can invert the direction vector of SpaceClaim operations that they are
associated with; this change is applied to the current and subsequent design point updates. As a
result, when a Workbench input parameter is used as a driving dimension for a SpaceClaim geometry,
negative dimension values may result in incorrect or unexpected geometric changes.

• Workbench can stop working when updating multiple design points in one task through Remote
Solve Manager installed on a Linux cluster. The following error message is displayed in the Remote
Solve Manager Job Monitoring application:

ClusterJobs Command Exit Code: 134

Assertion at class.c:2876, condition 'iid <= 65535' not met

To work around this issue, reduce the number of design points that are updated in each task.

• When using Workbench on Linux systems, you cannot use a Mechanical APDL system to launch
MAPDL when the graphics mode is set to 3D. You must use the X11 graphics mode.

• Because Workbench and Ansys AEDT use two different unit systems, upstream parameter values are
transferred to AEDT with SI unit values. There are no computations errors, but when you graphically
display the design in AEDT, you cannot see the units as specified in Workbench. They are displayed
as unitless values in SI.
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Workbench User Preferences
User preferences are set in the Options dialog box.

The preferences you set here are local settings, affecting only you. Some changes made in the Options
dialog take place immediately, while others take place after you restart Workbench.

Use the Restore Defaults button to reset the settings visible on the current page to their default values;
settings on other pages remain unchanged.

Note:

An IT manager can a place a site-wide configuration file into the installation directory of each
client machine to ensure that the Workbench software preferences are configured as the
company requires. To force a preference to be set to a particular value at startup, edit
\Program Files\ANSYS Inc\22.2\Framework\Site\SiteStartup.wbjn.

You can set user preferences in the following categories:

Project Management

Appearance

Regional and Language Options

Graphics Interaction

Journals and Logs

Project Reporting

Solution Process

Extensions

Mechanical APDL

CFX

Design Exploration

Distributed Compute Services

External Data

Fluent

Mechanical

Meshing

Engineering Data

Ansys Minerva

Microsoft Office Excel

TurboSystem
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Geometry Import

Material Designer

Project Management

From Tools → Options → Project Management, you can specify the following.

DescriptionPreference

Sets the file directory that is selected by default when saving or opening a
project.

When you select a different location for a project by browsing to it in
a dialog, Workbench remembers the folder location for subsequent

Default Folder for
Permanent Files

operations for the rest of the session; however, upon starting a new
session, the default returns to the location specified here.

To have Workbench determine the default location, select the Automat-
ically Determined by Workbench check box. To set the default location
yourself, clear the Automatically Determined by Workbench check
box and browse to the required folder.

Sets the folder where temporary files are written. The directory specified
here holds project files that are generated before the project is saved. Once
a project is saved, files are written to the project directory (p. 278).

Folder for Temporary Files

Sets the file compression level for archiving projects (p. 270) to the .wbpz
format. The default is 3. Possible values are 0 through 9, with 0 as no
compression and 9 as maximum compression.

.wbpz Compression Level

Specifies which licensing method to use. You can:Share a single license
between applications
when possible • Share a single license between applications (selected by default)

• Use a separate license for each application (clear the check box)

If you change this setting, you must restart Workbench for this setting
to take effect.

For more details on these licensing methods, see Ansys Workbench
Licensing Methods in the Ansys, Inc. Licensing Guide.

Appearance

From Tools → Options → Appearance, you can specify the following.

DescriptionPreference

Graphics Style

Controls the graphics style of the Ansys Workbench,DesignModeler, Meshing, and Mechanical applications.

Sets a solid graphic background or a gradient background that varies from
top to bottom, left to right, or diagonally. The default is the top to bottom
gradient.

Background Style
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DescriptionPreference

Sets a graphic background color from the built-in color palette. The default
color is blue.

Background Color

Sets a second graphic background color from the built-in color palette. The
second color is used for gradient background displays. For example, if you

Background Color2

want a top-bottom gradient that starts out white and ends up black, Back-
ground Color should be set to white and Background Color2 should be
set to black. The default color is white.

Sets the color of all text from the built-in color palette. The default color is
black.

Text Color

Sets the edge colors from the built-in color palette.Edge Colors

Sets the color of all meshed edges from the built-in color palette. The default
color is black.

Meshed

Display

Controls how Workbench displays information.

Sets the number of digits that appear for numbers in Ansys simulation
environments. The default is 5 and possible values are 3 through 10.

This setting affects only the numbers that are displayed. It does not
imply any numerical round-off of internal calculations.

Number of Significant
Digits

When a user-entered number has a decimal halfway between two
integers, the number is rounded to the nearest even integer. For
example, a value of 20.5 is rounded down to 20, while a value of 21.5
is rounded up to 22.

Sets the number of files that appear in the Recently Used Files list for both
the File menu and the context menus. The default is 4 and the maximum
number of files that you can display is 20.

If the number specified here exceeds the number of recently used files
that are available, the list displays the available number. This setting is
applied to the current Workbench session.

Number of Files in
Recently Used Files List

When selected, beta features are displayed with the word beta in parentheses.
This check box is cleared by default.

Beta features remain untested in this release and therefore are neither
documented nor supported and may result in unpredictable behavior.

Beta Options

The beta option on Linux for Mechanical Explicit Dynamics is not passed
to the solver and as such has no effect for solver related beta
functionality.

When selected, displays deprecated features, with the word unsupported in
parentheses, in the Toolbox. This check box is cleared by default.

While unsupported features may still be used in older projects, we
recommend updating projects to currently supported features. Because

Unsupported Features

these features are unsupported, they may not function correctly in
newer versions of the product.
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DescriptionPreference

When selected, displays text labels on toolbars. This check box is selected
by default.

This option applies to the Ansys Workbench interface, the Mechanical
application, the Meshing application, and DesignModeler only.

Text on Toolbars

When selected, displays connections between systems as a single link. The
label indicates all bundled connections. For example, linked systems that

Connections are Bundled
at Startup

shared Engineering Data, Geometry, and Model cells display a single link
with the notation 2:4, indicating that cells two (Engineering Data) through
four (Model) are connected. This check box is cleared by default.

This setting defines the initial default for all projects and can be
overridden within each project by selecting View → Show Connections
Bundled, or by selecting this option from the context menu on the
Project Schematic. Use of this option affects only newly created
projects.

When selected, displays the system label letters and numbers. This check
box is selected by default.

This setting defines the initial default for all projects and can be
overridden within each project by selecting View → Show System

System Coordinates are
Shown at Startup

Coordinates, or by selecting this option from the context menu on the
Project Schematic.

When selected, the quick help icon in cells where quick help is available.
The icon appears as a small blue triangle in the lower right corner of the
cell. This check box is selected by default.

Quick Help Icons in System
Cells

When selected, allows text in tables to wrap within the cells. This check box
is selected by default.

Word-wrap Text in Tables

Regional and Language Options

From Tools → Options → Regional and Language Options, you can specify the language used for
Workbench text and messages.

You can choose to use English, German, French, or Japanese, if localized files are available. Workbench
records the language selected at installation and specified from this option in the languageset-
tings.txt file. You can also manually edit the languagesettings.txt file to specify the language.
You must exit Workbench and start a new session for changes to the language option to take effect.

Workbench looks for the languagesettings.txt file in the following locations, in order:

1. %appdata%\Ansys\v222 on Windows or $HOME/.ansys/v222 on Linux

2. <install_dir>\Ansys Inc\v222\commonfiles\Language (Windows) or <in-
stall_dir>/ansys_inc/v222/commonfiles/language (Linux)

Be aware that not all external applications may be translated; therefore, you may see some text and
messages in English even if you have specified a different language.
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Graphics Interaction

From Tools → Options → Graphics Interaction, you can specify the following.

DescriptionPreference

Sets the action that the mouse wheel performs when used.Mouse Wheel

Sets the action that the mouse middle button performs when used.Middle Button

Sets the action that the mouse right button performs when used.Right Button

Sets the action that occurs when pressing Shift on the keyboard and clicking
the left mouse button simultaneously.

Shift +Left Button

Sets the action that occurs when pressing Shift on the keyboard and clicking
the middle mouse button simultaneously.

Shift +Middle Button

Sets the action that occurs when pressing Shift on the keyboard and clicking
the right mouse button simultaneously.

Shift +Right Button

Sets the action that occurs when pressing Ctrl on the keyboard and clicking
the left mouse button simultaneously.

Ctrl +Left Button

Sets the action that occurs when pressing Ctrl on the keyboard and clicking
the middle mouse button simultaneously.

Ctrl +Middle Button

Sets the action that occurs when pressing Ctrl on the keyboard and clicking
the right mouse button simultaneously.

Ctrl +Right Button

Sets the action that occurs when pressing Ctrl+Shift on the keyboard and
clicking the left mouse button simultaneously.

Ctrl +Shift +Left Button

Sets whether to zoom on a model by moving the mouse in or out.To Zoom In Closer

When selected, a short animation shows the model moving/twisting
toward its final pose if you make a standard view change (such as front,
back, left, right, bottom, top, isometric, and Look At Face/Plane/Sketch).

Dynamic Viewing During
Rotation

This check box is selected by default. Clear this check box if you are
using an older graphics card.

When selected, enables the use of the Spaceball 3D import device (not
supported in UNIX). This check box is selected by default.

Use Spaceball

Sets a limit in degrees for what kind of face and edge angles the system
considers smooth. This affects the Extend to Adjacent and Extend to Limits

Extend Selection Angle
Limit

Extend Selection toolbar buttons in DesignModeler. Extend Selection buttons
are also present in the Mechanical application.

The default value is 20° and the range is from 0° to 90°.

Sets the angular increment of the Configure tool when defining a joint.Angle Increment for
Configure Tool

Journals and Logs

From Tools → Options → Journals and Logs, you can specify the following.
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DescriptionPreference

When selected, records a journal file (p. 252) (.wbjn) for each Workbench
session and enables the other journal options.

Record Journal File

Selects the directory where journal files are written.

On Windows, the directory preference defaults to %TEMP%\Workbench-
Journals.

Journal File Directory

On Linux, the directory preference defaults to the following, in order:

1. $TEMP/WorkbenchJournals

2. $TMP/WorkbenchJournals

3. $HOME/.ansys/WorkbenchJournals

If you record a session for future playback, the same information is
written to both the location specified here and to the file specified
when you begin recording.

Sets the number of days to keep journal files. The default is 7.Days to Keep Journal File

When selected, adds a pause after each command when running a journal
file. Also enables the Seconds to Pause field.

When running a journal
file, pause after each
command

Sets the number of seconds to pause between commands. The default is 1.Seconds to Pause

When selected, writes two log files for each Workbench session and
enables the other log file options. The two files are:

Write Workbench Log Files

• UIEventsprocID.log

• CoreEventsprocID.log

where procID is the process ID of the Workbench session. To identify
the log file of the most recent session, it is most convenient to sort the
directory by date. The log file contains information that is useful to
technical support whenever an error is encountered. Other applications
may continue to write log files to their own directories, even if launched
from Workbench.

Selects the directory where log files are written.

On Windows, the directory preference defaults to %TEMP%\Workbench-
Logs.

Workbench Log Files
Directory

On Linux, the directory preference defaults to the following, in order:

1. $TEMP/WorkbenchLogs

2. $TMP/WorkbenchLogs

3. $HOME/.ansys/WorkbenchLogs
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DescriptionPreference

The log file directory preference takes effect immediately when the
Options dialog is closed.

Sets the number of days to keep log files. The default is 7.Days to Keep Workbench
Log File

Project Reporting

From Tools → Options → Project Reporting, you can set if exported reports automatically open in a
browser (p. 266) when they are generated.

Solution Process

From Tools → Options → Solution Process, you can specify the defaults for many of the solution
process properties of Solution cells. For projects with parametric design points, these settings also
control the defaults for the design point update process setting for the Parameter Set bar. For more
information on using these properties to submit a job to Remote Solve Manager (RSM), see Submitting
Solutions to Remote Solve Manager (p. 321).

DescriptionPreference

Sets how the solution is run by default. Select from the following:Default Update Option

• Run in Foreground: The solution runs within the current Workbench
session.

• Run in Background: The solution runs in the background on the
local machine. This option is available only for Solution cells that
support background execution.

• Submit to Remote Solve Manager: The solution runs in the
background either on the local computer or, if Remote Solve Manager
is configured, on one or more remote computers. If you submit to
RSM, the solution continues to run even if you close the current
Workbench session.

If you have not defined configurations in RSM, or obtained configurations
from your RSM administrator, see RSM Configuration in the Remote Solve
Manager User's Guide.

Specifies the starting condition of each design point for design point updates.
By default, when each design point is updated, the design point is initialized

Default Design Point
Update Order

with the data of the design point designated as Current (except for retained
design points with valid retained data, which do not require initialization
data). However, in some cases it may be more efficient to update each design
point starting from the data of the previously updated design point, rather
than restarting from Current each time.

• Update From Current: Causes each design point to be initialized
from the Current design point. This is the default value.
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DescriptionPreference

• Update Design Points in Order: Causes each design point to be
initialized from the previous design point.

If you selected One Job for Each Design Point in the Default Job
Submission field, the Default Design Point Update Order is applicable
only if you also selected Geometry in the Pre-RSM Foreground Update
field.

This setting takes effect the next time you create a new project. See
Changing the Design Point Update Order (p. 310) for more information.

When selected, enables the Interconnect and MPI Type parallel run settings
available for Fluent RSM runs. These settings require that the remote compute

Show Advanced Solver
Options

servers can accept the Interconnect and MPI Type that you specify;
compatibility is not checked automatically.

Specifies how an update is performed for retained design points. Select one
of the following options:

Retained Design Point

• Update parameters: Only parameters are updated for retained design
points. If a component is not needed to get the value of an output
parameter, it is not updated. This is the default value.

• Update full project: Full project is updated for retained design points.
Use this setting if you want to generate reports, or other content,
from components that do not produce output parameters.

Sets the RSM queue that is selected by default when you select the Submit
to Remote Solve Manager update option. The list of available queues

Default RSM Queue

depends on the configurations that are available in the RSM configuration
directory. See Sharing and Accessing RSM Configurations in the Remote Solve
Manager User's Guide.

Sets the default name that appears in the Job Name field. The name must
start with an alphanumeric character, must not contain spaces or the
characters ! @ $ * ? \ and must not be longer than 15 characters.

Default Job Name

When selected, enables the solver monitor to periodically query RSM for
output files in order to display progress (where applicable).

Download Progress
Information by Default

Specifies the time interval, in seconds, between solver queries to RSM in
order to display progress. The default is 30. Setting this value to zero (0)

Default Progress
Download Interval
(Seconds) results in continuous queries; that is, as soon as files are downloaded from

the compute server, Workbench immediately queries again. This option is
available for CFX systems only.

Specifies if you want the solution to run in serial or parallel mode. The default
is Serial. The parallel option is available only if the selected solver supports
parallel execution mode.

Default Execution Mode

Specifies the default number of processes to use if you choose to run in
parallel mode. Must be set to 2 or greater.

Default Number of
Processes
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DescriptionPreference

Specifies how geometry is handled before submitting project updates to
RSM. Select one of the following options:

Pre-RSM Foreground
Update

• None: Submits project updates to RSM without updating the geometry
locally.

• Geometry: Updates your geometry locally before submitting project
updates to RSM.

Extensions

From Tools → Options → Extensions, you can configure settings for Ansys ACT extensions.

For more details on these options, see Extension Configuration in the ACT Developer's Guide.

DescriptionPreference

Defines the additional folders where ACT searches for the extensions that
the Extension Manager displays. You can define several folder names,
separating them with a semicolon (;).

Additional Extension Folders

Specifies whether to save binary extensions within the project when the
project is saved.

Save Binary Extensions with
Project

When selected, enables debug mode for IronPython scripts of loaded
extensions.

Debug Mode

Mechanical APDL

From Tools → Options → Mechanical APDL, you can specify the following.

For more details on these options, see The File Management Tab in the Operations Guide.

DescriptionPreference

Sets the startup command line options.Command Line Options

Specifies the portion (in megabytes) of total memory that the database
uses for the initial allocation. The default is 1024.

Database Memory (MB)

Specifies the initial allocation of memory (in megabytes) requested for the
Mechanical APDL run. The default is 2048.

Workspace Memory (MB)

Sets the number of cores used for parallel processing.Utilized cores

Defines the base filename used for all files generated by the Mechanical
APDL session. The default is file. You can change it to any alphanumeric
string up to 32 characters long.

Job Name

Sets the default license level.License

Sets the graphics device. The user interface requires a terminal that supports
graphics.

Graphics Device

When selected, activates distributed computing settings.Distributed
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DescriptionPreference

Specifies machine information for distributed computing.Machine List

Provides access to the Graphics Processing Unit (GPU) acceleration capability
offered in the Project Schematic and inside Mechanical APDL. Three options
are available, None, NVIDIA and Intel. The default is None.

Selecting this option from Options → Mechanical APDL applies the
setting to all newly added systems in the Project Schematic. You can

GPU Accelerator

override these settings by changing the GPU Accelerator selection on
individual systems by right-clicking Analysis and editing the properties.

Specifies the number of GPUs each machine has. The default is 1.Number of GPUs per
Machine

When selected, reads the start.ans file at start-up.Read START.ANS

Sets a custom Mechanical APDL executable to start in the launcher.Custom Executable Path

When selected, downloads all distributed files.Download Distributed Files

CFX

From Tools → Options → CFX, you can specify the following.

For more details on these options, see Properties Pane in the CFX Introduction.

DescriptionPreference

When selected, deletes any associated old solution data automatically
after updating the Solution cell.

Keep Latest Solution Data
Only

When selected, retains cached solution data for non-current design
points (in addition to the current design point) after they are solved.

Cache Solution Data

Sets how data is gathered to initialize the solution.Initialization Option

Sets the option used to resolve execution control conflicts.

For more information, see Troubleshooting in the CFX Introduction.

Execution Control Conflict
Option

Design Exploration

From Tools → Options → Design Exploration, you can specify the following.

DescriptionPreference

When selected, displays advanced properties (in italics) for certain
DesignXplorer objects in the Properties pane.

Show Advanced Options

When selected, saves design points created for a design exploration cell to
the project’s design points table once the solution completes. Also enables
the Retain Data for Each Preserved Design Point check box.

Preserve Design Points after
DX Run

When selected, retains data for each design point saved in the project’s
design point table.

Retain Data for Each
Preserved Design Point
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DescriptionPreference

When selected, enables additional attempts to solve design points that
failed to update during the first run. Also enables Number of Retries and
Retry Delay (seconds).

Retry All Failed Design
Points

Sets the number of times to try to update failed design points. The default
is 5.

Number of Retries

Sets the number of seconds to elapse between tries. The default is 120.Retry Delay (seconds)

Sets the number of points for a continuous input parameter axis in a 2D
or 3D Response Surface chart. The range is from 2 to 100. The default is
25. Increasing the number of points enhances the chart resolution.

Chart Resolution

Sets the relative importance or significance to assume for input variables.
The allowable range is from 0.0 to 1.0, where 0 means that all input

Significance Level

variables are assumed to be insignificant and 1.0 means that all input
variables are assumed to be significant. The default is 0.025.

Sets the calculation method for determining sensitivity correlation
coefficients. The default is Rank Order (Spearman).

Correlation Coefficient
Calculation Type

When selected, displays full parameter names rather than short parameter
names.

Display Parameter Full
Name

Sets the naming style for input parameters within design exploration. The
default is Uncertainty Management Style.

Parameter Naming
Convention

When selected, displays an alert before performing a Min-Max search
operation when there are discrete input parameters to warn that the search
could be time-consuming.

Confirm if Min-Max Search
can take a long time

Note:

If you expand Design Exploration in the tree, you will see three child tabs: Design of
Experiments, Response Surface, and Sampling and Optimization. For more information
about the options on all four DesignXplorer tabs, see Design Exploration Options in the
DesignXplorer User's Guide.

Distributed Compute Services

From Tools → Options → Distributed Compute Services, you can specify the following.

DescriptionPreference

Sets the URL for starting the DC server. The default for starting a local server
is https:/localhost/dcs. The format of a URL for starting a remote

Server URL

server is https://hostname:port/dcs or https://IPad-
dress:port/dcs.

When selected, automatically starts an evaluator on the local machine when
design point updates are requested. This check box is selected by default.

Auto-Start Local Evaluator

If you clear this check box, you can start the evaluator on the local machine
by going to the Windows Start menu and selecting DC Evaluator. You can
also start it from the command line by typing dclauncher.exe start
evaluator.
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External Data

From Tools → Options → External Data, you can specify the following.

DescriptionPreference

Sets how the External Data file is handled when importing External
Data (p. 109).

Files Import Type

• By Copy: Copies the External Data file into the project folder.

• By Reference (default): Directly references the External Data file. For
large size files, this drastically reduces disk storage requirements and
improves performance.

Fluent

From Tools → Options → Fluent, you can specify the following.

General options apply to all Fluent-based systems in the Workbench project, regardless of whether the
system was created before, or after, the option is enabled. Note that these options are not saved with
the project, and the settings are always applied to the currently loaded project.

Default options for new Fluent system apply to all newly created Fluent-based systems in the Workbench
project. They can be overridden by editing the properties specified for the Setup and Solution cell.
The settings specified in the Setup and Solution cell properties are always respected and saved with
the Workbench project. Therefore, for previously saved projects, these saved settings are used.

DescriptionPreference

General Options

When selected, displays a warning message when solution data exists and
you attempt to open Fluent from the Setup cell.

When you open Fluent from the Setup cell, the mesh and settings file
associated with the Setup cell are loaded into Fluent which may or
may not be what you want.

Show Warning on Editing
Setup if Solution Has
Current or Initial Data

The check box is selected by default.

When selected, old solution data is automatically removed when starting
a new computation.

The check box is selected by default.

Automatically Delete Old
Solutions On Start Of New
Calculation

When selected, reuses the Fluent session for other design point calculations.
This option works with foreground parametric updates only.

The check box is cleared by default.

Reuse Fluent Session for
Design Points

Default Options for New Fluent System
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DescriptionPreference

When selected, displays the Fluent Launcher when Fluent starts.

The check box is selected by default.

Show Launcher at Startup

When selected, displays the mesh after the mesh or case/data is read into
Fluent.

The check box is selected by default.

Display Mesh After Reading

When selected, embeds the graphics windows in the Fluent application
window.

When cleared, unlocks the graphics windows so they are free-standing.

Embed Graphics Windows

The check box is selected by default.

When selected, sets the graphics window to the Workbench color scheme.

When cleared, sets the graphic window to the classic black background
color.

Use Workbench Color
Scheme

The check box is selected by default.

When selected, allows you to specify compiler settings for compiling
user-defined functions (UDFs) with Fluent.

The check box is selected by default.

Set up Compilation
Environment for UDF

Sets either the single-precision or the double-precision solver.Precision

When selected, bypasses loading the mesh and setting files and reapplying
the pre-set mesh operations every time the Setup cell is edited, resulting
in faster runs.

This option is especially beneficial when computing simulations across
multiple design points involving Fluent-related parametric changes.

Enable Generation of Setup
Output Case File

The Fluent solver automatically generates the output case file,
name-Setup-Output.cas, every time you modify the mesh, set
mesh operations prior to running the simulation in Fluent, or start a
Fluent session with a mesh file only.

The generated output case file is used when launching the next Fluent
session from the Setup cell if the regular case file is out-of-date or not
available.

The check box is selected by default.

When selected, allows you to be graphically view Fluent solution
convergence and monitor data without having Fluent open.

Once this option is enabled, you can use the Show Solution
Monitoring option in the Solution cell context menu to display
convergence and monitor charts.

Enable Solution Monitoring

This check box is selected by default.
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DescriptionPreference

When selected, Instructs the Fluent solver to automatically generate an
interpolation file, *.ip, at the end of the run. Unlike the *.dat file, the

Enable Generation of
Interpolation File

*.ip file can be used to restart the Fluent session, even if the mesh has
been modified

This check box is cleared by default.

Mechanical

From Tools → Options → Mechanical, you can specify the following.

DescriptionPreference

When selected, enables computed contact detection when geometry is
imported into Mechanical.

This check box is enabled by default.

Auto Detect Contact On
Attach

When selected, enables the default setting for the Save Mesh Data In
Separate File property in Mechanical systems (such as Static Structural) for

Save Mesh Data In
Separate File

subsequently created Mechanical systems. The property setting controls
whether mesh data is stored in a separate .acmo file for the current system.

Saving the mesh data in a separate file reduces the overall file space
required and reduces the possibility of disc corruption in very large
database files on Linux systems.

Specifies when the Mechanical application releases its license when running
in batch mode:

Release License for
Pending Jobs

• On Demand: When the Solution cell for a Mechanical system is in
the pending state during a batch run, the right-click menu has a
Release License option. This closes the Mechanical application but
does not interfere with the completion of the run. (Default)

• Always: Causes the Mechanical application to automatically close
and release its license during batch runs when the Solution cell is
in the pending state.

• Design Point Run Only: Causes the Mechanical application to
automatically close and release its license during Update All Design
Points runs when the Solution cell is in the pending state.

When selected, causes Mechanical not to copy design point results data
when parameters are changed in Mechanical simulations, as the design
points are re-evaluated in those cases.

Note that no working directory files (such as macros) are copied, so to
use this setting you must move any files that you have put into the

Maximize Design Point
Performance

working directory (the solver files directory) to the user_files
directory.
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DescriptionPreference

Sets the number of seconds between each query to Remote Solve Manager
for the Mechanical solution update job status. The default is 20. This setting
only takes effect when the Mechanical solution is submitted to RSM.

Remote Job Status Check
Interval in Seconds

When selected, directs the Mechanical application to automatically restart
after the specified number of design points when running in batch mode.

Each restart resets the Mechanical application and slightly lengthens
the processing time, but can improve overall system performance

During a design point
update, periodically restart
the Mechanical application

(memory and CPU) when the generation steps of each design point
(geometry, mesh, solve, post processing) are long. In such cases, specify
a low number of design points before restarts.

In cases where the generation steps for each design point are short,
reduce processing time by increasing the number of design points
before restarts or prevent restarts completely by disabling this
preference.

Sets the number of design points to update when the During a design
point update, periodically restart the Mechanical application check box
is selected. The default is 1.

Number of design points
to update before restarting
the Mechanical application

When selected, sets the number of cores used by the data transfer mapping,
interpolation operations and result postprocessing to a user-specified value.

Limit Number of Cores for
Data Mapping and
Post-Processing

Sets the maximum number of cores used when the Limit Number of Cores
for Data Mapping and Post-Processing check box is selected. The default
is 2.

Maximum number of cores

Select one or more check boxes to enable Mechanical beta features in
Workbench.

Beta features selection

Meshing

From Tools → Options → Meshing, you can specify the following.

DescriptionPreference

When selected, enables contact detection computing when geometry is
imported into Meshing.

This check box is selected by default.

Auto Detect Contact On
Attach

When selected, enables the default setting for the Save Mesh Data In
Separate File property in Mechanical systems (such as Static Structural) for

Save Mesh Data In
Separate File

subsequently created Mechanical systems. The property setting controls
whether mesh data is stored in a separate .acmo file for the current system.

Saving the mesh data in a separate file reduces the overall file space
required and reduces the possibility of disc corruption in very large
database files on Linux systems.
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DescriptionPreference

When selected, directs the Meshing application to automatically restart after
the specified number of design points when running in batch mode.

Each restart resets the Meshing application and slightly lengthens the
processing time, but can improve overall system performance (memory

During a design point
update, periodically restart
the Meshing application

and CPU) when the meshing of each design point is long. In such cases,
specify a low number of design points before restarts.

In cases where the meshing step for each design point are short, reduce
processing time by increasing the number of design points before
restarts or prevent restarts completely by disabling this preference.

Sets the number of design points to update when the During a design
point update, periodically restart the Meshing application check box is
selected. The default is 1.

Number of design points
to update before restarting
the Meshing application

Engineering Data

From Tools → Options → Engineering Data, you can specify the following.

DescriptionPreference

When selected, filters Toolbox content based on your selection in the
Properties pane.

Filter toolbox content for
selection

When selected, clears the default material used when materials are
imported with geometry attached.

Unset the default material
when materials are imported
with geometry.

When selected, consolidates the material information when it is imported
into Workbench.

Consolidate materials on
import

Ansys Minerva

From Tools → Options → Ansys Minerva, you can specify the following.

DescriptionPreference

Sets the method to used to authenticate with Ansys Minerva. Select the method
that matches what is configured for the Ansys Minerva server. Select from the
following options:

Authentication
Type

• Basic—Uses a username and password to authenticate using the internal
mechanism within Ansys Minerva.

• Browser—Uses the browser to authenticate. If you are logged into Ansys Minerva
in the browser, those credentials are used.

• Windows—Uses Active Directory to pass the credentials of the user currently
logged into the Ansys Minerva server.

Sets the URL of the Ansys Minerva server that Workbench connects to.Server URL
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DescriptionPreference

Sets the name of the Ansys Minerva database to access.Database

Microsoft Office Excel

From Tools → Options → Microsoft Office Excel Options, you can specify the following for the Microsoft
Office Excel add-in.

DescriptionPreference

Sets a prefix to filter which Excel named ranges are exposed as parameters
in a Workbench project.

All named ranges defined in the Excel file that include that prefix are
displayed as parameters in the project. By default, this setting is blank
(no filter).

Named Ranges Filtering
Prefix

If you specify a prefix, the prefix is used to filter the named ranges for
all new design exploration systems. For example, if you set this option
to WB, the Named Range Key property (in the Setup section of the
Properties pane of the Microsoft Office Excel Analysis system) is set to
WB for all new projects you create.

If you have specified a different filtering prefix the project level in the
Named Range Key property, the project-level setting is not affected by
changes to this option.

TurboSystem

From Tools → Options → TurboSystem, you can specify the following.

DescriptionPreference

When selected, causes subsequently created Turbo Mesh cells to have the
Meshing → Inlet Domain and Meshing → Outlet Domain properties
initially selected.

Include inlet/outlet domains
in Turbo Mesh cells by
default

Controls the default value of the Data Transfer → Geometry Transfer
Type property of subsequently created Blade Design cells.

Data transfer type

Geometry Import

From Tools → Options → Geometry Import → Geometry Import, you can specify the following.
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DescriptionPreference

Sets the geometry editor. You can select from DesignModeler or SpaceClaim
Direct Modeler (default).

Note:

The SpaceClaim Direct Modeler option is not available when
the Use SpaceClaim Direct Modeler as an External CAD
option is enabled.

Preferred Geometry Editor

Sets how the CAD license is kept or released.CAD Licensing

• Hold: Instructs Workbench to keep the license after the import or
refresh operation has completed. The option is useful when executing
design studies.

If the Hold option was previously set and subsequently changed to
Release, the license is released immediately after clicking OK in the
Options dialog box. A plug-in license that is held is always released
when exiting the Workbench session.

• Release (default): Instructs Workbench to free the license for someone
else's use after the import or refresh operation has completed.

Note:

The CAD Licensing option is not supported for geometry
import into SpaceClaim Direct Modeler. Regardless of the
setting of CAD Licensing, SpaceClaim Direct Modeler always
releases its CAD licenses after importing.

When selected, SpaceClaim is controlled as an external CAD system, with
no direct integration into the Project Schematic.

When cleared, SpaceClaim is fully integrated into the Project Schematic
as a geometry editor.

Use SpaceClaim Direct
Modeler as an External
CAD

This check box is cleared by default.

Note:

• Switching this preference from within an active project
could result in project schematic inconsistencies and
undesired behavior. We recommend that you set this
preference during project creation and ensure that all users
interacting with the project do not change it.

• If the preference must be changed, the Geometry systems
that reference SpaceClaim geometry should be Reset and
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DescriptionPreference

reconfigured to properly release any previously stored
parameters and file references.

• You cannot use SpaceClaim with meshing tools enabled
as an external CAD system. If the meshing options are
enabled and this preference is selected, the following error
message is displayed when you connect to a downstream
system:

Can not use SpaceClaim w/Meshing as an
external CAD system. Please change your
settings.

When selected, SpaceClaim Direct Modeler adopts the units of the Workbench
project when it is launched from Workbench.

Use Workbench Project
Units for Length and
Angle

When selected, SpaceClaim Direct Modeler adopts the language used by
Workbench when it is launched from Workbench Project Schematic.

Use Workbench Language
Settings

Controls the visibility of the geometry editor during a design point update.Geometry editor behavior
during update

• Default: The update is run in batch mode. If the geometry editor was
open prior to the update, it is reopened at the completion of the
update.

• Run interactively: Forces the geometry editor to be run interactively
for the entire update. If the geometry editor was open prior to the
update, it is reopened at the completion of the update.

• Run in batch mode: Forces the geometry editor to be run in batch
mode for the entire update. The geometry editor is left closed at the
completion of the update.

When selected, directs the geometry editor to stay open (in batch or
interactively based on the setting of Geometry editor behavior during

Keep the geometry editor
running for optimized
design point updates update) and use the same session during a design point update. Allows for

quicker processing time as the geometry editor is not restarted after each
design point.

When selected, directs the geometry editor to automatically restart after the
specified number of design points (as specified by the setting of Number
of design points to update before restarting the geometry editor).

Periodically restart the
geometry editor

Sets the number of design points that are updated before the geometry
editor is restarted. The default is 0, which executes the same as if this
preference were disabled.

Number of design points
to update before
restarting the geometry
editor

Each restart resets the geometry editor and slightly lengthens processing
time, but can improve overall system performance (memory and CPU)
when the time needed for the geometry update of each design point
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DescriptionPreference

is long. In such cases, specify a low number (1 or more) of design points
before each restart. In cases where the time needed for the geometry
update of each design point is short, reduce processing time by
increasing the number of design points before each restart, or prevent
restarts completely by disabling this preference.

For detailed descriptions of the basic geometry import options, see the Basic
Geometry Options table in Geometry Preferences.

Basic options

For detailed descriptions of the advanced geometry import options, see the
Advanced Geometry Options table in Geometry Preferences.

Advanced options

Material Designer

From Tools > Options > Material Designer, you can specify the following:

DescriptionPreference

Controls the visibility of Material Designer during a design point
update.

Material Designer
behavior during
update

• Default: The update is run in batch mode. If Material Designer
was open prior to the update, it is reopened at the completion
of the update.

• Run interactively: Forces Material Designer to run interactively
for the entire update. If Material Designer was open prior to
the update, it is reopened at the completion of the update.

• Run in batch mode: Forces Material Designer to run in batch
mode for the entire update. Material Designer is left closed at
the completion of the update.

When selected, directs Material Designer to stay open (in batch
or interactively, based on the setting of Material Designer be-

Keep Material
Designer running

havior during update) and use the same session during a designfor optimized design
point updates point update. Allows for quicker processing time as Material

Designer is not restarted after each design point.

When selected, directs Material Designer to restart automatically
after the specified number of design points (as specified by the

Periodically restart
Material Designer

setting Number of design points to update before restarting
Material Designer).

Sets the number of design points that are updated before
Material Designer is restarted. The default is 0, which executes
as if this preference were disabled.

Number of design
points to update
before restarting the
Material Designer

Each restart resets Material Designer and slightly lengthens
processing time, but restarts can improve overall system
performance (memory and CPU) when the time needed for the
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DescriptionPreference

update of each design point is long. In such cases, specify a low
number of design points (1 or more) before each restart.

In cases where the time needed for the update of each design
point is short, you can reduce processing time by increasing the
number of design points before each restart, or you can prevent
restarts by disabling this preference altogether.
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Workbench Interface Reference
The following user interface components are discussed in detail:

Tabs in Workbench

Panes within Tabs

Cells in Workbench

Menus in Workbench

Tabs in Workbench

Tabs are workspaces that allow you to interact with different parts of your project. Most cells of a system
open in separate windows outside of the Workbench application; the following is a list of tabs for systems
and cells that open within Workbench.

• 3D ROM

• Analysis (p. 192) (Mechanical APDL)

• Analysis (p. 206) (Microsoft Office Excel)

• System Coupling (p. 219)

• Design of Experiments

• Direct Optimization

• Engineering Data

• External Data (p. 108)

• External Model (p. 129)

• Parameter Set (p. 298)

• Parameters Correlation

• Project (p. 47)

• Response Surface

• Response Surface Optimization

• Six Sigma Analysis
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Panes within Tabs

Workbench provides the following categories of panes.

Common Panes

Common panes are ones that are included on multiple tabs, but are configured per tab. changes to the
pane on one tab are not reflected on other tabs of the same sort, the pane contains different data on
each tab.

The following common panes are available:

• Project Schematic Pane (p. 440)

• Toolbox Pane (p. 441)

• Toolbox Customization Pane (p. 443)

• Files Pane (p. 443)

• Outline Pane (p. 443)

• Properties Pane (p. 444)

• Table Pane (p. 445)

• Chart Pane (p. 445)

• Scene Pane (p. 445)

• Solution Information Pane (p. 445)

Persistent Panes

Persistent panes remain configured as you have specified when you navigate between tabs. For example,
if you display a persistent pane in one tab, then switch to a different one, the persistent pane remains
visible in the second tab.

The following persistent panes are available:

• Messages Pane (p. 446)

• Progress Pane (p. 446)

• Sidebar Help (p. 447)

Project Schematic Pane

Located in the Project tab, the Project Schematic pane is the main workspace for your project.
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Opening the Properties pane allows you to manage the following properties for the Project
Schematic pane.

DescriptionProperty

Displays all project notes (p. 241)
created.

Notes

Toolbox Pane

Located in the Project tab, the Toolbox pane contains the types of data you can add to your project.

To add data, you take the systems located in the Toolbox pane and add them to the Project
Schematic pane.

Systems are divided into categories which can be expanded or collapsed to show or hide the systems
in that category. You can select systems from the following categories:

• Analysis Systems (p. 74)

• Component Systems (p. 102)

• Custom Systems (p. 223)
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• Design Exploration (p. 229)

The contents of each category are determined by which products you have installed and what licenses
are available. If you do not have a particular product installed or do not have an available license,
the individual systems corresponding to that product are not shown in the Toolbox.

For detailed information on system categories and individual systems, see Working Through a Sys-
tem (p. 67).

Additionally, you can customize the Toolbox further, specifying that only some of the available systems
are visible. For customization details, see Configuring the Toolbox (p. 25).
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The Toolbox pane persists across tabs. It contains systems on the Project tab, but on other tabs it
contains other sorts of information, such as charts, and engineering materials.

Toolbox Customization Pane

The Toolbox Customization pane enables you to specify which systems display in the Toolbox. For
more information, see Configuring the Toolbox (p. 25).

Files Pane

The Files pane shows a list of all files associated with, and added to, the project. It enables you to
see the name and type of file, the IDs of the cells the file is associated with, the size of the file, the
location of the file, and other information.

For more information on how to manage and work with the files shown in the pane, see Working in
the Files Pane (p. 273).

Outline Pane

When data is available for an item, the Outline pane presents data in a summary form. You can access
the Outline pane in the Project tab, the Parameter Set tab, the Parameters tab, or the tab for any
cell in a Design Exploration or Engineering Data system.
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To open the Outline pane, double-click the Parameter Set bar or a system cell. Or, right-click the
cell and select Edit from the context menu.

Examples of the Outline pane include the Outline of All Parameters in the Parameter Set tab and
the Outline of Schematic in an application tab.

For information about using the Outline pane for parameters and design points, see Working with
Parameters and Design Points (p. 283).

Properties Pane

The Properties pane enables you to see properties for the Project Schematic, systems, cells, and
schematic links.

The specific items shown in the Properties pane varies according to what you have selected.

Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.444

Workbench Interface Reference



In some cases, it displays basic information about the component that cannot be modified from the
Properties pane. For example, if you choose to view properties on a link between systems, a list of
uneditable connection properties (for example, type and from/to cell identifiers) is displayed.

In other cases, the Properties pane displays detailed information that can be edited. For example, if
you choose either Edit or Properties from the Vista TF Setup cell, a fully-editable list of properties
is displayed.

If more information on a specific Properties pane is available, you can view the quick help for the
cell for which you are viewing properties.

Table Pane

When the Table pane is included in a tab, it allows you to view project data in table format. Examples
of the Table pane are the Table of Design Points in the Parameter Set tab and the Table of
Properties in an Engineering Data tab.

Some tables are editable and some are not. In general, if you can add a new row, you an asterisk is
displayed (*) in the last row. If a cell is editable, you can double-click in the cell to select the content
and change it. In some tables, columns may include a drop-down menu of additional actions that
are available for that column. Tables for different applications and different purposes have different
features and behavior. See the documentation for the specific application for details on using tables.

Chart Pane

When the Chart pane is included on a tab, it enables you to view charts that have been added and
generated for the project. Each type of tab has different charts available. For example, the Parameter
Set tab has a different set of charts than the DesignXplorer Parameters Correlation tab has.

For more information about using charts, see Working with the Chart Pane (p. 255).

Scene Pane

The Scene pane is available in the Fluent interface. To activate the Scene pane, enable Show Solution
Monitoring from Fluent (right-click the Solution cell of a Fluent system to open the Fluent Solution
Monitor). For more information, see Monitoring Fluent Solutions in Workbench in the Fluent in
Workbench User's Guide.

Solution Information Pane

The Solution Information pane is available in the System Coupling or Fluent system’s interface. For
more information, see System Coupling User's Guide or Fluent in Workbench User's Guide.
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Messages Pane

The Messages pane displays any messages you have, such as error and warning messages, solver
messages, status messages, and so on.

During any update (cell, system, project, design point, multiple design point), any messages that are
generated are displayed in the Messages pane. The Messages pane opens automatically if an error
message occurs during an update, but in other situations you must open it manually.

You can display or hide the Messages pane by clicking Show Messages or Hide Messages in the
lower right corner of any Workbench tab.

Progress Pane

The Progress pane displays a progress bar during an update. You can display or hide the Progress
pane by clicking Show Progress or Hide Progress in the lower right corner of the window. You can
also interrupt an update process (p. 245).
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Sidebar Help

The Sidebar Help pane displays context sensitive help text and links. For more information on using
this pane, see Using Help (p. 22).

Cells in Workbench

The systems that you add to the Project Schematic are made up of one or more cells.

Related topics:

Types of Cells

Understanding Cell States

Cell Properties

Types of Cells

The following common types of cells occur in many of the analysis and component systems available
in Workbench; Other cell types may be available in certain systems; see the application-specific doc-
umentation in Working Through a System (p. 67) for these cell descriptions.

Engineering Data

Use the Engineering Data cell with Mechanical systems or the Engineering Data component sys-
tem (p. 107) to define or access material models for use in an analysis. To define material data, open
the Engineering Data tab by either double-clicking the Engineering Data cell or right-clicking the
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cell and selecting Edit from the context menu. For more information, see Overview in the Engineering
Data User's Guide.

Geometry

Use the Geometry cell to import, create, edit or update the geometry model used for analysis. Right-
click the cell to access these functions in the context menu. The right-click options are context sens-
itive and change as the state of your geometry changes, so not all of the options are available at all
times.

Note:

The SpaceClaim Direct Modeler features are available only if you have SpaceClaim Direct
Modeler installed and the Ansys SpaceClaim Direct Modeler license available.

Model/Mesh

The Model cell in the Mechanical application analysis systems or the Mechanical Model component
system is associated with the Model branch in the Mechanical application and affects the definition
of the geometry, coordinate systems, connections and mesh branches of the model definition.

When linking two systems, you cannot create a share between the Model cells of two established
systems. You can generate a second system that is linked at the Model cell of the first system, but
you cannot add a share after the second system has been created. Likewise, you cannot delete a link
between the Model cells of two systems.

The Mesh cell in Fluid Flow analysis systems or the Mesh component system (p. 202) is used to create
a mesh using the Meshing application. It can also be used to import an existing mesh file.

Setup

Use the Setup cell to launch the appropriate application for that system. You define your loads,
boundary conditions, and configure your analysis in the application. The data from the application
is incorporated into the project in Workbench, including connections between systems.

Solution

From the Solution cell, you can access the Solution branch of your application, and you can share
solution data with other downstream systems (for instance, you can specify the solution from one
analysis as input conditions to another analysis). If you have an analysis running as a remote process,
the Solution cell is in a Pending (p. 449) state until the remote process completes.

Results

The Results cell indicates the availability and status of the analysis results (commonly referred to as
postprocessing). From the Results cell, you cannot share data with any other system.
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Understanding Cell States

Workbench integrates multiple applications into a single, seamless project flow, where individual cells
can obtain data from and provide data to other cells. As a result of this flow of data, a cell's state can
change in response to changes made to the project. Workbench provides visual indications of a cell's
state at any given time with icons on the right side of each cell.

Typical Cell States

DescriptionIconState

Required upstream data does not exist. Some applications may
not allow you to open them with the cell in this state. For

Unfulfilled

example, if you have not yet assigned a geometry to a system,
all downstream cells appear as unfulfilled, because they cannot
progress until you assign a geometry.

Upstream data has changed since the last refresh or update.
You may or may not need to update output data. When a cell

Refresh
Required

is in this state, you can edit the cell, refresh the data, update
upstream components, or update the cell.

The advantage to refreshing rather than updating a cell is
that you are alerted to potential effects on downstream
cells and make any necessary adjustments before you
update it. This option is especially useful if you have a
complex system in which an update could take significant
time and computer resources.

All of the cell's inputs are current. However, you must take a
corrective action to proceed. To complete the corrective action,

Attention
Required

you may need to interact with this cell or with an upstream cell
that provides data to this cell. Cells in this state cannot be
updated until the corrective action is taken.

This state can also signify that no upstream data is
available, but you can still interact with the cell. For
instance, some applications support an "empty" mode of
operation in which it is possible to enter the application
and perform operations regardless of the consumption of
upstream data.

Local data has changed and the output of the cell must be
updated.

Update
Required

An update has been performed on the cell and no failures have
occurred. It is possible to edit the cell and for the cell to provide
up-to-date generated data to other cells.

Up to Date

The cell is locally up-to-date but may change when next updated
as a result of changes made to upstream cells.

Input Changes
Pending

Solution-Specific States

The Solution or Analysis cell for certain solvers can display the following solution-specific states.
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DescriptionIconState

Indicates that you have interrupted the solution during an
update, leaving the cell paused in an update required state.

This option performs a graceful stop of the solver, which
completes its current iteration. Although some calculations

Interrupted,
Update
Required

may have been performed, output parameters are not
updated. A solution file is written containing any results
that have been calculated. The solve resumes with the next
update command.

Indicates that you have interrupted the solution during an
update, leaving the cell in an up-to-date state.

This option performs a graceful stop of the solver, which
completes its current iteration. Output parameters are

Interrupted,
Up to Date

updated according to the calculations performed so far, and
a solution file is written. You can use the solution for
postprocessing. For example, you can look at the
intermediate result. Because the cell is already up-to-date,
it is not affected by a design point update.
To resume the solve, right-click and select Continue Calculation
from the context menu.

Signifies that a batch or asynchronous solution is in progress.
When a cell enters the pending state, you can interact with the

Pending

project to exit Workbench or work with other parts of the project.
If you make changes to the project that are upstream of the
updating cell, then the cell is not in an up-to-date state when
the solution completes.

Note:

When up-to-date cells are connected to cells in a different type of system, the state of the
up-to-date cells may change to Update Required. This behavior occurs because additional
files have to be generated to satisfy the newly added system.

For example, assume that you have built a fluid flow system (Fluid Flow (CFX)) that is up-
to-date.
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If you then connect the Mesh cell to a fluid flow system (Fluent), the mesh files for CFX
Setup are the only files that will have been generated by the update process. After con-
necting another system to the up-to-date Mesh cell, the Mesh cell transitions to the update
required state to signify that additional files must be generated for satisfy the Fluent system.

The cells already connected to the Mesh cell transition to the refresh required state after
the Mesh cell is updated. Updating the project unnecessarily re-updates the previously
up-to-date cells (CFX Setup, Solution, and Results). We recommended that you establish
the connection to the Fluent system before updating components downstream of the
Mesh in the Fluid Flow (CFX) system.

Failure States

If a particular action fails, Workbench provides a visual indication as well. You can pane any related
error messages in the Messages pane by clicking Show Messages in the lower right portion of the
window.
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DescriptionIconState

The last attempt to refresh cell input data failed and
the cell remains in a refresh required state.

Refresh Failed, Refresh
Required

The last attempt to update the cell and calculate
output data failed and the cell remains in an update
required state.

Update Failed, Update
Required

The last attempt to update the cell and calculate
output data failed. The cell remains in an attention
required state.

Update Failed, Attention
Required

Cell Properties

Every cell in Workbench has various properties associated with it. Most of these properties are specific
to the type of system, type of cell, and state of the cell, and are documented in the specific application
documentation. However, some cell properties are common across many cells, regardless of type of
system or cell state. Those properties are described here.

To pane cell properties, right-click the cell and select Properties from the context menu. The Prop-
erties pane opens, displaying all properties applicable to that cell in its current state. Both the property
name and its current value are shown. Some properties are editable, while others cannot be edited
because of the specific configuration of that project and/or cell.

DescriptionProperty

Displays the directory where any information associated with this component resides.
For more information on the general Workbench directory structure, see Project
Directories (p. 278).

Component ID

Displays all system and cell notes (p. 241) created.Notes

Displays the license used by this component during the most recent update. If the
component does not require a license during an update, the value displayed is Not
Applicable.

Last Update
Used Licenses

Specifies that a component should be included in any design point update operation,
even if it does not have output parameters. If you enable this property for a

Always Include
in Design Point
Update component, the component is updated when you update design points, regardless

of whether parameter values are affected.

Used for CFD-Post components.

Controls whether the mesh data is stored in a separate .acmo file, rather than being
stored in the database file, when you save your project. Saving the mesh data in

Save Mesh
Data In
Separate File separate file reduces the overall file space required and reduces the possibility of

disc corruption in very large database files on Linux systems.

Used by the Model cell (non-fluid flow analyses such as Static Structural) and
by the Mesh cell (Fluid Flow analyses and Mesh components).

The default setting for this field is controlled by the Save Mesh Data In Separate
File setting in the Workbench Mechanical (p. 430) or Meshing (p. 431) options.
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Menus in Workbench

The following types of menus are available in Workbench:

Menu Bar

Context Menus

Menu Bar

The menu bar gives you access to the following menus.

File Menu

DescriptionMenu Item

Creates a new project (p. 48).New

Opens an existing project (p. 48).Open

Saves the current project (p. 269).Save

Saves the current project (p. 269) under a different name and/or location.Save As

Imports a legacy database (p. 50).Import

Generates an archive file that contains all project files (p. 270).Archive

Provides options for connecting to and working with Ansys Minerva
repositories (p. 393).

Ansys Minerva

Opens a sub-menu containing journalling and scripting options (p. 251).Scripting

Writes out a report of the current project in .html/.htm format (p. 266).Export Report

Displays the four most recently opened projects.Recently Viewed
Files

Closes Workbench. You are prompted to save any unsaved data.Exit

View Menu

DescriptionMenu Item

Updates the pane.Refresh

Restores the current workspace layout to its default settings.Reset Workspace

Restores the original window layout.Reset Window
Layout

Displays the list of Workbench panes. You can select which panes you want to
display. Any changes you make to panes are carried forward to subsequent

List of panes

Workbench sessions. For a detailed description of the individual panes listed
here, see Panes within Tabs (p. 440).

Displays multiple links connecting systems as a single link where possible. A
bundled connection includes a label indicating the shared cells (for example, 2-4
indicates that cells 2, 3, and 4 are shared between systems).

Show Connections
Bundled

Shows the alphanumeric column and row headings for each system. This option
is selected by default.

Show System
Coordinates
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Tools Menu

DescriptionMenu Item

Reconnects to updates that were pending when the project was closed. This option
is available only if the project has cells in the Pending (p. 449) state. Upon opening a

Reconnect

project, Workbench automatically retrieves the data for any completed background
update.

After reconnecting to pending solution data, it is important to save the project.
For a Solution cell update, if you decline to save the project before exiting, the
intermediate solver data is discarded and is not accessible in future Workbench
sessions. For more information, see Exiting a Project During a Remote Solve
Manager Solution Cell Update (p. 347).

Refreshes all cells in the project (p. 245).Refresh Project

Resumes design point updates that were pending when the project was closed. This
option is available only if the project has design points that are paused due to cells
in a Pending (p. 449) state.

Resume

Updates all design points in a project that are in an Update Required (p. 449) state.
This option is available only when the project contains multiple design points.

Update All
Design Points

Updates all cells in the project (p. 243) that are in an Update Required (p. 449) state.Update Project

Temporarily suspends or resumes the collection of design point data from Remote
Solve Manager (RSM)

These options are enabled when RSM is processing an Update Project or an
Update All Design Points operation. For more information, see Suspending and
Resuming Collection of RSM Design Point Results (p. 361).

Suspend
Collecting RSM
Results /
Resume
Collecting RSM
Results

Ignores any results calculated so far and return the project to its normal state.

Use this option if you have a remote or background solve process (some
component or components in the project were saved in a Pending state) and
attempts to reconnect have failed.

Abandon
Pending
Updates

If you use this option, you may need to manually remove processes that were
not stopped or files that were not removed.

Defines your user preferences for Workbench. The preferences you set here are local
settings and affect only you. For descriptions, see Workbench User Preferences (p. 417).

Options

Units Menu

DescriptionMenu Item

Displays the value and unit as defined in Workbench or the original source
application. No conversion information is displayed.

Display Values as
Defined

Converts displayed units to correspond to the selected project unit system.Display Values in
Project Units

Opens the Unit Systems dialog box, where you can choose which unit systems
to display in the Units menu and define custom unit systems. For more
information, see Configuring Units in Workbench (p. 26).

Unit Systems
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Extensions Menu

DescriptionMenu Items

Opens the ACT Start Page, which provides you with convenient access to ACT
functionality. From this page, you can access multiple tools for both the
development and execution of extensions.

ACT Start Page

Opens the Extension Manager, which enables you to specify which extensions you
want to load.

Manage
Extensions

Provides for installing a binary extension (WBEX file) into your Application
Data folder so that this extension is available in the Extension Manager.

Install Extension

Opens the binary extension builder so that you can compile a binary version of
an extension from the scripted version.

Build Binary
Extension

Opens the ACT Console, where you can interactively test commands during the
development or debugging of an extension.

View ACT Console

Opens the ACT App Builder, where you can create ACT extensions in a visual
environment.

Open App Builder

Opens the Extensions Log File, which provides messages generated by the
extension. If present, warnings are shown in orange text, and errors are shown in
red text.

View Log File

Jobs Menu

DescriptionMenu Item

Displays the Job Monitor dialog box, which enables you to see the status
of jobs that have been submitted to Remote Solve Manager for the current
project.

For more information, see Monitoring and Controlling Remote Solve
Manager Jobs in Workbench (p. 348).

Open Job Monitor

Opens a browser window and launches the DPS Web App (p. 367).Open the Design Point
Service Web App

Synchronizes (p. 369) the Workbench project with the Design Point Service.Sync with Design Point
Service

Signs you out from Distributed Compute Services (DCS).Sign out from
Distributed Compute
Services

Help Menu

DescriptionMenu Item

Opens the online help (p. 24).Ansys Workbench Help

Opens the Sidebar Help (p. 23) pane.Show Context Help

Opens the Ansys, Inc. Installation Guides.Installation Help

Opens the  Licensing Documentation.Licensing Help

Opens the Sidebar Help (p. 23) pane to the Getting Started topic.Getting Started
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DescriptionMenu Item

Opens the Ansys Product Improvement Program (p. 15) dialog box.Ansys Product
Improvement Program

Opens the About Ansys Workbench dialog box containing various
product details.

About Ansys Workbench

Context Menus

Context menu options provide capabilities that enable you to work with your existing systems or to
add to and modify projects.

The following types of context menus are available in Workbench:

Common Context Menu Options

In addition to the menu items that are unique to each system or cell, some of the options on the
context-sensitive menu are available with most systems and cells.

DescriptionMenu Item

Opens the cell workspace tab so you can review the data and edit as needed.Edit

Creates a new system that is a duplicate of the selected system (p. 236).Duplicate

Refreshes input data and generates required output data (p. 242).Update

Updates the components upstream of the cell without updating the cell
itself (p. 244).

Update Upstream
Components

Renames the system or cell.Rename

Reads in all modified upstream data but does not necessarily regenerate the
outputs of the cell (p. 245).

Refresh

Displays a quick help panel for the cell, if available (p. 22).Quick Help

Displays an editable panel where you can enter notes about a system, cell, or
project (p. 241).

Add/Edit Note

Displays applicable properties in the Properties pane.Properties

Lists all recently used files.Recently Used

Removes or erases any data that the cell has generated or is to generate and
store if any such data is present (p. 247).

Clear Generated
Data

Removes or erases both input and output data to the cell and sets the cell state
back to the default (p. 248).

Reset

Transfer Data Context Menu Options

Many cells include transfer data options in their context menu. Transfer data options are available
only from root cells. If a cell is derived from an upstream cell (for example, when two systems share
a geometry), you can transfer data only to/from the originating cell.
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DescriptionMenu Item

Creates an upstream system that can provide data to the selected cell (p. 64).Transfer Data from
New

Creates a downstream system that can accept data from the selected
cell (p. 64).

Transfer Data to New

Tab Context Menu Options

When you click cells in the Project Schematic, some of them open in separate tabs. The context
menu options available depend on which tabs are open. For example, if only the Project tab is open,
no context options are available. The following context menu options are available for tabs.

DescriptionMenu Item

Closes the selected tab. Available for all tabs except for the Project tab.Close Tab

Closes all other tabs if accessed from the Project tab. Closes all tabs except for the
one selected and the Project tab if accessed from another tab.

Available for all tabs when multiple tabs are open.

Close Other
Tabs

Closes all tabs (including the selected tab) except for the Project tab. Available for
all tabs except for the Project tab.

Close All

System Header Context Menu Options

The following options are available from the context menu for system headers.

DescriptionMenu Item

Refreshes all cells in the selected system (p. 245).Refresh

Updates all cells in the selected system, along with any cells in upstream systems
that provide data to them (p. 244).

Update
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DescriptionMenu Item

Duplicates all cells (p. 236). No data is shared between the two systems. Equivalent
to issuing a duplicate on the first cell of the system.

Duplicate

Switches the analysis or solver type for an existing system (p. 241).Replace with

Deletes the system from the schematic (p. 240).Delete

Creates new cells at the points where the previous cells were removed.

Some cells can be deleted manually (for example the Results cell in a Fluid
Flow system). in some cases, transferring data from one system replaces the

Recreate Deleted
Cells

data that was previously consumed from upstream cells in the same system,
and so those upstream cells are deleted.

Renames the system (p. 235).Rename

Displays system properties in the Properties pane.Properties

Displays an editable panel where you can enter notes about a system, cell, or
project (p. 241)

Add/Edit Note

Project Schematic Context Menu Options

Right-click in white space in the Project Schematic to select a context menu option for the project.
The options that are visible depend on the specific configuration of the project.

DescriptionMenu Item

Resumes design point updates that were pending when the project was closed. This
option is available only if the project has design points that are paused due to cells
in a Pending (p. 449) state.

Resume

Refreshes all cells in the project (p. 245).Refresh Project

Reconnects to updates that were pending when the project was closed. This option
is available only if the project has cells in the Pending (p. 449) state. Upon opening

Reconnect

a project, Workbench automatically retrieves the data for any completed background
update.

After reconnecting to pending solution data, it is important to save the project.
For a Solution cell update, if you decline to save the project before exiting, the
intermediate solver data is discarded and is not accessible in future Workbench
sessions. For more information, see Exiting a Project During a Remote Solve
Manager Solution Cell Update (p. 347).

Updates all design points in a project (p. 309) that are in an Update Required (p. 449)
state. This option is available only when the project contains multiple design points.

Update All
Design Points

Updates all cells in the project (p. 243) that are in an Update Required (p. 449) state.Update Project

Adds systems to custom template (p. 228).Add to Custom

Select a new type of system to add to the project (p. 58).New system
type...

Displays multiple links connecting systems as a single link where possible. A bundled
connection includes a label indicating the shared cells (for example, 2-4 indicates
that cells 2, 3, and 4 are shared between systems).

Show
Connections
Bundled
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DescriptionMenu Item

Shows the alphanumeric column and row headings for each system. This option is
selected by default.

Show System
Coordinates

Resizes the systems in the Project Schematic to better fit in the window as it is
currently sized.

Fit

Displays an editable panel where you can enter notes about a system, cell, or
project (p. 241).

Add/Edit Note

Link Context Menu Options

You can right-click a link to see additional context menu options.

DescriptionMenu
Item

Deletes the selected link (p. 65).Delete

Opens the Properties pane for the link, where you can see the link type, origination cell,
and destination cell.

Note:

To properly update the state of a cell for a linked system, either open the
Mechanical application or click Update Project on the toolbar.

Properties

Geometry Context Menu Options

The following options are available from the context menu for a Geometry cell.

DescriptionMenu Item

Launches DesignModeler or SpaceClaim Direct Modeler, where you can build
a new geometry.

New Geometry (or New
DesignModeler
Geometry/New
SpaceClaim Direct
Modeler Geometry)
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DescriptionMenu Item

Opens a dialog box where you can navigate to an existing geometry file or
select a file from the list of recently viewed files.

Import Geometry

Opens the model in DesignModeler or SpaceClaim Direct Modeler to modify
it.

Edit (or Edit Geometry
in DesignModeler/Edit
Geometry in SpaceClaim
Direct Modeler)

Opens a dialog box where you can navigate to an existing geometry file or
select a file from the list of recently viewed files to replace the currently
specified file.

Replace Geometry

Generates an existing CAD geometry using the parameter values as defined
in the CAD system.

Update from CAD

Reads in all modified upstream data but does not regenerate the geometry.
Enabled when the Geometry cell is in the Refresh Required state.

Refresh

Displays a Properties pane where you can select basic and advanced
geometry properties. For property descriptions, see Geometry Preferences.

Properties

Setup Context Menu Options

The following options are available from the context menu for a Setup cell.

DescriptionMenu
Item

Launches one of the following options:Edit

• Mechanical application with the geometry loaded and with cells mapped to their
respective tree locations in the Mechanical application.

• CFX-Pre.

Imports either an existing Mechanical case file containing physics data, region, and mesh
information for your analysis, or an existing Fluent case file.

Import
Case

Solution Context Menu Options

The following options are available from the context menu for a Solution cell.

DescriptionMenu Item

Launches one of the following options:Edit

• Mechanical application open to the solution branch.

• CFX-Pre.

• Fluent.
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DescriptionMenu Item

Deletes the Solution and Results cell. This changes the system to a setup-only system,
meaning the system generates only an input file. It does not solve or post results. The
solution object and objects below it are removed from the Mechanical application tree.

Delete

Displays the most recent CFX-Solver results files imported (if any) and specify the
CFX-Solver results file to load in the Open dialog box. When the results file is loaded,
the system displays only the Solution cell and the Results cell.

Import
Solution

Opens the Ansys CFX-Solver Manager and shows the results of the previous run.Display
Monitors

Selects an existing Fluent data set (for example, one solved on an external cluster) into
a Solution cell in a Fluent system and immediately start postprocessing in CFD-Post,

Import Final
Data

without the need to run the minimum of one more solver iteration. This option becomes
available after importing case file into the Setup cell.
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Glossary
analysis system A template that has all the cells required to complete an analysis

for a particular type of physics, such as static structural.

archive Save all project files and data into a single package that can be
shared, stored, and reused.

cell A part of a system that represents a discrete task in the process of
completing the overall analysis. Typical cells include Engineering
Data, Geometry, Model or Mesh, Setup, Solution, and Results.

component system A system template that has the cells necessary to complete only a
portion of a complete analysis. Often these systems are task-oriented
(for example, a system to create a geometry or to produce a mesh)
or are associated with a particular application.

component update An update of a single component (or cell) within a system in an
Ansys Workbench project. For example, an update of the Analysis
cell within a project is a component update.

A Solution cell update is the only component update currently
supported by Remote Solve Manager.

context menu A context-sensitive list of options available from a cell or other
component, accessed by a right-mouse click.

custom system A system template that has all of systems necessary to complete a
coupled analysis, such as FSI or thermal-stress.

data-integrated applica-
tion

An application that has a separate interface from the Ansys Work-
bench project window but that still communicates with Ansys
Workbench.

Design Exploration Systems in the Design Exploration group are used to access
DesignXplorer functionality. These systems connect to the Parameter
Set bar in order to drive parametric studies by varying project
parameters.

design point A set of input parameter values and corresponding output parameter
values that make up a single solved instance of a project.

design point update An update of one or more design points in an Ansys Workbench
project. You can update a single design point, a selected set of
design points, or all the design points in a project. During a design
point update, solution data is updated only where output parameters
have been defined.

Design point updates can be submitted to Remote Solve Manager.

downstream In the Project Schematic, data flows from top-to-bottom within sys-
tems and from left-to-right between systems. A cell is said to be

463
Release 2022 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.



downstream if it is below a cell in the same system, or to the right
of a cell in a separate system. Downstream cells use data from up-
stream cells as input.

links Systems in the Project Schematic that are dependent on each other
in some manner are connected with links. Links with a square ter-
minator indicate that data is shared between the two cells connected
by the link, and links with a round terminator indicate that data is
transferred from the upstream to the downstream cell.

parameter A property of a model that can be varied (input parameter) or the
result of varying such a property (output parameter). Custom input
or custom output parameters can be defined by a constant value;
derived parameters are defined by an expression of other parameters
(for example, "P2+3*P3").

project The project is the full collection of systems, components, data, and
their connections that you create to achieve an overall CAE goal.

Project Schematic A region of the Ansys Workbench project window where you will
construct and interact with your project. Projects are represented
as connected systems displayed in a flowchart form that allows en-
gineering intent, data relationships, and the state of the analysis
project to be understood at a glance.

project update An update of an entire Workbench project. All the systems, compon-
ents, and design points in the project are updated.

refresh An action that reads in all modified upstream data but does not
necessarily regenerate the outputs of the cell.

systems A collection of cells that together perform a dedicated task. Types
of systems include analysis systems, component systems, and custom
systems.

Toolbox A region of the Ansys Workbench interface, located on the left side
of the interface, from which you can choose systems or other com-
ponents to add to the project. The Toolbox is context-sensitive,
meaning the options that appear will change based on what is se-
lected elsewhere in the interface.

update An action that updates data in a particular system or cell with any
new information that has been added to the project since the last
update and regenerates the outputs.

upstream In the Project Schematic, data flows from top-to-bottom within
systems and from left-to-right between systems. A cell is said to be
upstream if it is above a cell in the same system or to the left of a
cell in a separate system. Upstream cells provide their output data
to downstream cells.
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